VPN file sharing etc

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Hello

I have used the New Connection Wizard to enable an
incomming VPN connection to an XP Prof computer behind a
NETGEAR DG834 router. I enabled VPN pass-through, via the
router, to the computer in question.

When I connect to it across the Net (setup via XP's New
Connection Wizard ... Connect to the network at my
workplace), I get a warning saying:

TCP/IP CP error 733. [...]

IPX/SPX or compatible CP connected successfully.

So it appears to work in part. But I cannot see the
remote machine and I cannot access its shared folders
etc. If I use (DOS) NET VIEW, I only see my own computer
listed.

Could someone please tell me what I'm doing wrong?

Any help more than appreciated, Andy
5 answers Last reply
More about file sharing
  1. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Browsing can be difficult across a router. Can you manually map a drive to a
    known computer and share. You also may need to put that computer's IP
    address in your hosts and lmhosts files.

    --
    Bob Cerelli
    http://www.onecomputerguy.com

    "Andy" <anonymous@discussions.microsoft.com> wrote in message
    news:1b20801c4201b$201c2de0$a301280a@phx.gbl...
    > Hello
    >
    > I have used the New Connection Wizard to enable an
    > incomming VPN connection to an XP Prof computer behind a
    > NETGEAR DG834 router. I enabled VPN pass-through, via the
    > router, to the computer in question.
    >
    > When I connect to it across the Net (setup via XP's New
    > Connection Wizard ... Connect to the network at my
    > workplace), I get a warning saying:
    >
    > TCP/IP CP error 733. [...]
    >
    > IPX/SPX or compatible CP connected successfully.
    >
    > So it appears to work in part. But I cannot see the
    > remote machine and I cannot access its shared folders
    > etc. If I use (DOS) NET VIEW, I only see my own computer
    > listed.
    >
    > Could someone please tell me what I'm doing wrong?
    >
    > Any help more than appreciated, Andy
  2. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    A couple of things that Bob said echo for me in reading this:

    You apparently have a successful IPX connection, but no luck on TCP/IP.

    If you have no use for IPX, and many people don't--I'd remove it at both
    ends of the connection. If you are trying to reach older Netware servers,
    you may well have need of it, however.

    The fact that IPX gets through but IP does not may well be indictative of a
    firewall in place--check at the host end for any sort of software firewall,
    and check the forwarding of port 1723, TCP in the router.

    "Andy" <anonymous@discussions.microsoft.com> wrote in message
    news:1b20801c4201b$201c2de0$a301280a@phx.gbl...
    > Hello
    >
    > I have used the New Connection Wizard to enable an
    > incomming VPN connection to an XP Prof computer behind a
    > NETGEAR DG834 router. I enabled VPN pass-through, via the
    > router, to the computer in question.
    >
    > When I connect to it across the Net (setup via XP's New
    > Connection Wizard ... Connect to the network at my
    > workplace), I get a warning saying:
    >
    > TCP/IP CP error 733. [...]
    >
    > IPX/SPX or compatible CP connected successfully.
    >
    > So it appears to work in part. But I cannot see the
    > remote machine and I cannot access its shared folders
    > etc. If I use (DOS) NET VIEW, I only see my own computer
    > listed.
    >
    > Could someone please tell me what I'm doing wrong?
    >
    > Any help more than appreciated, Andy
  3. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    On Sun, 11 Apr 2004 16:17:14 -0700, "Andy"
    <anonymous@discussions.microsoft.com> wrote:

    >Hello
    >
    >I have used the New Connection Wizard to enable an
    >incomming VPN connection to an XP Prof computer behind a
    >NETGEAR DG834 router. I enabled VPN pass-through, via the
    >router, to the computer in question.

    Did you forward port 1723 to the VPN machine?

    You have to do this for both machines.

    You also have to disable firewalls until you sort out the rules for
    passing VPN traffic. Shutting the GUI is not good enough - you have to
    disable the firewall engine thru the GUI.

    Sometimes you can find the culprit with "msconfig".


    --

    Map Of The Vast Right Wing Conspiracy:
    http://www.freewebs.com/vrwc/

    "There is much to be said in favor of the Internet.
    By giving us the opinions of the uneducated, it keeps
    us in touch with the ignorance of the community."
  4. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Thanks for your suggestions guys.

    Bob Cerelli:

    NET USE, to map a shared drive, doesn't work (assuming
    this is what you mean by "map manually"). This is true
    whether I use \\ComputerName\ShareName or
    \\RouterIP\ShareName. But then, I don't think it's the
    router's IP I'm interested in. It's a computer behind the
    router after all. But I'm not sure exactly how that bit
    works anyhow.

    For this reason, I don't think editing lmhosts or hosts
    will help. Actually, I did try this but no luck.

    Bob and Bill:

    The VPN client PC has Norton Firewall installed on it,
    and it's connected directly to my ISP & Net via a Modem.
    I have put the remote router's IP address into the
    Norton "trusted list", so it should receive anything from
    that IP. I have tried turning off Norton, but it made no
    difference.

    I also checked that none of the client's network
    connections have "Protect my computer ... from the
    Internet" enabled in the Advanced Property tab. Which I
    *assume* will turn off the Microsoft firewall.

    At the VPN server end, whenever my client connects, the
    router log gives a message about sending VPN packets to
    the correct computer's IP. And all outgoing router ports
    are open.

    The Firewall rules in the router have the following
    incoming "ports" enabled: VPN PTPP (TCP:1723) + VPN L2TP
    (UDP:1701) + VPN IPSEC(UDP:500). So I *assume* this will
    forward TCP 1723 without me having to do anything else.
    And a port scan with Norton shows that port 1723 is open.

    So I assume I have perhaps left Microsoft's firewall
    switched on somewhere at the VPN server end. It will have
    to wait until I can get access to it. If it's not that,
    then I guess VPN doesn't work.

    Incidentally, I enabled both TCP/IP and IPX/SPX just to
    get things going. I assume that file sharing will work
    via the VPN, so I guess I just need to enable Microsoft
    file sharing in the VPN connection?

    Another confusing thing: if I enable both TCP/IP and
    IPX/SPX to my ISP via the modem connection, then IPX/SPX
    fails. But when I then connect to the VPN server, it
    complains that IPX/SPX cannot be used for connecting more
    than once. So has my ISP connection "used up" TCP/IP, so
    that the remaining unused IPX/SPX is all that will work?

    Thanks, Andy
  5. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Pretty sure you don't want to use the router's IP address in either the
    LMHOTS or HOSTS file for a VPN connection. Use the actual internal IP
    address of the computers you want to connect to

    --
    Bob Cerelli
    http://www.onecomputerguy.com

    "Andy" <anonymous@discussions.microsoft.com> wrote in message
    news:1b5a301c4209d$b2eedf50$a301280a@phx.gbl...
    > Thanks for your suggestions guys.
    >
    > Bob Cerelli:
    >
    > NET USE, to map a shared drive, doesn't work (assuming
    > this is what you mean by "map manually"). This is true
    > whether I use \\ComputerName\ShareName or
    > \\RouterIP\ShareName. But then, I don't think it's the
    > router's IP I'm interested in. It's a computer behind the
    > router after all. But I'm not sure exactly how that bit
    > works anyhow.
    >
    > For this reason, I don't think editing lmhosts or hosts
    > will help. Actually, I did try this but no luck.
    >
    > Bob and Bill:
    >
    > The VPN client PC has Norton Firewall installed on it,
    > and it's connected directly to my ISP & Net via a Modem.
    > I have put the remote router's IP address into the
    > Norton "trusted list", so it should receive anything from
    > that IP. I have tried turning off Norton, but it made no
    > difference.
    >
    > I also checked that none of the client's network
    > connections have "Protect my computer ... from the
    > Internet" enabled in the Advanced Property tab. Which I
    > *assume* will turn off the Microsoft firewall.
    >
    > At the VPN server end, whenever my client connects, the
    > router log gives a message about sending VPN packets to
    > the correct computer's IP. And all outgoing router ports
    > are open.
    >
    > The Firewall rules in the router have the following
    > incoming "ports" enabled: VPN PTPP (TCP:1723) + VPN L2TP
    > (UDP:1701) + VPN IPSEC(UDP:500). So I *assume* this will
    > forward TCP 1723 without me having to do anything else.
    > And a port scan with Norton shows that port 1723 is open.
    >
    > So I assume I have perhaps left Microsoft's firewall
    > switched on somewhere at the VPN server end. It will have
    > to wait until I can get access to it. If it's not that,
    > then I guess VPN doesn't work.
    >
    > Incidentally, I enabled both TCP/IP and IPX/SPX just to
    > get things going. I assume that file sharing will work
    > via the VPN, so I guess I just need to enable Microsoft
    > file sharing in the VPN connection?
    >
    > Another confusing thing: if I enable both TCP/IP and
    > IPX/SPX to my ISP via the modem connection, then IPX/SPX
    > fails. But when I then connect to the VPN server, it
    > complains that IPX/SPX cannot be used for connecting more
    > than once. So has my ISP connection "used up" TCP/IP, so
    > that the remaining unused IPX/SPX is all that will work?
    >
    > Thanks, Andy
    >
Ask a new question

Read More

Connection VPN File Sharing Computers Windows XP