Sign in with
Sign up | Sign in
Your question

ICS and remote desktop port changing

Last response: in Windows XP
Share
Anonymous
April 29, 2004 2:54:07 AM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Ok my story is kind of complicated.

Basically I have two computer where computer1 is connected to the
internet and allows ICS (internet connection sharing) for computer2.
Both computers are running xp-pro.

So far I change the port for "remote desktop" on computer2 to port
1002.

I then went to computer1 and manage to change the setting under
advance to re-route all TCP 1002 service to computer2.
When I go back to computer1 and type into the RDP-client
computer2:1002 it works great.

The problem is that when I get out of my local network lets say
computer3 and try
xxx.xxx.xxx: 1002 it does not work.

Does anybody know what the problem is? Any help will be appreciated.
In fact thanks for reading this far!

al
Anonymous
April 29, 2004 9:34:14 AM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Did you also configure the XP Internet Connection Firewall (ICF), if enabled, or other personal
firewall to forwarded TCP Port 1002 to PC2?

http://members.cox.net/ajarvi/RemoteDesktop/Multiple_PC...

--
Al Jarvi (MS-MVP Windows Networking)

Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
The MS-MVP Program - http://mvp.support.microsoft.com
This posting is provided "AS IS" with no warranties, and confers no rights...

"Alex Lee" <simplitia@yahoo.com> wrote in message
news:21ba229.0404282154.6b5ffffd@posting.google.com...
> Ok my story is kind of complicated.
>
> Basically I have two computer where computer1 is connected to the
> internet and allows ICS (internet connection sharing) for computer2.
> Both computers are running xp-pro.
>
> So far I change the port for "remote desktop" on computer2 to port
> 1002.
>
> I then went to computer1 and manage to change the setting under
> advance to re-route all TCP 1002 service to computer2.
> When I go back to computer1 and type into the RDP-client
> computer2:1002 it works great.
>
> The problem is that when I get out of my local network lets say
> computer3 and try
> xxx.xxx.xxx: 1002 it does not work.
>
> Does anybody know what the problem is? Any help will be appreciated.
> In fact thanks for reading this far!
>
> al
Anonymous
April 29, 2004 12:18:37 PM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

I am usinf a linksys router and have this configured to the specs from the
link sooner al posted. I am running 2 windows 2000 servers with terminal
services. For some reason I cannot get the computer listening on 3390 to
respond. Any suggestions?





"Sooner Al" <SoonerAl@somewhere.net.invalid> wrote in message
news:o 2MWGWdLEHA.644@tk2msftngp13.phx.gbl...
> Did you also configure the XP Internet Connection Firewall (ICF), if
enabled, or other personal
> firewall to forwarded TCP Port 1002 to PC2?
>
> http://members.cox.net/ajarvi/RemoteDesktop/Multiple_PC...
>
> --
> Al Jarvi (MS-MVP Windows Networking)
>
> Please post *ALL* questions and replies to the news group for the mutual
benefit of all of us...
> The MS-MVP Program - http://mvp.support.microsoft.com
> This posting is provided "AS IS" with no warranties, and confers no
rights...
>
> "Alex Lee" <simplitia@yahoo.com> wrote in message
> news:21ba229.0404282154.6b5ffffd@posting.google.com...
> > Ok my story is kind of complicated.
> >
> > Basically I have two computer where computer1 is connected to the
> > internet and allows ICS (internet connection sharing) for computer2.
> > Both computers are running xp-pro.
> >
> > So far I change the port for "remote desktop" on computer2 to port
> > 1002.
> >
> > I then went to computer1 and manage to change the setting under
> > advance to re-route all TCP 1002 service to computer2.
> > When I go back to computer1 and type into the RDP-client
> > computer2:1002 it works great.
> >
> > The problem is that when I get out of my local network lets say
> > computer3 and try
> > xxx.xxx.xxx: 1002 it does not work.
> >
> > Does anybody know what the problem is? Any help will be appreciated.
> > In fact thanks for reading this far!
> >
> > al
>
Related resources
Anonymous
April 29, 2004 12:31:01 PM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Try this telnet test on Port 3390 to see if you can pinpoint the problem.

http://support.microsoft.com/default.aspx?scid=kb;en-us;Q187628

Does this work over the private LAN?

--
Al Jarvi (MS-MVP Windows Networking)

Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
The MS-MVP Program - http://mvp.support.microsoft.com
This posting is provided "AS IS" with no warranties, and confers no rights...

"Connie Gibson" <conniegibson@hchd.net> wrote in message
news:0v-dndMVuNRZnAzdRVn-sw@amaonline.com...
>I am usinf a linksys router and have this configured to the specs from the
> link sooner al posted. I am running 2 windows 2000 servers with terminal
> services. For some reason I cannot get the computer listening on 3390 to
> respond. Any suggestions?
>
>
>
>
>
> "Sooner Al" <SoonerAl@somewhere.net.invalid> wrote in message
> news:o 2MWGWdLEHA.644@tk2msftngp13.phx.gbl...
>> Did you also configure the XP Internet Connection Firewall (ICF), if
> enabled, or other personal
>> firewall to forwarded TCP Port 1002 to PC2?
>>
>> http://members.cox.net/ajarvi/RemoteDesktop/Multiple_PC...
>>
>> --
>> Al Jarvi (MS-MVP Windows Networking)
>>
>> Please post *ALL* questions and replies to the news group for the mutual
> benefit of all of us...
>> The MS-MVP Program - http://mvp.support.microsoft.com
>> This posting is provided "AS IS" with no warranties, and confers no
> rights...
>>
>> "Alex Lee" <simplitia@yahoo.com> wrote in message
>> news:21ba229.0404282154.6b5ffffd@posting.google.com...
>> > Ok my story is kind of complicated.
>> >
>> > Basically I have two computer where computer1 is connected to the
>> > internet and allows ICS (internet connection sharing) for computer2.
>> > Both computers are running xp-pro.
>> >
>> > So far I change the port for "remote desktop" on computer2 to port
>> > 1002.
>> >
>> > I then went to computer1 and manage to change the setting under
>> > advance to re-route all TCP 1002 service to computer2.
>> > When I go back to computer1 and type into the RDP-client
>> > computer2:1002 it works great.
>> >
>> > The problem is that when I get out of my local network lets say
>> > computer3 and try
>> > xxx.xxx.xxx: 1002 it does not work.
>> >
>> > Does anybody know what the problem is? Any help will be appreciated.
>> > In fact thanks for reading this far!
>> >
>> > al
>>
>
>
Anonymous
April 29, 2004 1:15:40 PM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

No does not work over a private lan, I have one TS on port 3389 and I can
use it on the lan or wan works fine. I set up a second TS and changed the
port to 3390 on it and port forwarding in the linksys router the same as the
port 3389 entry and the 3390 TS will not connect.
I am using one public IP in the router and wanting to connect through rdt
with the adress:p ort number on 2 different machines. Any suggestions? I am
using a linksys BEFSR11.

TIA




"Sooner Al" <SoonerAl@somewhere.net.invalid> wrote in message
news:uGRa64eLEHA.3348@TK2MSFTNGP09.phx.gbl...
> Try this telnet test on Port 3390 to see if you can pinpoint the problem.
>
> http://support.microsoft.com/default.aspx?scid=kb;en-us;Q187628
>
> Does this work over the private LAN?
>
> --
> Al Jarvi (MS-MVP Windows Networking)
>
> Please post *ALL* questions and replies to the news group for the mutual
benefit of all of us...
> The MS-MVP Program - http://mvp.support.microsoft.com
> This posting is provided "AS IS" with no warranties, and confers no
rights...
>
> "Connie Gibson" <conniegibson@hchd.net> wrote in message
> news:0v-dndMVuNRZnAzdRVn-sw@amaonline.com...
> >I am usinf a linksys router and have this configured to the specs from
the
> > link sooner al posted. I am running 2 windows 2000 servers with terminal
> > services. For some reason I cannot get the computer listening on 3390
to
> > respond. Any suggestions?
> >
> >
> >
> >
> >
> > "Sooner Al" <SoonerAl@somewhere.net.invalid> wrote in message
> > news:o 2MWGWdLEHA.644@tk2msftngp13.phx.gbl...
> >> Did you also configure the XP Internet Connection Firewall (ICF), if
> > enabled, or other personal
> >> firewall to forwarded TCP Port 1002 to PC2?
> >>
> >> http://members.cox.net/ajarvi/RemoteDesktop/Multiple_PC...
> >>
> >> --
> >> Al Jarvi (MS-MVP Windows Networking)
> >>
> >> Please post *ALL* questions and replies to the news group for the
mutual
> > benefit of all of us...
> >> The MS-MVP Program - http://mvp.support.microsoft.com
> >> This posting is provided "AS IS" with no warranties, and confers no
> > rights...
> >>
> >> "Alex Lee" <simplitia@yahoo.com> wrote in message
> >> news:21ba229.0404282154.6b5ffffd@posting.google.com...
> >> > Ok my story is kind of complicated.
> >> >
> >> > Basically I have two computer where computer1 is connected to the
> >> > internet and allows ICS (internet connection sharing) for computer2.
> >> > Both computers are running xp-pro.
> >> >
> >> > So far I change the port for "remote desktop" on computer2 to port
> >> > 1002.
> >> >
> >> > I then went to computer1 and manage to change the setting under
> >> > advance to re-route all TCP 1002 service to computer2.
> >> > When I go back to computer1 and type into the RDP-client
> >> > computer2:1002 it works great.
> >> >
> >> > The problem is that when I get out of my local network lets say
> >> > computer3 and try
> >> > xxx.xxx.xxx: 1002 it does not work.
> >> >
> >> > Does anybody know what the problem is? Any help will be appreciated.
> >> > In fact thanks for reading this far!
> >> >
> >> > al
> >>
> >
> >
>
Anonymous
April 29, 2004 2:08:34 PM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

If you can not connect over the private LAN to the TS you changed the listening port on, from
another PC on the LAN, then its a problem with...

1. The TS not being configured for the new port correctly.
2. The TS not being configured correctly.
3. Not using the correct IP for the TS.
4. Some other problem.

Note that to test this you can *NOT* be on the private LAN and using the public IP of the router. To
test properly you need to be at a remote location, or dialup to the internet, in order to use the
public IP of the router.
--
Al Jarvi (MS-MVP Windows Networking)

Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
The MS-MVP Program - http://mvp.support.microsoft.com
This posting is provided "AS IS" with no warranties, and confers no rights...

"Connie Gibson" <conniegibson@hchd.net> wrote in message
news:C-idnRTaJeeBkgzdRVn-tw@amaonline.com...
> No does not work over a private lan, I have one TS on port 3389 and I can
> use it on the lan or wan works fine. I set up a second TS and changed the
> port to 3390 on it and port forwarding in the linksys router the same as the
> port 3389 entry and the 3390 TS will not connect.
> I am using one public IP in the router and wanting to connect through rdt
> with the adress:p ort number on 2 different machines. Any suggestions? I am
> using a linksys BEFSR11.
>
> TIA
>
>
>
>
> "Sooner Al" <SoonerAl@somewhere.net.invalid> wrote in message
> news:uGRa64eLEHA.3348@TK2MSFTNGP09.phx.gbl...
>> Try this telnet test on Port 3390 to see if you can pinpoint the problem.
>>
>> http://support.microsoft.com/default.aspx?scid=kb;en-us;Q187628
>>
>> Does this work over the private LAN?
>>
>> --
>> Al Jarvi (MS-MVP Windows Networking)
>>
>> Please post *ALL* questions and replies to the news group for the mutual
> benefit of all of us...
>> The MS-MVP Program - http://mvp.support.microsoft.com
>> This posting is provided "AS IS" with no warranties, and confers no
> rights...
>>
>> "Connie Gibson" <conniegibson@hchd.net> wrote in message
>> news:0v-dndMVuNRZnAzdRVn-sw@amaonline.com...
>> >I am usinf a linksys router and have this configured to the specs from
> the
>> > link sooner al posted. I am running 2 windows 2000 servers with terminal
>> > services. For some reason I cannot get the computer listening on 3390
> to
>> > respond. Any suggestions?
>> >
>> >
>> >
>> >
>> >
>> > "Sooner Al" <SoonerAl@somewhere.net.invalid> wrote in message
>> > news:o 2MWGWdLEHA.644@tk2msftngp13.phx.gbl...
>> >> Did you also configure the XP Internet Connection Firewall (ICF), if
>> > enabled, or other personal
>> >> firewall to forwarded TCP Port 1002 to PC2?
>> >>
>> >> http://members.cox.net/ajarvi/RemoteDesktop/Multiple_PC...
>> >>
>> >> --
>> >> Al Jarvi (MS-MVP Windows Networking)
>> >>
>> >> Please post *ALL* questions and replies to the news group for the
> mutual
>> > benefit of all of us...
>> >> The MS-MVP Program - http://mvp.support.microsoft.com
>> >> This posting is provided "AS IS" with no warranties, and confers no
>> > rights...
>> >>
>> >> "Alex Lee" <simplitia@yahoo.com> wrote in message
>> >> news:21ba229.0404282154.6b5ffffd@posting.google.com...
>> >> > Ok my story is kind of complicated.
>> >> >
>> >> > Basically I have two computer where computer1 is connected to the
>> >> > internet and allows ICS (internet connection sharing) for computer2.
>> >> > Both computers are running xp-pro.
>> >> >
>> >> > So far I change the port for "remote desktop" on computer2 to port
>> >> > 1002.
>> >> >
>> >> > I then went to computer1 and manage to change the setting under
>> >> > advance to re-route all TCP 1002 service to computer2.
>> >> > When I go back to computer1 and type into the RDP-client
>> >> > computer2:1002 it works great.
>> >> >
>> >> > The problem is that when I get out of my local network lets say
>> >> > computer3 and try
>> >> > xxx.xxx.xxx: 1002 it does not work.
>> >> >
>> >> > Does anybody know what the problem is? Any help will be appreciated.
>> >> > In fact thanks for reading this far!
>> >> >
>> >> > al
>> >>
>> >
>> >
>>
>
>
Anonymous
April 29, 2004 10:22:04 PM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Thank you all for all the feedback.
I finally got it to work. I found out from browsing around google
groups, that for some weird reason port 1002 does not seem to work
very well with ICS.
I typed in "port 1002 Windows" under google groups and someone had a
conflict with this port and ICS:

So I simply changed the port I used. Unfortunently I am under a
university firewall with very limited ports available. I finally
settled with port 3306 I believe is a port used for mysql or
something. And like magic all is well!
I can now log on from outside my lan to two different computers on my
network. Ya!

thanks again everyone. It is people like you that makes the web useful
and what it was intended for.

Alex
Anonymous
April 30, 2004 4:15:52 AM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Terrific.

Here's a KB article which (partially) explains why 1002 didn't work:

http://support.microsoft.com/default.aspx?scid=kb;en-us;315846

1002 is used for the ILS service used by Netmeeting, as I found here:

http://www.securityfocus.com/infocus/1620

"Alex Lee" <simplitia@yahoo.com> wrote in message
news:21ba229.0404291722.53b5e14e@posting.google.com...
> Thank you all for all the feedback.
> I finally got it to work. I found out from browsing around google
> groups, that for some weird reason port 1002 does not seem to work
> very well with ICS.
> I typed in "port 1002 Windows" under google groups and someone had a
> conflict with this port and ICS:
>
> So I simply changed the port I used. Unfortunently I am under a
> university firewall with very limited ports available. I finally
> settled with port 3306 I believe is a port used for mysql or
> something. And like magic all is well!
> I can now log on from outside my lan to two different computers on my
> network. Ya!
>
> thanks again everyone. It is people like you that makes the web useful
> and what it was intended for.
>
> Alex
!