Remote Desktop thru Port 80

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

i have winxp pro installed at home and winxp home in the
office.

however, all ports except port 80 are blocked in the
office.
i have already changed the listening port for the remote
desktop at home to port 80.
but i still can't connect back home.

does anyone know why and how to fix it?

thx.
6 answers Last reply
More about remote desktop port
  1. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Steve wrote:
    > i have winxp pro installed at home and winxp home in the
    > office.
    >
    > however, all ports except port 80 are blocked in the
    > office.
    > i have already changed the listening port for the remote
    > desktop at home to port 80.
    > but i still can't connect back home.
    >
    > does anyone know why and how to fix it?

    Since you have changed the listening port, I can only assume you are
    connecting to that port.
    Also, you have rebooted the machine after making your registry changes?

    To be sure, try the command line like the following example (Start -> Run):

    MSTSC /v:<ip address>:port

    For example: MSTSC /v:192.168.0.150:80

    Of course, your external IP will be different, since 192.168 is an internal
    only IP.

    You may want to get the newest (I believe - correct me if I am wrong here)
    Remote Desktop Connection Client from here:
    http://www.microsoft.com/downloads/details.aspx?FamilyID=a8255ffc-4b4a-40e7-a706-cde7e9b57e79&DisplayLang=en

    --
    <- Shenan ->
    --
  2. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    thx shenan

    i have reboot my machine at home,
    and i have the latest remote desktop client installed at
    work.

    i tried the command line thingy but it still didn't work.

    it has a windows popup saying...

    [remote desktop disconnected]
    'the remote connection has timed out. please try
    connecting to the remote computer again.'

    it seems that it has made the outgoing connection,
    but cannot get the incoming one. (correct me if i am
    wrong.)


    >-----Original Message-----
    >Steve wrote:
    >> i have winxp pro installed at home and winxp home in
    the
    >> office.
    >>
    >> however, all ports except port 80 are blocked in the
    >> office.
    >> i have already changed the listening port for the
    remote
    >> desktop at home to port 80.
    >> but i still can't connect back home.
    >>
    >> does anyone know why and how to fix it?
    >
    >Since you have changed the listening port, I can only
    assume you are
    >connecting to that port.
    >Also, you have rebooted the machine after making your
    registry changes?
    >
    >To be sure, try the command line like the following
    example (Start -> Run):
    >
    >MSTSC /v:<ip address>:port
    >
    >For example: MSTSC /v:192.168.0.150:80
    >
    >Of course, your external IP will be different, since
    192.168 is an internal
    >only IP.
    >
    >You may want to get the newest (I believe - correct me
    if I am wrong here)
    >Remote Desktop Connection Client from here:
    >http://www.microsoft.com/downloads/details.aspx?
    FamilyID=a8255ffc-4b4a-40e7-a706-
    cde7e9b57e79&DisplayLang=en
    >
    >--
    ><- Shenan ->
    >--
    >
    >
    >.
    >
  3. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    I can give a couple more reasons why this might not work.

    1) your ISP might block port 80. Some do, including very large ones,
    Verizon, for example.

    2) You may be mistaking the presence of a transparent proxy server on your
    network for actually having port 80 open. RD traffic isn't HTTP traffic, so
    it doesn't work through the proxy.

    It's kind of late, so I'll save you the lecture about the risks of incuring
    the possibly justified rath of your job's IT department.

    "Steve" <anonymous@discussions.microsoft.com> wrote in message
    news:9d7a01c43442$e2b0a5d0$a601280a@phx.gbl...
    > thx shenan
    >
    > i have reboot my machine at home,
    > and i have the latest remote desktop client installed at
    > work.
    >
    > i tried the command line thingy but it still didn't work.
    >
    > it has a windows popup saying...
    >
    > [remote desktop disconnected]
    > 'the remote connection has timed out. please try
    > connecting to the remote computer again.'
    >
    > it seems that it has made the outgoing connection,
    > but cannot get the incoming one. (correct me if i am
    > wrong.)
    >
    >
    >
    >
    >>-----Original Message-----
    >>Steve wrote:
    >>> i have winxp pro installed at home and winxp home in
    > the
    >>> office.
    >>>
    >>> however, all ports except port 80 are blocked in the
    >>> office.
    >>> i have already changed the listening port for the
    > remote
    >>> desktop at home to port 80.
    >>> but i still can't connect back home.
    >>>
    >>> does anyone know why and how to fix it?
    >>
    >>Since you have changed the listening port, I can only
    > assume you are
    >>connecting to that port.
    >>Also, you have rebooted the machine after making your
    > registry changes?
    >>
    >>To be sure, try the command line like the following
    > example (Start -> Run):
    >>
    >>MSTSC /v:<ip address>:port
    >>
    >>For example: MSTSC /v:192.168.0.150:80
    >>
    >>Of course, your external IP will be different, since
    > 192.168 is an internal
    >>only IP.
    >>
    >>You may want to get the newest (I believe - correct me
    > if I am wrong here)
    >>Remote Desktop Connection Client from here:
    >>http://www.microsoft.com/downloads/details.aspx?
    > FamilyID=a8255ffc-4b4a-40e7-a706-
    > cde7e9b57e79&DisplayLang=en
    >>
    >>--
    >><- Shenan ->
    >>--
    >>
    >>
    >>.
    >>
  4. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    >-----Original Message-----
    >I can give a couple more reasons why this might not work.
    >
    >1) your ISP might block port 80. Some do, including
    very large ones,
    >Verizon, for example.

    why would port 80 be blocked? isn't the web traffic
    suppose to go thru this port? thx.

    >
    >2) You may be mistaking the presence of a transparent
    proxy server on your
    >network for actually having port 80 open. RD traffic
    isn't HTTP traffic, so
    >it doesn't work through the proxy.

    so, if this is the case, how can i get around this? thx.


    >
    >It's kind of late, so I'll save you the lecture about
    the risks of incuring
    >the possibly justified rath of your job's IT department.
    >
    >"Steve" <anonymous@discussions.microsoft.com> wrote in
    message
    >news:9d7a01c43442$e2b0a5d0$a601280a@phx.gbl...
    >> thx shenan
    >>
    >> i have reboot my machine at home,
    >> and i have the latest remote desktop client installed
    at
    >> work.
    >>
    >> i tried the command line thingy but it still didn't
    work.
    >>
    >> it has a windows popup saying...
    >>
    >> [remote desktop disconnected]
    >> 'the remote connection has timed out. please try
    >> connecting to the remote computer again.'
    >>
    >> it seems that it has made the outgoing connection,
    >> but cannot get the incoming one. (correct me if i am
    >> wrong.)
    >>
    >>
    >>
    >>
    >>>-----Original Message-----
    >>>Steve wrote:
    >>>> i have winxp pro installed at home and winxp home in
    >> the
    >>>> office.
    >>>>
    >>>> however, all ports except port 80 are blocked in the
    >>>> office.
    >>>> i have already changed the listening port for the
    >> remote
    >>>> desktop at home to port 80.
    >>>> but i still can't connect back home.
    >>>>
    >>>> does anyone know why and how to fix it?
    >>>
    >>>Since you have changed the listening port, I can only
    >> assume you are
    >>>connecting to that port.
    >>>Also, you have rebooted the machine after making your
    >> registry changes?
    >>>
    >>>To be sure, try the command line like the following
    >> example (Start -> Run):
    >>>
    >>>MSTSC /v:<ip address>:port
    >>>
    >>>For example: MSTSC /v:192.168.0.150:80
    >>>
    >>>Of course, your external IP will be different, since
    >> 192.168 is an internal
    >>>only IP.
    >>>
    >>>You may want to get the newest (I believe - correct me
    >> if I am wrong here)
    >>>Remote Desktop Connection Client from here:
    >>>http://www.microsoft.com/downloads/details.aspx?
    >> FamilyID=a8255ffc-4b4a-40e7-a706-
    >> cde7e9b57e79&DisplayLang=en
    >>>
    >>>--
    >>><- Shenan ->
    >>>--
    >>>
    >>>
    >>>.
    >>>
    >
    >
    >.
    >
  5. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    They block it inbound towards customers, not outbound towards the
    webservers. Commercial accounts with fixed IP's aren't blocked, I believe.

    There are some other tunneling methods that may work-but they are nothing I
    have experience with or can describe, I'm afraid. This query comes up
    multiple times a week here--do some reading.


    "Steve" <anonymous@discussions.microsoft.com> wrote in message
    news:ad5001c436a4$94c8a390$a601280a@phx.gbl...
    >
    >>-----Original Message-----
    >>I can give a couple more reasons why this might not work.
    >>
    >>1) your ISP might block port 80. Some do, including
    > very large ones,
    >>Verizon, for example.
    >
    > why would port 80 be blocked? isn't the web traffic
    > suppose to go thru this port? thx.
    >
    >>
    >>2) You may be mistaking the presence of a transparent
    > proxy server on your
    >>network for actually having port 80 open. RD traffic
    > isn't HTTP traffic, so
    >>it doesn't work through the proxy.
    >
    > so, if this is the case, how can i get around this? thx.
    >
    >
    >>
    >>It's kind of late, so I'll save you the lecture about
    > the risks of incuring
    >>the possibly justified rath of your job's IT department.
    >>
    >>"Steve" <anonymous@discussions.microsoft.com> wrote in
    > message
    >>news:9d7a01c43442$e2b0a5d0$a601280a@phx.gbl...
    >>> thx shenan
    >>>
    >>> i have reboot my machine at home,
    >>> and i have the latest remote desktop client installed
    > at
    >>> work.
    >>>
    >>> i tried the command line thingy but it still didn't
    > work.
    >>>
    >>> it has a windows popup saying...
    >>>
    >>> [remote desktop disconnected]
    >>> 'the remote connection has timed out. please try
    >>> connecting to the remote computer again.'
    >>>
    >>> it seems that it has made the outgoing connection,
    >>> but cannot get the incoming one. (correct me if i am
    >>> wrong.)
    >>>
    >>>
    >>>
    >>>
    >>>>-----Original Message-----
    >>>>Steve wrote:
    >>>>> i have winxp pro installed at home and winxp home in
    >>> the
    >>>>> office.
    >>>>>
    >>>>> however, all ports except port 80 are blocked in the
    >>>>> office.
    >>>>> i have already changed the listening port for the
    >>> remote
    >>>>> desktop at home to port 80.
    >>>>> but i still can't connect back home.
    >>>>>
    >>>>> does anyone know why and how to fix it?
    >>>>
    >>>>Since you have changed the listening port, I can only
    >>> assume you are
    >>>>connecting to that port.
    >>>>Also, you have rebooted the machine after making your
    >>> registry changes?
    >>>>
    >>>>To be sure, try the command line like the following
    >>> example (Start -> Run):
    >>>>
    >>>>MSTSC /v:<ip address>:port
    >>>>
    >>>>For example: MSTSC /v:192.168.0.150:80
    >>>>
    >>>>Of course, your external IP will be different, since
    >>> 192.168 is an internal
    >>>>only IP.
    >>>>
    >>>>You may want to get the newest (I believe - correct me
    >>> if I am wrong here)
    >>>>Remote Desktop Connection Client from here:
    >>>>http://www.microsoft.com/downloads/details.aspx?
    >>> FamilyID=a8255ffc-4b4a-40e7-a706-
    >>> cde7e9b57e79&DisplayLang=en
    >>>>
    >>>>--
    >>>><- Shenan ->
    >>>>--
    >>>>
    >>>>
    >>>>.
    >>>>
    >>
    >>
    >>.
    >>
  6. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    In addition to Bill's suggestion, you may want to check with your ISP
    to verify that they are blocking incoming web connections and find out
    what port, if any, they aren't blocking...

    After this, you can reset Remote Desktop to use this port.

    Jeffrey Randow (Windows Net. & Smart Display MVP)
    jeffreyr-support@remotenetworktechnology.com

    Please post all responses to the newsgroups for the benefit
    of all USENET users. Messages sent via email may or may not
    be answered depending on time availability....

    Remote Networking Technology Support Site -
    http://www.remotenetworktechnology.com
    Windows XP Expert Zone - http://www.microsoft.com/windowsxp/expertzone

    On Mon, 10 May 2004 08:36:37 -0700, "Steve"
    <anonymous@discussions.microsoft.com> wrote:

    >
    >>-----Original Message-----
    >>I can give a couple more reasons why this might not work.
    >>
    >>1) your ISP might block port 80. Some do, including
    >very large ones,
    >>Verizon, for example.
    >
    >why would port 80 be blocked? isn't the web traffic
    >suppose to go thru this port? thx.
    >
    >>
    >>2) You may be mistaking the presence of a transparent
    >proxy server on your
    >>network for actually having port 80 open. RD traffic
    >isn't HTTP traffic, so
    >>it doesn't work through the proxy.
    >
    >so, if this is the case, how can i get around this? thx.
    >
    >
    >>
    >>It's kind of late, so I'll save you the lecture about
    >the risks of incuring
    >>the possibly justified rath of your job's IT department.
    >>
    >>"Steve" <anonymous@discussions.microsoft.com> wrote in
    >message
    >>news:9d7a01c43442$e2b0a5d0$a601280a@phx.gbl...
    >>> thx shenan
    >>>
    >>> i have reboot my machine at home,
    >>> and i have the latest remote desktop client installed
    >at
    >>> work.
    >>>
    >>> i tried the command line thingy but it still didn't
    >work.
    >>>
    >>> it has a windows popup saying...
    >>>
    >>> [remote desktop disconnected]
    >>> 'the remote connection has timed out. please try
    >>> connecting to the remote computer again.'
    >>>
    >>> it seems that it has made the outgoing connection,
    >>> but cannot get the incoming one. (correct me if i am
    >>> wrong.)
    >>>
    >>>
    >>>
    >>>
    >>>>-----Original Message-----
    >>>>Steve wrote:
    >>>>> i have winxp pro installed at home and winxp home in
    >>> the
    >>>>> office.
    >>>>>
    >>>>> however, all ports except port 80 are blocked in the
    >>>>> office.
    >>>>> i have already changed the listening port for the
    >>> remote
    >>>>> desktop at home to port 80.
    >>>>> but i still can't connect back home.
    >>>>>
    >>>>> does anyone know why and how to fix it?
    >>>>
    >>>>Since you have changed the listening port, I can only
    >>> assume you are
    >>>>connecting to that port.
    >>>>Also, you have rebooted the machine after making your
    >>> registry changes?
    >>>>
    >>>>To be sure, try the command line like the following
    >>> example (Start -> Run):
    >>>>
    >>>>MSTSC /v:<ip address>:port
    >>>>
    >>>>For example: MSTSC /v:192.168.0.150:80
    >>>>
    >>>>Of course, your external IP will be different, since
    >>> 192.168 is an internal
    >>>>only IP.
    >>>>
    >>>>You may want to get the newest (I believe - correct me
    >>> if I am wrong here)
    >>>>Remote Desktop Connection Client from here:
    >>>>http://www.microsoft.com/downloads/details.aspx?
    >>> FamilyID=a8255ffc-4b4a-40e7-a706-
    >>> cde7e9b57e79&DisplayLang=en
    >>>>
    >>>>--
    >>>><- Shenan ->
    >>>>--
    >>>>
    >>>>
    >>>>.
    >>>>
    >>
    >>
    >>.
    >>
Ask a new question

Read More

Remote Desktop Office Windows XP