Remote desktop disables my sound driver. any ideas ?

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

I have a server computer (xp) with sound card +speakers.
I connect via remote desktop and as soon as i do it
removes the sound driver for playback. i can log onto the
server localy and the sound plays fine, i have tried
everything inc driver and a new sound card. any idea why
windows decides to remove the driver ?
12 answers Last reply
More about remote desktop disables sound driver ideas
  1. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    This is a known issue.. The workaround is to start an audio
    application (like Media Player) before you connect w/ Remote Desktop.
    Once you connect, you should be able to maintain a connection to your
    local audio device.

    BTW: Make sure you have Sound Redirection Left at Remote Computer...

    Jeffrey Randow (Windows Net. & Smart Display MVP)
    jeffreyr-support@remotenetworktechnology.com

    Please post all responses to the newsgroups for the benefit
    of all USENET users. Messages sent via email may or may not
    be answered depending on time availability....

    Remote Networking Technology Support Site -
    http://www.remotenetworktechnology.com
    Windows XP Expert Zone - http://www.microsoft.com/windowsxp/expertzone

    On Mon, 10 May 2004 05:34:58 -0700, "Bri"
    <anonymous@discussions.microsoft.com> wrote:

    >I have a server computer (xp) with sound card +speakers.
    >I connect via remote desktop and as soon as i do it
    >removes the sound driver for playback. i can log onto the
    >server localy and the sound plays fine, i have tried
    >everything inc driver and a new sound card. any idea why
    >windows decides to remove the driver ?
  2. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Thanks Jeffrey

    I was hoping that there was a cure for this problem, I
    will just leave wmediaplayer running and see how that
    goes.
    ----------
    Brian

    >-----Original Message-----
    >This is a known issue.. The workaround is to start an
    audio
    >application (like Media Player) before you connect w/
    Remote Desktop.
    >Once you connect, you should be able to maintain a
    connection to your
    >local audio device.
    >
    >BTW: Make sure you have Sound Redirection Left at
    Remote Computer...
    >
    >Jeffrey Randow (Windows Net. & Smart Display MVP)
    >jeffreyr-support@remotenetworktechnology.com
    >
    >Please post all responses to the newsgroups for the
    benefit
    >of all USENET users. Messages sent via email may or may
    not
    >be answered depending on time availability....
    >
    >Remote Networking Technology Support Site -
    >http://www.remotenetworktechnology.com
    >Windows XP Expert Zone -
    http://www.microsoft.com/windowsxp/expertzone
    >
    >On Mon, 10 May 2004 05:34:58 -0700, "Bri"
    ><anonymous@discussions.microsoft.com> wrote:
    >
    >>I have a server computer (xp) with sound card +speakers.
    >>I connect via remote desktop and as soon as i do it
    >>removes the sound driver for playback. i can log onto
    the
    >>server localy and the sound plays fine, i have tried
    >>everything inc driver and a new sound card. any idea
    why
    >>windows decides to remove the driver ?
    >
    >.
    >
  3. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    The fix is coming... So there is hope.. :)

    Jeffrey Randow (Windows Net. & Smart Display MVP)
    jeffreyr-support@remotenetworktechnology.com

    Please post all responses to the newsgroups for the benefit
    of all USENET users. Messages sent via email may or may not
    be answered depending on time availability....

    Remote Networking Technology Support Site -
    http://www.remotenetworktechnology.com
    Windows XP Expert Zone - http://www.microsoft.com/windowsxp/expertzone

    On Thu, 13 May 2004 06:45:19 -0700,
    <anonymous@discussions.microsoft.com> wrote:

    >Thanks Jeffrey
    >
    >I was hoping that there was a cure for this problem, I
    >will just leave wmediaplayer running and see how that
    >goes.
    >----------
    >Brian
    >
    >>-----Original Message-----
    >>This is a known issue.. The workaround is to start an
    >audio
    >>application (like Media Player) before you connect w/
    >Remote Desktop.
    >>Once you connect, you should be able to maintain a
    >connection to your
    >>local audio device.
    >>
    >>BTW: Make sure you have Sound Redirection Left at
    >Remote Computer...
    >>
    >>Jeffrey Randow (Windows Net. & Smart Display MVP)
    >>jeffreyr-support@remotenetworktechnology.com
    >>
    >>Please post all responses to the newsgroups for the
    >benefit
    >>of all USENET users. Messages sent via email may or may
    >not
    >>be answered depending on time availability....
    >>
    >>Remote Networking Technology Support Site -
    >>http://www.remotenetworktechnology.com
    >>Windows XP Expert Zone -
    >http://www.microsoft.com/windowsxp/expertzone
    >>
    >>On Mon, 10 May 2004 05:34:58 -0700, "Bri"
    >><anonymous@discussions.microsoft.com> wrote:
    >>
    >>>I have a server computer (xp) with sound card +speakers.
    >>>I connect via remote desktop and as soon as i do it
    >>>removes the sound driver for playback. i can log onto
    >the
    >>>server localy and the sound plays fine, i have tried
    >>>everything inc driver and a new sound card. any idea
    >why
    >>>windows decides to remove the driver ?
    >>
    >>.
    >>
  4. Hello, dear music lovers away from home! :sol:

    Before I go any further, I must offer this disclaimer: there is no guarantee that this will actually work every time. It is merely a theory that I have.

    Bring [remote sound] to this computer

    When I leave the house, I leave the computer logged on under someone else's name. When I get to work, I log on as me and just kick off the other "user". (It brings up a box saying something like "User X is logged on. If you continue, X has to disconnect. Are you sure you want to continue?" "Yes" is the response we like here.) The audio has worked every time so far since I started doing that.

    Of course, I usually fail to do consecutive Remote Desktop sessions; I just do one at work and then come back home. Chances are, if you do consecutive remote sessions, the audio will only work so many times before, one time, you log on and, lo and behold, there's that same problem again. But I may try, perhaps later this month when I house-sit for my aunt up north, to enable a remote connection for another user on this computer and then just keep kicking off the other user or myself as necessary. Or perhaps someone else can try this in the meantime and see if it works. :whistle:

    Again, this is just a theory. I still fail to understand the logic of audio not always working the way it ought to via Remote Desktop. But I feel this is worth a shot.

    Best of luck to anyone who has had this problem with the audio drivers and Remote Desktop.

    Peace,
    ~C.A.~
  5. Eww.......sorry, that trick has suddenly ceased to work today.

    GRRRR!!!!

    ~C.A.~
  6. Okay, I put a password on a rarely-used account on here and tried logging on as that user. The audio worked when I did that. I changed back over to myself, and it gave me the same old "Cannot open the audio device" error. Changed back to the other user, it worked! So, today, at least, the audio worked as it should on the one account but not on mine.

    I can only think that it has something to do with how long a user has been logged on for one sitting.....because my username, the audio for which had been working for a while and then today suddenly didn't, had been logged on for a while, whereas the freshly logged-on (via Remote Desktop) alternate account had wonderfully fine audio. (Although I had to go through a few media players because they kept crashing for some reason, but that's another story.)

    Perhaps you shall have to fully log off your user.....in other words, don't merely close Remote Desktop, but actually "Log Off" via the start menu.....and then log on again. Bit of a pain, perhaps.....but I'll try it, possibly tomorrow.

    Further bulletins as events warrant.....

    ~C.A.~
  7. Back from the dead...but has anyone found a solution for this?
  8. Hey again.

    That last thing I said last time I posted....about fully logging off and logging in again?

    That works.

    At least for me it does.

    Kind of a quirk, though: When you're back "home," if you've logged in remotely and disconnected without logging off and then connected "here," the home computer will, for some reason, put password prompts on the other users, even though they don't have passwords. This is, of course, fixed by fully logging off your user account (and you can log in again as desired without consequence).

    I've been doing this for some time now. I still don't know exactly what causes the problem, but I got a good workaround for it anyway. And the problem doesn't always occur. Often, it goes quite a number of flawless days without a hitch. But when there is a hitch, it's easily left in the dust.

    Lotsa luck. I'm off to groom Lucy (the cat). Apparently, this thing will e-mail me if there's a response.

    Rock on,
    ~C.A.~
  9. Well, 2 years on more or less and I have just caught up with this issue re: remote desktop audio problems.
    What I would like to know is, has anyone ever found a solution to this or is the above workaround still the best option?

    Thanks
    Geoff Cooper
    UK
  10. *Might* have found something! This has been frustrating me for many years and the only solution was to login locally, then log out of the session and back in.

    Disable then Reenable Sound device in device manager


    Today, however, I went into Device Manager (Start > Run > compmgmt.msc) under "Sound, video and game controllers" and found my chipset audio (Realtek High Def Audio). Said it was working properly but I click the drop down on "Device usage" and changed it to "Do not use this device (disable)", clicked OK and then go back in and reenable the device.

    I am using Lync and after doing this, Lync (Microsoft Communicator) instantly found my audio! Woo Hoo. Hope this helps someone.
  11. The setting you want is in the RDP connection window, set it to "play audio through remote computer". That will use the remote computers own soundcard.
Ask a new question

Read More

Remote Desktop Sound Driver Windows XP