how to use RDP if only port 80 is free

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

all ports except port 80 are blocked at work. (i think)
i have tried to connect through port 80 but with no luck.

is there any other way to get around this problem?

thx.
6 answers Last reply
More about port free
  1. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Give us some more info. Are you trying to connect INTO work from the
    outside, or into some other location from work. When you say all ports
    except 80 are blocked, is that outbound ports? That's rare. 80 (as you may
    know) is http, having nothing to do with remote desktop (rdp). If outbound
    ports are blocked, then there's nothing you can do. give us the exact
    situation:

    o Where is host computer, what operating system- xp home or xp pro?
    o where is client computer.
    o what firewall/routing devices are you behind at both locations- remote and
    host.

    Paul

    "Steve" <anonymous@discussions.microsoft.com> wrote in message
    news:c1cf01c43840$7965beb0$a001280a@phx.gbl...
    > all ports except port 80 are blocked at work. (i think)
    > i have tried to connect through port 80 but with no luck.
    >
    > is there any other way to get around this problem?
    >
    > thx.
  2. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    >-----Original Message-----
    >Give us some more info. Are you trying to connect INTO
    work from the
    >outside, or into some other location from work. When
    you say all ports
    >except 80 are blocked, is that outbound ports? That's
    rare. 80

    may be i should clarify that all inbound traffic are
    either forwarded to the corresponding ip (i.e. mail and
    stuffs) or forwarded to a 'phantom' machine.

    (as you may
    >know) is http, having nothing to do with remote desktop
    (rdp). If outbound
    >ports are blocked, then there's nothing you can do.
    give us the exact
    >situation:

    trying to connect home from work.

    >
    >o Where is host computer, what operating system- xp home
    or xp pro?

    host computer at home running xp pro

    >o where is client computer.

    client computer at work running xp home

    >o what firewall/routing devices are you behind at both
    locations- remote and
    >host.

    at home, behind zonealarm and already set to allow
    connection from work

    at work, with a linksys router and the sys.adm. has
    control.

    >
    >Paul
    >
    >"Steve" <anonymous@discussions.microsoft.com> wrote in
    message
    >news:c1cf01c43840$7965beb0$a001280a@phx.gbl...
    >> all ports except port 80 are blocked at work. (i think)
    >> i have tried to connect through port 80 but with no
    luck.
    >>
    >> is there any other way to get around this problem?
    >>
    >> thx.
    >
    >
    >.
    >
  3. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    > may be i should clarify that all inbound traffic are
    > either forwarded to the corresponding ip (i.e. mail and
    > stuffs) or forwarded to a 'phantom' machine.

    Ok, that shouldn't be anything to cause you trouble.

    >
    > at home, behind zonealarm and already set to allow
    > connection from work

    For your first test, I would strongly advise disabling zonealarm completely
    to make sure it's not interfering. 2nd, make sure (on both machines) that
    the built in XP firewall is completely disable. This produces a lot of
    headaches for us an our customers whenever there are any connectivity
    issues.

    About Zonealarm, I can say that when I first set up my home network, even
    though I 'knew what I was doing', zonealarm gave me more headaches and would
    cause more headscratching (I suddenly can't connect any more) than it was
    worth. Zonealarms a good program for single computer, but once you have a
    home network behind a router, careful configuration of your router/firewall
    security will do extremely well for protecting yourself.

    The next step would be to attempt to 'ping' your host computer at home and
    see if you get a reply. Again, zonealarm in its default state will block
    all ICMP (ping) traffic and therefore will make it look like there's no
    machine at that address. So again, for the initial testing phase, I
    strongly suggest turning zonealarm off to get a good baseline.

    Lastly, and most simply, make sure the 'terminal services' service is active
    and running on your host machine at home. I read a lot of messages from
    people on this group simply being unable to make an rdp connection to their
    system at home. With XP, this is extremely simple and robust- so I have to
    assume that most of the people here are misunderstanding something subtle
    about network communications or their setup. Let me know what you find and
    we should get you going with little trouble. Good luck.

    Paul

    >
    > at work, with a linksys router and the sys.adm. has
    > control.
    >
    > >
    > >Paul
    > >
    > >"Steve" <anonymous@discussions.microsoft.com> wrote in
    > message
    > >news:c1cf01c43840$7965beb0$a001280a@phx.gbl...
    > >> all ports except port 80 are blocked at work. (i think)
    > >> i have tried to connect through port 80 but with no
    > luck.
    > >>
    > >> is there any other way to get around this problem?
    > >>
    > >> thx.
    > >
    > >
    > >.
    > >
  4. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    >-----Original Message-----
    >> may be i should clarify that all inbound traffic are
    >> either forwarded to the corresponding ip (i.e. mail and
    >> stuffs) or forwarded to a 'phantom' machine.
    >
    >Ok, that shouldn't be anything to cause you trouble.
    >
    >>
    >> at home, behind zonealarm and already set to allow
    >> connection from work
    >
    >For your first test, I would strongly advise disabling
    zonealarm completely
    >to make sure it's not interfering.

    tried, no luck.

    2nd, make sure (on both machines) that
    >the built in XP firewall is completely disable. This
    produces a lot of
    >headaches for us an our customers whenever there are any
    connectivity
    >issues.

    confirmed both machines has the xp firewall disabled.

    >
    >About Zonealarm, I can say that when I first set up my
    home network, even
    >though I 'knew what I was doing', zonealarm gave me more
    headaches and would
    >cause more headscratching (I suddenly can't connect any
    more) than it was
    >worth. Zonealarms a good program for single computer,
    but once you have a
    >home network behind a router, careful configuration of
    your router/firewall
    >security will do extremely well for protecting yourself.
    >
    >The next step would be to attempt to 'ping' your host
    computer at home and
    >see if you get a reply. Again, zonealarm in its default
    state will block
    >all ICMP (ping) traffic and therefore will make it look
    like there's no
    >machine at that address. So again, for the initial
    testing phase, I
    >strongly suggest turning zonealarm off to get a good
    baseline.

    yes, i am able to ping the host computer.

    >
    >Lastly, and most simply, make sure the 'terminal
    services' service is active
    >and running on your host machine at home.

    confirmed rdp is eabled.

    one more note. i was able to connect before, even through
    port 3389 or other ports below 443.

    but i think the system admin. had changed the
    configuration of the router, probably now he decided to
    block all unnecessary ports.

    that's why i wanna connect through the http port now.

    thx.


    >I read a lot of messages from
    >people on this group simply being unable to make an rdp
    connection to their
    >system at home. With XP, this is extremely simple and
    robust- so I have to
    >assume that most of the people here are misunderstanding
    something subtle
    >about network communications or their setup. Let me
    know what you find and
    >we should get you going with little trouble. Good luck.
    >
    >Paul
    >
    >>
    >> at work, with a linksys router and the sys.adm. has
    >> control.
    >>
    >> >
    >> >Paul
    >> >
    >> >"Steve" <anonymous@discussions.microsoft.com> wrote in
    >> message
    >> >news:c1cf01c43840$7965beb0$a001280a@phx.gbl...
    >> >> all ports except port 80 are blocked at work. (i
    think)
    >> >> i have tried to connect through port 80 but with no
    >> luck.
    >> >>
    >> >> is there any other way to get around this problem?
    >> >>
    >> >> thx.
    >> >
    >> >
    >> >.
    >> >
    >
    >
    >.
    >
  5. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    > one more note. i was able to connect before, even through
    > port 3389 or other ports below 443.
    >
    > but i think the system admin. had changed the
    > configuration of the router, probably now he decided to
    > block all unnecessary ports.
    >
    > that's why i wanna connect through the http port now.

    Hmm, it's entirely possible that the admin has disabled outgoing ports- it's
    not common, but that may be what's happening. If other experts intervene, I
    believe that there is a way to force terminal services to 'listen' on
    another port other than 3389-- however, that also means thatyou'd have to
    modify the client to 'talk' on whatever port you modified the listening
    machine. I'll do some searching around and see if any of this is possible.

    Paul
  6. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    >
    > but i think the system admin. had changed the
    > configuration of the router, probably now he decided to
    > block all unnecessary ports.

    Oh, by the way, a bit of social advice. When working in a technology
    company, some lessons drawn from being in the military can actually carry
    over, if you know where to apply them. For instance, almost everyone who's
    been in the miltary will tell you "make friends with the supply sergeant,
    and if possible, the guy who runs the mess hall". My advice would be to
    make friends with the network administrator- it's an important relationship-
    because in these days of internet and remote connectivity he/she is in a
    position to either make your life very, very easy, or very very difficult.

    :)

    Paul
Ask a new question

Read More

Connection Microsoft Windows XP