Linksys router, w/ RD

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

I set my router to forward a special port to my internal
192.168.x.x static IP.

I changed the RD listening port to the same port that is
forwarded, by means of the registry.

This is exact same method I used for VNC, which works
fine (albeit much slower than RD).

RD does not work. Do I need to forward both 3389 and my
special listening port?

Any ideas why VNC works, but RD does not, but yet they
use the same porting methods?

Thanks,

Jeff
5 answers Last reply
More about linksys router
  1. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Some things to look at...

    1. Did you reboot the PC after makiing the registry change?
    2. Can you call the PC over your local home LAN using the new port and connect?
    3. Verify the port forwarding on the Linksys router is working by using this telnet test...The test must be executed from a remote location...

    http://support.microsoft.com/default.aspx?scid=kb;en-us;Q187628

    --
    Al Jarvi (MS-MVP Windows Networking)

    Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
    The MS-MVP Program - http://mvp.support.microsoft.com
    This posting is provided "AS IS" with no warranties, and confers no rights...
  2. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    1. I don't think I rebooted, come to think of it....will
    that make that much of a difference, even if I saved it
    in the registry? I guess it can't hurt to try though.

    2. Yes, Remote Desktop works fine by putting in the
    computer name and running it over LAN.

    3. I'll try the test too, thanks.

    >-----Original Message-----
    >Some things to look at...
    >
    >1. Did you reboot the PC after makiing the registry
    change?
    >2. Can you call the PC over your local home LAN using
    the new port and connect?
    >3. Verify the port forwarding on the Linksys router is
    working by using this telnet test...The test must be
    executed from a remote location...
    >
    >http://support.microsoft.com/default.aspx?scid=kb;en-
    us;Q187628
    >
    >--
    > Al Jarvi (MS-MVP Windows Networking)
    >
    >Please post *ALL* questions and replies to the news
    group for the mutual benefit of all of us...
    >The MS-MVP Program - http://mvp.support.microsoft.com
    >This posting is provided "AS IS" with no warranties, and
    confers no rights...
    >
    >.
    >
  3. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    The port change doe not take effect until you reboot. The service in
    question isn't restartable--and starts with the system.

    <anonymous@discussions.microsoft.com> wrote in message
    news:1058501c43f6d$4991bed0$a301280a@phx.gbl...
    > 1. I don't think I rebooted, come to think of it....will
    > that make that much of a difference, even if I saved it
    > in the registry? I guess it can't hurt to try though.
    >
    > 2. Yes, Remote Desktop works fine by putting in the
    > computer name and running it over LAN.
    >
    > 3. I'll try the test too, thanks.
    >
    >>-----Original Message-----
    >>Some things to look at...
    >>
    >>1. Did you reboot the PC after makiing the registry
    > change?
    >>2. Can you call the PC over your local home LAN using
    > the new port and connect?
    >>3. Verify the port forwarding on the Linksys router is
    > working by using this telnet test...The test must be
    > executed from a remote location...
    >>
    >>http://support.microsoft.com/default.aspx?scid=kb;en-
    > us;Q187628
    >>
    >>--
    >> Al Jarvi (MS-MVP Windows Networking)
    >>
    >>Please post *ALL* questions and replies to the news
    > group for the mutual benefit of all of us...
    >>The MS-MVP Program - http://mvp.support.microsoft.com
    >>This posting is provided "AS IS" with no warranties, and
    > confers no rights...
    >>
    >>.
    >>
  4. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    That did it! Boy, was that a noob mistake. Thanks so
    much, it works great now.

    >-----Original Message-----
    >The port change doe not take effect until you reboot.
    The service in
    >question isn't restartable--and starts with the system.
    >
    ><anonymous@discussions.microsoft.com> wrote in message
    >news:1058501c43f6d$4991bed0$a301280a@phx.gbl...
    >> 1. I don't think I rebooted, come to think of
    it....will
    >> that make that much of a difference, even if I saved it
    >> in the registry? I guess it can't hurt to try though.
    >>
    >> 2. Yes, Remote Desktop works fine by putting in the
    >> computer name and running it over LAN.
    >>
    >> 3. I'll try the test too, thanks.
    >>
    >>>-----Original Message-----
    >>>Some things to look at...
    >>>
    >>>1. Did you reboot the PC after makiing the registry
    >> change?
    >>>2. Can you call the PC over your local home LAN using
    >> the new port and connect?
    >>>3. Verify the port forwarding on the Linksys router is
    >> working by using this telnet test...The test must be
    >> executed from a remote location...
    >>>
    >>>http://support.microsoft.com/default.aspx?scid=kb;en-
    >> us;Q187628
    >>>
    >>>--
    >>> Al Jarvi (MS-MVP Windows Networking)
    >>>
    >>>Please post *ALL* questions and replies to the news
    >> group for the mutual benefit of all of us...
    >>>The MS-MVP Program - http://mvp.support.microsoft.com
    >>>This posting is provided "AS IS" with no warranties,
    and
    >> confers no rights...
    >>>
    >>>.
    >>>
    >
    >
    >.
    >
  5. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    More and more stuff doesn't require a restart--this is a goal, for
    operations that the average user needs to do. This one probably doesn't fit
    that category, though.

    <anonymous@discussions.microsoft.com> wrote in message
    news:10ca701c440c6$eb96b000$a101280a@phx.gbl...
    > That did it! Boy, was that a noob mistake. Thanks so
    > much, it works great now.
    >
    >>-----Original Message-----
    >>The port change doe not take effect until you reboot.
    > The service in
    >>question isn't restartable--and starts with the system.
    >>
    >><anonymous@discussions.microsoft.com> wrote in message
    >>news:1058501c43f6d$4991bed0$a301280a@phx.gbl...
    >>> 1. I don't think I rebooted, come to think of
    > it....will
    >>> that make that much of a difference, even if I saved it
    >>> in the registry? I guess it can't hurt to try though.
    >>>
    >>> 2. Yes, Remote Desktop works fine by putting in the
    >>> computer name and running it over LAN.
    >>>
    >>> 3. I'll try the test too, thanks.
    >>>
    >>>>-----Original Message-----
    >>>>Some things to look at...
    >>>>
    >>>>1. Did you reboot the PC after makiing the registry
    >>> change?
    >>>>2. Can you call the PC over your local home LAN using
    >>> the new port and connect?
    >>>>3. Verify the port forwarding on the Linksys router is
    >>> working by using this telnet test...The test must be
    >>> executed from a remote location...
    >>>>
    >>>>http://support.microsoft.com/default.aspx?scid=kb;en-
    >>> us;Q187628
    >>>>
    >>>>--
    >>>> Al Jarvi (MS-MVP Windows Networking)
    >>>>
    >>>>Please post *ALL* questions and replies to the news
    >>> group for the mutual benefit of all of us...
    >>>>The MS-MVP Program - http://mvp.support.microsoft.com
    >>>>This posting is provided "AS IS" with no warranties,
    > and
    >>> confers no rights...
    >>>>
    >>>>.
    >>>>
    >>
    >>
    >>.
    >>
Ask a new question

Read More

Routers Linksys Microsoft Windows XP