Sign in with
Sign up | Sign in
Your question

Remote Desktop Connection Only Works One Way

Last response: in Windows XP
Share
Anonymous
a b D Laptop
May 28, 2004 2:52:37 PM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Hi All,

I'm trying to setup my home desktop to accept incoming
remote desktop connections. My intent is to connect to my
desktop from my laptop when I'm away from home. However, I
can't get it to work. Here's the problem, everytime I try
to connect to my desktop from the laptop I get the error
message that, "The client could not connect to the remote
computer. Remote connections might not be enabled...." The
strange part is, I can connect to my laptop from my desktop
just fine. The settings are the same for both computers.
I'm running XP Pro on both systems. I turned off the
firewall for testing purposes. As a matter of fact, the
only difference between the two systems is the way I'm
connecting to the interenet. The desktop is using a
broadband connection (Bellsouth DSL), and the laptop is
using a dialup connection (Bellsouth Dialup). Does anybody
have a clue why the Remote Desktop Connection is working in
one direction but not the other even though all the
settings are the same for both computers? BTW I also tried
to connect to a friend in England who is using a broadband
connection, a cable modem setup. It didn't work in either
direction either. Is there special settings for broadband
connections or something? If anybody can provide some help,
I'd appreciate it.
May 28, 2004 6:30:46 PM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

>-----Original Message-----
>Hi All,
>
>I'm trying to setup my home desktop to accept incoming
>remote desktop connections. My intent is to connect to my
>desktop from my laptop when I'm away from home. However,
I
>can't get it to work. Here's the problem, everytime I try
>to connect to my desktop from the laptop I get the error
>message that, "The client could not connect to the remote
>computer. Remote connections might not be enabled...."
The
>strange part is, I can connect to my laptop from my
desktop
>just fine. The settings are the same for both computers.
>I'm running XP Pro on both systems. I turned off the
>firewall for testing purposes. As a matter of fact, the
>only difference between the two systems is the way I'm
>connecting to the interenet. The desktop is using a
>broadband connection (Bellsouth DSL), and the laptop is
>using a dialup connection (Bellsouth Dialup). Does
anybody
>have a clue why the Remote Desktop Connection is working
in
>one direction but not the other even though all the
>settings are the same for both computers? BTW I also
tried
>to connect to a friend in England who is using a
broadband
>connection, a cable modem setup. It didn't work in either
>direction either. Is there special settings for broadband
>connections or something? If anybody can provide some
help,
>I'd appreciate it.
>.
>
Is the remote desktop installed on the laptop? If not go
to install add/remove software->windows components->
select Internet Information systems click detail select
World wide web service click detail check remote desktop
web connection and install it.
Also if it is installed already or after you have
installed it the first time go to system properties
select the remote tab and check the "Allow user to
connect to this computer remotely" checkbox. With you
friend in England if he has a firewall/router he may need
To open port 3389 to allow RDP to connect.

Craig
May 29, 2004 6:35:16 AM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

I just had (and resolved) the same problem yesterday.
After three days of wondering, testing, and question
asking to all the right (and sometimes wrong) network
administrators in various GOVERNMENT agencies, I hit
paydirt.

I have two home towers. Both have XP Pro. Computer(A) is
connected via Verizon Online DSL. Computer(B) was
connected via NetZero dial-up (for testing purposes). (A)
could RDC (B) but not vice-versa.

The IP Address that NetZero assigned (B) was a legitimate
(public) IP Address (although short-lived because NetZero
will timeout rather quickly if system remains idle, thus
requiring you to restart the NetZero connection and be
assigned a new temporary IP Address).

The IP Address that was assigned to (A) was from a private
series (192.168.*.*) of IP addresses set by a DHCP through
my DSL modem. (i.e. - my modem also acts as a kind of
router). What does that mean? That means my (real)
public IP Address was being hidden for some ungodly
reason. I went to my command prompt and
typed "ipconfig". I found out my default gateway and
typed it in the address bar on Internet Explorer
(http://192.168.*.*). This gave me a login prompt to
input the username and password I initially used to
activate my modem & DSL service allowing me access to all
kinds of system and configuration info from Westell (my
modem manufacturer). I found out their DNS info and got
them to assign my modem a single (public) static IP
Address. I then manually assigned the new static IP
Address and DNS info to my computer versus allowing it to
automatically obtain both. And voila!!! Problem solved.
I can either activate ICF and be sure to allow remote
desktop traffic, or I can choose to not activate ICF and
flow smoothly either way.

Now, there is no guarantee that you will be able to take
the same steps to obtain a legitimate IP. But if your IP
Address starts with 192.168.*.*, you definitely need to
change it in order to remotely access your computer. You
may have to contact your ISP and find out from them what
your true IP Address is and manually reconfigure your
system.

Good luck... Hope this was helpful.

>-----Original Message-----
>Hi All,
>
>I'm trying to setup my home desktop to accept incoming
>remote desktop connections. My intent is to connect to my
>desktop from my laptop when I'm away from home. However, I
>can't get it to work. Here's the problem, everytime I try
>to connect to my desktop from the laptop I get the error
>message that, "The client could not connect to the remote
>computer. Remote connections might not be enabled...." The
>strange part is, I can connect to my laptop from my
desktop
>just fine. The settings are the same for both computers.
>I'm running XP Pro on both systems. I turned off the
>firewall for testing purposes. As a matter of fact, the
>only difference between the two systems is the way I'm
>connecting to the interenet. The desktop is using a
>broadband connection (Bellsouth DSL), and the laptop is
>using a dialup connection (Bellsouth Dialup). Does anybody
>have a clue why the Remote Desktop Connection is working
in
>one direction but not the other even though all the
>settings are the same for both computers? BTW I also tried
>to connect to a friend in England who is using a broadband
>connection, a cable modem setup. It didn't work in either
>direction either. Is there special settings for broadband
>connections or something? If anybody can provide some
help,
>I'd appreciate it.
!