Remote Desktop on SSH tunnel

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

I'm trying to establish a remote desktop session trough a
SSH tunnel I enable the port 3389 to be forwarded and
locally I connect to the port 2500 so when I try the
connection with my pc which have windows XP professional I
got an error like
"The Client Could not connect. You are alreary connected
to the console of thi computer. A new console session
cannot be established".

When I try from another PC which have Win2k it works fine.
Best Regards,
Alberto
5 answers Last reply
More about remote desktop tunnel
  1. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    See this page for help with this issue...

    http://www.remotenetworktechnology.com/ow.asp?Remote%5FNetwork%5FHome%2FRemoteDesktop%2FFrequentlyAskedQuestionsPage#h23

    --
    Al Jarvi (MS-MVP Windows Networking)

    Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
    The MS-MVP Program - http://mvp.support.microsoft.com
    This posting is provided "AS IS" with no warranties, and confers no rights...

    "Alberto Ferrari" <alberto.ferrari@sunrisetelecom.it> wrote in message
    news:191dc01c44c60$446bbfa0$a001280a@phx.gbl...
    > I'm trying to establish a remote desktop session trough a
    > SSH tunnel I enable the port 3389 to be forwarded and
    > locally I connect to the port 2500 so when I try the
    > connection with my pc which have windows XP professional I
    > got an error like
    > "The Client Could not connect. You are alreary connected
    > to the console of thi computer. A new console session
    > cannot be established".
    >
    > When I try from another PC which have Win2k it works fine.
    > Best Regards,
    > Alberto


    ---
    Outgoing mail is certified Virus Free.
    Checked by AVG anti-virus system (http://www.grisoft.com).
    Version: 6.0.700 / Virus Database: 457 - Release Date: 6/6/2004
  2. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    "Alberto Ferrari" <alberto.ferrari@sunrisetelecom.it> wrote in message
    news:191dc01c44c60$446bbfa0$a001280a@phx.gbl...
    | I'm trying to establish a remote desktop session trough a
    | SSH tunnel I enable the port 3389 to be forwarded and
    | locally I connect to the port 2500 so when I try the
    | connection with my pc which have windows XP professional I
    | got an error like
    | "The Client Could not connect. You are alreary connected
    | to the console of thi computer. A new console session
    | cannot be established".
    |
    | When I try from another PC which have Win2k it works fine.
    | Best Regards,
    | Alberto

    Use putty to do the port forwarding and connect on the local machine to
    127.0.0.2:2500. The RD client in XP doesn't like being connected to
    127.0.0.1 or localhost (which are the same thing) but does not complain when
    using 127.0.0.2. The latest version of putty is required for this IIRC.

    --
    Chris Lewis
  3. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    "Alberto Ferrari" <alberto.ferrari@sunrisetelecom.it> wrote in message news:<191dc01c44c60$446bbfa0$a001280a@phx.gbl>...
    > I'm trying to establish a remote desktop session trough a
    > SSH tunnel I enable the port 3389 to be forwarded and
    > locally I connect to the port 2500 so when I try the
    > connection with my pc which have windows XP professional I
    > got an error like
    > "The Client Could not connect. You are alreary connected
    > to the console of thi computer. A new console session
    > cannot be established".
    >
    > When I try from another PC which have Win2k it works fine.
    > Best Regards,
    > Alberto

    Alberto -
    Please take a look at my website http://www.wissh.com for two things:
    On the technology page, it will explain what is going wrong, and two,
    you can download the client I wrote to get around this problem.

    Hope this helps,
    Chad Amberg
  4. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    or wait for SP2, which will fix this issue... :)

    Jeffrey Randow (Windows Networking & Smart Display MVP)
    jeffreyr-support@remotenetworktechnology.com

    Please post all responses to the newsgroups for the benefit
    of all USENET users. Messages sent via email may or may not
    be answered depending on time availability....

    Remote Networking Technology Support Site -
    http://www.remotenetworktechnology.com
    Windows XP Expert Zone - http://www.microsoft.com/windowsxp/expertzone

    On Mon, 7 Jun 2004 00:23:02 -0700, "Alberto Ferrari"
    <alberto.ferrari@sunrisetelecom.it> wrote:

    >I'm trying to establish a remote desktop session trough a
    >SSH tunnel I enable the port 3389 to be forwarded and
    >locally I connect to the port 2500 so when I try the
    >connection with my pc which have windows XP professional I
    >got an error like
    >"The Client Could not connect. You are alreary connected
    >to the console of thi computer. A new console session
    >cannot be established".
    >
    >When I try from another PC which have Win2k it works fine.
    >Best Regards,
    >Alberto
  5. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Al

    Thanks - that worked perfectly for my XP Professional

    Chris
Ask a new question

Read More

Remote Desktop Tunnel Connection Windows XP