RDC fails after Wake-On-LAN event

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Hello,

I have a PC at work with a static IP address. For several months I've been
using OpenVPN to connect from home. I can easily run Remote Desktop
Connection over this OpenVPN connection.

Now that it's summer, I wanna reduce the amount of heat produced in my
office. So I want my PC to go into standby after half an hour of non use.
But this is where things go wrong. And this is very wierd. RDC seems to
crash for no apparent reason when I wake my sleeping office PC from home.
Has anyone else had this problem? Is there a fix? Here's the procedure
that causes the crash:

A1) Before leaving work I log off and put my PC into standby.
A2) At home, I send a magic packet to my office PC to wake it up.
A3) After a few seconds, my OpenVPN client successfully connects to my
office
PC. This proves the magic packet works.
A4) I can now browse my office PC's shared folders and ping it. This proves
the OpenVPN connection works.
A5) When I launch RDC, it crashes on the login page. My home computer won't
let me do anything (not even control-alt-delete). After a few minutes the
RDC client exits without any error message.
A6) When I get back to work, I find my office PC has crashed and I have to
do
a hard-reset.

Also, this doesn't work:

B) Do exactly the same as above but from a PC at work (not using OpenVPN).
The PC successfully comes out of standby and but RDC crashes. This suggests
that the problem I'm experiencing has nothing to do with OpenVPN. Instead,
I fear the problem is that the RDC server dislikes being woken from standby
by WOL.

These things do work:

1) Do exactly the same as the failing procedure (A1-A6) but shutdown the PC
fully
(ACPI state S5) instead of putting it into standby. I can boot my PC from
home, initiate OpenVPN and run RDC
without fail. This proves the magic packet can be sent successfully from
home and that the OpenVPN is configured correctly.

2) Do exactly the same as in B but wake my PC by pressing a button on the
keyboard. I then connect via RDC from another machine. This works fine.

So, my question is: why does RDC fail specifically when I wake my office PC
from standby using Wake-On-LAN?

My config is:

Office PC
- Windows XP Pro SP1 fully patched
- OpenVPN 1.6
- Intel D875PBZ motherboard with onboard Intel gigabit Ethernet adapter
(most recent drivers & Intel PROset)
- I've set the BIOS to allow the Ethernet adapter to wake the PC
- The BIOS is set to put the PC into ACPI state S3 (suspend to RAM) when the
OS asks for "standby".
- Running Kerio personal firewall. It's configured to allow the relevant
OpenVPN and RDC connections.
- My institute has a hardware firewall with 2 incoming ports open - one for
the magic packet and one for the OpenVPN connection.
- PROset connections: "Enable PME = hardware default"; "Wake On Link
Settings = disabled"; "Wake On Settings = OS Controlled"

Home PC
- Windows XP Pro SP1 fully patched
- OpenVPN 1.6
- 3Com 802.11g wireless network
- Pipex 512k ADSL connection
- Hardware router

Thanks,
Jack
6 answers Last reply
More about fails wake event
  1. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    If you change the video to (yecch) standard VGA, or something you can stand
    that isn't the latest and greatest, does it change the behavior.

    I hear what you are saying, but I'm inclined to give a passing grade to the
    nic and drivers, since the VPN functionality seems to be perfect. That
    leads me to think about the video drivers next--perhaps irrationally. What
    video? If Nvidia, do you have their client service running? What happens
    if you disable that service?

    "Daniel Kelly (AKA Jack)" <d.kellyNOSPAM@NOSPAM.ucl.ac.uk> wrote in message
    news:cakfgv$1mgc$1@uns-a.ucl.ac.uk...
    > Hello,
    >
    > I have a PC at work with a static IP address. For several months I've
    > been
    > using OpenVPN to connect from home. I can easily run Remote Desktop
    > Connection over this OpenVPN connection.
    >
    > Now that it's summer, I wanna reduce the amount of heat produced in my
    > office. So I want my PC to go into standby after half an hour of non use.
    > But this is where things go wrong. And this is very wierd. RDC seems to
    > crash for no apparent reason when I wake my sleeping office PC from home.
    > Has anyone else had this problem? Is there a fix? Here's the procedure
    > that causes the crash:
    >
    > A1) Before leaving work I log off and put my PC into standby.
    > A2) At home, I send a magic packet to my office PC to wake it up.
    > A3) After a few seconds, my OpenVPN client successfully connects to my
    > office
    > PC. This proves the magic packet works.
    > A4) I can now browse my office PC's shared folders and ping it. This
    > proves
    > the OpenVPN connection works.
    > A5) When I launch RDC, it crashes on the login page. My home computer
    > won't
    > let me do anything (not even control-alt-delete). After a few minutes the
    > RDC client exits without any error message.
    > A6) When I get back to work, I find my office PC has crashed and I have to
    > do
    > a hard-reset.
    >
    > Also, this doesn't work:
    >
    > B) Do exactly the same as above but from a PC at work (not using OpenVPN).
    > The PC successfully comes out of standby and but RDC crashes. This
    > suggests
    > that the problem I'm experiencing has nothing to do with OpenVPN.
    > Instead,
    > I fear the problem is that the RDC server dislikes being woken from
    > standby
    > by WOL.
    >
    > These things do work:
    >
    > 1) Do exactly the same as the failing procedure (A1-A6) but shutdown the
    > PC
    > fully
    > (ACPI state S5) instead of putting it into standby. I can boot my PC from
    > home, initiate OpenVPN and run RDC
    > without fail. This proves the magic packet can be sent successfully from
    > home and that the OpenVPN is configured correctly.
    >
    > 2) Do exactly the same as in B but wake my PC by pressing a button on the
    > keyboard. I then connect via RDC from another machine. This works fine.
    >
    > So, my question is: why does RDC fail specifically when I wake my office
    > PC
    > from standby using Wake-On-LAN?
    >
    > My config is:
    >
    > Office PC
    > - Windows XP Pro SP1 fully patched
    > - OpenVPN 1.6
    > - Intel D875PBZ motherboard with onboard Intel gigabit Ethernet adapter
    > (most recent drivers & Intel PROset)
    > - I've set the BIOS to allow the Ethernet adapter to wake the PC
    > - The BIOS is set to put the PC into ACPI state S3 (suspend to RAM) when
    > the
    > OS asks for "standby".
    > - Running Kerio personal firewall. It's configured to allow the relevant
    > OpenVPN and RDC connections.
    > - My institute has a hardware firewall with 2 incoming ports open - one
    > for
    > the magic packet and one for the OpenVPN connection.
    > - PROset connections: "Enable PME = hardware default"; "Wake On Link
    > Settings = disabled"; "Wake On Settings = OS Controlled"
    >
    > Home PC
    > - Windows XP Pro SP1 fully patched
    > - OpenVPN 1.6
    > - 3Com 802.11g wireless network
    > - Pipex 512k ADSL connection
    > - Hardware router
    >
    > Thanks,
    > Jack
    >
    >
    >
    >
    >
  2. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Hi Bill,

    Thanks loads for your reply.

    You're right, my video could well be to blame. I have a Matrox P750 (latest
    drivers) graphics card and a Matrox RT.X10 video editing card. But the
    RT.X10 is disabled in the hardware profile I use for day-to-day stuff.

    I will try tinkering around with the video ASAP and get back to you.

    Thanks,
    Jack


    "Bill Sanderson" <Bill_Sanderson@msn.com.plugh.org> wrote in message
    news:ecyBljiUEHA.2972@TK2MSFTNGP12.phx.gbl...
    > If you change the video to (yecch) standard VGA, or something you can
    stand
    > that isn't the latest and greatest, does it change the behavior.
    >
    > I hear what you are saying, but I'm inclined to give a passing grade to
    the
    > nic and drivers, since the VPN functionality seems to be perfect. That
    > leads me to think about the video drivers next--perhaps irrationally.
    What
    > video? If Nvidia, do you have their client service running? What happens
    > if you disable that service?
    >
    > "Daniel Kelly (AKA Jack)" <d.kellyNOSPAM@NOSPAM.ucl.ac.uk> wrote in
    message
    > news:cakfgv$1mgc$1@uns-a.ucl.ac.uk...
    > > Hello,
    > >
    > > I have a PC at work with a static IP address. For several months I've
    > > been
    > > using OpenVPN to connect from home. I can easily run Remote Desktop
    > > Connection over this OpenVPN connection.
    > >
    > > Now that it's summer, I wanna reduce the amount of heat produced in my
    > > office. So I want my PC to go into standby after half an hour of non
    use.
    > > But this is where things go wrong. And this is very wierd. RDC seems
    to
    > > crash for no apparent reason when I wake my sleeping office PC from
    home.
    > > Has anyone else had this problem? Is there a fix? Here's the procedure
    > > that causes the crash:
    > >
    > > A1) Before leaving work I log off and put my PC into standby.
    > > A2) At home, I send a magic packet to my office PC to wake it up.
    > > A3) After a few seconds, my OpenVPN client successfully connects to my
    > > office
    > > PC. This proves the magic packet works.
    > > A4) I can now browse my office PC's shared folders and ping it. This
    > > proves
    > > the OpenVPN connection works.
    > > A5) When I launch RDC, it crashes on the login page. My home computer
    > > won't
    > > let me do anything (not even control-alt-delete). After a few minutes
    the
    > > RDC client exits without any error message.
    > > A6) When I get back to work, I find my office PC has crashed and I have
    to
    > > do
    > > a hard-reset.
    > >
    > > Also, this doesn't work:
    > >
    > > B) Do exactly the same as above but from a PC at work (not using
    OpenVPN).
    > > The PC successfully comes out of standby and but RDC crashes. This
    > > suggests
    > > that the problem I'm experiencing has nothing to do with OpenVPN.
    > > Instead,
    > > I fear the problem is that the RDC server dislikes being woken from
    > > standby
    > > by WOL.
    > >
    > > These things do work:
    > >
    > > 1) Do exactly the same as the failing procedure (A1-A6) but shutdown the
    > > PC
    > > fully
    > > (ACPI state S5) instead of putting it into standby. I can boot my PC
    from
    > > home, initiate OpenVPN and run RDC
    > > without fail. This proves the magic packet can be sent successfully
    from
    > > home and that the OpenVPN is configured correctly.
    > >
    > > 2) Do exactly the same as in B but wake my PC by pressing a button on
    the
    > > keyboard. I then connect via RDC from another machine. This works
    fine.
    > >
    > > So, my question is: why does RDC fail specifically when I wake my office
    > > PC
    > > from standby using Wake-On-LAN?
    > >
    > > My config is:
    > >
    > > Office PC
    > > - Windows XP Pro SP1 fully patched
    > > - OpenVPN 1.6
    > > - Intel D875PBZ motherboard with onboard Intel gigabit Ethernet adapter
    > > (most recent drivers & Intel PROset)
    > > - I've set the BIOS to allow the Ethernet adapter to wake the PC
    > > - The BIOS is set to put the PC into ACPI state S3 (suspend to RAM) when
    > > the
    > > OS asks for "standby".
    > > - Running Kerio personal firewall. It's configured to allow the
    relevant
    > > OpenVPN and RDC connections.
    > > - My institute has a hardware firewall with 2 incoming ports open - one
    > > for
    > > the magic packet and one for the OpenVPN connection.
    > > - PROset connections: "Enable PME = hardware default"; "Wake On Link
    > > Settings = disabled"; "Wake On Settings = OS Controlled"
    > >
    > > Home PC
    > > - Windows XP Pro SP1 fully patched
    > > - OpenVPN 1.6
    > > - 3Com 802.11g wireless network
    > > - Pipex 512k ADSL connection
    > > - Hardware router
    > >
    > > Thanks,
    > > Jack
    > >
    > >
    > >
    > >
    > >
    >
    >
  3. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    "Daniel Kelly \(AKA Jack\)" <d.kellyNOSPAM@NOSPAM.ucl.ac.uk> wrote in message news:<camjr3$23uu$1@uns-a.ucl.ac.uk>...
    > Hi Bill,
    >
    > Thanks loads for your reply.
    >
    > You're right, my video could well be to blame. I have a Matrox P750 (latest
    > drivers) graphics card and a Matrox RT.X10 video editing card. But the
    > RT.X10 is disabled in the hardware profile I use for day-to-day stuff.
    >
    > I will try tinkering around with the video ASAP and get back to you.
    >
    > Thanks,
    > Jack
    >

    Hi Jack and Bill

    Did you get anywhere with this? Was the video to blame?
    I have (more or less) exactly the same problem.

    Cheers

    Lewis
  4. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Hi,

    No, I haven't progressed much. I'll do some more experiments tonight ( ~7pm
    GMT)

    I've posted on the Matrox forum and they've replied... you can see my thred
    here:

    http://forum.matrox.com/mga/viewtopic.php?p=52437

    Lewis, do you have a Matrox graphics card too? If so, which drivers are you
    using? The most recent?

    Thanks,
    Jack


    "Lewis Veale" <lewis.veale@pdms.com> wrote in message
    news:b99df28.0406151236.3158942b@posting.google.com...
    > "Daniel Kelly \(AKA Jack\)" <d.kellyNOSPAM@NOSPAM.ucl.ac.uk> wrote in
    message news:<camjr3$23uu$1@uns-a.ucl.ac.uk>...
    > > Hi Bill,
    > >
    > > Thanks loads for your reply.
    > >
    > > You're right, my video could well be to blame. I have a Matrox P750
    (latest
    > > drivers) graphics card and a Matrox RT.X10 video editing card. But the
    > > RT.X10 is disabled in the hardware profile I use for day-to-day stuff.
    > >
    > > I will try tinkering around with the video ASAP and get back to you.
    > >
    > > Thanks,
    > > Jack
    > >
    >
    > Hi Jack and Bill
    >
    > Did you get anywhere with this? Was the video to blame?
    > I have (more or less) exactly the same problem.
    >
    > Cheers
    >
    > Lewis
  5. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Hi,

    OK - here's my report back after tinkering a little...

    The only thing that works is this:

    1) Remotely log into office machine using RDC. Then log off.
    2) Put office machine into standby (this has to be done locally)
    3) Now I can wake my office machine using WOL and successfully connect using
    RDC.
    4) This trick stops working as soon as I log in locally.

    Things I've tried (but with no luck) include:
    - Tinkering with every WOL-related setting in the Intel proSET application
    - Tinkering with every WOL-related setting in the BIOS
    - Turning off all the accelerated graphics functions on my PC (this stops
    Matrox Powerdesk from loading, I believe)
    - Connecting with the lowest graphics specs

    Please - anyone got any ideas why my office machine wont let me wake-on-lan
    and the connect via Remote Desktop Connection?

    Many thanks,
    Jack


    "Daniel Kelly (AKA Jack)" <d.kellyNOSPAM@NOSPAM.ucl.ac.uk> wrote in message
    news:cap52f$lfk$1@uns-a.ucl.ac.uk...
    > Hi,
    >
    > No, I haven't progressed much. I'll do some more experiments tonight (
    ~7pm
    > GMT)
    >
    > I've posted on the Matrox forum and they've replied... you can see my
    thred
    > here:
    >
    > http://forum.matrox.com/mga/viewtopic.php?p=52437
    >
    > Lewis, do you have a Matrox graphics card too? If so, which drivers are
    you
    > using? The most recent?
    >
    > Thanks,
    > Jack
    >
    >
    >
    > "Lewis Veale" <lewis.veale@pdms.com> wrote in message
    > news:b99df28.0406151236.3158942b@posting.google.com...
    > > "Daniel Kelly \(AKA Jack\)" <d.kellyNOSPAM@NOSPAM.ucl.ac.uk> wrote in
    > message news:<camjr3$23uu$1@uns-a.ucl.ac.uk>...
    > > > Hi Bill,
    > > >
    > > > Thanks loads for your reply.
    > > >
    > > > You're right, my video could well be to blame. I have a Matrox P750
    > (latest
    > > > drivers) graphics card and a Matrox RT.X10 video editing card. But
    the
    > > > RT.X10 is disabled in the hardware profile I use for day-to-day stuff.
    > > >
    > > > I will try tinkering around with the video ASAP and get back to you.
    > > >
    > > > Thanks,
    > > > Jack
    > > >
    > >
    > > Hi Jack and Bill
    > >
    > > Did you get anywhere with this? Was the video to blame?
    > > I have (more or less) exactly the same problem.
    > >
    > > Cheers
    > >
    > > Lewis
    >
    >
  6. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    I'm afraid I lost track of this one.

    When I use WOL, I use it with the machines in an OFF condition--not on
    standby.

    Have you tested this way? They need to be switched off, rather than powered
    off by a power strip.


    "Daniel Kelly (AKA Jack)" <d.kellyNOSPAM@NOSPAM.ucl.ac.uk> wrote in message
    news:casslg$306c$1@uns-a.ucl.ac.uk...
    > Hi,
    >
    > OK - here's my report back after tinkering a little...
    >
    > The only thing that works is this:
    >
    > 1) Remotely log into office machine using RDC. Then log off.
    > 2) Put office machine into standby (this has to be done locally)
    > 3) Now I can wake my office machine using WOL and successfully connect
    > using
    > RDC.
    > 4) This trick stops working as soon as I log in locally.
    >
    > Things I've tried (but with no luck) include:
    > - Tinkering with every WOL-related setting in the Intel proSET application
    > - Tinkering with every WOL-related setting in the BIOS
    > - Turning off all the accelerated graphics functions on my PC (this stops
    > Matrox Powerdesk from loading, I believe)
    > - Connecting with the lowest graphics specs
    >
    > Please - anyone got any ideas why my office machine wont let me
    > wake-on-lan
    > and the connect via Remote Desktop Connection?
    >
    > Many thanks,
    > Jack
    >
    >
    >
    > "Daniel Kelly (AKA Jack)" <d.kellyNOSPAM@NOSPAM.ucl.ac.uk> wrote in
    > message
    > news:cap52f$lfk$1@uns-a.ucl.ac.uk...
    >> Hi,
    >>
    >> No, I haven't progressed much. I'll do some more experiments tonight (
    > ~7pm
    >> GMT)
    >>
    >> I've posted on the Matrox forum and they've replied... you can see my
    > thred
    >> here:
    >>
    >> http://forum.matrox.com/mga/viewtopic.php?p=52437
    >>
    >> Lewis, do you have a Matrox graphics card too? If so, which drivers are
    > you
    >> using? The most recent?
    >>
    >> Thanks,
    >> Jack
    >>
    >>
    >>
    >> "Lewis Veale" <lewis.veale@pdms.com> wrote in message
    >> news:b99df28.0406151236.3158942b@posting.google.com...
    >> > "Daniel Kelly \(AKA Jack\)" <d.kellyNOSPAM@NOSPAM.ucl.ac.uk> wrote in
    >> message news:<camjr3$23uu$1@uns-a.ucl.ac.uk>...
    >> > > Hi Bill,
    >> > >
    >> > > Thanks loads for your reply.
    >> > >
    >> > > You're right, my video could well be to blame. I have a Matrox P750
    >> (latest
    >> > > drivers) graphics card and a Matrox RT.X10 video editing card. But
    > the
    >> > > RT.X10 is disabled in the hardware profile I use for day-to-day
    >> > > stuff.
    >> > >
    >> > > I will try tinkering around with the video ASAP and get back to you.
    >> > >
    >> > > Thanks,
    >> > > Jack
    >> > >
    >> >
    >> > Hi Jack and Bill
    >> >
    >> > Did you get anywhere with this? Was the video to blame?
    >> > I have (more or less) exactly the same problem.
    >> >
    >> > Cheers
    >> >
    >> > Lewis
    >>
    >>
    >
    >
Ask a new question

Read More

Connection OpenVPN Windows XP