Playing back DVD on PC: black picture on external screen?

Archived from groups: alt.video.dvd.software,rec.video.desktop,alt.home-theater.misc,rec.video.dvd.tech (More info?)

I am experiencing a stange problem when playing back DVDs on my IBM
ThinkPad T41 laptop with a digital plasma screen attached.

Movies play fine on the laptop's LCD matrix or on an external LCD
digital flat panel, connected thru a DVI port. However, if I connect a
digital plasma monitor to the same DVI port, the WinDVD window appears
black on the plasma screen (no matter, in windowed or full screen
mode), however the laptop screen shows it fine at the very same time.
The rest of the Windows desktop and apps is being shown just fine on
the plasma.

Software: WinDVD 4.0 DXVA
Video Adapter: ATI Mobility Radeon 7500
OS: Windows XP Professional
External LCD Flat Panel: ViewSonic VX710 (via DVI)
External Plasma Flat Panel: Sony PFM-42X1 (via DVI HDCP-enabled)

Any clue what might be causing this? I suspect this can be related to
the fact that my plasma's DVI input is HDCP enabled, but the whole
issue still makes no sense.

TIA!
13 answers Last reply
More about playing back black picture external screen
  1. Archived from groups: alt.video.dvd.software,rec.video.desktop,alt.home-theater.misc,rec.video.dvd.tech (More info?)

    I have the T40, and it is similar. Try switching to just the external screen
    with Fn-F7.

    Brad Houser

    "Wondering" < @ . > wrote in message
    news:k5jan01mvogtslqsjdaqd7qp1225ar5mb4@4ax.com...
    > I am experiencing a stange problem when playing back DVDs on my IBM
    > ThinkPad T41 laptop with a digital plasma screen attached.
    >
    > Movies play fine on the laptop's LCD matrix or on an external LCD
    > digital flat panel, connected thru a DVI port. However, if I connect a
    > digital plasma monitor to the same DVI port, the WinDVD window appears
    > black on the plasma screen (no matter, in windowed or full screen
    > mode), however the laptop screen shows it fine at the very same time.
    > The rest of the Windows desktop and apps is being shown just fine on
    > the plasma.
    >
    > Software: WinDVD 4.0 DXVA
    > Video Adapter: ATI Mobility Radeon 7500
    > OS: Windows XP Professional
    > External LCD Flat Panel: ViewSonic VX710 (via DVI)
    > External Plasma Flat Panel: Sony PFM-42X1 (via DVI HDCP-enabled)
    >
    > Any clue what might be causing this? I suspect this can be related to
    > the fact that my plasma's DVI input is HDCP enabled, but the whole
    > issue still makes no sense.
    >
    > TIA!
  2. Archived from groups: alt.video.dvd.software,rec.video.desktop,rec.video.dvd.tech (More info?)

    On Tue, 19 Oct 2004 17:40:49 GMT, Wondering <  @ . > wrote:

    >Video Adapter: ATI Mobility Radeon 7500

    Try again after switching on Theater Mode in the Overlay
    (Clone mode options) settings.
  3. Archived from groups: alt.video.dvd.software,rec.video.desktop,rec.video.dvd.tech (More info?)

    On Tue, 19 Oct 2004 21:45:08 GMT, Wondering <  @ . > wrote:

    >"These overlay settings are only available in dual-controller Clone
    >mode, and not single display or extended desktop configurations."

    It probably means you have extended your desktop onto your second
    display. Uncheck that option. Take a look at this picture:
    http://www.havank.demon.nl/video/anderen/ati_images/pgm-ati-fig2.jpg
  4. Archived from groups: alt.video.dvd.software,rec.video.desktop,rec.video.dvd.tech (More info?)

    Have your external display plugged in before you do this, or reboot after
    you connect the second display. If your driver is the same as my ATI AIW
    7500 desktop card, the following should work. Right click on your desktop
    and choose "properties". Click on the "settings" tab and go the the
    "advanced" button. Now click on the "displays" tab. See the little blue
    boxes below each monitor? Make sure that the one with the DOT is selected
    for each monitor that is connected. Hope that helps.

    Sanman


    "erratic" <erratic@reply-to.address> wrote in message
    news:S_fdd.283805$ME7.14645312@phobos.telenet-ops.be...
    > On Tue, 19 Oct 2004 21:45:08 GMT, Wondering < @ . > wrote:
    >
    > >"These overlay settings are only available in dual-controller Clone
    > >mode, and not single display or extended desktop configurations."
    >
    > It probably means you have extended your desktop onto your second
    > display. Uncheck that option. Take a look at this picture:
    > http://www.havank.demon.nl/video/anderen/ati_images/pgm-ati-fig2.jpg
  5. Archived from groups: alt.video.dvd.software,rec.video.desktop,rec.video.dvd.tech (More info?)

    On Tue, 19 Oct 2004 21:50:42 GMT, erratic <erratic@reply-to.address>
    wrote:

    >On Tue, 19 Oct 2004 21:45:08 GMT, Wondering <  @ . > wrote:
    >
    >>"These overlay settings are only available in dual-controller Clone
    >>mode, and not single display or extended desktop configurations."
    >
    >It probably means you have extended your desktop onto your second
    >display. Uncheck that option. Take a look at this picture:
    >http://www.havank.demon.nl/video/anderen/ati_images/pgm-ati-fig2.jpg


    Nope. I was aware of that one. I use a single display/desktop
    configuration, and my external screen shows the same picture as the
    laptop's panel...
  6. Archived from groups: alt.video.dvd.software,rec.video.desktop,rec.video.dvd.tech,alt.home-theater.misc (More info?)

    On Tue, 19 Oct 2004 18:58:08 -0400, "Sanman" <me@you.com> wrote:

    >Have your external display plugged in before you do this, or reboot after
    >you connect the second display. If your driver is the same as my ATI AIW
    >7500 desktop card, the following should work. Right click on your desktop
    >and choose "properties". Click on the "settings" tab and go the the
    >"advanced" button. Now click on the "displays" tab. See the little blue
    >boxes below each monitor? Make sure that the one with the DOT is selected
    >for each monitor that is connected. Hope that helps.
    >
    >Sanman


    It did, thanks! Looks like a DVD can only be played on 1 monitor at a
    time (the primary one). I am not sure why, though. Both WinDVD and
    Windows Media Player behave in the same way. It could be a content
    protection issue, however I didn't see any difference between playing
    back a retail DVD or a decrypted copy with CSS/Macrovision/region
    removed. Go figure...
  7. Archived from groups: alt.video.dvd.software,rec.video.desktop,rec.video.dvd.tech,alt.home-theater.misc (More info?)

    On Wed, 20 Oct 2004 17:02:07 GMT, Wondering <  @ . > wrote:

    >It did, thanks! Looks like a DVD can only be played on 1 monitor at a
    >time (the primary one).

    With Theater Mode you can play it on both displays. Desktop users can
    enable Theater Mode. Apparently you can't, so maybe it's a limitation
    of the Mobility drivers.
    http://www.rage3d.com/board/showthread.php?t=33663869
  8. Archived from groups: alt.video.dvd.software,rec.video.desktop,alt.home-theater.misc,rec.video.dvd.tech (More info?)

    Try the changing the colour depth. Just upgraded my desktop to LCD using DVI
    from CRT and had the same thing happen except green. Changing from 16bit
    color to 32bit colour fixed it.

    "Wondering" < @ . > wrote in message
    news:k5jan01mvogtslqsjdaqd7qp1225ar5mb4@4ax.com...
    > I am experiencing a stange problem when playing back DVDs on my IBM
    > ThinkPad T41 laptop with a digital plasma screen attached.
    >
    > Movies play fine on the laptop's LCD matrix or on an external LCD
    > digital flat panel, connected thru a DVI port. However, if I connect a
    > digital plasma monitor to the same DVI port, the WinDVD window appears
    > black on the plasma screen (no matter, in windowed or full screen
    > mode), however the laptop screen shows it fine at the very same time.
    > The rest of the Windows desktop and apps is being shown just fine on
    > the plasma.
    >
    > Software: WinDVD 4.0 DXVA
    > Video Adapter: ATI Mobility Radeon 7500
    > OS: Windows XP Professional
    > External LCD Flat Panel: ViewSonic VX710 (via DVI)
    > External Plasma Flat Panel: Sony PFM-42X1 (via DVI HDCP-enabled)
    >
    > Any clue what might be causing this? I suspect this can be related to
    > the fact that my plasma's DVI input is HDCP enabled, but the whole
    > issue still makes no sense.
    >
    > TIA!
  9. Archived from groups: alt.video.dvd.software,rec.video.desktop,rec.video.dvd.tech,alt.home-theater.misc (More info?)

    On Wed, 20 Oct 2004 17:09:27 GMT, erratic <erratic@reply-to.address>
    wrote:

    >On Wed, 20 Oct 2004 17:02:07 GMT, Wondering <  @ . > wrote:
    >
    >>It did, thanks! Looks like a DVD can only be played on 1 monitor at a
    >>time (the primary one).
    >
    >With Theater Mode you can play it on both displays. Desktop users can
    >enable Theater Mode. Apparently you can't, so maybe it's a limitation
    >of the Mobility drivers.
    >http://www.rage3d.com/board/showthread.php?t=33663869

    You're, most likely, correct. I'm gonna try with my desktop box
    tonight. However, that one has GeForce FX 5700 Ultra, so the situation
    will be different.

    By the way, how is your TV connected? Via DVI or S-video?
  10. Archived from groups: alt.video.dvd.software,rec.video.desktop,rec.video.dvd.tech,alt.home-theater.misc (More info?)

    On Wed, 20 Oct 2004 23:50:23 GMT, Wondering <  @ . > wrote:

    >You're, most likely, correct. I'm gonna try with my desktop box
    >tonight. However, that one has GeForce FX 5700 Ultra, so the situation
    >will be different.

    I'm sure it's possible with a GeForce card as well, but it's not called
    Theater Mode. I think this website explains it:
    nVidia GeForce: http://www.weethet.nl/english/video_pc2tv_nvidia.php
    ATI Radeon: http://www.weethet.nl/english/video_pc2tv_ati.php

    >By the way, how is your TV connected? Via DVI or S-video?

    I use one of those PC to TV Senders.
    http://www.marmitek.com/en/catalogus/subgroep.php?subgroep=42
    Good enough for DivX/XviD. DVDs look better in a standalone DVD player.
  11. Archived from groups: alt.video.dvd.software,rec.video.desktop,alt.home-theater.misc,rec.video.dvd.tech (More info?)

    Wondering <  @ . > wrote in
    news:k5jan01mvogtslqsjdaqd7qp1225ar5mb4@4ax.com:

    > I am experiencing a stange problem when playing back DVDs on my IBM
    > ThinkPad T41 laptop with a digital plasma screen attached.
    >
    > Movies play fine on the laptop's LCD matrix or on an external LCD
    > digital flat panel, connected thru a DVI port. However, if I connect a
    > digital plasma monitor to the same DVI port, the WinDVD window appears
    > black on the plasma screen (no matter, in windowed or full screen
    > mode), however the laptop screen shows it fine at the very same time.
    > The rest of the Windows desktop and apps is being shown just fine on
    > the plasma.
    >
    > Software: WinDVD 4.0 DXVA
    > Video Adapter: ATI Mobility Radeon 7500
    > OS: Windows XP Professional
    > External LCD Flat Panel: ViewSonic VX710 (via DVI)
    > External Plasma Flat Panel: Sony PFM-42X1 (via DVI HDCP-enabled)
    >
    > Any clue what might be causing this? I suspect this can be related to
    > the fact that my plasma's DVI input is HDCP enabled, but the whole
    > issue still makes no sense.
    >
    > TIA!

    I had the same problem with my Thinkpad T40. When trying to run
    2 screens (the LCD and an external), the DVD overlay would not
    show on the external screen. When I made the external display the main
    output (with no LCD operation), the DVD played correctly. It
    has something to do the overlay and how memory is addressed so it
    can't be displayed on both at the same time.

    Your mileage may vary. :)

    --
    Tim.

    "Those who give up essential liberties for temporary safety deserve
    neither liberty nor safety." - Benjamin Franklin
  12. Archived from groups: alt.video.dvd.software,rec.video.desktop,alt.home-theater.misc,rec.video.dvd.tech (More info?)

    "Brad Houser" <bradDOThouser@intel.com> wrote in
    news:cl4bol$afv$1@news01.intel.com:

    > I have the T40, and it is similar. Try switching to just the external
    > screen with Fn-F7.
    >
    > Brad Houser
    >

    Yes. This has been my experience, too.


    --
    Tim.

    "Those who give up essential liberties for temporary safety deserve neither
    liberty nor safety." - Benjamin Franklin
  13. Archived from groups: alt.video.dvd.software,rec.video.desktop (More info?)

    > "Those who give up essential liberties for temporary safety deserve
    neither
    > liberty nor safety." - Benjamin Franklin

    Ben Franklin never met Bin Laden.
Ask a new question

Read More

Tuner Cards DVD Video DVI Graphics