Remote Web Workplace - Help please

Archived from groups: microsoft.public.windowsxp.work_remotely,microsoft.public.windows.server.sbs (More info?)

Hi everybody, I'm having a little problem with Remote Web Workplace, and I
hope someone can help me out. The problem is:

If I access through https://mypublicdomain/tsweb
- I can connect to any computer on my network
If I access through https://localhost/remote
- I can connect to any computer on my network
If I access through https://mypublicdomain/remote
- I can't connect to any computer on my network! Everything works
fine, until I choose the computer and press connect, then I see the
following message:

"The client could not establish a connection to the remote computer. The
most likely causes for this error are:
a.. Remote connections might not be enabled at the remote computer.
b.. The maximum number of connections might be exceeded at the remote
computer.
c.. A network error might have occurred while establishing the connection.
d.. The Remote Web Workplace designated port might be blocked by a
firewall. "
Can someone help me out, please? I don't know where to look anymore....

Thanks in advance
14 answers Last reply
More about remote workplace please
  1. Archived from groups: microsoft.public.windowsxp.work_remotely,microsoft.public.windows.server.sbs (More info?)

    Pedro,

    Make sure that TCP Port 4125 is open/forwarded back to the SBS server from
    your router/firewall. Remote Web Workplace uses TCP port 443 to connect to
    the site using SSL and then from the external client to the server uses TCP
    port 4125, then from the server to the internal client is TCP port 3389.


    --

    Hope that helps,
    David Copeland
    Microsoft Small Business Server Support

    This posting is provided "AS IS" with no warranties, and confers no rights.

    Newsgroups:
    SBS v4.x : microsoft.public.backoffice.smallbiz
    SBS 2000: microsoft.public.backoffice.smallbiz2000
    SBS 2003: microsoft.public.windows.server.sbs


    "PG" <Pedro.Gomes@clix.pt> wrote in message
    news:%23hFLKkSXEHA.3716@TK2MSFTNGP10.phx.gbl...
    > Hi everybody, I'm having a little problem with Remote Web Workplace, and I
    > hope someone can help me out. The problem is:
    >
    > If I access through https://mypublicdomain/tsweb
    > - I can connect to any computer on my network
    > If I access through https://localhost/remote
    > - I can connect to any computer on my network
    > If I access through https://mypublicdomain/remote
    > - I can't connect to any computer on my network! Everything works
    > fine, until I choose the computer and press connect, then I see the
    > following message:
    >
    > "The client could not establish a connection to the remote computer. The
    > most likely causes for this error are:
    > a.. Remote connections might not be enabled at the remote computer.
    > b.. The maximum number of connections might be exceeded at the remote
    > computer.
    > c.. A network error might have occurred while establishing the
    > connection.
    > d.. The Remote Web Workplace designated port might be blocked by a
    > firewall. "
    > Can someone help me out, please? I don't know where to look anymore....
    >
    > Thanks in advance
    >
    >
  2. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    You won't be able to connect to any computers behind a firewall
    without establishing a VPN...

    Jeffrey Randow (Windows Networking & Smart Display MVP)
    jeffreyr-support@remotenetworktechnology.com

    Please post all responses to the newsgroups for the benefit
    of all USENET users. Messages sent via email may or may not
    be answered depending on time availability....

    Remote Networking Technology Support Site -
    http://www.remotenetworktechnology.com
    Windows XP Expert Zone - http://www.microsoft.com/windowsxp/expertzone

    On Mon, 28 Jun 2004 16:45:29 +0100, "PG" <Pedro.Gomes@clix.pt> wrote:

    >Hi everybody, I'm having a little problem with Remote Web Workplace, and I
    >hope someone can help me out. The problem is:
    >
    >If I access through https://mypublicdomain/tsweb
    > - I can connect to any computer on my network
    >If I access through https://localhost/remote
    > - I can connect to any computer on my network
    >If I access through https://mypublicdomain/remote
    > - I can't connect to any computer on my network! Everything works
    >fine, until I choose the computer and press connect, then I see the
    >following message:
    >
    >"The client could not establish a connection to the remote computer. The
    >most likely causes for this error are:
    > a.. Remote connections might not be enabled at the remote computer.
    > b.. The maximum number of connections might be exceeded at the remote
    >computer.
    > c.. A network error might have occurred while establishing the connection.
    > d.. The Remote Web Workplace designated port might be blocked by a
    >firewall. "
    >Can someone help me out, please? I don't know where to look anymore....
    >
    >Thanks in advance
    >
  3. Archived from groups: microsoft.public.windowsxp.work_remotely,microsoft.public.windows.server.sbs (More info?)

    I already have port 4125 opened on my ISA server, David.

    "David Copeland [MSFT]" <davidcop@online.microsoft.com> wrote in message
    news:eYnsUPTXEHA.2364@TK2MSFTNGP12.phx.gbl...
    > Pedro,
    >
    > Make sure that TCP Port 4125 is open/forwarded back to the SBS server from
    > your router/firewall. Remote Web Workplace uses TCP port 443 to connect
    to
    > the site using SSL and then from the external client to the server uses
    TCP
    > port 4125, then from the server to the internal client is TCP port 3389.
    >
    >
    > --
    >
    > Hope that helps,
    > David Copeland
    > Microsoft Small Business Server Support
    >
    > This posting is provided "AS IS" with no warranties, and confers no
    rights.
    >
    > Newsgroups:
    > SBS v4.x : microsoft.public.backoffice.smallbiz
    > SBS 2000: microsoft.public.backoffice.smallbiz2000
    > SBS 2003: microsoft.public.windows.server.sbs
    >
    >
    > "PG" <Pedro.Gomes@clix.pt> wrote in message
    > news:%23hFLKkSXEHA.3716@TK2MSFTNGP10.phx.gbl...
    > > Hi everybody, I'm having a little problem with Remote Web Workplace, and
    I
    > > hope someone can help me out. The problem is:
    > >
    > > If I access through https://mypublicdomain/tsweb
    > > - I can connect to any computer on my network
    > > If I access through https://localhost/remote
    > > - I can connect to any computer on my network
    > > If I access through https://mypublicdomain/remote
    > > - I can't connect to any computer on my network! Everything works
    > > fine, until I choose the computer and press connect, then I see the
    > > following message:
    > >
    > > "The client could not establish a connection to the remote computer. The
    > > most likely causes for this error are:
    > > a.. Remote connections might not be enabled at the remote computer.
    > > b.. The maximum number of connections might be exceeded at the remote
    > > computer.
    > > c.. A network error might have occurred while establishing the
    > > connection.
    > > d.. The Remote Web Workplace designated port might be blocked by a
    > > firewall. "
    > > Can someone help me out, please? I don't know where to look anymore....
    > >
    > > Thanks in advance
    > >
    > >
    >
    >
  4. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    I have to establish a VPN first????

    Are you sure of this? I believe that the whole purpose of the Remote Web
    Workplace thing, is to make thing's easy just using an HTTP connection to
    your company...

    If I need a VPN for Remote Web Workplace to work, then why does Terminal
    services work without one?


    "Jeffrey Randow (MVP)" <jeffreyr-support@remotenetworktechnology.com> wrote
    in message news:0vf1e09h7kmforicpi98f4tv3u9ee03r8g@4ax.com...
    > You won't be able to connect to any computers behind a firewall
    > without establishing a VPN...
    >
    > Jeffrey Randow (Windows Networking & Smart Display MVP)
    > jeffreyr-support@remotenetworktechnology.com
    >
    > Please post all responses to the newsgroups for the benefit
    > of all USENET users. Messages sent via email may or may not
    > be answered depending on time availability....
    >
    > Remote Networking Technology Support Site -
    > http://www.remotenetworktechnology.com
    > Windows XP Expert Zone - http://www.microsoft.com/windowsxp/expertzone
    >
    > On Mon, 28 Jun 2004 16:45:29 +0100, "PG" <Pedro.Gomes@clix.pt> wrote:
    >
    > >Hi everybody, I'm having a little problem with Remote Web Workplace, and
    I
    > >hope someone can help me out. The problem is:
    > >
    > >If I access through https://mypublicdomain/tsweb
    > > - I can connect to any computer on my network
    > >If I access through https://localhost/remote
    > > - I can connect to any computer on my network
    > >If I access through https://mypublicdomain/remote
    > > - I can't connect to any computer on my network! Everything works
    > >fine, until I choose the computer and press connect, then I see the
    > >following message:
    > >
    > >"The client could not establish a connection to the remote computer. The
    > >most likely causes for this error are:
    > > a.. Remote connections might not be enabled at the remote computer.
    > > b.. The maximum number of connections might be exceeded at the remote
    > >computer.
    > > c.. A network error might have occurred while establishing the
    connection.
    > > d.. The Remote Web Workplace designated port might be blocked by a
    > >firewall. "
    > >Can someone help me out, please? I don't know where to look anymore....
    > >
    > >Thanks in advance
    > >
    >
  5. Archived from groups: microsoft.public.windowsxp.work_remotely,microsoft.public.windows.server.sbs (More info?)

    What is it with almost everybody, that they seem to forget that RWW is
    working with 444!

    443 is for OWA, RWW needs 444 and 4125 forwarded from the router to the
    external nic-IP.


    --
    Regards,

    Marina
    Microsoft SBS-MVP

    "PG" <Pedro.Gomes@clix.pt> schreef in bericht
    news:uxr5%239aXEHA.2388@TK2MSFTNGP11.phx.gbl...
    > I already have port 4125 opened on my ISA server, David.
    >
    > "David Copeland [MSFT]" <davidcop@online.microsoft.com> wrote in message
    > news:eYnsUPTXEHA.2364@TK2MSFTNGP12.phx.gbl...
    > > Pedro,
    > >
    > > Make sure that TCP Port 4125 is open/forwarded back to the SBS server
    from
    > > your router/firewall. Remote Web Workplace uses TCP port 443 to connect
    > to
    > > the site using SSL and then from the external client to the server uses
    > TCP
    > > port 4125, then from the server to the internal client is TCP port 3389.
    > >
    > >
    > > --
    > >
    > > Hope that helps,
    > > David Copeland
    > > Microsoft Small Business Server Support
    > >
    > > This posting is provided "AS IS" with no warranties, and confers no
    > rights.
    > >
    > > Newsgroups:
    > > SBS v4.x : microsoft.public.backoffice.smallbiz
    > > SBS 2000: microsoft.public.backoffice.smallbiz2000
    > > SBS 2003: microsoft.public.windows.server.sbs
    > >
    > >
    > > "PG" <Pedro.Gomes@clix.pt> wrote in message
    > > news:%23hFLKkSXEHA.3716@TK2MSFTNGP10.phx.gbl...
    > > > Hi everybody, I'm having a little problem with Remote Web Workplace,
    and
    > I
    > > > hope someone can help me out. The problem is:
    > > >
    > > > If I access through https://mypublicdomain/tsweb
    > > > - I can connect to any computer on my network
    > > > If I access through https://localhost/remote
    > > > - I can connect to any computer on my network
    > > > If I access through https://mypublicdomain/remote
    > > > - I can't connect to any computer on my network! Everything
    works
    > > > fine, until I choose the computer and press connect, then I see the
    > > > following message:
    > > >
    > > > "The client could not establish a connection to the remote computer.
    The
    > > > most likely causes for this error are:
    > > > a.. Remote connections might not be enabled at the remote computer.
    > > > b.. The maximum number of connections might be exceeded at the remote
    > > > computer.
    > > > c.. A network error might have occurred while establishing the
    > > > connection.
    > > > d.. The Remote Web Workplace designated port might be blocked by a
    > > > firewall. "
    > > > Can someone help me out, please? I don't know where to look
    anymore....
    > > >
    > > > Thanks in advance
    > > >
    > > >
    > >
    > >
    >
    >
  6. Archived from groups: microsoft.public.windowsxp.work_remotely,microsoft.public.windows.server.sbs (More info?)

    Only if you want Companyweb (Sharepoint) available to external users do you
    need 444.

    --
    Les Connor [SBS MVP]
    -------------------------------------
    SBS Rocks !


    "Marina Roos [SBS-MVP]" <marina@roos.nodontwantspam.nl.com> wrote in message
    news:OXQyDPeXEHA.2716@tk2msftngp13.phx.gbl...
    > What is it with almost everybody, that they seem to forget that RWW is
    > working with 444!
    >
    > 443 is for OWA, RWW needs 444 and 4125 forwarded from the router to the
    > external nic-IP.
    >
    >
    > --
    > Regards,
    >
    > Marina
    > Microsoft SBS-MVP
    >
    > "PG" <Pedro.Gomes@clix.pt> schreef in bericht
    > news:uxr5%239aXEHA.2388@TK2MSFTNGP11.phx.gbl...
    > > I already have port 4125 opened on my ISA server, David.
    > >
    > > "David Copeland [MSFT]" <davidcop@online.microsoft.com> wrote in message
    > > news:eYnsUPTXEHA.2364@TK2MSFTNGP12.phx.gbl...
    > > > Pedro,
    > > >
    > > > Make sure that TCP Port 4125 is open/forwarded back to the SBS server
    > from
    > > > your router/firewall. Remote Web Workplace uses TCP port 443 to
    connect
    > > to
    > > > the site using SSL and then from the external client to the server
    uses
    > > TCP
    > > > port 4125, then from the server to the internal client is TCP port
    3389.
    > > >
    > > >
    > > > --
    > > >
    > > > Hope that helps,
    > > > David Copeland
    > > > Microsoft Small Business Server Support
    > > >
    > > > This posting is provided "AS IS" with no warranties, and confers no
    > > rights.
    > > >
    > > > Newsgroups:
    > > > SBS v4.x : microsoft.public.backoffice.smallbiz
    > > > SBS 2000: microsoft.public.backoffice.smallbiz2000
    > > > SBS 2003: microsoft.public.windows.server.sbs
    > > >
    > > >
    > > > "PG" <Pedro.Gomes@clix.pt> wrote in message
    > > > news:%23hFLKkSXEHA.3716@TK2MSFTNGP10.phx.gbl...
    > > > > Hi everybody, I'm having a little problem with Remote Web Workplace,
    > and
    > > I
    > > > > hope someone can help me out. The problem is:
    > > > >
    > > > > If I access through https://mypublicdomain/tsweb
    > > > > - I can connect to any computer on my network
    > > > > If I access through https://localhost/remote
    > > > > - I can connect to any computer on my network
    > > > > If I access through https://mypublicdomain/remote
    > > > > - I can't connect to any computer on my network! Everything
    > works
    > > > > fine, until I choose the computer and press connect, then I see the
    > > > > following message:
    > > > >
    > > > > "The client could not establish a connection to the remote computer.
    > The
    > > > > most likely causes for this error are:
    > > > > a.. Remote connections might not be enabled at the remote computer.
    > > > > b.. The maximum number of connections might be exceeded at the
    remote
    > > > > computer.
    > > > > c.. A network error might have occurred while establishing the
    > > > > connection.
    > > > > d.. The Remote Web Workplace designated port might be blocked by a
    > > > > firewall. "
    > > > > Can someone help me out, please? I don't know where to look
    > anymore....
    > > > >
    > > > > Thanks in advance
    > > > >
    > > > >
    > > >
    > > >
    > >
    > >
    >
    >
  7. Archived from groups: microsoft.public.windowsxp.work_remotely,microsoft.public.windows.server.sbs (More info?)

    Anymore ideas, as where I can look for the problem? I'm running out of
    ideas...

    My router forwards all ports to my ISA server.
    On my ISA server I created a protocol rule allowing both Inbound and
    Outbound port 4125 to my internal server. And still nothing... When I press
    "connect" the same stupid error apears... :(

    Thank's for all your help so far... Hope you can help me figure this out...


    "Les Connor [SBS MVP]" <les.connor@DEL.cfive.ca> wrote in message
    news:u6y75WfXEHA.1888@TK2MSFTNGP11.phx.gbl...
    > Only if you want Companyweb (Sharepoint) available to external users do
    you
    > need 444.
    >
    > --
    > Les Connor [SBS MVP]
    > -------------------------------------
    > SBS Rocks !
    >
    >
    >
    > "Marina Roos [SBS-MVP]" <marina@roos.nodontwantspam.nl.com> wrote in
    message
    > news:OXQyDPeXEHA.2716@tk2msftngp13.phx.gbl...
    > > What is it with almost everybody, that they seem to forget that RWW is
    > > working with 444!
    > >
    > > 443 is for OWA, RWW needs 444 and 4125 forwarded from the router to the
    > > external nic-IP.
    > >
    > >
    > > --
    > > Regards,
    > >
    > > Marina
    > > Microsoft SBS-MVP
    > >
    > > "PG" <Pedro.Gomes@clix.pt> schreef in bericht
    > > news:uxr5%239aXEHA.2388@TK2MSFTNGP11.phx.gbl...
    > > > I already have port 4125 opened on my ISA server, David.
    > > >
    > > > "David Copeland [MSFT]" <davidcop@online.microsoft.com> wrote in
    message
    > > > news:eYnsUPTXEHA.2364@TK2MSFTNGP12.phx.gbl...
    > > > > Pedro,
    > > > >
    > > > > Make sure that TCP Port 4125 is open/forwarded back to the SBS
    server
    > > from
    > > > > your router/firewall. Remote Web Workplace uses TCP port 443 to
    > connect
    > > > to
    > > > > the site using SSL and then from the external client to the server
    > uses
    > > > TCP
    > > > > port 4125, then from the server to the internal client is TCP port
    > 3389.
    > > > >
    > > > >
    > > > > --
    > > > >
    > > > > Hope that helps,
    > > > > David Copeland
    > > > > Microsoft Small Business Server Support
    > > > >
    > > > > This posting is provided "AS IS" with no warranties, and confers no
    > > > rights.
    > > > >
    > > > > Newsgroups:
    > > > > SBS v4.x : microsoft.public.backoffice.smallbiz
    > > > > SBS 2000: microsoft.public.backoffice.smallbiz2000
    > > > > SBS 2003: microsoft.public.windows.server.sbs
    > > > >
    > > > >
    > > > > "PG" <Pedro.Gomes@clix.pt> wrote in message
    > > > > news:%23hFLKkSXEHA.3716@TK2MSFTNGP10.phx.gbl...
    > > > > > Hi everybody, I'm having a little problem with Remote Web
    Workplace,
    > > and
    > > > I
    > > > > > hope someone can help me out. The problem is:
    > > > > >
    > > > > > If I access through https://mypublicdomain/tsweb
    > > > > > - I can connect to any computer on my network
    > > > > > If I access through https://localhost/remote
    > > > > > - I can connect to any computer on my network
    > > > > > If I access through https://mypublicdomain/remote
    > > > > > - I can't connect to any computer on my network! Everything
    > > works
    > > > > > fine, until I choose the computer and press connect, then I see
    the
    > > > > > following message:
    > > > > >
    > > > > > "The client could not establish a connection to the remote
    computer.
    > > The
    > > > > > most likely causes for this error are:
    > > > > > a.. Remote connections might not be enabled at the remote
    computer.
    > > > > > b.. The maximum number of connections might be exceeded at the
    > remote
    > > > > > computer.
    > > > > > c.. A network error might have occurred while establishing the
    > > > > > connection.
    > > > > > d.. The Remote Web Workplace designated port might be blocked by
    a
    > > > > > firewall. "
    > > > > > Can someone help me out, please? I don't know where to look
    > > anymore....
    > > > > >
    > > > > > Thanks in advance
    > > > > >
    > > > > >
    > > > >
    > > > >
    > > >
    > > >
    > >
    > >
    >
    >
  8. Archived from groups: microsoft.public.windowsxp.work_remotely,microsoft.public.windows.server.sbs (More info?)

    Pedro,

    Here's something you could try to verify that port 4125 is open to your
    server.. basically going to configure an SMTP virtual server to listen on
    port 4125 and try to connect.

    1) Go into Start/Server Management/Advanced Management/First Organization
    (Exchange)/Servers/servername/Protocols/SMTP right click on SMTP and
    select New/SMTP virtual server.
    2) Give it a name of something like test1
    3) For the IP address just leave it at all unassigned and click the Finish
    button. Click Yes to the prompt asking if you are sure you want to use that
    address.
    4) Right click on the new SMTP virtual server created in step2 and select
    Properties and click the Advanced button to the right of the IP Address
    field.
    5) Click the Edit button then change the port from 25 to 4125 then click the
    OK button (3 times to get all the way back out)
    6) Right click on the new SMTP virtual server and select Start

    If it is able to successfully start, then from a remote machine try
    telneting to your server on port 4125.. using the following command

    telnet x.x.x.x 4125

    where x.x.x.x is the IP address used to reach the external side of the
    server.

    You should get back an Exchange banner.. If you do then it appears that
    the port is open to the server.. and we may need to look more specifically
    at remote web workplace.. if you are not able to connect, then it could be
    an indication that the port isn't open.. as another test you may want to
    verify it works from an internal client.

    Be sure to go back and delete the test1 SMTP virtual server after your test.

    Another option you may want to do if you have a remote XP client is to
    install the support tools from the XP cd.. and then use netcap to get a
    network trace attempting to connect.. from that we may be able to see if
    it's making the connection or not to the server.. and/or possible tell if a
    router/firewall is blocking the port (based on an ICMP error response)

    --

    Hope that helps,
    David Copeland
    Microsoft Small Business Server Support

    This posting is provided "AS IS" with no warranties, and confers no rights.

    Newsgroups:
    SBS v4.x : microsoft.public.backoffice.smallbiz
    SBS 2000: microsoft.public.backoffice.smallbiz2000
    SBS 2003: microsoft.public.windows.server.sbs


    "PG" <Pedro.Gomes@clix.pt> wrote in message
    news:%23RGOLlnXEHA.1356@TK2MSFTNGP09.phx.gbl...
    > Anymore ideas, as where I can look for the problem? I'm running out of
    > ideas...
    >
    > My router forwards all ports to my ISA server.
    > On my ISA server I created a protocol rule allowing both Inbound and
    > Outbound port 4125 to my internal server. And still nothing... When I
    > press
    > "connect" the same stupid error apears... :(
    >
    > Thank's for all your help so far... Hope you can help me figure this
    > out...
    >
    >
    > "Les Connor [SBS MVP]" <les.connor@DEL.cfive.ca> wrote in message
    > news:u6y75WfXEHA.1888@TK2MSFTNGP11.phx.gbl...
    >> Only if you want Companyweb (Sharepoint) available to external users do
    > you
    >> need 444.
    >>
    >> --
    >> Les Connor [SBS MVP]
    >> -------------------------------------
    >> SBS Rocks !
    >>
    >>
    >>
    >> "Marina Roos [SBS-MVP]" <marina@roos.nodontwantspam.nl.com> wrote in
    > message
    >> news:OXQyDPeXEHA.2716@tk2msftngp13.phx.gbl...
    >> > What is it with almost everybody, that they seem to forget that RWW is
    >> > working with 444!
    >> >
    >> > 443 is for OWA, RWW needs 444 and 4125 forwarded from the router to the
    >> > external nic-IP.
    >> >
    >> >
    >> > --
    >> > Regards,
    >> >
    >> > Marina
    >> > Microsoft SBS-MVP
    >> >
    >> > "PG" <Pedro.Gomes@clix.pt> schreef in bericht
    >> > news:uxr5%239aXEHA.2388@TK2MSFTNGP11.phx.gbl...
    >> > > I already have port 4125 opened on my ISA server, David.
    >> > >
    >> > > "David Copeland [MSFT]" <davidcop@online.microsoft.com> wrote in
    > message
    >> > > news:eYnsUPTXEHA.2364@TK2MSFTNGP12.phx.gbl...
    >> > > > Pedro,
    >> > > >
    >> > > > Make sure that TCP Port 4125 is open/forwarded back to the SBS
    > server
    >> > from
    >> > > > your router/firewall. Remote Web Workplace uses TCP port 443 to
    >> connect
    >> > > to
    >> > > > the site using SSL and then from the external client to the server
    >> uses
    >> > > TCP
    >> > > > port 4125, then from the server to the internal client is TCP port
    >> 3389.
    >> > > >
    >> > > >
    >> > > > --
    >> > > >
    >> > > > Hope that helps,
    >> > > > David Copeland
    >> > > > Microsoft Small Business Server Support
    >> > > >
    >> > > > This posting is provided "AS IS" with no warranties, and confers no
    >> > > rights.
    >> > > >
    >> > > > Newsgroups:
    >> > > > SBS v4.x : microsoft.public.backoffice.smallbiz
    >> > > > SBS 2000: microsoft.public.backoffice.smallbiz2000
    >> > > > SBS 2003: microsoft.public.windows.server.sbs
    >> > > >
    >> > > >
    >> > > > "PG" <Pedro.Gomes@clix.pt> wrote in message
    >> > > > news:%23hFLKkSXEHA.3716@TK2MSFTNGP10.phx.gbl...
    >> > > > > Hi everybody, I'm having a little problem with Remote Web
    > Workplace,
    >> > and
    >> > > I
    >> > > > > hope someone can help me out. The problem is:
    >> > > > >
    >> > > > > If I access through https://mypublicdomain/tsweb
    >> > > > > - I can connect to any computer on my network
    >> > > > > If I access through https://localhost/remote
    >> > > > > - I can connect to any computer on my network
    >> > > > > If I access through https://mypublicdomain/remote
    >> > > > > - I can't connect to any computer on my network! Everything
    >> > works
    >> > > > > fine, until I choose the computer and press connect, then I see
    > the
    >> > > > > following message:
    >> > > > >
    >> > > > > "The client could not establish a connection to the remote
    > computer.
    >> > The
    >> > > > > most likely causes for this error are:
    >> > > > > a.. Remote connections might not be enabled at the remote
    > computer.
    >> > > > > b.. The maximum number of connections might be exceeded at the
    >> remote
    >> > > > > computer.
    >> > > > > c.. A network error might have occurred while establishing the
    >> > > > > connection.
    >> > > > > d.. The Remote Web Workplace designated port might be blocked by
    > a
    >> > > > > firewall. "
    >> > > > > Can someone help me out, please? I don't know where to look
    >> > anymore....
    >> > > > >
    >> > > > > Thanks in advance
    >> > > > >
    >> > > > >
    >> > > >
    >> > > >
    >> > >
    >> > >
    >> >
    >> >
    >>
    >>
    >
    >
  9. Archived from groups: microsoft.public.windowsxp.work_remotely,microsoft.public.windows.server.sbs (More info?)

    Hi Pedro,

    Rerun the CEICW wizard and make sure you make changes to the Firewall part.
    Make sure you enable the services you want to be accessible from the
    internet.

    --
    Regards,

    Marina
    Microsoft SBS-MVP

    "PG" <Pedro.Gomes@clix.pt> schreef in bericht
    news:%23RGOLlnXEHA.1356@TK2MSFTNGP09.phx.gbl...
    > Anymore ideas, as where I can look for the problem? I'm running out of
    > ideas...
    >
    > My router forwards all ports to my ISA server.
    > On my ISA server I created a protocol rule allowing both Inbound and
    > Outbound port 4125 to my internal server. And still nothing... When I
    press
    > "connect" the same stupid error apears... :(
    >
    > Thank's for all your help so far... Hope you can help me figure this
    out...
    >
    >
    > "Les Connor [SBS MVP]" <les.connor@DEL.cfive.ca> wrote in message
    > news:u6y75WfXEHA.1888@TK2MSFTNGP11.phx.gbl...
    > > Only if you want Companyweb (Sharepoint) available to external users do
    > you
    > > need 444.
    > >
    > > --
    > > Les Connor [SBS MVP]
    > > -------------------------------------
    > > SBS Rocks !
    > >
    > >
    > >
    > > "Marina Roos [SBS-MVP]" <marina@roos.nodontwantspam.nl.com> wrote in
    > message
    > > news:OXQyDPeXEHA.2716@tk2msftngp13.phx.gbl...
    > > > What is it with almost everybody, that they seem to forget that RWW is
    > > > working with 444!
    > > >
    > > > 443 is for OWA, RWW needs 444 and 4125 forwarded from the router to
    the
    > > > external nic-IP.
    > > >
    > > >
    > > > --
    > > > Regards,
    > > >
    > > > Marina
    > > > Microsoft SBS-MVP
    > > >
    > > > "PG" <Pedro.Gomes@clix.pt> schreef in bericht
    > > > news:uxr5%239aXEHA.2388@TK2MSFTNGP11.phx.gbl...
    > > > > I already have port 4125 opened on my ISA server, David.
    > > > >
    > > > > "David Copeland [MSFT]" <davidcop@online.microsoft.com> wrote in
    > message
    > > > > news:eYnsUPTXEHA.2364@TK2MSFTNGP12.phx.gbl...
    > > > > > Pedro,
    > > > > >
    > > > > > Make sure that TCP Port 4125 is open/forwarded back to the SBS
    > server
    > > > from
    > > > > > your router/firewall. Remote Web Workplace uses TCP port 443 to
    > > connect
    > > > > to
    > > > > > the site using SSL and then from the external client to the server
    > > uses
    > > > > TCP
    > > > > > port 4125, then from the server to the internal client is TCP port
    > > 3389.
    > > > > >
    > > > > >
    > > > > > --
    > > > > >
    > > > > > Hope that helps,
    > > > > > David Copeland
    > > > > > Microsoft Small Business Server Support
    > > > > >
    > > > > > This posting is provided "AS IS" with no warranties, and confers
    no
    > > > > rights.
    > > > > >
    > > > > > Newsgroups:
    > > > > > SBS v4.x : microsoft.public.backoffice.smallbiz
    > > > > > SBS 2000: microsoft.public.backoffice.smallbiz2000
    > > > > > SBS 2003: microsoft.public.windows.server.sbs
    > > > > >
    > > > > >
    > > > > > "PG" <Pedro.Gomes@clix.pt> wrote in message
    > > > > > news:%23hFLKkSXEHA.3716@TK2MSFTNGP10.phx.gbl...
    > > > > > > Hi everybody, I'm having a little problem with Remote Web
    > Workplace,
    > > > and
    > > > > I
    > > > > > > hope someone can help me out. The problem is:
    > > > > > >
    > > > > > > If I access through https://mypublicdomain/tsweb
    > > > > > > - I can connect to any computer on my network
    > > > > > > If I access through https://localhost/remote
    > > > > > > - I can connect to any computer on my network
    > > > > > > If I access through https://mypublicdomain/remote
    > > > > > > - I can't connect to any computer on my network!
    Everything
    > > > works
    > > > > > > fine, until I choose the computer and press connect, then I see
    > the
    > > > > > > following message:
    > > > > > >
    > > > > > > "The client could not establish a connection to the remote
    > computer.
    > > > The
    > > > > > > most likely causes for this error are:
    > > > > > > a.. Remote connections might not be enabled at the remote
    > computer.
    > > > > > > b.. The maximum number of connections might be exceeded at the
    > > remote
    > > > > > > computer.
    > > > > > > c.. A network error might have occurred while establishing the
    > > > > > > connection.
    > > > > > > d.. The Remote Web Workplace designated port might be blocked
    by
    > a
    > > > > > > firewall. "
    > > > > > > Can someone help me out, please? I don't know where to look
    > > > anymore....
    > > > > > >
    > > > > > > Thanks in advance
    > > > > > >
    > > > > > >
    > > > > >
    > > > > >
    > > > >
    > > > >
    > > >
    > > >
    > >
    > >
    >
    >
  10. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Hi Pedro,

    I'm having exactly the same problem if I connect via WindowsXP Home, when I use WindowsXP professional I don't have the problem.
    Is this also in your case?

    Bart

    "PG" wrote:

    > I have to establish a VPN first????
    >
    > Are you sure of this? I believe that the whole purpose of the Remote Web
    > Workplace thing, is to make thing's easy just using an HTTP connection to
    > your company...
    >
    > If I need a VPN for Remote Web Workplace to work, then why does Terminal
    > services work without one?
    >
    >
    > "Jeffrey Randow (MVP)" <jeffreyr-support@remotenetworktechnology.com> wrote
    > in message news:0vf1e09h7kmforicpi98f4tv3u9ee03r8g@4ax.com...
    > > You won't be able to connect to any computers behind a firewall
    > > without establishing a VPN...
    > >
    > > Jeffrey Randow (Windows Networking & Smart Display MVP)
    > > jeffreyr-support@remotenetworktechnology.com
    > >
    > > Please post all responses to the newsgroups for the benefit
    > > of all USENET users. Messages sent via email may or may not
    > > be answered depending on time availability....
    > >
    > > Remote Networking Technology Support Site -
    > > http://www.remotenetworktechnology.com
    > > Windows XP Expert Zone - http://www.microsoft.com/windowsxp/expertzone
    > >
    > > On Mon, 28 Jun 2004 16:45:29 +0100, "PG" <Pedro.Gomes@clix.pt> wrote:
    > >
    > > >Hi everybody, I'm having a little problem with Remote Web Workplace, and
    > I
    > > >hope someone can help me out. The problem is:
    > > >
    > > >If I access through https://mypublicdomain/tsweb
    > > > - I can connect to any computer on my network
    > > >If I access through https://localhost/remote
    > > > - I can connect to any computer on my network
    > > >If I access through https://mypublicdomain/remote
    > > > - I can't connect to any computer on my network! Everything works
    > > >fine, until I choose the computer and press connect, then I see the
    > > >following message:
    > > >
    > > >"The client could not establish a connection to the remote computer. The
    > > >most likely causes for this error are:
    > > > a.. Remote connections might not be enabled at the remote computer.
    > > > b.. The maximum number of connections might be exceeded at the remote
    > > >computer.
    > > > c.. A network error might have occurred while establishing the
    > connection.
    > > > d.. The Remote Web Workplace designated port might be blocked by a
    > > >firewall. "
    > > >Can someone help me out, please? I don't know where to look anymore....
    > > >
    > > >Thanks in advance
    > > >
    > >
    >
    >
    >
  11. Archived from groups: microsoft.public.windowsxp.work_remotely,microsoft.public.windows.server.sbs (More info?)

    Hi David, and thanks for the tips...

    I've tryied everything you said and here is the results:

    I created the Vitrual SMTP server and everything looked ok Internal and
    external.

    Then I tryed using the netcap and all I could notice was these three
    sentences repeating in the capture filein the following order:

    CONNECT mydomain.com:443 HTTP/1.0
    HTTP/1.1 200 Connection established
    HTTP/1.1 407 Proxy Authentication Required ( The ISA Server requires
    authorization to fulfill the request. Access to the Web Proxy service is
    denied. )

    It points to an ISA problem, so I went to my ISA server and forced my
    incoming web listener to ask for identification to unauthenticated users,
    but it didn't seem to have any effect, it's all still working in the same
    way! I access the site, i put a username and password, i choose a computer,
    hit connect, and the error appears.... :(

    What can I be doing wrong here?


    Could have anything to do with the fact that my ISA server is in a different
    box from my SBS server? I'm not using the ISA server that is on the SBS box,
    but it's still there, just sitting aroung... and I've got everything else
    working fine this way, OWA, TSWEB, WWW, Mail...

    The layout for the RWW scheme is:

    Router --- ISA Box --- SBS Box(RWW)


    I want to take the chance, and thank everybody for trying to help me sort
    this out...

    Thank you very much...


    "David Copeland [MSFT]" <davidcop@online.microsoft.com> wrote in message
    news:eDX05rrXEHA.3664@TK2MSFTNGP12.phx.gbl...
    > Pedro,
    >
    > Here's something you could try to verify that port 4125 is open to your
    > server.. basically going to configure an SMTP virtual server to listen
    on
    > port 4125 and try to connect.
    >
    > 1) Go into Start/Server Management/Advanced Management/First Organization
    > (Exchange)/Servers/servername/Protocols/SMTP right click on SMTP and
    > select New/SMTP virtual server.
    > 2) Give it a name of something like test1
    > 3) For the IP address just leave it at all unassigned and click the Finish
    > button. Click Yes to the prompt asking if you are sure you want to use
    that
    > address.
    > 4) Right click on the new SMTP virtual server created in step2 and select
    > Properties and click the Advanced button to the right of the IP Address
    > field.
    > 5) Click the Edit button then change the port from 25 to 4125 then click
    the
    > OK button (3 times to get all the way back out)
    > 6) Right click on the new SMTP virtual server and select Start
    >
    > If it is able to successfully start, then from a remote machine try
    > telneting to your server on port 4125.. using the following command
    >
    > telnet x.x.x.x 4125
    >
    > where x.x.x.x is the IP address used to reach the external side of the
    > server.
    >
    > You should get back an Exchange banner.. If you do then it appears that
    > the port is open to the server.. and we may need to look more specifically
    > at remote web workplace.. if you are not able to connect, then it could be
    > an indication that the port isn't open.. as another test you may want to
    > verify it works from an internal client.
    >
    > Be sure to go back and delete the test1 SMTP virtual server after your
    test.
    >
    > Another option you may want to do if you have a remote XP client is to
    > install the support tools from the XP cd.. and then use netcap to get a
    > network trace attempting to connect.. from that we may be able to see if
    > it's making the connection or not to the server.. and/or possible tell if
    a
    > router/firewall is blocking the port (based on an ICMP error response)
    >
    > --
    >
    > Hope that helps,
    > David Copeland
    > Microsoft Small Business Server Support
    >
    > This posting is provided "AS IS" with no warranties, and confers no
    rights.
    >
    > Newsgroups:
    > SBS v4.x : microsoft.public.backoffice.smallbiz
    > SBS 2000: microsoft.public.backoffice.smallbiz2000
    > SBS 2003: microsoft.public.windows.server.sbs
    >
    >
    > "PG" <Pedro.Gomes@clix.pt> wrote in message
    > news:%23RGOLlnXEHA.1356@TK2MSFTNGP09.phx.gbl...
    > > Anymore ideas, as where I can look for the problem? I'm running out of
    > > ideas...
    > >
    > > My router forwards all ports to my ISA server.
    > > On my ISA server I created a protocol rule allowing both Inbound and
    > > Outbound port 4125 to my internal server. And still nothing... When I
    > > press
    > > "connect" the same stupid error apears... :(
    > >
    > > Thank's for all your help so far... Hope you can help me figure this
    > > out...
    > >
    > >
    > > "Les Connor [SBS MVP]" <les.connor@DEL.cfive.ca> wrote in message
    > > news:u6y75WfXEHA.1888@TK2MSFTNGP11.phx.gbl...
    > >> Only if you want Companyweb (Sharepoint) available to external users do
    > > you
    > >> need 444.
    > >>
    > >> --
    > >> Les Connor [SBS MVP]
    > >> -------------------------------------
    > >> SBS Rocks !
    > >>
    > >>
    > >>
    > >> "Marina Roos [SBS-MVP]" <marina@roos.nodontwantspam.nl.com> wrote in
    > > message
    > >> news:OXQyDPeXEHA.2716@tk2msftngp13.phx.gbl...
    > >> > What is it with almost everybody, that they seem to forget that RWW
    is
    > >> > working with 444!
    > >> >
    > >> > 443 is for OWA, RWW needs 444 and 4125 forwarded from the router to
    the
    > >> > external nic-IP.
    > >> >
    > >> >
    > >> > --
    > >> > Regards,
    > >> >
    > >> > Marina
    > >> > Microsoft SBS-MVP
    > >> >
    > >> > "PG" <Pedro.Gomes@clix.pt> schreef in bericht
    > >> > news:uxr5%239aXEHA.2388@TK2MSFTNGP11.phx.gbl...
    > >> > > I already have port 4125 opened on my ISA server, David.
    > >> > >
    > >> > > "David Copeland [MSFT]" <davidcop@online.microsoft.com> wrote in
    > > message
    > >> > > news:eYnsUPTXEHA.2364@TK2MSFTNGP12.phx.gbl...
    > >> > > > Pedro,
    > >> > > >
    > >> > > > Make sure that TCP Port 4125 is open/forwarded back to the SBS
    > > server
    > >> > from
    > >> > > > your router/firewall. Remote Web Workplace uses TCP port 443 to
    > >> connect
    > >> > > to
    > >> > > > the site using SSL and then from the external client to the
    server
    > >> uses
    > >> > > TCP
    > >> > > > port 4125, then from the server to the internal client is TCP
    port
    > >> 3389.
    > >> > > >
    > >> > > >
    > >> > > > --
    > >> > > >
    > >> > > > Hope that helps,
    > >> > > > David Copeland
    > >> > > > Microsoft Small Business Server Support
    > >> > > >
    > >> > > > This posting is provided "AS IS" with no warranties, and confers
    no
    > >> > > rights.
    > >> > > >
    > >> > > > Newsgroups:
    > >> > > > SBS v4.x : microsoft.public.backoffice.smallbiz
    > >> > > > SBS 2000: microsoft.public.backoffice.smallbiz2000
    > >> > > > SBS 2003: microsoft.public.windows.server.sbs
    > >> > > >
    > >> > > >
    > >> > > > "PG" <Pedro.Gomes@clix.pt> wrote in message
    > >> > > > news:%23hFLKkSXEHA.3716@TK2MSFTNGP10.phx.gbl...
    > >> > > > > Hi everybody, I'm having a little problem with Remote Web
    > > Workplace,
    > >> > and
    > >> > > I
    > >> > > > > hope someone can help me out. The problem is:
    > >> > > > >
    > >> > > > > If I access through https://mypublicdomain/tsweb
    > >> > > > > - I can connect to any computer on my network
    > >> > > > > If I access through https://localhost/remote
    > >> > > > > - I can connect to any computer on my network
    > >> > > > > If I access through https://mypublicdomain/remote
    > >> > > > > - I can't connect to any computer on my network!
    Everything
    > >> > works
    > >> > > > > fine, until I choose the computer and press connect, then I see
    > > the
    > >> > > > > following message:
    > >> > > > >
    > >> > > > > "The client could not establish a connection to the remote
    > > computer.
    > >> > The
    > >> > > > > most likely causes for this error are:
    > >> > > > > a.. Remote connections might not be enabled at the remote
    > > computer.
    > >> > > > > b.. The maximum number of connections might be exceeded at the
    > >> remote
    > >> > > > > computer.
    > >> > > > > c.. A network error might have occurred while establishing the
    > >> > > > > connection.
    > >> > > > > d.. The Remote Web Workplace designated port might be blocked
    by
    > > a
    > >> > > > > firewall. "
    > >> > > > > Can someone help me out, please? I don't know where to look
    > >> > anymore....
    > >> > > > >
    > >> > > > > Thanks in advance
    > >> > > > >
    > >> > > > >
    > >> > > >
    > >> > > >
    > >> > >
    > >> > >
    > >> >
    > >> >
    > >>
    > >>
    > >
    > >
    >
    >
  12. Archived from groups: microsoft.public.windowsxp.work_remotely,microsoft.public.windows.server.sbs (More info?)

    Pedro,

    Can you logon to RWW from the ISA server (make sure that IE on the ISA
    server is not configured to use a Proxy server for the test) and then use
    the IP address of the SBS server to connect with.. then once logged on to
    RWW try to connect to one of the clients or the SBS server itself (if logged
    on to RWW as administrator).

    Just to be sure.. from a machine out on the Internet you could telnet to the
    external IP address of your ISA server on port 4125 and got the SMTP banner
    back correct? by way of a server publishing rule???

    Would it be possible for you to email me a copy of the netcap taken from an
    XP machine on the Internet attempting to connect.. (you would need to remove
    the "online." from my address)

    --

    Hope that helps,
    David Copeland
    Microsoft Small Business Server Support

    This posting is provided "AS IS" with no warranties, and confers no rights.

    Newsgroups:
    SBS v4.x : microsoft.public.backoffice.smallbiz
    SBS 2000: microsoft.public.backoffice.smallbiz2000
    SBS 2003: microsoft.public.windows.server.sbs


    "PG" <Pedro.Gomes@clix.pt> wrote in message
    news:ej462x0XEHA.2344@TK2MSFTNGP11.phx.gbl...
    > Hi David, and thanks for the tips...
    >
    > I've tryied everything you said and here is the results:
    >
    > I created the Vitrual SMTP server and everything looked ok Internal and
    > external.
    >
    > Then I tryed using the netcap and all I could notice was these three
    > sentences repeating in the capture filein the following order:
    >
    > CONNECT mydomain.com:443 HTTP/1.0
    > HTTP/1.1 200 Connection established
    > HTTP/1.1 407 Proxy Authentication Required ( The ISA Server requires
    > authorization to fulfill the request. Access to the Web Proxy service is
    > denied. )
    >
    > It points to an ISA problem, so I went to my ISA server and forced my
    > incoming web listener to ask for identification to unauthenticated users,
    > but it didn't seem to have any effect, it's all still working in the same
    > way! I access the site, i put a username and password, i choose a
    > computer,
    > hit connect, and the error appears.... :(
    >
    > What can I be doing wrong here?
    >
    >
    > Could have anything to do with the fact that my ISA server is in a
    > different
    > box from my SBS server? I'm not using the ISA server that is on the SBS
    > box,
    > but it's still there, just sitting aroung... and I've got everything else
    > working fine this way, OWA, TSWEB, WWW, Mail...
    >
    > The layout for the RWW scheme is:
    >
    > Router --- ISA Box --- SBS Box(RWW)
    >
    >
    > I want to take the chance, and thank everybody for trying to help me sort
    > this out...
    >
    > Thank you very much...
    >
    >
    > "David Copeland [MSFT]" <davidcop@online.microsoft.com> wrote in message
    > news:eDX05rrXEHA.3664@TK2MSFTNGP12.phx.gbl...
    >> Pedro,
    >>
    >> Here's something you could try to verify that port 4125 is open to your
    >> server.. basically going to configure an SMTP virtual server to listen
    > on
    >> port 4125 and try to connect.
    >>
    >> 1) Go into Start/Server Management/Advanced Management/First Organization
    >> (Exchange)/Servers/servername/Protocols/SMTP right click on SMTP and
    >> select New/SMTP virtual server.
    >> 2) Give it a name of something like test1
    >> 3) For the IP address just leave it at all unassigned and click the
    >> Finish
    >> button. Click Yes to the prompt asking if you are sure you want to use
    > that
    >> address.
    >> 4) Right click on the new SMTP virtual server created in step2 and select
    >> Properties and click the Advanced button to the right of the IP Address
    >> field.
    >> 5) Click the Edit button then change the port from 25 to 4125 then click
    > the
    >> OK button (3 times to get all the way back out)
    >> 6) Right click on the new SMTP virtual server and select Start
    >>
    >> If it is able to successfully start, then from a remote machine try
    >> telneting to your server on port 4125.. using the following command
    >>
    >> telnet x.x.x.x 4125
    >>
    >> where x.x.x.x is the IP address used to reach the external side of the
    >> server.
    >>
    >> You should get back an Exchange banner.. If you do then it appears that
    >> the port is open to the server.. and we may need to look more
    >> specifically
    >> at remote web workplace.. if you are not able to connect, then it could
    >> be
    >> an indication that the port isn't open.. as another test you may want to
    >> verify it works from an internal client.
    >>
    >> Be sure to go back and delete the test1 SMTP virtual server after your
    > test.
    >>
    >> Another option you may want to do if you have a remote XP client is to
    >> install the support tools from the XP cd.. and then use netcap to get a
    >> network trace attempting to connect.. from that we may be able to see if
    >> it's making the connection or not to the server.. and/or possible tell if
    > a
    >> router/firewall is blocking the port (based on an ICMP error response)
    >>
    >> --
    >>
    >> Hope that helps,
    >> David Copeland
    >> Microsoft Small Business Server Support
    >>
    >> This posting is provided "AS IS" with no warranties, and confers no
    > rights.
    >>
    >> Newsgroups:
    >> SBS v4.x : microsoft.public.backoffice.smallbiz
    >> SBS 2000: microsoft.public.backoffice.smallbiz2000
    >> SBS 2003: microsoft.public.windows.server.sbs
    >>
    >>
    >> "PG" <Pedro.Gomes@clix.pt> wrote in message
    >> news:%23RGOLlnXEHA.1356@TK2MSFTNGP09.phx.gbl...
    >> > Anymore ideas, as where I can look for the problem? I'm running out of
    >> > ideas...
    >> >
    >> > My router forwards all ports to my ISA server.
    >> > On my ISA server I created a protocol rule allowing both Inbound and
    >> > Outbound port 4125 to my internal server. And still nothing... When I
    >> > press
    >> > "connect" the same stupid error apears... :(
    >> >
    >> > Thank's for all your help so far... Hope you can help me figure this
    >> > out...
    >> >
    >> >
    >> > "Les Connor [SBS MVP]" <les.connor@DEL.cfive.ca> wrote in message
    >> > news:u6y75WfXEHA.1888@TK2MSFTNGP11.phx.gbl...
    >> >> Only if you want Companyweb (Sharepoint) available to external users
    >> >> do
    >> > you
    >> >> need 444.
    >> >>
    >> >> --
    >> >> Les Connor [SBS MVP]
    >> >> -------------------------------------
    >> >> SBS Rocks !
    >> >>
    >> >>
    >> >>
    >> >> "Marina Roos [SBS-MVP]" <marina@roos.nodontwantspam.nl.com> wrote in
    >> > message
    >> >> news:OXQyDPeXEHA.2716@tk2msftngp13.phx.gbl...
    >> >> > What is it with almost everybody, that they seem to forget that RWW
    > is
    >> >> > working with 444!
    >> >> >
    >> >> > 443 is for OWA, RWW needs 444 and 4125 forwarded from the router to
    > the
    >> >> > external nic-IP.
    >> >> >
    >> >> >
    >> >> > --
    >> >> > Regards,
    >> >> >
    >> >> > Marina
    >> >> > Microsoft SBS-MVP
    >> >> >
    >> >> > "PG" <Pedro.Gomes@clix.pt> schreef in bericht
    >> >> > news:uxr5%239aXEHA.2388@TK2MSFTNGP11.phx.gbl...
    >> >> > > I already have port 4125 opened on my ISA server, David.
    >> >> > >
    >> >> > > "David Copeland [MSFT]" <davidcop@online.microsoft.com> wrote in
    >> > message
    >> >> > > news:eYnsUPTXEHA.2364@TK2MSFTNGP12.phx.gbl...
    >> >> > > > Pedro,
    >> >> > > >
    >> >> > > > Make sure that TCP Port 4125 is open/forwarded back to the SBS
    >> > server
    >> >> > from
    >> >> > > > your router/firewall. Remote Web Workplace uses TCP port 443 to
    >> >> connect
    >> >> > > to
    >> >> > > > the site using SSL and then from the external client to the
    > server
    >> >> uses
    >> >> > > TCP
    >> >> > > > port 4125, then from the server to the internal client is TCP
    > port
    >> >> 3389.
    >> >> > > >
    >> >> > > >
    >> >> > > > --
    >> >> > > >
    >> >> > > > Hope that helps,
    >> >> > > > David Copeland
    >> >> > > > Microsoft Small Business Server Support
    >> >> > > >
    >> >> > > > This posting is provided "AS IS" with no warranties, and confers
    > no
    >> >> > > rights.
    >> >> > > >
    >> >> > > > Newsgroups:
    >> >> > > > SBS v4.x : microsoft.public.backoffice.smallbiz
    >> >> > > > SBS 2000: microsoft.public.backoffice.smallbiz2000
    >> >> > > > SBS 2003: microsoft.public.windows.server.sbs
    >> >> > > >
    >> >> > > >
    >> >> > > > "PG" <Pedro.Gomes@clix.pt> wrote in message
    >> >> > > > news:%23hFLKkSXEHA.3716@TK2MSFTNGP10.phx.gbl...
    >> >> > > > > Hi everybody, I'm having a little problem with Remote Web
    >> > Workplace,
    >> >> > and
    >> >> > > I
    >> >> > > > > hope someone can help me out. The problem is:
    >> >> > > > >
    >> >> > > > > If I access through https://mypublicdomain/tsweb
    >> >> > > > > - I can connect to any computer on my network
    >> >> > > > > If I access through https://localhost/remote
    >> >> > > > > - I can connect to any computer on my network
    >> >> > > > > If I access through https://mypublicdomain/remote
    >> >> > > > > - I can't connect to any computer on my network!
    > Everything
    >> >> > works
    >> >> > > > > fine, until I choose the computer and press connect, then I
    >> >> > > > > see
    >> > the
    >> >> > > > > following message:
    >> >> > > > >
    >> >> > > > > "The client could not establish a connection to the remote
    >> > computer.
    >> >> > The
    >> >> > > > > most likely causes for this error are:
    >> >> > > > > a.. Remote connections might not be enabled at the remote
    >> > computer.
    >> >> > > > > b.. The maximum number of connections might be exceeded at
    >> >> > > > > the
    >> >> remote
    >> >> > > > > computer.
    >> >> > > > > c.. A network error might have occurred while establishing
    >> >> > > > > the
    >> >> > > > > connection.
    >> >> > > > > d.. The Remote Web Workplace designated port might be blocked
    > by
    >> > a
    >> >> > > > > firewall. "
    >> >> > > > > Can someone help me out, please? I don't know where to look
    >> >> > anymore....
    >> >> > > > >
    >> >> > > > > Thanks in advance
    >> >> > > > >
    >> >> > > > >
    >> >> > > >
    >> >> > > >
    >> >> > >
    >> >> > >
    >> >> >
    >> >> >
    >> >>
    >> >>
    >> >
    >> >
    >>
    >>
    >
    >
  13. Archived from groups: microsoft.public.windowsxp.work_remotely,microsoft.public.windows.server.sbs (More info?)

    Hi David,

    I did what you asked and it worked perfectly from the ISA box, using the IP
    address or using the FQDN of the SBS box, no problem at all....

    Yes to the server publishing rule question...

    And I'm sending you also an *.txt file with the info you asked to your
    e-mail


    "David Copeland [MSFT]" <davidcop@online.microsoft.com> wrote in message
    news:u6kuNT1XEHA.384@TK2MSFTNGP10.phx.gbl...
    > Pedro,
    >
    > Can you logon to RWW from the ISA server (make sure that IE on the ISA
    > server is not configured to use a Proxy server for the test) and then use
    > the IP address of the SBS server to connect with.. then once logged on to
    > RWW try to connect to one of the clients or the SBS server itself (if
    logged
    > on to RWW as administrator).
    >
    > Just to be sure.. from a machine out on the Internet you could telnet to
    the
    > external IP address of your ISA server on port 4125 and got the SMTP
    banner
    > back correct? by way of a server publishing rule???
    >
    > Would it be possible for you to email me a copy of the netcap taken from
    an
    > XP machine on the Internet attempting to connect.. (you would need to
    remove
    > the "online." from my address)
    >
    > --
    >
    > Hope that helps,
    > David Copeland
    > Microsoft Small Business Server Support
    >
    > This posting is provided "AS IS" with no warranties, and confers no
    rights.
    >
    > Newsgroups:
    > SBS v4.x : microsoft.public.backoffice.smallbiz
    > SBS 2000: microsoft.public.backoffice.smallbiz2000
    > SBS 2003: microsoft.public.windows.server.sbs
    >
    >
    > "PG" <Pedro.Gomes@clix.pt> wrote in message
    > news:ej462x0XEHA.2344@TK2MSFTNGP11.phx.gbl...
    > > Hi David, and thanks for the tips...
    > >
    > > I've tryied everything you said and here is the results:
    > >
    > > I created the Vitrual SMTP server and everything looked ok Internal and
    > > external.
    > >
    > > Then I tryed using the netcap and all I could notice was these three
    > > sentences repeating in the capture filein the following order:
    > >
    > > CONNECT mydomain.com:443 HTTP/1.0
    > > HTTP/1.1 200 Connection established
    > > HTTP/1.1 407 Proxy Authentication Required ( The ISA Server requires
    > > authorization to fulfill the request. Access to the Web Proxy service is
    > > denied. )
    > >
    > > It points to an ISA problem, so I went to my ISA server and forced my
    > > incoming web listener to ask for identification to unauthenticated
    users,
    > > but it didn't seem to have any effect, it's all still working in the
    same
    > > way! I access the site, i put a username and password, i choose a
    > > computer,
    > > hit connect, and the error appears.... :(
    > >
    > > What can I be doing wrong here?
    > >
    > >
    > > Could have anything to do with the fact that my ISA server is in a
    > > different
    > > box from my SBS server? I'm not using the ISA server that is on the SBS
    > > box,
    > > but it's still there, just sitting aroung... and I've got everything
    else
    > > working fine this way, OWA, TSWEB, WWW, Mail...
    > >
    > > The layout for the RWW scheme is:
    > >
    > > Router --- ISA Box --- SBS Box(RWW)
    > >
    > >
    > > I want to take the chance, and thank everybody for trying to help me
    sort
    > > this out...
    > >
    > > Thank you very much...
    > >
    > >
    > > "David Copeland [MSFT]" <davidcop@online.microsoft.com> wrote in message
    > > news:eDX05rrXEHA.3664@TK2MSFTNGP12.phx.gbl...
    > >> Pedro,
    > >>
    > >> Here's something you could try to verify that port 4125 is open to your
    > >> server.. basically going to configure an SMTP virtual server to
    listen
    > > on
    > >> port 4125 and try to connect.
    > >>
    > >> 1) Go into Start/Server Management/Advanced Management/First
    Organization
    > >> (Exchange)/Servers/servername/Protocols/SMTP right click on SMTP and
    > >> select New/SMTP virtual server.
    > >> 2) Give it a name of something like test1
    > >> 3) For the IP address just leave it at all unassigned and click the
    > >> Finish
    > >> button. Click Yes to the prompt asking if you are sure you want to use
    > > that
    > >> address.
    > >> 4) Right click on the new SMTP virtual server created in step2 and
    select
    > >> Properties and click the Advanced button to the right of the IP Address
    > >> field.
    > >> 5) Click the Edit button then change the port from 25 to 4125 then
    click
    > > the
    > >> OK button (3 times to get all the way back out)
    > >> 6) Right click on the new SMTP virtual server and select Start
    > >>
    > >> If it is able to successfully start, then from a remote machine try
    > >> telneting to your server on port 4125.. using the following command
    > >>
    > >> telnet x.x.x.x 4125
    > >>
    > >> where x.x.x.x is the IP address used to reach the external side of the
    > >> server.
    > >>
    > >> You should get back an Exchange banner.. If you do then it appears
    that
    > >> the port is open to the server.. and we may need to look more
    > >> specifically
    > >> at remote web workplace.. if you are not able to connect, then it could
    > >> be
    > >> an indication that the port isn't open.. as another test you may want
    to
    > >> verify it works from an internal client.
    > >>
    > >> Be sure to go back and delete the test1 SMTP virtual server after your
    > > test.
    > >>
    > >> Another option you may want to do if you have a remote XP client is to
    > >> install the support tools from the XP cd.. and then use netcap to get a
    > >> network trace attempting to connect.. from that we may be able to see
    if
    > >> it's making the connection or not to the server.. and/or possible tell
    if
    > > a
    > >> router/firewall is blocking the port (based on an ICMP error response)
    > >>
    > >> --
    > >>
    > >> Hope that helps,
    > >> David Copeland
    > >> Microsoft Small Business Server Support
    > >>
    > >> This posting is provided "AS IS" with no warranties, and confers no
    > > rights.
    > >>
    > >> Newsgroups:
    > >> SBS v4.x : microsoft.public.backoffice.smallbiz
    > >> SBS 2000: microsoft.public.backoffice.smallbiz2000
    > >> SBS 2003: microsoft.public.windows.server.sbs
    > >>
    > >>
    > >> "PG" <Pedro.Gomes@clix.pt> wrote in message
    > >> news:%23RGOLlnXEHA.1356@TK2MSFTNGP09.phx.gbl...
    > >> > Anymore ideas, as where I can look for the problem? I'm running out
    of
    > >> > ideas...
    > >> >
    > >> > My router forwards all ports to my ISA server.
    > >> > On my ISA server I created a protocol rule allowing both Inbound and
    > >> > Outbound port 4125 to my internal server. And still nothing... When I
    > >> > press
    > >> > "connect" the same stupid error apears... :(
    > >> >
    > >> > Thank's for all your help so far... Hope you can help me figure this
    > >> > out...
    > >> >
    > >> >
    > >> > "Les Connor [SBS MVP]" <les.connor@DEL.cfive.ca> wrote in message
    > >> > news:u6y75WfXEHA.1888@TK2MSFTNGP11.phx.gbl...
    > >> >> Only if you want Companyweb (Sharepoint) available to external users
    > >> >> do
    > >> > you
    > >> >> need 444.
    > >> >>
    > >> >> --
    > >> >> Les Connor [SBS MVP]
    > >> >> -------------------------------------
    > >> >> SBS Rocks !
    > >> >>
    > >> >>
    > >> >>
    > >> >> "Marina Roos [SBS-MVP]" <marina@roos.nodontwantspam.nl.com> wrote in
    > >> > message
    > >> >> news:OXQyDPeXEHA.2716@tk2msftngp13.phx.gbl...
    > >> >> > What is it with almost everybody, that they seem to forget that
    RWW
    > > is
    > >> >> > working with 444!
    > >> >> >
    > >> >> > 443 is for OWA, RWW needs 444 and 4125 forwarded from the router
    to
    > > the
    > >> >> > external nic-IP.
    > >> >> >
    > >> >> >
    > >> >> > --
    > >> >> > Regards,
    > >> >> >
    > >> >> > Marina
    > >> >> > Microsoft SBS-MVP
    > >> >> >
    > >> >> > "PG" <Pedro.Gomes@clix.pt> schreef in bericht
    > >> >> > news:uxr5%239aXEHA.2388@TK2MSFTNGP11.phx.gbl...
    > >> >> > > I already have port 4125 opened on my ISA server, David.
    > >> >> > >
    > >> >> > > "David Copeland [MSFT]" <davidcop@online.microsoft.com> wrote in
    > >> > message
    > >> >> > > news:eYnsUPTXEHA.2364@TK2MSFTNGP12.phx.gbl...
    > >> >> > > > Pedro,
    > >> >> > > >
    > >> >> > > > Make sure that TCP Port 4125 is open/forwarded back to the SBS
    > >> > server
    > >> >> > from
    > >> >> > > > your router/firewall. Remote Web Workplace uses TCP port 443
    to
    > >> >> connect
    > >> >> > > to
    > >> >> > > > the site using SSL and then from the external client to the
    > > server
    > >> >> uses
    > >> >> > > TCP
    > >> >> > > > port 4125, then from the server to the internal client is TCP
    > > port
    > >> >> 3389.
    > >> >> > > >
    > >> >> > > >
    > >> >> > > > --
    > >> >> > > >
    > >> >> > > > Hope that helps,
    > >> >> > > > David Copeland
    > >> >> > > > Microsoft Small Business Server Support
    > >> >> > > >
    > >> >> > > > This posting is provided "AS IS" with no warranties, and
    confers
    > > no
    > >> >> > > rights.
    > >> >> > > >
    > >> >> > > > Newsgroups:
    > >> >> > > > SBS v4.x : microsoft.public.backoffice.smallbiz
    > >> >> > > > SBS 2000: microsoft.public.backoffice.smallbiz2000
    > >> >> > > > SBS 2003: microsoft.public.windows.server.sbs
    > >> >> > > >
    > >> >> > > >
    > >> >> > > > "PG" <Pedro.Gomes@clix.pt> wrote in message
    > >> >> > > > news:%23hFLKkSXEHA.3716@TK2MSFTNGP10.phx.gbl...
    > >> >> > > > > Hi everybody, I'm having a little problem with Remote Web
    > >> > Workplace,
    > >> >> > and
    > >> >> > > I
    > >> >> > > > > hope someone can help me out. The problem is:
    > >> >> > > > >
    > >> >> > > > > If I access through https://mypublicdomain/tsweb
    > >> >> > > > > - I can connect to any computer on my network
    > >> >> > > > > If I access through https://localhost/remote
    > >> >> > > > > - I can connect to any computer on my network
    > >> >> > > > > If I access through https://mypublicdomain/remote
    > >> >> > > > > - I can't connect to any computer on my network!
    > > Everything
    > >> >> > works
    > >> >> > > > > fine, until I choose the computer and press connect, then I
    > >> >> > > > > see
    > >> > the
    > >> >> > > > > following message:
    > >> >> > > > >
    > >> >> > > > > "The client could not establish a connection to the remote
    > >> > computer.
    > >> >> > The
    > >> >> > > > > most likely causes for this error are:
    > >> >> > > > > a.. Remote connections might not be enabled at the remote
    > >> > computer.
    > >> >> > > > > b.. The maximum number of connections might be exceeded at
    > >> >> > > > > the
    > >> >> remote
    > >> >> > > > > computer.
    > >> >> > > > > c.. A network error might have occurred while establishing
    > >> >> > > > > the
    > >> >> > > > > connection.
    > >> >> > > > > d.. The Remote Web Workplace designated port might be
    blocked
    > > by
    > >> > a
    > >> >> > > > > firewall. "
    > >> >> > > > > Can someone help me out, please? I don't know where to look
    > >> >> > anymore....
    > >> >> > > > >
    > >> >> > > > > Thanks in advance
    > >> >> > > > >
    > >> >> > > > >
    > >> >> > > >
    > >> >> > > >
    > >> >> > >
    > >> >> > >
    > >> >> >
    > >> >> >
    > >> >>
    > >> >>
    > >> >
    > >> >
    > >>
    > >>
    > >
    > >
    >
    >
  14. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    No BartVDA, it's with XP Professional...

    "BartVDA" <BartVDA@discussions.microsoft.com> wrote in message
    news:C7506ED6-06E3-406F-B74D-56B47ACEE544@microsoft.com...
    > Hi Pedro,
    >
    > I'm having exactly the same problem if I connect via WindowsXP Home, when
    I use WindowsXP professional I don't have the problem.
    > Is this also in your case?
    >
    > Bart
    >
    > "PG" wrote:
    >
    > > I have to establish a VPN first????
    > >
    > > Are you sure of this? I believe that the whole purpose of the Remote
    Web
    > > Workplace thing, is to make thing's easy just using an HTTP connection
    to
    > > your company...
    > >
    > > If I need a VPN for Remote Web Workplace to work, then why does Terminal
    > > services work without one?
    > >
    > >
    > > "Jeffrey Randow (MVP)" <jeffreyr-support@remotenetworktechnology.com>
    wrote
    > > in message news:0vf1e09h7kmforicpi98f4tv3u9ee03r8g@4ax.com...
    > > > You won't be able to connect to any computers behind a firewall
    > > > without establishing a VPN...
    > > >
    > > > Jeffrey Randow (Windows Networking & Smart Display MVP)
    > > > jeffreyr-support@remotenetworktechnology.com
    > > >
    > > > Please post all responses to the newsgroups for the benefit
    > > > of all USENET users. Messages sent via email may or may not
    > > > be answered depending on time availability....
    > > >
    > > > Remote Networking Technology Support Site -
    > > > http://www.remotenetworktechnology.com
    > > > Windows XP Expert Zone - http://www.microsoft.com/windowsxp/expertzone
    > > >
    > > > On Mon, 28 Jun 2004 16:45:29 +0100, "PG" <Pedro.Gomes@clix.pt> wrote:
    > > >
    > > > >Hi everybody, I'm having a little problem with Remote Web Workplace,
    and
    > > I
    > > > >hope someone can help me out. The problem is:
    > > > >
    > > > >If I access through https://mypublicdomain/tsweb
    > > > > - I can connect to any computer on my network
    > > > >If I access through https://localhost/remote
    > > > > - I can connect to any computer on my network
    > > > >If I access through https://mypublicdomain/remote
    > > > > - I can't connect to any computer on my network! Everything
    works
    > > > >fine, until I choose the computer and press connect, then I see the
    > > > >following message:
    > > > >
    > > > >"The client could not establish a connection to the remote computer.
    The
    > > > >most likely causes for this error are:
    > > > > a.. Remote connections might not be enabled at the remote computer.
    > > > > b.. The maximum number of connections might be exceeded at the
    remote
    > > > >computer.
    > > > > c.. A network error might have occurred while establishing the
    > > connection.
    > > > > d.. The Remote Web Workplace designated port might be blocked by a
    > > > >firewall. "
    > > > >Can someone help me out, please? I don't know where to look
    anymore....
    > > > >
    > > > >Thanks in advance
    > > > >
    > > >
    > >
    > >
    > >
Ask a new question

Read More

Connection Computers Microsoft Windows XP