Sign in with
Sign up | Sign in
Your question

Need help with VPN problem

Last response: in Windows XP
Share
July 21, 2004 2:24:16 PM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

At home, I can access my work computer thru the office VPN. I want to do the
reverse which is to access my home computer from work. My home computer is
XP pro behind a D-Link router. I have configured my home computer to be a
VPN server (allowed incoming connections, assigned ip range, provide
permission to my local user account). In the router, I have forwarded port
1723 to my home PC's IP address. With all these set, I can't still connect
to my home pc using VPN. I keep getting the message, Error 721: The remote
computer did not respond. I can't even ping my routers public IP assigned by
my DSL provider.

By the way, at work, I am behind the company's firewall and I don't have any
access to the firewall's settings. My work pc is a laptop running XP pro as
well. At work, I can connect to my home pc using Remote Desktop so I think
VPN should also work. I need to connect thru VPN because I need to map a
drive to my home pc so I can easily transfer files between my home pc and my
work pc.

Can somebody help me please. Thanks in advance.

--Francis--

More about : vpn problem

Anonymous
July 21, 2004 5:23:33 PM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Hello

Your company will ahve to provide you with the correct settings
and software so you cn access the VPN, their should be some
software that you have to install on your pc, VPN software
from oyur company, they need to provide you with that

alvin


Francis wrote:

> At home, I can access my work computer thru the office VPN. I want to do the
> reverse which is to access my home computer from work. My home computer is
> XP pro behind a D-Link router. I have configured my home computer to be a
> VPN server (allowed incoming connections, assigned ip range, provide
> permission to my local user account). In the router, I have forwarded port
> 1723 to my home PC's IP address. With all these set, I can't still connect
> to my home pc using VPN. I keep getting the message, Error 721: The remote
> computer did not respond. I can't even ping my routers public IP assigned by
> my DSL provider.
>
> By the way, at work, I am behind the company's firewall and I don't have any
> access to the firewall's settings. My work pc is a laptop running XP pro as
> well. At work, I can connect to my home pc using Remote Desktop so I think
> VPN should also work. I need to connect thru VPN because I need to map a
> drive to my home pc so I can easily transfer files between my home pc and my
> work pc.
>
> Can somebody help me please. Thanks in advance.
>
> --Francis--
Anonymous
July 21, 2004 8:10:58 PM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Why not use the file transfer facilities of Remote Desktop? See a message
from Sooner Al posted today with all the details in it.

Your router may be set not to allow ping responses. This setting has
different wording from various vendors, and I'm not sure what D-link might
call it.

You need to check with D-link about what is necessary to set up for a PPTP
VPN connection inbound. This will normally be available through a FAQ or
some automated KB system in the support area of a given vendors web site.

What is important is that there are two protocols involved in a PPTP VPN:
TCP, on port 1723, and GRE protocol 47. It is the latter protocol that can
be the sticking point--some vendors open it automagically when 1723 is
opened, others use terminology such as "pptp passthrough". Not sure what
D-Link does.

Then you've got the issue of the company firewall. You'd be better off
testing this from a friends house so that you can eliminate the issue of the
firewall and be sure things at home are set up right--then test at work.

All in all--I'd go with looking at what Sooner Al posted about file
transfers with Remote Desktop--that should work just fine, unless your
company has locked them down via group policy.

"Francis" <ftarcelo@sddpc.org> wrote in message
news:uLUA3c0bEHA.3476@tk2msftngp13.phx.gbl...
> At home, I can access my work computer thru the office VPN. I want to do
> the
> reverse which is to access my home computer from work. My home computer is
> XP pro behind a D-Link router. I have configured my home computer to be a
> VPN server (allowed incoming connections, assigned ip range, provide
> permission to my local user account). In the router, I have forwarded port
> 1723 to my home PC's IP address. With all these set, I can't still connect
> to my home pc using VPN. I keep getting the message, Error 721: The remote
> computer did not respond. I can't even ping my routers public IP assigned
> by
> my DSL provider.
>
> By the way, at work, I am behind the company's firewall and I don't have
> any
> access to the firewall's settings. My work pc is a laptop running XP pro
> as
> well. At work, I can connect to my home pc using Remote Desktop so I think
> VPN should also work. I need to connect thru VPN because I need to map a
> drive to my home pc so I can easily transfer files between my home pc and
> my
> work pc.
>
> Can somebody help me please. Thanks in advance.
>
> --Francis--
>
>
Related resources
July 21, 2004 8:10:59 PM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Bill / Alvin,

Thanks to both your responses. It seems to me that the corp's firewall
really has something to do with my problem because when I dial-up to my ISP
provider (from work), instead of using the corp network, I am able to ping
my home router's public IP. However, I still can't connect thru VPN. That
may have something to do with the "pptp passthrough" you mentioned Bill.

But what I'm puzzled about is why remote desktop works thru the corp
firewall, and the pinging or VPN won't.

The reason why I don't want to use RDP is because my wife usually works on
my home pc and when I connect to it via RDP, it kicks her out of whatever
she's doing on the computer.

Thanks again,
--Francis--


"Bill Sanderson" <Bill_Sanderson@msn.com.plugh.org> wrote in message
news:%23kHtW71bEHA.3524@TK2MSFTNGP12.phx.gbl...
> Why not use the file transfer facilities of Remote Desktop? See a message
> from Sooner Al posted today with all the details in it.
>
> Your router may be set not to allow ping responses. This setting has
> different wording from various vendors, and I'm not sure what D-link might
> call it.
>
> You need to check with D-link about what is necessary to set up for a PPTP
> VPN connection inbound. This will normally be available through a FAQ or
> some automated KB system in the support area of a given vendors web site.
>
> What is important is that there are two protocols involved in a PPTP VPN:
> TCP, on port 1723, and GRE protocol 47. It is the latter protocol that
can
> be the sticking point--some vendors open it automagically when 1723 is
> opened, others use terminology such as "pptp passthrough". Not sure what
> D-Link does.
>
> Then you've got the issue of the company firewall. You'd be better off
> testing this from a friends house so that you can eliminate the issue of
the
> firewall and be sure things at home are set up right--then test at work.
>
> All in all--I'd go with looking at what Sooner Al posted about file
> transfers with Remote Desktop--that should work just fine, unless your
> company has locked them down via group policy.
>
> "Francis" <ftarcelo@sddpc.org> wrote in message
> news:uLUA3c0bEHA.3476@tk2msftngp13.phx.gbl...
> > At home, I can access my work computer thru the office VPN. I want to do
> > the
> > reverse which is to access my home computer from work. My home computer
is
> > XP pro behind a D-Link router. I have configured my home computer to be
a
> > VPN server (allowed incoming connections, assigned ip range, provide
> > permission to my local user account). In the router, I have forwarded
port
> > 1723 to my home PC's IP address. With all these set, I can't still
connect
> > to my home pc using VPN. I keep getting the message, Error 721: The
remote
> > computer did not respond. I can't even ping my routers public IP
assigned
> > by
> > my DSL provider.
> >
> > By the way, at work, I am behind the company's firewall and I don't have
> > any
> > access to the firewall's settings. My work pc is a laptop running XP pro
> > as
> > well. At work, I can connect to my home pc using Remote Desktop so I
think
> > VPN should also work. I need to connect thru VPN because I need to map a
> > drive to my home pc so I can easily transfer files between my home pc
and
> > my
> > work pc.
> >
> > Can somebody help me please. Thanks in advance.
> >
> > --Francis--
> >
> >
>
>
Anonymous
July 21, 2004 11:22:03 PM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Firewalls can be configured to block any or all ports, inbound and out.

You're quite lucky that they've allowed RD outbound, but I understand your
reason for not wanting to use it.

FWIW, if you log in with your wife's userid and password, you won't disturb
her session (assuming she's not actively typing away) and there's a shortcut
you can use to pop the desktop back to her when you are done:

%windir%\system32\tscon.exe 0 /dest:console

When you can get the VPN to connect via your dialup ISP, test from work.

You could ask if they'll open it (vpn), I suppose.

If you get solidly stuck, post back with the model of the router, and the
firmware version, and I can see whether they have an online manual or other
details, or perhaps a firmware upgrade to help.


"Francis" <ftarcelo@sddpc.org> wrote in message
news:o mRwOn2bEHA.596@TK2MSFTNGP11.phx.gbl...
> Bill / Alvin,
>
> Thanks to both your responses. It seems to me that the corp's firewall
> really has something to do with my problem because when I dial-up to my
> ISP
> provider (from work), instead of using the corp network, I am able to ping
> my home router's public IP. However, I still can't connect thru VPN. That
> may have something to do with the "pptp passthrough" you mentioned Bill.
>
> But what I'm puzzled about is why remote desktop works thru the corp
> firewall, and the pinging or VPN won't.
>
> The reason why I don't want to use RDP is because my wife usually works on
> my home pc and when I connect to it via RDP, it kicks her out of whatever
> she's doing on the computer.
>
> Thanks again,
> --Francis--
>
>
> "Bill Sanderson" <Bill_Sanderson@msn.com.plugh.org> wrote in message
> news:%23kHtW71bEHA.3524@TK2MSFTNGP12.phx.gbl...
>> Why not use the file transfer facilities of Remote Desktop? See a
>> message
>> from Sooner Al posted today with all the details in it.
>>
>> Your router may be set not to allow ping responses. This setting has
>> different wording from various vendors, and I'm not sure what D-link
>> might
>> call it.
>>
>> You need to check with D-link about what is necessary to set up for a
>> PPTP
>> VPN connection inbound. This will normally be available through a FAQ or
>> some automated KB system in the support area of a given vendors web site.
>>
>> What is important is that there are two protocols involved in a PPTP VPN:
>> TCP, on port 1723, and GRE protocol 47. It is the latter protocol that
> can
>> be the sticking point--some vendors open it automagically when 1723 is
>> opened, others use terminology such as "pptp passthrough". Not sure what
>> D-Link does.
>>
>> Then you've got the issue of the company firewall. You'd be better off
>> testing this from a friends house so that you can eliminate the issue of
> the
>> firewall and be sure things at home are set up right--then test at work.
>>
>> All in all--I'd go with looking at what Sooner Al posted about file
>> transfers with Remote Desktop--that should work just fine, unless your
>> company has locked them down via group policy.
>>
>> "Francis" <ftarcelo@sddpc.org> wrote in message
>> news:uLUA3c0bEHA.3476@tk2msftngp13.phx.gbl...
>> > At home, I can access my work computer thru the office VPN. I want to
>> > do
>> > the
>> > reverse which is to access my home computer from work. My home computer
> is
>> > XP pro behind a D-Link router. I have configured my home computer to be
> a
>> > VPN server (allowed incoming connections, assigned ip range, provide
>> > permission to my local user account). In the router, I have forwarded
> port
>> > 1723 to my home PC's IP address. With all these set, I can't still
> connect
>> > to my home pc using VPN. I keep getting the message, Error 721: The
> remote
>> > computer did not respond. I can't even ping my routers public IP
> assigned
>> > by
>> > my DSL provider.
>> >
>> > By the way, at work, I am behind the company's firewall and I don't
>> > have
>> > any
>> > access to the firewall's settings. My work pc is a laptop running XP
>> > pro
>> > as
>> > well. At work, I can connect to my home pc using Remote Desktop so I
> think
>> > VPN should also work. I need to connect thru VPN because I need to map
>> > a
>> > drive to my home pc so I can easily transfer files between my home pc
> and
>> > my
>> > work pc.
>> >
>> > Can somebody help me please. Thanks in advance.
>> >
>> > --Francis--
>> >
>> >
>>
>>
>
>
July 22, 2004 1:53:24 PM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Bill,

Thanks a bunch for all these info. I did search the net for docs on my
D-Link DI-614+ router and was able to download a very recent firmware
upgrade. I also got some info on VPN faqs. My next move would be to try and
"bribe" our IT security officer to open up port 1723 on the firewall.

Thanks again and I appreciate the help.

--Francis--

"Bill Sanderson" <Bill_Sanderson@msn.com.plugh.org> wrote in message
news:e9LWJm3bEHA.2660@TK2MSFTNGP12.phx.gbl...
> Firewalls can be configured to block any or all ports, inbound and out.
>
> You're quite lucky that they've allowed RD outbound, but I understand your
> reason for not wanting to use it.
>
> FWIW, if you log in with your wife's userid and password, you won't
disturb
> her session (assuming she's not actively typing away) and there's a
shortcut
> you can use to pop the desktop back to her when you are done:
>
> %windir%\system32\tscon.exe 0 /dest:console
>
> When you can get the VPN to connect via your dialup ISP, test from work.
>
> You could ask if they'll open it (vpn), I suppose.
>
> If you get solidly stuck, post back with the model of the router, and the
> firmware version, and I can see whether they have an online manual or
other
> details, or perhaps a firmware upgrade to help.
>
>
> "Francis" <ftarcelo@sddpc.org> wrote in message
> news:o mRwOn2bEHA.596@TK2MSFTNGP11.phx.gbl...
> > Bill / Alvin,
> >
> > Thanks to both your responses. It seems to me that the corp's firewall
> > really has something to do with my problem because when I dial-up to my
> > ISP
> > provider (from work), instead of using the corp network, I am able to
ping
> > my home router's public IP. However, I still can't connect thru VPN.
That
> > may have something to do with the "pptp passthrough" you mentioned Bill.
> >
> > But what I'm puzzled about is why remote desktop works thru the corp
> > firewall, and the pinging or VPN won't.
> >
> > The reason why I don't want to use RDP is because my wife usually works
on
> > my home pc and when I connect to it via RDP, it kicks her out of
whatever
> > she's doing on the computer.
> >
> > Thanks again,
> > --Francis--
> >
> >
> > "Bill Sanderson" <Bill_Sanderson@msn.com.plugh.org> wrote in message
> > news:%23kHtW71bEHA.3524@TK2MSFTNGP12.phx.gbl...
> >> Why not use the file transfer facilities of Remote Desktop? See a
> >> message
> >> from Sooner Al posted today with all the details in it.
> >>
> >> Your router may be set not to allow ping responses. This setting has
> >> different wording from various vendors, and I'm not sure what D-link
> >> might
> >> call it.
> >>
> >> You need to check with D-link about what is necessary to set up for a
> >> PPTP
> >> VPN connection inbound. This will normally be available through a FAQ
or
> >> some automated KB system in the support area of a given vendors web
site.
> >>
> >> What is important is that there are two protocols involved in a PPTP
VPN:
> >> TCP, on port 1723, and GRE protocol 47. It is the latter protocol that
> > can
> >> be the sticking point--some vendors open it automagically when 1723 is
> >> opened, others use terminology such as "pptp passthrough". Not sure
what
> >> D-Link does.
> >>
> >> Then you've got the issue of the company firewall. You'd be better off
> >> testing this from a friends house so that you can eliminate the issue
of
> > the
> >> firewall and be sure things at home are set up right--then test at
work.
> >>
> >> All in all--I'd go with looking at what Sooner Al posted about file
> >> transfers with Remote Desktop--that should work just fine, unless your
> >> company has locked them down via group policy.
> >>
> >> "Francis" <ftarcelo@sddpc.org> wrote in message
> >> news:uLUA3c0bEHA.3476@tk2msftngp13.phx.gbl...
> >> > At home, I can access my work computer thru the office VPN. I want to
> >> > do
> >> > the
> >> > reverse which is to access my home computer from work. My home
computer
> > is
> >> > XP pro behind a D-Link router. I have configured my home computer to
be
> > a
> >> > VPN server (allowed incoming connections, assigned ip range, provide
> >> > permission to my local user account). In the router, I have forwarded
> > port
> >> > 1723 to my home PC's IP address. With all these set, I can't still
> > connect
> >> > to my home pc using VPN. I keep getting the message, Error 721: The
> > remote
> >> > computer did not respond. I can't even ping my routers public IP
> > assigned
> >> > by
> >> > my DSL provider.
> >> >
> >> > By the way, at work, I am behind the company's firewall and I don't
> >> > have
> >> > any
> >> > access to the firewall's settings. My work pc is a laptop running XP
> >> > pro
> >> > as
> >> > well. At work, I can connect to my home pc using Remote Desktop so I
> > think
> >> > VPN should also work. I need to connect thru VPN because I need to
map
> >> > a
> >> > drive to my home pc so I can easily transfer files between my home pc
> > and
> >> > my
> >> > work pc.
> >> >
> >> > Can somebody help me please. Thanks in advance.
> >> >
> >> > --Francis--
> >> >
> >> >
> >>
> >>
> >
> >
>
>
!