Sign in with
Sign up | Sign in
Your question

RH 7.1 - what do you think?

Tags:
Last response: in Linux/Free BSD
Share
May 17, 2001 7:37:43 AM

I'm (again :)  totally screwed up my RH 6.2 installation so I though that it's good time to try sth. newer for a change. I was pretty dissapointed about RH 7.0, is 7.1 any better? Has anyone tried it out? Or has RH screwed up again and Debian/Slackware/Turbolinux is the way to go? :)  Thank you for your thoughts...

More about : question

May 17, 2001 10:09:21 AM

Don't look at me, I'd tell you "Redhat has always sucked, Slackware all the way." Or I'd advise you to be really masochist and install <A HREF="http://www.linuxfromscratch.org/" target="_new">Linux from scratch.</A> :wink:

Seriously, though, I would consider a different distro. RedHat's been getting more and more broken ever since the 5.x days. I've heard good things about SuSE. Mandrake is OK, but just a tad unstable. Debian and Slackware are good if you <i>really</i> know what you're doing.

Kelledin

bash-2.04$ kill -9 1
init: Just what do you think you're doing, Dave?
Anonymous
May 17, 2001 2:04:57 PM

I may be trying it soon.

My Mandrake 8 box just rebooted itself yesterday morning for no apparent reason. and I've had some random lockups as well.

If I was satisfied with this kind of stability, I'd have stuck with windows :-(

I should mention that I'm pretty confident that it's not a hardware problem. I had a RedHat 6.2 variant on there that was rock-solid.

In theory, there is no difference between theory and practice.
In practice, there is.<P ID="edit"><FONT SIZE=-1><EM>Edited by ergeorge on 05/17/01 10:11 AM.</EM></FONT></P>
Related resources
May 18, 2001 4:16:29 AM

Someone told me they had the exact same problem with Mandrake 8. It rebooted for no reason at all. He spend half a day trying to figure it out and then tried to re-install. Said it seemed to work but then started to randomly lock-up. He had Mandrake 7.2 in before and it worked fine and Slackware is on it and works fine. So it must be a bug in Mandrake.

I use SuSE and I'm very happy with it. It has yet to crash on me!
May 18, 2001 4:55:19 AM

I've been noticing some small quirks in Mandrake8 myself. Here is a strange error I got while messing around with the Galleon web browser. It kicked me out of Xwindows back to the login screen.

Just funky. But I still wouldnt give it up. I've become addicted to that damn TableTennis game that came with the installation.

If you take a truth and follow it blindly, it will become a Falsehood and you a Fanatic.
May 18, 2001 8:08:02 AM

I tried that RH 7.1 out: better than 7.0, all new bells'n'whistles, good hardware support out-of-the-box, lot of stuff in my native language. Only problem is that X server works wierdly: 2D speed is form Trident9000 class (e.g. dead slow). I installed Nvidia video drivers and disabled all modules that I think might cause problems (DRI and others like that) but it's still very slow: XMMS built-in 2D plugins seems to run about 2FPS (even the smallest/simplest ones). I checked X log file, it sill seems to load some extra rendering modules that aren't even mentioned in conf. file. I'm out of ideas, I'll try to compile new X server for next. If I can't get everything running like I want with RH 7.1 I'll go with Debian...
Anonymous
May 18, 2001 3:40:47 PM

Do you have any details on his hardware/config?
Some discussions elsewhere might be pointing to ReiserFS (which I'm using).

In theory, there is no difference between theory and practice.
In practice, there is.
May 18, 2001 5:57:49 PM

Hmmm ReiserFS was less than stable prior to 3.6.25--I could easily put some strain on the 3.6.24 patches and make the kernel oops. After that, ReiserFS has been just fine.

My best advice would be to compile a stock 2.4.4 kernel and try that. Just keep the .config file from your old kernel source directory so you keep all your current config settings.

Kelledin

bash-2.04$ kill -9 1
init: Just what do you think you're doing, Dave?
May 22, 2001 10:23:29 AM

ive heard some very good things about 7.1 my friends run either that or debian (7.1 for workstations/laptops, debian for their servers) 7.1 is a huge improvement over 7.0 (which was utter SH!T but still... 7.1 is worth trying...

you do not strengthen teh weak by weakening the strong
Anonymous
May 22, 2001 2:35:42 PM

The discussion on ReiserFS centers around the 'notail' mount option. If you use this option (which the Mandrake install doesn't) it is supposed to be slightly faster & more stable, but less efficient in using disk space.

As I understand it, by default, very small files are inserted directly into the binary tree that reiserfs uses to maintain the filesystem. Larger files have an address in the tree. Using the notail option forces the small files to use addresses in the tree also. Seems that this would be slower, but the space efficiency loss makes sense.

In any case, to change this behavior, you have to re-write the entire filesystem. ie. move everything off the partition, remount the partition with the notail option, then copy everything back. I haven't tried it yet, I'm guessing I'll have to boot from the CD in order to move the low level stuff.

Somebody from Mandrake pointed me to all of this, so they know the potential for problems exists! I'm kind of annoyed that they ship a distribution with a default that they know is potentially unstable :frown:

On another front, RedHat 7.1 refuses to install on my box. It tells me my partition table on sda is corrupt and refuses to go on. sda is my 3ware IDE RAID controller.



In theory, there is no difference between theory and practice.
In practice, there is.
June 3, 2001 8:07:49 PM

I like it except for a HD problem at boot-up. It says

ide_dma_timeout func only:14
Chipset supported ide_dmaproc
Status=0x58 {DriveReady SeekComplete DataRequest

when probing DMA on my disk. It slows my boot-up process for 2-3 minutes. I tried anything I could think of (and with the help of others here) messing with hdparm to disabled DMA, no success. We figured out that it was directly in the kernel but I'm really not a kernel compiling pro :) . For that I will stick with an earlier version.

It's better to be rich and healthy than poor and sick!
Anonymous
June 4, 2001 3:51:44 PM

>I may be trying it soon.

Well, my Mandrake 8 install finally killed itself. Last Tuesday it locked up solid, and I had to do a hard reset again. When it came back up, it started failing during the boot, or shortly after trying to log in. It was now completely unusable. Probably a fs corruption due to the reset (ReiserFS can only do so much).

In any case, I didn't spend any time trying to debug/fix it. Slipped in the RedHat 7.1 CD instead. I had a brief problem because the RedHat installer didn't recognize the Mandrake partitions (?!?!), but a manual fdisk took care of that. From there on, the install was flawless. If <b>anybody</b> tells you linux is hard to install, politely tell them they are full of [-peep-]. I've never had an OS install go as smoothly as RedHat 7.1 or Mandrake 8.

First thing I did from there was install the nVidia drivers for my GeForceMX.

Some observations <i>wrt</i> Mandrake 8:

<b>RedHat 7.1 has not crashed for me since I installed.</b>
<i>Granted, I'ts only been a few days, but it's better then my experience with Mandrake. It may have been the ReiserFS that was causing the problems. I don't have the patience to find out, and Mandrake shouldn't ship it if they think it has problems.</i>

<b>kdevelop worked right "out of the box".</b>
<i>I had some difficulties with kdevelop under Mandrake 8. It didn't find some things that it wanted (htdig?) when it first started even though they were installed. And my first build attempt failed due to some permission error. I never bothered to track that down either.</i>

<b>My favorite code editor/IDE, CodeCrusader, works</b>
<i>Under Mandrake 8, the rpms installed fine, but when you tried to run it, you got nothing. No error, no window, nothing.</i>

<b>lm_sensors, lm_sensors-devel are available for during the install.</b>
<i>Mandrake 8 doesn't come with lm_sensors, so you need to get the rpms from the redhat distro. Considering the thermal issues AMD computers have, I think this is a serious ommision. Note that I still couldn't get khealthcare to build :-( Still no response from the maintainer either.</i>

And finally, RedHat 7.1 just feels cleaner & snappier to me. Stuff seems to load faster. Probably just perception.

In any case, I think Mandrake needs to do some more QA on their releases.


<i>Cognite Tute</i>
(Think for Yourself)
June 6, 2001 9:47:05 AM

What chipset does your mobo have? I've heard of my friend complaining about same thing using RH 7.1 with it's VIA MVP3-based mobo. I have been too lazy to check it out but if I finally do, I'll let you know how to get it work properly. BTW, compiling kernel is easy :) 

I have been running RH 7.1 about month for now, everything works nicely after a little tweaking. Got XMMS SDL plugins running normally after updating SDL and recompiling XMMS. I'm still impressed how much stuff is (correctly) translated into my native language (estonian). For user, who doesn't know much about computers, GUI in native language is IMO huge improvement. Better beware, M$ ;-)
June 6, 2001 3:48:46 PM

I have an ASUS K7V (KX133 chipset), my harddisk is connected with an UDMA66 compliant cable. I had a similar problem under Windows 2000 professionnal but there is a way to specify "PIO mode only" for my disk.

Thanks for the reply

It's better to be rich and healthy than poor and sick!
June 8, 2001 3:45:34 PM

You still may need to compile new kernel afterall: there's option "Use multi-mode by default" under "IDE, ATA and ATAPI Block devices" with following help included into latest 2.4.5 kernel:

"CONFIG_IDEDISK_MULTI_MODE:

If you get this error, try to say Y here:

hda: set_multmode: status=0x51 { DriveReady SeekComplete Error }
hda: set_multmode: error=0x04 { DriveStatusError} "

I guess that exactly what you might need...
!