Sign in with
Sign up | Sign in
Your question

Remote desktop client and ALTGR problem solved

Tags:
  • Remote Desktop
  • Windows XP
Last response: in Windows XP
Share
Anonymous
July 23, 2004 5:32:37 AM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

There are often problems with ALT GR key combinations and the Remote
Desktop client (mstsc.exe), the ALT key appears "sticky".
On my PC I was able to make the "Alt Gr" work as expected again very
easily (for XP), but hard to find out:

On the client PC open Control Panel -> Regional and Language Options
-> Languages Tab -> Details Button.

In the Dialog "Text Services and Input Languages" press the Button
"Key Settings". If that button is disabled, just add another language
with the "Add" button.
In the "Advanced Key Settings" dialog press "Change Key Sequence" for
"Switch between input languages". Now you are close:

In the "Change Key Sequence" Dialog uncheck "Switch keyboard layout"
and confirm the change through the series of dialogs.
You may remove the extra language if you like.

In my test, however, I found that the problem does not (or less
likely) occur with more than one language/keyboard configured.
I did not change anything on the server, just on the client.

More about : remote desktop client altgr problem solved

February 10, 2009 2:58:07 PM

I tried this on the client and it didn't help.

I tried it on the server and it worked!

Thanks!
March 4, 2010 9:38:40 AM

I did it on client (on server the box was already unchecked) and now it seams that the problem is gone. Finally. Still I had to add language to make the "Key Settings" button to appear. And removed it afterwards.

Thank you!
!