TMPGEnc "Video arrange Method" - how to get it to work

Archived from groups: rec.video.desktop (More info?)

Some quick background (numbered questions at the end). I was
converting analog video from my Sony Hi8 camcorder to DVD video using
an AverMedia DVD EZMaker PCI card (NEC 7130 chip version) and noticed
that people seem to be a bit fatter on the DVD than in the original
video. To confirm this, I shot some video of my entertainment center
(for lots of fixed vertical and horizontal lines), converted it to DVD
using my normal method (captured using VirtualVCR, encoded to MPEG2
using TMPGEnc, authored using Pinnacle Studio 8, and burned to DVD)
and compared the original video played back on the TV with the
resulting DVD played back on the TV. Vertical lines in the DVD were
shifted and farther apart than in the original.

I posted a message titled "Captured video slightly stretched
horizontally" to this newsgroup (see
http://groups.google.com/groups?hl=en&lr=&threadm=b0188aad.0410250843.6fe720b4%40posting.google.com&rnum=1&prev=/groups%3Fhl%3Den%26lr%3D%26q%3Ddejatom2002%26meta%3Dgroup%253Drec.video.desktop.*)
and eventually got a very excellent reply that pointed me to the
analog capture guide at doom9.org
(http://www.doom9.org/capture/start.html), particularly the section on
the capture window (http://www.doom9.org/capture/capture_window.html).

Through a series of tests, I found that my capture card's capture
window is really only approximately 704x480, even though the output
from the capture card driver is 720x480. The doom9.org article helped
me figure out how to use the VirutalDub "resize" filter to get the
aspect ratio correct again by squeezing the stretched 720x480 data
back into 704x480 and adding black vertical bars. So far, so good.

BUT - it occurred to me that with all the settings in TMPGEnc, I
SHOULD be able to get the same result without going through the
VirtualDub step. So I tested again. When encoding, I tried every
combination/permutation of "Source aspect ratio" set to "4:3 525
(NTSC)" or "4:3 525 (NTSC, 704x480)" and "Video arrange Method" set to
"Full Screen", "Full Screen (keep aspect) ratio", "Center", or "Center
(keep aspect ratio)". Against all intuitive logic, the results were
IDENTICAL when played back on the T.V. After much usenet searching, I
finally found an article that suggested using a "Video arrange Method"
of "Center (custom)" set to 704x480, and that worked (added black bars
on each side that resulted in the proper aspect ratio when played back
on the T.V.).

1. Why does a "Video arrange Method" of "Center (custom)" set to
704x480 produce different output than simply using a "Video arrange
Method" of "Center (keep aspect ratio)" when the "Source aspect ratio"
is set to "4:3 525 (NTSC, 704x480)"?

2. Does anyone know anything about the algorithm TMPGEnc uses to
resize the image when using the "Center (custom)" video arrange
method? Will it produce better/same/worse quality than using
VirtualDub's "Precise bicubic" resize filter?
6 answers Last reply
More about tmpgenc video arrange method work
  1. Archived from groups: rec.video.desktop (More info?)

    "Thomas Lew" <dejatom2002@yahoo.com> wrote in message
    news:b0188aad.0411120830.7eedf1e8@posting.google.com...
    > Some quick background (numbered questions at the end). I was
    > converting analog video from my Sony Hi8 camcorder to DVD video using
    > an AverMedia DVD EZMaker PCI card (NEC 7130 chip version) and noticed
    > that people seem to be a bit fatter on the DVD than in the original
    > video. To confirm this, I shot some video of my entertainment center
    > (for lots of fixed vertical and horizontal lines), converted it to DVD
    > using my normal method (captured using VirtualVCR, encoded to MPEG2
    > using TMPGEnc, authored using Pinnacle Studio 8, and burned to DVD)
    > and compared the original video played back on the TV with the
    > resulting DVD played back on the TV. Vertical lines in the DVD were
    > shifted and farther apart than in the original.
    >
    > I posted a message titled "Captured video slightly stretched
    > horizontally" to this newsgroup (see
    > http://groups.google.com/groups?hl=en&lr=&threadm=b0188aad.0410250843.6fe720b4%40posting.google.com&rnum=1&prev=/groups%3Fhl%3Den%26lr%3D%26q%3Ddejatom2002%26meta%3Dgroup%253Drec.video.desktop.*)
    > and eventually got a very excellent reply that pointed me to the
    > analog capture guide at doom9.org
    > (http://www.doom9.org/capture/start.html), particularly the section on
    > the capture window (http://www.doom9.org/capture/capture_window.html).
    >
    > Through a series of tests, I found that my capture card's capture
    > window is really only approximately 704x480, even though the output
    > from the capture card driver is 720x480. The doom9.org article helped
    > me figure out how to use the VirutalDub "resize" filter to get the
    > aspect ratio correct again by squeezing the stretched 720x480 data
    > back into 704x480 and adding black vertical bars. So far, so good.
    >
    > BUT - it occurred to me that with all the settings in TMPGEnc, I
    > SHOULD be able to get the same result without going through the
    > VirtualDub step. So I tested again. When encoding, I tried every
    > combination/permutation of "Source aspect ratio" set to "4:3 525
    > (NTSC)" or "4:3 525 (NTSC, 704x480)" and "Video arrange Method" set to
    > "Full Screen", "Full Screen (keep aspect) ratio", "Center", or "Center
    > (keep aspect ratio)". Against all intuitive logic, the results were
    > IDENTICAL when played back on the T.V. After much usenet searching, I
    > finally found an article that suggested using a "Video arrange Method"
    > of "Center (custom)" set to 704x480, and that worked (added black bars
    > on each side that resulted in the proper aspect ratio when played back
    > on the T.V.).
    >
    > 1. Why does a "Video arrange Method" of "Center (custom)" set to
    > 704x480 produce different output than simply using a "Video arrange
    > Method" of "Center (keep aspect ratio)" when the "Source aspect ratio"
    > is set to "4:3 525 (NTSC, 704x480)"?
    >
    > 2. Does anyone know anything about the algorithm TMPGEnc uses to
    > resize the image when using the "Center (custom)" video arrange
    > method? Will it produce better/same/worse quality than using
    > VirtualDub's "Precise bicubic" resize filter?

    This sounds like you have a better understanding of the subject
    than I do. Am I missing, or misunderstanding, something - except
    for the bicubic reference, you make no mention of the shape of the
    pixels themselves. Isn't that a factor also?

    Luck;
    Ken

    Urgo: "He gets so - confused."
  2. Archived from groups: rec.video.desktop (More info?)

    If you're going to DVD, just resize to 704x480 and do NOT add black bars to
    go to 720x480. 704x480 is legit format DVD format. My capture card doesn't
    support overscan so I capture at burn at 704x480/576.

    --Leonid

    Thomas Lew <dejatom2002@yahoo.com> wrote:
    : Some quick background (numbered questions at the end). I was
    : converting analog video from my Sony Hi8 camcorder to DVD video using
    : an AverMedia DVD EZMaker PCI card (NEC 7130 chip version) and noticed
    : that people seem to be a bit fatter on the DVD than in the original
    : video. To confirm this, I shot some video of my entertainment center
    : (for lots of fixed vertical and horizontal lines), converted it to DVD
    : using my normal method (captured using VirtualVCR, encoded to MPEG2
    : using TMPGEnc, authored using Pinnacle Studio 8, and burned to DVD)
    : and compared the original video played back on the TV with the
    : resulting DVD played back on the TV. Vertical lines in the DVD were
    : shifted and farther apart than in the original.

    : I posted a message titled "Captured video slightly stretched
    : horizontally" to this newsgroup (see
    : http://groups.google.com/groups?hl=en&lr=&threadm=b0188aad.0410250843.6fe720b4%40posting.google.com&rnum=1&prev=/groups%3Fhl%3Den%26lr%3D%26q%3Ddejatom2002%26meta%3Dgroup%253Drec.video.desktop.*)
    : and eventually got a very excellent reply that pointed me to the
    : analog capture guide at doom9.org
    : (http://www.doom9.org/capture/start.html), particularly the section on
    : the capture window (http://www.doom9.org/capture/capture_window.html).

    : Through a series of tests, I found that my capture card's capture
    : window is really only approximately 704x480, even though the output
    : from the capture card driver is 720x480. The doom9.org article helped
    : me figure out how to use the VirutalDub "resize" filter to get the
    : aspect ratio correct again by squeezing the stretched 720x480 data
    : back into 704x480 and adding black vertical bars. So far, so good.

    : BUT - it occurred to me that with all the settings in TMPGEnc, I
    : SHOULD be able to get the same result without going through the
    : VirtualDub step. So I tested again. When encoding, I tried every
    : combination/permutation of "Source aspect ratio" set to "4:3 525
    : (NTSC)" or "4:3 525 (NTSC, 704x480)" and "Video arrange Method" set to
    : "Full Screen", "Full Screen (keep aspect) ratio", "Center", or "Center
    : (keep aspect ratio)". Against all intuitive logic, the results were
    : IDENTICAL when played back on the T.V. After much usenet searching, I
    : finally found an article that suggested using a "Video arrange Method"
    : of "Center (custom)" set to 704x480, and that worked (added black bars
    : on each side that resulted in the proper aspect ratio when played back
    : on the T.V.).

    : 1. Why does a "Video arrange Method" of "Center (custom)" set to
    : 704x480 produce different output than simply using a "Video arrange
    : Method" of "Center (keep aspect ratio)" when the "Source aspect ratio"
    : is set to "4:3 525 (NTSC, 704x480)"?

    : 2. Does anyone know anything about the algorithm TMPGEnc uses to
    : resize the image when using the "Center (custom)" video arrange
    : method? Will it produce better/same/worse quality than using
    : VirtualDub's "Precise bicubic" resize filter?
  3. Archived from groups: rec.video.desktop (More info?)

    Thomas Lew <dejatom2002@yahoo.com> wrote:
    : 1. Why does a "Video arrange Method" of "Center (custom)" set to
    : 704x480 produce different output than simply using a "Video arrange
    : Method" of "Center (keep aspect ratio)" when the "Source aspect ratio"
    : is set to "4:3 525 (NTSC, 704x480)"?

    I believe that if you feed TMPGEnc with the same resolution that you're going
    to output, it will not modify your image.

    If I feed TMPGenc with 704x480 image, I have the following settings:
    Video tab:
    Size: 704x480
    Aspect ratio: 4:3

    In advanced tab I have:
    Source aspect ratio: 4:3 Display
    Video arrange method: center (keep aspect ratio) - but it really doesn't matter
    what I put for video arrange method. Results are gonna be the same. I also
    suggest cliping frame. Just click on clip (Advanced tab 3rd from the bottom)
    and clip the unwanted material from the bottom and from the right keeping the
    resolution (check all the Masks checkboxes).

    --Leonid
  4. Archived from groups: rec.video.desktop (More info?)

    "Ken Maltby" <kmaltby@sbcglobal.net> wrote in message news:<xcednTR5SK1PcgncRVn-vQ@giganews.com>...

    > This sounds like you have a better understanding of the subject
    > than I do. Am I missing, or misunderstanding, something - except
    > for the bicubic reference, you make no mention of the shape of the
    > pixels themselves. Isn't that a factor also?

    That's what the resize filter is doing. Essentially "squishing" a
    720px image into a 704px image (with the vertical px count staying the
    same) makes each pixel effectively "skinnier" than it was originally.
    Note that resize is not the same thing as a crop, which would leave
    the aspect ratio / pixel shape the same. Read the doom9.org guide for
    more details - it's really very good; it just doesn't cover TMPGEnc
    for use in analog capture.

    Leonid Makarovsky <venom@cs.bu.edu> wrote in message news:<cn2ug4$1ge$1@news3.bu.edu>...
    > If you're going to DVD, just resize to 704x480 and do NOT add black bars to
    > go to 720x480. 704x480 is legit format DVD format. My capture card doesn't
    > support overscan so I capture at burn at 704x480/576.

    Could you provide more details on specifically how to do this? Based
    in the information I got from doom9.org and my own subsequent
    tests/measurements, I know that my capture driver always outputs a
    720x480 physical image even though its capture window is only 704x480
    - stretching the image to fit.

    1. How exactly do you suggest I resize the image without using one of
    the two methods I described in my original post?

    2. Although 704x480 is a legitimate DVD size, the DVD template in
    TMPGEnc appears to fix the output size at 720x480 (i.e. in the "Video"
    tab, the output "Size" setting is greyed out).

    Leonid Makarovsky <venom@cs.bu.edu> wrote in message news:<cn2vb9$7td$1@news3.bu.edu>...

    > I believe that if you feed TMPGEnc with the same resolution that you're going
    > to output, it will not modify your image.

    Again, not sure how to do this. My driver always outputs a 720x480
    (stretched from 704x480 image).

    > If I feed TMPGenc with 704x480 image, I have the following settings:
    > Video tab:
    > Size: 704x480
    > Aspect ratio: 4:3

    The "Size" setting is locked in TMPGEnc's DVD template.

    Thanks!

    Thomas
  5. Archived from groups: rec.video.desktop (More info?)

    On 13 Nov 2004 10:33:55 -0800, dejatom2002@yahoo.com (Thomas Lew) wrote:

    >Again, not sure how to do this. My driver always outputs a 720x480
    >(stretched from 704x480 image).

    If you capture directly to 704x480 the picture will not be stretched,
    but you have to avoid resizing to 720x480 afterwards. Keep the 704x480
    resolution throughout the editing/encoding process. If you're using
    software that resizes 704x480 to 720x480 you should add black bars
    before using that software (or use better software).

    >> If I feed TMPGenc with 704x480 image, I have the following settings:
    >> Video tab:
    >> Size: 704x480
    >> Aspect ratio: 4:3
    >
    >The "Size" setting is locked in TMPGEnc's DVD template.

    You can unlock the settings.
    http://dvd-hq.info/Compression.html
    "If some settings in TMPGEnc appear to be locked, this may be due to the
    fact that you loaded one of the original templates. To unlock all
    settings, load a file called unlock.mcf that you will find inside the
    template\extra sub-folder. Newer versions of TMPGEnc also let you unlock
    the settings by clicking on the text on the left side."
  6. Archived from groups: rec.video.desktop (More info?)

    Thomas Lew <dejatom2002@yahoo.com> wrote:
    : Could you provide more details on specifically how to do this? Based
    : in the information I got from doom9.org and my own subsequent

    When you capture, choose 704x480. I don't know what program you capture with,
    but you shouldn't be capturing with 720x480. It looks like your capture card
    doesnt' support overscan.

    : tests/measurements, I know that my capture driver always outputs a
    : 720x480 physical image even though its capture window is only 704x480
    : - stretching the image to fit.

    What capture program do you capture with? I lost your original post.

    : 1. How exactly do you suggest I resize the image without using one of
    : the two methods I described in my original post?

    To repair your stretched file your best bet is AVISynth. Download it.
    http://www.avisynth.org/

    Then have the following script. The body of the script:
    AVISource("YourAVIFileName.avi")
    LanczosResize(704,480)

    Call the script AnythingYouLike.avs (extention should be avs).

    Then download AnythingYouLike.avs file into TMPGenc instead of AVI file.
    Or first download this file into VirtualDub.

    : 2. Although 704x480 is a legitimate DVD size, the DVD template in
    : TMPGEnc appears to fix the output size at 720x480 (i.e. in the "Video"
    : tab, the output "Size" setting is greyed out).

    RTFM. I agree they never provide the tips. I wouldn't know it either if someone
    on this newsgroups hadn't told me. On the Video tab point your cursor on the
    size label. Right click and chose unlock. I'm sure you can figure out what to
    do next. You can unlock anything you want there.

    --Leonid

    PS. I have my own customized templates if you'd like.
Ask a new question

Read More

Tuner Cards DVD Video Graphics