Dorm to College

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Okay, I need everyone's help with this one... Let me explain the setup and then what I want to do/my problem.

I have a Netgear MR314 802.11b wireless router hooked up to a cable modem. I have four computers (A, B, C, and D) in my house. A, B, C, and D are all Windows XP Professional and all have Remote Desktop enabled. I am able to use RD within the network so that A can access B, C, or D and B can access A, C, or D, etc etc.. The firewall allows Port 3389 to be sent to Computer A.

I will be attending college this fall and, since my parents are not the most computer-savvy people in the world, I wish to access Computer A so that I can fix problems, show them how to do something, etc. I also fix the neighbors/friends/other family computers, and those people have agreed with me to set up Remote Desktop so that I can fix their problems from college.

The problem is that I can't seem to get RD to work over the Internet. For instance, I can access Computer A by typing "Computer A" in the Remote Desktop computer name/IP address space (I can also type in the local IP address on the network, 192.168.0.11) to do this as well); however, I can not access Computer A (this is the same one the router is programmed to forward port 3389 to) by typing in the IP address of my cable modem (the public IP assigned to me).

Correct me if I'm wrong, but I should be able to type my public IP address in the box in RD and it should directly connect to the computer that the router has forwarded the port to (in this case, Computer A). However, I simply can not remote desktop over the internet.

In the "domain" box should I type in the name of the computer I'm connecting to? Does RD not function correctly when the client making the request is from the same public IP as the host it's being sent to? Since the port is forwarded and the remote desktop is enabled on every computer, the RD call should work, in theory, but it doesn't.
Please tell me what I'm doing wrong and how to set it up!!!
2 answers Last reply
More about dorm college
  1. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    When you test remote access to "Computer A" using the public IP you must be at a remote location,
    ie. at a neighbors house for example. It is not a valid test to call from one of your local PCs, ie
    "Computer B" for example, using the public IP of the router, and try to connect to "Computer A".

    You should leave the domain field blank your case...

    --
    Al Jarvi (MS-MVP Windows Networking)

    Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
    The MS-MVP Program - http://mvp.support.microsoft.com
    This posting is provided "AS IS" with no warranties, and confers no rights...

    "DrJChen" <DrJChen@discussions.microsoft.com> wrote in message
    news:7DDC3FCF-F538-47A1-9E24-CFCE5002820C@microsoft.com...
    > Okay, I need everyone's help with this one... Let me explain the setup and then what I want to
    > do/my problem.
    >
    > I have a Netgear MR314 802.11b wireless router hooked up to a cable modem. I have four computers
    > (A, B, C, and D) in my house. A, B, C, and D are all Windows XP Professional and all have Remote
    > Desktop enabled. I am able to use RD within the network so that A can access B, C, or D and B can
    > access A, C, or D, etc etc.. The firewall allows Port 3389 to be sent to Computer A.
    >
    > I will be attending college this fall and, since my parents are not the most computer-savvy people
    > in the world, I wish to access Computer A so that I can fix problems, show them how to do
    > something, etc. I also fix the neighbors/friends/other family computers, and those people have
    > agreed with me to set up Remote Desktop so that I can fix their problems from college.
    >
    > The problem is that I can't seem to get RD to work over the Internet. For instance, I can access
    > Computer A by typing "Computer A" in the Remote Desktop computer name/IP address space (I can also
    > type in the local IP address on the network, 192.168.0.11) to do this as well); however, I can not
    > access Computer A (this is the same one the router is programmed to forward port 3389 to) by
    > typing in the IP address of my cable modem (the public IP assigned to me).
    >
    > Correct me if I'm wrong, but I should be able to type my public IP address in the box in RD and it
    > should directly connect to the computer that the router has forwarded the port to (in this case,
    > Computer A). However, I simply can not remote desktop over the internet.
    >
    > In the "domain" box should I type in the name of the computer I'm connecting to? Does RD not
    > function correctly when the client making the request is from the same public IP as the host it's
    > being sent to? Since the port is forwarded and the remote desktop is enabled on every computer,
    > the RD call should work, in theory, but it doesn't.
    > Please tell me what I'm doing wrong and how to set it up!!!
  2. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    I am not sure that I fully understand, but here is a recap:
    - Your Netgear forwards 3389 to Comp A (make sure it is the TCP port that
    gets forwarded)
    - You can access A,B,C, using RDP in any combination by using either IP or
    name
    The question is are you trying to access Comp A from Comp B by using the ISP
    public IP?
    If that is what are you trying then your router will most likely not route
    internally, for example:
    - Comp A IP = 192.168.0.10
    - Comp B IP = 192.168.0.11
    - Netgear / ISP Cable Modem IP = A.B.C.D
    If you are trying to access Comp A from Comp B by typing ISP address A.B.C.D
    it may not work especially with netgear, try new firmware maybe you get
    lucky.
    If you are trying to access Comp A from outside your network, like your
    friends PC, then use A.B.C.D. not name.
    To check if it is an issue with your ISP make Comp A DMZ for the purpose of
    testing if it works then your port forwarding is not setup correctly in the
    router.


    "DrJChen" <DrJChen@discussions.microsoft.com> wrote in message
    news:7DDC3FCF-F538-47A1-9E24-CFCE5002820C@microsoft.com...
    > Okay, I need everyone's help with this one... Let me explain the setup and
    then what I want to do/my problem.
    >
    > I have a Netgear MR314 802.11b wireless router hooked up to a cable modem.
    I have four computers (A, B, C, and D) in my house. A, B, C, and D are all
    Windows XP Professional and all have Remote Desktop enabled. I am able to
    use RD within the network so that A can access B, C, or D and B can access
    A, C, or D, etc etc.. The firewall allows Port 3389 to be sent to Computer
    A.
    >
    > I will be attending college this fall and, since my parents are not the
    most computer-savvy people in the world, I wish to access Computer A so that
    I can fix problems, show them how to do something, etc. I also fix the
    neighbors/friends/other family computers, and those people have agreed with
    me to set up Remote Desktop so that I can fix their problems from college.
    >
    > The problem is that I can't seem to get RD to work over the Internet. For
    instance, I can access Computer A by typing "Computer A" in the Remote
    Desktop computer name/IP address space (I can also type in the local IP
    address on the network, 192.168.0.11) to do this as well); however, I can
    not access Computer A (this is the same one the router is programmed to
    forward port 3389 to) by typing in the IP address of my cable modem (the
    public IP assigned to me).
    >
    > Correct me if I'm wrong, but I should be able to type my public IP address
    in the box in RD and it should directly connect to the computer that the
    router has forwarded the port to (in this case, Computer A). However, I
    simply can not remote desktop over the internet.
    >
    > In the "domain" box should I type in the name of the computer I'm
    connecting to? Does RD not function correctly when the client making the
    request is from the same public IP as the host it's being sent to? Since the
    port is forwarded and the remote desktop is enabled on every computer, the
    RD call should work, in theory, but it doesn't.
    > Please tell me what I'm doing wrong and how to set it up!!!
Ask a new question

Read More

Computers Windows XP