Why can I not connect with Remote Desktop?

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

When I try to log onto my pc using Remote Desktop from
another computer, I get the message, "The local policy of
this system does not permit you to logon interactively."
I am using an account that is part of the administrators
group, as well as the remote desktop users group. I am
using Windows XP Pro. Does anybody have any ideas what is
going on? Thanks.
7 answers Last reply
More about connect remote desktop
  1. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Does the account have a password set? If not, set one.

    There's also a policy setting which may be involved, but it isn't coming to
    mind at the moment, nor did it the last time I ran into this in person!

    If you've got a password, write back, and maybe somebody else can find us
    the policy setting, or I can dig it out of my collected tips--my
    recollection is that the policy setting tends to come up on Windows 2000
    upgraded to XP machines.


    "Harry Keck" <anonymous@discussions.microsoft.com> wrote in message
    news:5e8001c4815d$5a9592b0$a401280a@phx.gbl...
    > When I try to log onto my pc using Remote Desktop from
    > another computer, I get the message, "The local policy of
    > this system does not permit you to logon interactively."
    > I am using an account that is part of the administrators
    > group, as well as the remote desktop users group. I am
    > using Windows XP Pro. Does anybody have any ideas what is
    > going on? Thanks.
  2. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    On the computer you need to connect to:

    Control Panel >> System
    Click the "Remote" tab
    Check "Allow users to connect remotely to this computer"
    Also check "Allow Remote Assistance invitations to be sent from this computer"

    "Harry Keck" wrote:

    > When I try to log onto my pc using Remote Desktop from
    > another computer, I get the message, "The local policy of
    > this system does not permit you to logon interactively."
    > I am using an account that is part of the administrators
    > group, as well as the remote desktop users group. I am
    > using Windows XP Pro. Does anybody have any ideas what is
    > going on? Thanks.
    >
  3. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Yes, I do have a password set. Also, I am pretty sure that this machine was
    not an upgrade from 2000.

    "Bill Sanderson" wrote:

    > Does the account have a password set? If not, set one.
    >
    > There's also a policy setting which may be involved, but it isn't coming to
    > mind at the moment, nor did it the last time I ran into this in person!
    >
    > If you've got a password, write back, and maybe somebody else can find us
    > the policy setting, or I can dig it out of my collected tips--my
    > recollection is that the policy setting tends to come up on Windows 2000
    > upgraded to XP machines.
    >
    >
    > "Harry Keck" <anonymous@discussions.microsoft.com> wrote in message
    > news:5e8001c4815d$5a9592b0$a401280a@phx.gbl...
    > > When I try to log onto my pc using Remote Desktop from
    > > another computer, I get the message, "The local policy of
    > > this system does not permit you to logon interactively."
    > > I am using an account that is part of the administrators
    > > group, as well as the remote desktop users group. I am
    > > using Windows XP Pro. Does anybody have any ideas what is
    > > going on? Thanks.
    >
    >
    >
  4. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    I have both of these options selected.

    "Shadow" wrote:

    > On the computer you need to connect to:
    >
    > Control Panel >> System
    > Click the "Remote" tab
    > Check "Allow users to connect remotely to this computer"
    > Also check "Allow Remote Assistance invitations to be sent from this computer"
    >
    > "Harry Keck" wrote:
    >
    > > When I try to log onto my pc using Remote Desktop from
    > > another computer, I get the message, "The local policy of
    > > this system does not permit you to logon interactively."
    > > I am using an account that is part of the administrators
    > > group, as well as the remote desktop users group. I am
    > > using Windows XP Pro. Does anybody have any ideas what is
    > > going on? Thanks.
    > >
  5. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Here are some ideas:

    Let us know what works.

    In the upgrade case, I have found the issue often is a registry key
    described in this thread:

    http://groups.google.com/groups?q=windows+2000+xp+upgrade+rdp+policy+setting&hl=en&lr=&ie=UTF-8&c2coff=1&selm=uP4%24nh1GEHA.2844%40TK2MSFTNGP12.phx.gbl&rnum=1

    Microsoft Staff Feng Mao has provided this response to a similar query:
    ---------------------------
    Thank you for posting!

    If the error message is the same as Bill mentioned:

    The local policy of this system does not permit you to logon interactively.

    Besides the suggestion from group.google.com. There are some other articles
    in Microsoft knowledge base which might be helpful.

    826903 "The local policy of this system does not permit you to logon
    http://support.microsoft.com/?id=826903

    289289 Remote desktop connection "The local policy of this system does not
    http://support.microsoft.com/?id=289289

    Have a nice day!

    Thanks & Regards,

    Feng Mao [MSFT], MCSE
    Microsoft Online Partner Support
    -------------------------------------------
    Get Secure! - www.microsoft.com/security

    =====================================================
    When responding to posts, please "Reply to Group" via your newsreader so
    that others may learn and benefit from your issue.
    =====================================================
    This posting is provided "AS IS" with no warranties, and confers no rights.

    "Harry Keck" <HarryKeck@discussions.microsoft.com> wrote in message
    news:12190E0F-1591-45EA-9752-12059708F179@microsoft.com...
    > Yes, I do have a password set. Also, I am pretty sure that this machine
    > was
    > not an upgrade from 2000.
    >
    > "Bill Sanderson" wrote:
    >
    >> Does the account have a password set? If not, set one.
    >>
    >> There's also a policy setting which may be involved, but it isn't coming
    >> to
    >> mind at the moment, nor did it the last time I ran into this in person!
    >>
    >> If you've got a password, write back, and maybe somebody else can find us
    >> the policy setting, or I can dig it out of my collected tips--my
    >> recollection is that the policy setting tends to come up on Windows 2000
    >> upgraded to XP machines.
    >>
    >>
    >> "Harry Keck" <anonymous@discussions.microsoft.com> wrote in message
    >> news:5e8001c4815d$5a9592b0$a401280a@phx.gbl...
    >> > When I try to log onto my pc using Remote Desktop from
    >> > another computer, I get the message, "The local policy of
    >> > this system does not permit you to logon interactively."
    >> > I am using an account that is part of the administrators
    >> > group, as well as the remote desktop users group. I am
    >> > using Windows XP Pro. Does anybody have any ideas what is
    >> > going on? Thanks.
    >>
    >>
    >>
  6. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    I think that the info from the google post actually worked. When I logged on
    from Remote Desktop I got an error about the security log being full, but it
    let me log on anyway. Here is what I did. Thanks, Bill.

    Start->Run, "gpedit.msc"
    > Expand Computer Configuration->Windows Settings->Security
    > Settings->Local Policies->User Rights Assignment.
    >
    > On the right side of the snap-in, find "Allow logon
    > through Terminal Services".
    >
    > Remove everything that's there, then Add User or Group,
    > and input the account you want to have access.
    >
    > No reboots required, the policy will affect all
    > subsequent Remote Desktop logons. Those accounts not
    > allowed via this policy to connect will get back an error
    > stating "The local policy of this system does not permit
    > you to log on interactively"
    >


    "Bill Sanderson" wrote:

    > Here are some ideas:
    >
    > Let us know what works.
    >
    > In the upgrade case, I have found the issue often is a registry key
    > described in this thread:
    >
    > http://groups.google.com/groups?q=windows+2000+xp+upgrade+rdp+policy+setting&hl=en&lr=&ie=UTF-8&c2coff=1&selm=uP4%24nh1GEHA.2844%40TK2MSFTNGP12.phx.gbl&rnum=1
    >
    > Microsoft Staff Feng Mao has provided this response to a similar query:
    > ---------------------------
    > Thank you for posting!
    >
    > If the error message is the same as Bill mentioned:
    >
    > The local policy of this system does not permit you to logon interactively.
    >
    > Besides the suggestion from group.google.com. There are some other articles
    > in Microsoft knowledge base which might be helpful.
    >
    > 826903 "The local policy of this system does not permit you to logon
    > http://support.microsoft.com/?id=826903
    >
    > 289289 Remote desktop connection "The local policy of this system does not
    > http://support.microsoft.com/?id=289289
    >
    > Have a nice day!
    >
    > Thanks & Regards,
    >
    > Feng Mao [MSFT], MCSE
    > Microsoft Online Partner Support
    > -------------------------------------------
    > Get Secure! - www.microsoft.com/security
    >
    > =====================================================
    > When responding to posts, please "Reply to Group" via your newsreader so
    > that others may learn and benefit from your issue.
    > =====================================================
    > This posting is provided "AS IS" with no warranties, and confers no rights.
    >
    > "Harry Keck" <HarryKeck@discussions.microsoft.com> wrote in message
    > news:12190E0F-1591-45EA-9752-12059708F179@microsoft.com...
    > > Yes, I do have a password set. Also, I am pretty sure that this machine
    > > was
    > > not an upgrade from 2000.
    > >
    > > "Bill Sanderson" wrote:
    > >
    > >> Does the account have a password set? If not, set one.
    > >>
    > >> There's also a policy setting which may be involved, but it isn't coming
    > >> to
    > >> mind at the moment, nor did it the last time I ran into this in person!
    > >>
    > >> If you've got a password, write back, and maybe somebody else can find us
    > >> the policy setting, or I can dig it out of my collected tips--my
    > >> recollection is that the policy setting tends to come up on Windows 2000
    > >> upgraded to XP machines.
    > >>
    > >>
    > >> "Harry Keck" <anonymous@discussions.microsoft.com> wrote in message
    > >> news:5e8001c4815d$5a9592b0$a401280a@phx.gbl...
    > >> > When I try to log onto my pc using Remote Desktop from
    > >> > another computer, I get the message, "The local policy of
    > >> > this system does not permit you to logon interactively."
    > >> > I am using an account that is part of the administrators
    > >> > group, as well as the remote desktop users group. I am
    > >> > using Windows XP Pro. Does anybody have any ideas what is
    > >> > going on? Thanks.
    > >>
    > >>
    > >>
    >
    >
    >
  7. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Terrific--I'm not sure what other circumstances besides a windows 2000
    upgrade can create that issue, but I'm glad that did it for you. Seems to
    me that this is common enough to deserve a KB article.

    "Harry Keck" <HarryKeck@discussions.microsoft.com> wrote in message
    news:816E5800-1E51-4A7A-BFA0-CF601163CE65@microsoft.com...
    >I think that the info from the google post actually worked. When I logged
    >on
    > from Remote Desktop I got an error about the security log being full, but
    > it
    > let me log on anyway. Here is what I did. Thanks, Bill.
    >
    > Start->Run, "gpedit.msc"
    >> Expand Computer Configuration->Windows Settings->Security
    >> Settings->Local Policies->User Rights Assignment.
    >>
    >> On the right side of the snap-in, find "Allow logon
    >> through Terminal Services".
    >>
    >> Remove everything that's there, then Add User or Group,
    >> and input the account you want to have access.
    >>
    >> No reboots required, the policy will affect all
    >> subsequent Remote Desktop logons. Those accounts not
    >> allowed via this policy to connect will get back an error
    >> stating "The local policy of this system does not permit
    >> you to log on interactively"
    >>
    >
    >
    > "Bill Sanderson" wrote:
    >
    >> Here are some ideas:
    >>
    >> Let us know what works.
    >>
    >> In the upgrade case, I have found the issue often is a registry key
    >> described in this thread:
    >>
    >> http://groups.google.com/groups?q=windows+2000+xp+upgrade+rdp+policy+setting&hl=en&lr=&ie=UTF-8&c2coff=1&selm=uP4%24nh1GEHA.2844%40TK2MSFTNGP12.phx.gbl&rnum=1
    >>
    >> Microsoft Staff Feng Mao has provided this response to a similar query:
    >> ---------------------------
    >> Thank you for posting!
    >>
    >> If the error message is the same as Bill mentioned:
    >>
    >> The local policy of this system does not permit you to logon
    >> interactively.
    >>
    >> Besides the suggestion from group.google.com. There are some other
    >> articles
    >> in Microsoft knowledge base which might be helpful.
    >>
    >> 826903 "The local policy of this system does not permit you to logon
    >> http://support.microsoft.com/?id=826903
    >>
    >> 289289 Remote desktop connection "The local policy of this system does
    >> not
    >> http://support.microsoft.com/?id=289289
    >>
    >> Have a nice day!
    >>
    >> Thanks & Regards,
    >>
    >> Feng Mao [MSFT], MCSE
    >> Microsoft Online Partner Support
    >> -------------------------------------------
    >> Get Secure! - www.microsoft.com/security
    >>
    >> =====================================================
    >> When responding to posts, please "Reply to Group" via your newsreader so
    >> that others may learn and benefit from your issue.
    >> =====================================================
    >> This posting is provided "AS IS" with no warranties, and confers no
    >> rights.
    >>
    >> "Harry Keck" <HarryKeck@discussions.microsoft.com> wrote in message
    >> news:12190E0F-1591-45EA-9752-12059708F179@microsoft.com...
    >> > Yes, I do have a password set. Also, I am pretty sure that this
    >> > machine
    >> > was
    >> > not an upgrade from 2000.
    >> >
    >> > "Bill Sanderson" wrote:
    >> >
    >> >> Does the account have a password set? If not, set one.
    >> >>
    >> >> There's also a policy setting which may be involved, but it isn't
    >> >> coming
    >> >> to
    >> >> mind at the moment, nor did it the last time I ran into this in
    >> >> person!
    >> >>
    >> >> If you've got a password, write back, and maybe somebody else can find
    >> >> us
    >> >> the policy setting, or I can dig it out of my collected tips--my
    >> >> recollection is that the policy setting tends to come up on Windows
    >> >> 2000
    >> >> upgraded to XP machines.
    >> >>
    >> >>
    >> >> "Harry Keck" <anonymous@discussions.microsoft.com> wrote in message
    >> >> news:5e8001c4815d$5a9592b0$a401280a@phx.gbl...
    >> >> > When I try to log onto my pc using Remote Desktop from
    >> >> > another computer, I get the message, "The local policy of
    >> >> > this system does not permit you to logon interactively."
    >> >> > I am using an account that is part of the administrators
    >> >> > group, as well as the remote desktop users group. I am
    >> >> > using Windows XP Pro. Does anybody have any ideas what is
    >> >> > going on? Thanks.
    >> >>
    >> >>
    >> >>
    >>
    >>
    >>
Ask a new question

Read More

Remote Desktop Connection Microsoft Windows XP