Sign in with
Sign up | Sign in
Your question

Remote Desktop Web from client running ZoneAlarm

Tags:
  • Remote Desktop
  • Internet Explorer
  • Windows XP
Last response: in Windows XP
Share
Anonymous
August 18, 2004 6:15:02 PM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Found a lot of posts from people trying to an IIS server running TSweb
(Remote Desktop Web) from a clent with ZoneAlarm.

Specifically I routed TCP port 80 and 3389 to my server and could load
the Tsweb page but whenever I tried to connect I'd see an error icon
at the bottom left of the IE6 status bar. Upon double-clicking this
icon I got this message:

Line: 320
Char: 1
Eorror: Object doesn't support this property or method
Code: 0

After awhile I turned off ZoneAlarm 5.x and discovered that I could
then use Remote Desktop Web without error. I found that if I brought
up ZA program control, selected options for Internet Explorer and
unchecked "Enable privacy for this program" that I could use Remote
Desktop Web without shutting ZA down. It was necessary to delete the
file cache in IE (Tools > Internet Options > Delete Files > Delete all
offline content), shutdown IE, restart it, and then reload the Tsweb
site.

Unfortunately doing this effectively disables the pop-up/malicious
script protection in ZA. Oddly no option in the ZA privacy section
would allow Remote Destop Web to work. That includes turning cookie
control, ad-blocking and mobile code control off using the global
sliders or by making an entry for the specified web page.

For what it's worth.

More about : remote desktop web client running zonealarm

Anonymous
August 19, 2004 2:12:34 AM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Zone Alarm is blocking the ActiveX control needed to make the web
client work...

Jeffrey Randow (Windows Networking & Smart Display MVP)
jeffreyr-support@remotenetworktechnology.com

Please post all responses to the newsgroups for the benefit
of all USENET users. Messages sent via email may or may not
be answered depending on time availability....

Remote Networking Technology Support Site -
http://www.remotenetworktechnology.com
Windows XP Expert Zone - http://www.microsoft.com/windowsxp/expertzone

On 18 Aug 2004 14:15:02 -0700, noabody@hotmail.com (kcirevam) wrote:

>Found a lot of posts from people trying to an IIS server running TSweb
>(Remote Desktop Web) from a clent with ZoneAlarm.
>
>Specifically I routed TCP port 80 and 3389 to my server and could load
>the Tsweb page but whenever I tried to connect I'd see an error icon
>at the bottom left of the IE6 status bar. Upon double-clicking this
>icon I got this message:
>
>Line: 320
>Char: 1
>Eorror: Object doesn't support this property or method
>Code: 0
>
>After awhile I turned off ZoneAlarm 5.x and discovered that I could
>then use Remote Desktop Web without error. I found that if I brought
>up ZA program control, selected options for Internet Explorer and
>unchecked "Enable privacy for this program" that I could use Remote
>Desktop Web without shutting ZA down. It was necessary to delete the
>file cache in IE (Tools > Internet Options > Delete Files > Delete all
>offline content), shutdown IE, restart it, and then reload the Tsweb
>site.
>
>Unfortunately doing this effectively disables the pop-up/malicious
>script protection in ZA. Oddly no option in the ZA privacy section
>would allow Remote Destop Web to work. That includes turning cookie
>control, ad-blocking and mobile code control off using the global
>sliders or by making an entry for the specified web page.
>
>For what it's worth.
Anonymous
August 19, 2004 5:25:36 AM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Pondered this problem for awhile. It occured to me that I could
download another web browser soley for use as a remote desktop web
client. I'd have to uncheck "Privacy" for the new program just as I
did for Internet Explorer. After about an hour I realized that no
other web browser on the planet supports ActiveX, Duh!

After much soul searching I wondered if such a web browser already
existed on my computer. I pulled up "Windows Explorer" instead of
"Internet Explorer" and typed in the url for my IIS (Remote Desktop
Web) server. Sure enough Zone alarm popped up and asked if Windows
Explorer should be allowed to access the internet. I then opened up
ZA program control, as before, but this time I unchecked "Privacy" for
"Windows Explorer" and re-checked it for "Internet Explorer".

What was the result you ask? I'm now happily using Remote Desktop Web
through Windows Explorer. If I wanted to use Windows Explorer to surf
the web ZoneAlarm's stupid "Privacy" setting is turned off so I'll be
flooded with Pop-ups and malicious scripts. However I'm not going to
surf the web from Windows Explorer. When I pull up Internet Explorer
to surf the web, ZoneAlarm does just what it's supposed to, blocks
pop-ups and scripts.

It's not a perfect solution to the problem. After five hours of
searching the internet for a fix, my conclusion is that either no one
in the world knows the problem exists or cares. So I'm a bit proud to
have not only identified the problem but found a workaround.

Ultimately viewing the HTML source identifies why Remote Desktop Web
and ZA don't get along. Starting on line 21 of the Tsweb page I see a
style tag. Line 23 should be my head tag but it has been pushed down
to line 26. In between ZoneAlarm has inserted js.cgi. A
pop-up/malicious script blocker.

/style


script language='javascript'
src='http://127.0.0.1:1028/js.cgi?pcaw&r=25667'/script

/head

Java has a java.policy file where you can place known safe hosts.
Theoretically ZoneAlarm does the same thing in the Privacy section
where all web sites are stored and can be edited to allow pop-ups,
scripts and cookies. Unfortunately even after putting my web page in,
and editing all of these things off, ZA still inserted it's
destructive payload. So my workaround exists as is until ZoneAlarm
finds a better way to fix the problem.



noabody@hotmail.com (kcirevam) wrote in message news:<f4dd0d39.0408181203.37c3f54c@posting.google.com>...
> Found a lot of posts from people trying to an IIS server running TSweb
> (Remote Desktop Web) from a clent with ZoneAlarm.
>
> Specifically I routed TCP port 80 and 3389 to my server and could load
> the Tsweb page but whenever I tried to connect I'd see an error icon
> at the bottom left of the IE6 status bar. Upon double-clicking this
> icon I got this message:
>
> Line: 320
> Char: 1
> Eorror: Object doesn't support this property or method
> Code: 0
>
> After awhile I turned off ZoneAlarm 5.x and discovered that I could
> then use Remote Desktop Web without error. I found that if I brought
> up ZA program control, selected options for Internet Explorer and
> unchecked "Enable privacy for this program" that I could use Remote
> Desktop Web without shutting ZA down. It was necessary to delete the
> file cache in IE (Tools > Internet Options > Delete Files > Delete all
> offline content), shutdown IE, restart it, and then reload the Tsweb
> site.
>
> Unfortunately doing this effectively disables the pop-up/malicious
> script protection in ZA. Oddly no option in the ZA privacy section
> would allow Remote Destop Web to work. That includes turning cookie
> control, ad-blocking and mobile code control off using the global
> sliders or by making an entry for the specified web page.
>
> For what it's worth.
Anonymous
August 20, 2004 1:08:09 AM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Glad you found a solution.. :) 

Jeffrey Randow (Windows Networking & Smart Display MVP)
jeffreyr-support@remotenetworktechnology.com

Please post all responses to the newsgroups for the benefit
of all USENET users. Messages sent via email may or may not
be answered depending on time availability....

Remote Networking Technology Support Site -
http://www.remotenetworktechnology.com
Windows XP Expert Zone - http://www.microsoft.com/windowsxp/expertzone

On 19 Aug 2004 01:25:36 -0700, noabody@hotmail.com (kcirevam) wrote:

>Pondered this problem for awhile. It occured to me that I could
>download another web browser soley for use as a remote desktop web
>client. I'd have to uncheck "Privacy" for the new program just as I
>did for Internet Explorer. After about an hour I realized that no
>other web browser on the planet supports ActiveX, Duh!
>
>After much soul searching I wondered if such a web browser already
>existed on my computer. I pulled up "Windows Explorer" instead of
>"Internet Explorer" and typed in the url for my IIS (Remote Desktop
>Web) server. Sure enough Zone alarm popped up and asked if Windows
>Explorer should be allowed to access the internet. I then opened up
>ZA program control, as before, but this time I unchecked "Privacy" for
>"Windows Explorer" and re-checked it for "Internet Explorer".
>
>What was the result you ask? I'm now happily using Remote Desktop Web
>through Windows Explorer. If I wanted to use Windows Explorer to surf
>the web ZoneAlarm's stupid "Privacy" setting is turned off so I'll be
>flooded with Pop-ups and malicious scripts. However I'm not going to
>surf the web from Windows Explorer. When I pull up Internet Explorer
>to surf the web, ZoneAlarm does just what it's supposed to, blocks
>pop-ups and scripts.
>
>It's not a perfect solution to the problem. After five hours of
>searching the internet for a fix, my conclusion is that either no one
>in the world knows the problem exists or cares. So I'm a bit proud to
>have not only identified the problem but found a workaround.
>
>Ultimately viewing the HTML source identifies why Remote Desktop Web
>and ZA don't get along. Starting on line 21 of the Tsweb page I see a
>style tag. Line 23 should be my head tag but it has been pushed down
>to line 26. In between ZoneAlarm has inserted js.cgi. A
>pop-up/malicious script blocker.
>
>/style
>
>
> script language='javascript'
>src='http://127.0.0.1:1028/js.cgi?pcaw&r=25667'/script
>
>/head
>
>Java has a java.policy file where you can place known safe hosts.
>Theoretically ZoneAlarm does the same thing in the Privacy section
>where all web sites are stored and can be edited to allow pop-ups,
>scripts and cookies. Unfortunately even after putting my web page in,
>and editing all of these things off, ZA still inserted it's
>destructive payload. So my workaround exists as is until ZoneAlarm
>finds a better way to fix the problem.
>
>
>
>noabody@hotmail.com (kcirevam) wrote in message news:<f4dd0d39.0408181203.37c3f54c@posting.google.com>...
>> Found a lot of posts from people trying to an IIS server running TSweb
>> (Remote Desktop Web) from a clent with ZoneAlarm.
>>
>> Specifically I routed TCP port 80 and 3389 to my server and could load
>> the Tsweb page but whenever I tried to connect I'd see an error icon
>> at the bottom left of the IE6 status bar. Upon double-clicking this
>> icon I got this message:
>>
>> Line: 320
>> Char: 1
>> Eorror: Object doesn't support this property or method
>> Code: 0
>>
>> After awhile I turned off ZoneAlarm 5.x and discovered that I could
>> then use Remote Desktop Web without error. I found that if I brought
>> up ZA program control, selected options for Internet Explorer and
>> unchecked "Enable privacy for this program" that I could use Remote
>> Desktop Web without shutting ZA down. It was necessary to delete the
>> file cache in IE (Tools > Internet Options > Delete Files > Delete all
>> offline content), shutdown IE, restart it, and then reload the Tsweb
>> site.
>>
>> Unfortunately doing this effectively disables the pop-up/malicious
>> script protection in ZA. Oddly no option in the ZA privacy section
>> would allow Remote Destop Web to work. That includes turning cookie
>> control, ad-blocking and mobile code control off using the global
>> sliders or by making an entry for the specified web page.
>>
>> For what it's worth.
!