XP Port 3389 Not Listening

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

I have one XP Pro SP1 PC here at work that just does not listen on
Port 3389. netstat-an does not show that port as listening and I
cannot Telnet to the port.

* The Terminal Services service is started.

* No errors in the event viewer

* The two Remote Access checkboxes are checked in
the Remote Tab of the System Control Panel

* RDP-Tcp "Port Number" in the registry is set to 3389

* fDenyTSConnections in the registry is set to 0

* TSEnabled in the registry is set to 1

* ICF is not enabled


Any ideas?
10 answers Last reply
More about port 3389 listening
  1. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Do you see Port 3389 if you run netstat -ano
    ?

    Jeffrey Randow (Windows Networking & Smart Display MVP)
    jeffreyr-support@remotenetworktechnology.com

    Please post all responses to the newsgroups for the benefit
    of all USENET users. Messages sent via email may or may not
    be answered depending on time availability....

    Remote Networking Technology Support Site -
    http://www.remotenetworktechnology.com
    Windows XP Expert Zone - http://www.microsoft.com/windowsxp/expertzone

    On 19 Aug 2004 13:53:02 -0700, computer_prog@hotmail.com (Computer
    Prog) wrote:

    >I have one XP Pro SP1 PC here at work that just does not listen on
    >Port 3389. netstat-an does not show that port as listening and I
    >cannot Telnet to the port.
    >
    >* The Terminal Services service is started.
    >
    >* No errors in the event viewer
    >
    >* The two Remote Access checkboxes are checked in
    > the Remote Tab of the System Control Panel
    >
    >* RDP-Tcp "Port Number" in the registry is set to 3389
    >
    >* fDenyTSConnections in the registry is set to 0
    >
    >* TSEnabled in the registry is set to 1
    >
    >* ICF is not enabled
    >
    >
    >Any ideas?
  2. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Computer Prog wrote:

    > I have one XP Pro SP1 PC here at work that just does not listen on
    > Port 3389. netstat-an does not show that port as listening and I
    > cannot Telnet to the port.
    >
    > * The Terminal Services service is started.
    >
    > * No errors in the event viewer
    >
    > * The two Remote Access checkboxes are checked in
    > the Remote Tab of the System Control Panel
    >
    > * RDP-Tcp "Port Number" in the registry is set to 3389
    >
    > * fDenyTSConnections in the registry is set to 0
    >
    > * TSEnabled in the registry is set to 1
    >
    > * ICF is not enabled
    >
    >
    > Any ideas?
    Port forwarded in the router (if you have one)
    Wim
  3. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    WimvV <w.vvv.voort@home.nl.com> wrote in message news:<cg37a1$nq6$1@news5.tilbu1.nb.home.nl>...
    > >
    > Port forwarded in the router (if you have one)
    > Wim

    There is no router.
  4. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    "Jeffrey Randow (MVP)" <jeffreyr-support@remotenetworktechnology.com> wrote
    in news:funai0toe7cv50659iq8h6tc5vdovb8gks@4ax.com:

    > Do you see Port 3389 if you run netstat -ano
    > ?


    I did not see it with netstat -an, but I did not try netstat -ano. I am
    not sitting at the PC but I think that -ano will not show it either.
  5. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Have you attempted to change the security module type in
    the Local Machine policies?
    Look for :
    Local Security Settings -> Local Policies -> Security
    options ->
    Network access: Sharing and security model for local
    accounts.

    Change this setting to Classic - Local users authenticate
    as themselves.
    If not that one one of those settings should do the trick!

    Hope this helps you solve this problem for yourself.


    >-----Original Message-----
    >"Jeffrey Randow (MVP)" <jeffreyr-
    support@remotenetworktechnology.com> wrote
    >in news:funai0toe7cv50659iq8h6tc5vdovb8gks@4ax.com:
    >
    >> Do you see Port 3389 if you run netstat -ano
    >> ?
    >
    >
    >I did not see it with netstat -an, but I did not try
    netstat -ano. I am
    >not sitting at the PC but I think that -ano will not
    show it either.
    >.
    >
  6. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    I changed the Network Access to "Classic" and rebooted the PC.
    netstat -an and netstat -ano still do not show port 3389 as listening.
    Remote Desktop & Remote assistance are still checked, ICF is off,
    Terminal Services is started, no errors in the Event Viewer.


    "Zagan" <anonymous@discussions.microsoft.com> wrote in message news:<a1a801c486c3$b61d3a50$a601280a@phx.gbl>...
    > Have you attempted to change the security module type in
    > the Local Machine policies?
    > Look for :
    > Local Security Settings -> Local Policies -> Security
    > options ->
    > Network access: Sharing and security model for local
    > accounts.
    >
    > Change this setting to Classic - Local users authenticate
    > as themselves.
    > If not that one one of those settings should do the trick!
    >
    > Hope this helps you solve this problem for yourself.
  7. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Computer Prog wrote:

    > I changed the Network Access to "Classic" and rebooted the PC.
    > netstat -an and netstat -ano still do not show port 3389 as listening.
    > Remote Desktop & Remote assistance are still checked, ICF is off,
    > Terminal Services is started, no errors in the Event Viewer.
    >
    >
    >
    > "Zagan" <anonymous@discussions.microsoft.com> wrote in message news:<a1a801c486c3$b61d3a50$a601280a@phx.gbl>...
    >
    >>Have you attempted to change the security module type in
    >>the Local Machine policies?
    >>Look for :
    >>Local Security Settings -> Local Policies -> Security
    >>options ->
    >>Network access: Sharing and security model for local
    >>accounts.
    >>
    >>Change this setting to Classic - Local users authenticate
    >>as themselves.
    >>If not that one one of those settings should do the trick!
    >>
    >>Hope this helps you solve this problem for yourself.
    Does your admin account have a password?
    Wim
  8. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    This won't help as the Remote Desktop server is not listening on TCP
    Port 3389... :(

    Jeffrey Randow (Windows Networking & Smart Display MVP)
    jeffreyr-support@remotenetworktechnology.com

    Please post all responses to the newsgroups for the benefit
    of all USENET users. Messages sent via email may or may not
    be answered depending on time availability....

    Remote Networking Technology Support Site -
    http://www.remotenetworktechnology.com
    Windows XP Expert Zone - http://www.microsoft.com/windowsxp/expertzone

    On Sat, 21 Aug 2004 10:04:16 +0200, WimvV <w.vvv.voort@home.nl.com>
    wrote:

    >Computer Prog wrote:
    >
    >> I changed the Network Access to "Classic" and rebooted the PC.
    >> netstat -an and netstat -ano still do not show port 3389 as listening.
    >> Remote Desktop & Remote assistance are still checked, ICF is off,
    >> Terminal Services is started, no errors in the Event Viewer.
    >>
    >>
    >>
    >> "Zagan" <anonymous@discussions.microsoft.com> wrote in message news:<a1a801c486c3$b61d3a50$a601280a@phx.gbl>...
    >>
    >>>Have you attempted to change the security module type in
    >>>the Local Machine policies?
    >>>Look for :
    >>>Local Security Settings -> Local Policies -> Security
    >>>options ->
    >>>Network access: Sharing and security model for local
    >>>accounts.
    >>>
    >>>Change this setting to Classic - Local users authenticate
    >>>as themselves.
    >>>If not that one one of those settings should do the trick!
    >>>
    >>>Hope this helps you solve this problem for yourself.
    >Does your admin account have a password?
    >Wim
  9. Quote:
    * fDenyTSConnections in the registry is set to 0

    Thank you for this small nugget of information. I've been trying all day to resolve a similar issue and have been on just about every site I could find with any reference to my problem. This is the first reference I've seen to this registry setting and it sorted it out for me straightaway.

    Many thanks indeed.

    :-)
  10. If Terminal Services and Remote procedure call services are up, and no 3389 port listed on netstat -na then do the following (as a last option before repairing SO):

    1) Download devcon.exe from (http://support.microsoft.com/kb/311272) and run devcon.exe.

    2) An Extractor will popup, extract to "C:\devcon" or otherwise folder u like.
    3) Open a cmd prompt and navigate to the i386 folder extractor made.
    4) Type: devcon.exe -r install %windir%\inf\machine.inf root\rdpdr (All connections will be closed and machine will restart, save your work before execute that, and proceed)

    The machine will do a process, and then restart, wait until windows start, and then do an netstat -na, if the port 3389 appears listening it's all done.

    Good luck! :sol:
Ask a new question

Read More

Registry Windows XP