Remote Desktop and XP Pro SP2

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Never had a problem remoting in to XP pro w/SP1. However,
since updating to SP2 I can only remote in one time before
my machine has to be rebooted to remote in again.

I remote in the first time and all is fine. I disconnect
and attempt to remote in a second time and receive the
error: "The client cannot connect to the remote
machine..." Then it tells me that possible reasons are too
many connections, remote desktop not turned on, etc. Once
the machine is rebooted I am able to remote in again, but
only the one time before I have to repeat the process.

Any ideas? Nothing has changed except the update to SP2.

Vince
11 answers Last reply
More about remote desktop
  1. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Hi,

    I've got a very similar problem. As I understand you the "server"-machine
    has to be rebooted. This is the case for me too. Updated to SP2, nothing else
    changed.
    Do you have got Firewalls active?

    Greetings,
    Mat

    "vja2000" wrote:

    > Never had a problem remoting in to XP pro w/SP1. However,
    > since updating to SP2 I can only remote in one time before
    > my machine has to be rebooted to remote in again.
    >
    > I remote in the first time and all is fine. I disconnect
    > and attempt to remote in a second time and receive the
    > error: "The client cannot connect to the remote
    > machine..." Then it tells me that possible reasons are too
    > many connections, remote desktop not turned on, etc. Once
    > the machine is rebooted I am able to remote in again, but
    > only the one time before I have to repeat the process.
    >
    > Any ideas? Nothing has changed except the update to SP2.
    >
    > Vince
    >
    >
  2. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Mat,

    I seem to have resolved this issue by forwarding port 137 in my router. Upon
    viewing the sp2 firewall log I noticed that port 137 was trying to open for
    file and printer sharing. Since forwarding this port I have had no further
    issues with Remote Desktop. I did not try turning off or disallowing file and
    printer sharing in the sp2 firewall to see if this would serve the same
    purpose.

    Vince


    "Mat" wrote:

    > Hi,
    >
    > I've got a very similar problem. As I understand you the "server"-machine
    > has to be rebooted. This is the case for me too. Updated to SP2, nothing else
    > changed.
    > Do you have got Firewalls active?
    >
    > Greetings,
    > Mat
    >
    > "vja2000" wrote:
    >
    > > Never had a problem remoting in to XP pro w/SP1. However,
    > > since updating to SP2 I can only remote in one time before
    > > my machine has to be rebooted to remote in again.
    > >
    > > I remote in the first time and all is fine. I disconnect
    > > and attempt to remote in a second time and receive the
    > > error: "The client cannot connect to the remote
    > > machine..." Then it tells me that possible reasons are too
    > > many connections, remote desktop not turned on, etc. Once
    > > the machine is rebooted I am able to remote in again, but
    > > only the one time before I have to repeat the process.
    > >
    > > Any ideas? Nothing has changed except the update to SP2.
    > >
    > > Vince
    > >
    > >
  3. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    BAD...BAD...BAD... (unless you limit it only to the local subnet)

    Port 137 is not required for any remote desktop operation...

    Jeffrey Randow (Windows Networking & Smart Display MVP)
    jeffreyr-support@remotenetworktechnology.com

    Please post all responses to the newsgroups for the benefit
    of all USENET users. Messages sent via email may or may not
    be answered depending on time availability....

    Remote Networking Technology Support Site -
    http://www.remotenetworktechnology.com
    Windows XP Expert Zone - http://www.microsoft.com/windowsxp/expertzone

    On Wed, 25 Aug 2004 04:41:01 -0700, "vja2000"
    <vja2000@discussions.microsoft.com> wrote:

    >Mat,
    >
    >I seem to have resolved this issue by forwarding port 137 in my router. Upon
    >viewing the sp2 firewall log I noticed that port 137 was trying to open for
    >file and printer sharing. Since forwarding this port I have had no further
    >issues with Remote Desktop. I did not try turning off or disallowing file and
    >printer sharing in the sp2 firewall to see if this would serve the same
    >purpose.
    >
    >Vince
    >
    >
    >"Mat" wrote:
    >
    >> Hi,
    >>
    >> I've got a very similar problem. As I understand you the "server"-machine
    >> has to be rebooted. This is the case for me too. Updated to SP2, nothing else
    >> changed.
    >> Do you have got Firewalls active?
    >>
    >> Greetings,
    >> Mat
    >>
    >> "vja2000" wrote:
    >>
    >> > Never had a problem remoting in to XP pro w/SP1. However,
    >> > since updating to SP2 I can only remote in one time before
    >> > my machine has to be rebooted to remote in again.
    >> >
    >> > I remote in the first time and all is fine. I disconnect
    >> > and attempt to remote in a second time and receive the
    >> > error: "The client cannot connect to the remote
    >> > machine..." Then it tells me that possible reasons are too
    >> > many connections, remote desktop not turned on, etc. Once
    >> > the machine is rebooted I am able to remote in again, but
    >> > only the one time before I have to repeat the process.
    >> >
    >> > Any ideas? Nothing has changed except the update to SP2.
    >> >
    >> > Vince
    >> >
    >> >
  4. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Jeffrey,

    Do you remember this thread?

    http://groups.google.com/groups?hl=en&lr=&ie=UTF-8&frame=right&th=2bf3c59545c3630b&seekm=b9qdnX5tuMwXC4LcRVn-iQ%40comcast.com#link1

    The original poster could connect using an IP but not a name. Enabling File and Print Sharing, which
    also opens UDP Port 137, fixed this issue. I have not had a chance to test that, but I do know that
    I have F&PS enabled on both of my home XP SP2 machines and can access Remote Desktop on the XP Pro
    box by either IP or name. In my case, however, I severely restrict the F&PS address scope to the
    local machines by their IP addresses.

    --
    Al Jarvi (MS-MVP Windows Networking)

    Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
    The MS-MVP Program - http://mvp.support.microsoft.com
    This posting is provided "AS IS" with no warranties, and confers no rights...

    "Jeffrey Randow (MVP)" <jeffreyr-support@remotenetworktechnology.com> wrote in message
    news:oe32j0hgq7oseec1hc886inhkvhaom8oos@4ax.com...
    > BAD...BAD...BAD... (unless you limit it only to the local subnet)
    >
    > Port 137 is not required for any remote desktop operation...
    >
    > Jeffrey Randow (Windows Networking & Smart Display MVP)
    > jeffreyr-support@remotenetworktechnology.com
    >
    > Please post all responses to the newsgroups for the benefit
    > of all USENET users. Messages sent via email may or may not
    > be answered depending on time availability....
    >
    > Remote Networking Technology Support Site -
    > http://www.remotenetworktechnology.com
    > Windows XP Expert Zone - http://www.microsoft.com/windowsxp/expertzone
    >
    > On Wed, 25 Aug 2004 04:41:01 -0700, "vja2000"
    > <vja2000@discussions.microsoft.com> wrote:
    >
    >>Mat,
    >>
    >>I seem to have resolved this issue by forwarding port 137 in my router. Upon
    >>viewing the sp2 firewall log I noticed that port 137 was trying to open for
    >>file and printer sharing. Since forwarding this port I have had no further
    >>issues with Remote Desktop. I did not try turning off or disallowing file and
    >>printer sharing in the sp2 firewall to see if this would serve the same
    >>purpose.
    >>
    >>Vince
    >>
    >>
    >>"Mat" wrote:
    >>
    >>> Hi,
    >>>
    >>> I've got a very similar problem. As I understand you the "server"-machine
    >>> has to be rebooted. This is the case for me too. Updated to SP2, nothing else
    >>> changed.
    >>> Do you have got Firewalls active?
    >>>
    >>> Greetings,
    >>> Mat
    >>>
    >>> "vja2000" wrote:
    >>>
    >>> > Never had a problem remoting in to XP pro w/SP1. However,
    >>> > since updating to SP2 I can only remote in one time before
    >>> > my machine has to be rebooted to remote in again.
    >>> >
    >>> > I remote in the first time and all is fine. I disconnect
    >>> > and attempt to remote in a second time and receive the
    >>> > error: "The client cannot connect to the remote
    >>> > machine..." Then it tells me that possible reasons are too
    >>> > many connections, remote desktop not turned on, etc. Once
    >>> > the machine is rebooted I am able to remote in again, but
    >>> > only the one time before I have to repeat the process.
    >>> >
    >>> > Any ideas? Nothing has changed except the update to SP2.
    >>> >
    >>> > Vince
    >>> >
    >>> >
    >
  5. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Disabling that port disables NetBIOS... Thus, NetBIOS names will be
    blocked.... However, opening that port to the internet has severe
    security ramifications.

    Jeffrey Randow (Windows Networking & Smart Display MVP)
    jeffreyr-support@remotenetworktechnology.com

    Please post all responses to the newsgroups for the benefit
    of all USENET users. Messages sent via email may or may not
    be answered depending on time availability....

    Remote Networking Technology Support Site -
    http://www.remotenetworktechnology.com
    Windows XP Expert Zone - http://www.microsoft.com/windowsxp/expertzone

    On Sun, 29 Aug 2004 05:35:41 -0500, "Sooner Al"
    <SoonerAl@somewhere.net.invalid> wrote:

    >Jeffrey,
    >
    >Do you remember this thread?
    >
    >http://groups.google.com/groups?hl=en&lr=&ie=UTF-8&frame=right&th=2bf3c59545c3630b&seekm=b9qdnX5tuMwXC4LcRVn-iQ%40comcast.com#link1
    >
    >The original poster could connect using an IP but not a name. Enabling File and Print Sharing, which
    >also opens UDP Port 137, fixed this issue. I have not had a chance to test that, but I do know that
    >I have F&PS enabled on both of my home XP SP2 machines and can access Remote Desktop on the XP Pro
    >box by either IP or name. In my case, however, I severely restrict the F&PS address scope to the
    >local machines by their IP addresses.
  6. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Yep, but unfortunately PocketPCs running Windows Mobile 2003 don't have a hosts file option. Marc
    Zimmerman's Pocket Hosts does not play well with the OS for some odd reason...

    --
    Al Jarvi (MS-MVP Windows Networking)

    Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
    The MS-MVP Program - http://mvp.support.microsoft.com
    This posting is provided "AS IS" with no warranties, and confers no rights...

    "Jeffrey Randow (MVP)" <jeffreyr-support@remotenetworktechnology.com> wrote in message
    news:bln7j0h976thpdj0kh7c1uvhcjnor14k3u@4ax.com...
    > Disabling that port disables NetBIOS... Thus, NetBIOS names will be
    > blocked.... However, opening that port to the internet has severe
    > security ramifications.
    >
    > Jeffrey Randow (Windows Networking & Smart Display MVP)
    > jeffreyr-support@remotenetworktechnology.com
    >
    > Please post all responses to the newsgroups for the benefit
    > of all USENET users. Messages sent via email may or may not
    > be answered depending on time availability....
    >
    > Remote Networking Technology Support Site -
    > http://www.remotenetworktechnology.com
    > Windows XP Expert Zone - http://www.microsoft.com/windowsxp/expertzone
    >
    > On Sun, 29 Aug 2004 05:35:41 -0500, "Sooner Al"
    > <SoonerAl@somewhere.net.invalid> wrote:
    >
    >>Jeffrey,
    >>
    >>Do you remember this thread?
    >>
    >>http://groups.google.com/groups?hl=en&lr=&ie=UTF-8&frame=right&th=2bf3c59545c3630b&seekm=b9qdnX5tuMwXC4LcRVn-iQ%40comcast.com#link1
    >>
    >>The original poster could connect using an IP but not a name. Enabling File and Print Sharing,
    >>which
    >>also opens UDP Port 137, fixed this issue. I have not had a chance to test that, but I do know
    >>that
    >>I have F&PS enabled on both of my home XP SP2 machines and can access Remote Desktop on the XP Pro
    >>box by either IP or name. In my case, however, I severely restrict the F&PS address scope to the
    >>local machines by their IP addresses.
    >
  7. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Possibly a better solution is to setup a local DNS server.. This way
    you will be able to connect from the local LAN and on the internet (if
    you have the naming setup properly).

    Jeffrey Randow (Windows Networking & Smart Display MVP)
    jeffreyr-support@remotenetworktechnology.com

    Please post all responses to the newsgroups for the benefit
    of all USENET users. Messages sent via email may or may not
    be answered depending on time availability....

    Remote Networking Technology Support Site -
    http://www.remotenetworktechnology.com
    Windows XP Expert Zone - http://www.microsoft.com/windowsxp/expertzone

    On Tue, 31 Aug 2004 04:43:08 -0500, "Sooner Al"
    <SoonerAl@somewhere.net.invalid> wrote:

    >Yep, but unfortunately PocketPCs running Windows Mobile 2003 don't have a hosts file option. Marc
    >Zimmerman's Pocket Hosts does not play well with the OS for some odd reason...
  8. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    I doubt seriously if most home users will do that...

    --
    Al Jarvi (MS-MVP Windows Networking)

    Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
    The MS-MVP Program - http://mvp.support.microsoft.com
    This posting is provided "AS IS" with no warranties, and confers no rights...

    "Jeffrey Randow (MVP)" <jeffreyr-support@remotenetworktechnology.com> wrote in message
    news:vf0dj0d87qous1ce8ue1op3gquk4rbjejg@4ax.com...
    > Possibly a better solution is to setup a local DNS server.. This way
    > you will be able to connect from the local LAN and on the internet (if
    > you have the naming setup properly).
    >
    > Jeffrey Randow (Windows Networking & Smart Display MVP)
    > jeffreyr-support@remotenetworktechnology.com
    >
    > Please post all responses to the newsgroups for the benefit
    > of all USENET users. Messages sent via email may or may not
    > be answered depending on time availability....
    >
    > Remote Networking Technology Support Site -
    > http://www.remotenetworktechnology.com
    > Windows XP Expert Zone - http://www.microsoft.com/windowsxp/expertzone
    >
    > On Tue, 31 Aug 2004 04:43:08 -0500, "Sooner Al"
    > <SoonerAl@somewhere.net.invalid> wrote:
    >
    >>Yep, but unfortunately PocketPCs running Windows Mobile 2003 don't have a hosts file option. Marc
    >>Zimmerman's Pocket Hosts does not play well with the OS for some odd reason...
    >
  9. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    I understand perfectly what you guys are saying. And,
    apparently this bit of weirdness isn't effecting all
    machines. However, since opening up UDP port 137 in my
    router, I have had no issues with remote desktop. And, to
    verify the relevance of opening up this port, I disabled
    the port in my router and disabled file and print sharing.
    Once again, I returned to being able to remote in one time
    and one time only before requiring a reboot of my XP Pro
    machine. One reboot, one logon - that's it. I went in,
    turned on file and print sharing in the SP2 firewall,
    opened up the port in my router, and things are once again
    working just fine with regard to remote desktop. I would
    certainly prefer not to have this port or this service
    running, but I'm without a known choice as it stands right
    now.

    As an aside, I am quite frankly growing tired of the XP
    pro remote restrictions; specifically with regard to
    the "one logon at a time" restrictions. And, while my web
    server functions correctly, I have been unable to get FTP
    or Tsweb working correctly. I have a friend who will sell
    me his Windows 2000 Server software, but I have thusfar
    rejected the offer, primarily because I'm not certain as
    to whether or not I would still be able to use my computer
    as a desktop with the server software installed. In other
    words, whether or not I would still be able to run
    Quicken, Office XP, and etc. from my computer with the
    server software running. And, I'm certain there would be
    no more fast user switching with the server software.
    Still, if I knew I could run the programs mentioned above
    and utilize the computer as a server at the same time
    (without having to multiboot), I would purchase the server
    software from him and install it in a heartbeat.

    Vince
  10. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Not a single home user, but if you run a home network....

    :)

    Jeffrey Randow (Windows Networking & Smart Display MVP)
    jeffreyr-support@remotenetworktechnology.com

    Please post all responses to the newsgroups for the benefit
    of all USENET users. Messages sent via email may or may not
    be answered depending on time availability....

    Remote Networking Technology Support Site -
    http://www.remotenetworktechnology.com
    Windows XP Expert Zone - http://www.microsoft.com/windowsxp/expertzone

    On Thu, 2 Sep 2004 05:33:32 -0500, "Sooner Al"
    <SoonerAl@somewhere.net.invalid> wrote:

    >I doubt seriously if most home users will do that...
  11. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    As for your last statement - I run Windows 2003 Server on my Acer
    laptop with no issues (it is a development machine) other than getting
    the Centrino drivers installed...

    What issues are you having with FTP or TSWEB? The key thing with the
    two of them is having the proper ports forwarded...

    Note that some routers can mangle FTP port redirection if they don't
    have the proper NAT codes (early Belkins had this problem).

    Jeffrey Randow (Windows Networking & Smart Display MVP)
    jeffreyr-support@remotenetworktechnology.com

    Please post all responses to the newsgroups for the benefit
    of all USENET users. Messages sent via email may or may not
    be answered depending on time availability....

    Remote Networking Technology Support Site -
    http://www.remotenetworktechnology.com
    Windows XP Expert Zone - http://www.microsoft.com/windowsxp/expertzone

    On Thu, 2 Sep 2004 05:36:03 -0700, "vja2000" <vja2000@bellsouth.net>
    wrote:

    >I understand perfectly what you guys are saying. And,
    >apparently this bit of weirdness isn't effecting all
    >machines. However, since opening up UDP port 137 in my
    >router, I have had no issues with remote desktop. And, to
    >verify the relevance of opening up this port, I disabled
    >the port in my router and disabled file and print sharing.
    >Once again, I returned to being able to remote in one time
    >and one time only before requiring a reboot of my XP Pro
    >machine. One reboot, one logon - that's it. I went in,
    >turned on file and print sharing in the SP2 firewall,
    >opened up the port in my router, and things are once again
    >working just fine with regard to remote desktop. I would
    >certainly prefer not to have this port or this service
    >running, but I'm without a known choice as it stands right
    >now.
    >
    >As an aside, I am quite frankly growing tired of the XP
    >pro remote restrictions; specifically with regard to
    >the "one logon at a time" restrictions. And, while my web
    >server functions correctly, I have been unable to get FTP
    >or Tsweb working correctly. I have a friend who will sell
    >me his Windows 2000 Server software, but I have thusfar
    >rejected the offer, primarily because I'm not certain as
    >to whether or not I would still be able to use my computer
    >as a desktop with the server software installed. In other
    >words, whether or not I would still be able to run
    >Quicken, Office XP, and etc. from my computer with the
    >server software running. And, I'm certain there would be
    >no more fast user switching with the server software.
    >Still, if I knew I could run the programs mentioned above
    >and utilize the computer as a server at the same time
    >(without having to multiboot), I would purchase the server
    >software from him and install it in a heartbeat.
    >
    >Vince
Ask a new question

Read More

Remote Desktop Windows XP