Audio Sync encoding problem

Archived from groups: rec.video.desktop (More info?)

Hope this is not too long but trying to give enough info.

Fairly new to capturing (but picking up experience fast because of the
number of mistakes I have made) - I am capturing VHS using an XStream
TV/Capture Card - using VirtualVCR to do the actual capture, huffyuv
compression - capturing at 352x576 (working in PAL land)- audio at 44 or
48 Mhz (I have used various). I end up with an avi file that if I play it
on the PC is in sync from one end to the other. The statistics on the
actual capture say that there were some dropped frames - out of 175307
captured frames there were Dropped1=357 and Dropped2=58 - the captured
clip is 1 Hour 56 Minutes long (I don't know what the Dropped2 figure
represents ?).

However, notwithstanding the dropped frames the avi file appears to playy
in sync all the way through. I then encode the file using TMPG (version
TMPGEnc 2.521.58.169) - I have tried various settings but am currently
encoding to an MPEG2 (at 352x576) file using a Constant Quality setting,
'Normal' motion search. My problem is that the audio is going out of sync
! Obviously, depending what settings you use my recode's are taking
between 3 and 9 hours a time and you can only tell whether the audio
stays in sync by encoding the whole file (around 6 times to date, for
various problems !). I don't see anything in TMPG that adjusts the audio
but as I say the avi seems to be synced anyway so I assume that the
'capture' went OK.

If anyone has any helpful suggestions I would be really grateful.

Thanks
3 answers Last reply
More about audio sync encoding problem
  1. Archived from groups: rec.video.desktop (More info?)

    On 06 Dec 2004 13:01:17 GMT, Ken Frost <oldfrostyNOSPAM@btinternet.com>
    wrote:

    >there were Dropped1=357 and Dropped2=58 - the captured
    >clip is 1 Hour 56 Minutes long (I don't know what the Dropped2 figure
    >represents ?).

    http://virtualvcr.sourceforge.net/html/virtualvcr/general.php
    The VVCR programmer wrote: "The default dropped frames interface that
    comes with DirectShow is broken, I have created a new Dropped frame
    detection method that should be a lot more accurate then the default
    one. The new dropped frame system shows up under Dropped2 in the capture
    stats, it also makes available the frame numbers that were dropped be
    selecting "Show Dropped Frames" from the capture menu after a capture."

    So the Dropped2 counter reports the dropped frames that DirectShow (and
    most DirectShow capture apps) don't report. It's difficult to avoid
    "dropped2" frames when capturing from VHS tapes, but in my case the
    "dropped1" counter always remains at 0. You should read these guide-
    lines on how to avoid dropped frames:
    http://www.digitalfaq.com/capture/droppedframes.htm

    >My problem is that the audio is going out of sync

    Shouldn't really happen, even if there are dropped frames. Those frames
    should be replaced by the previous frame, but if the encoder doesn't do
    that you will lose sync. Try this: open the captured file in VirtualDub
    and check the sync there. If it's OK try frameserving to TMPGEnc:
    http://www.videohelp.com/virtualdubframeserve

    By the way, WDM capture apps usually create AVI files with internal
    video and audio offsets.
    http://darkfalz.kiczek.com/software/
    AVI Offset Calculator - This is intended for use with WDM capture
    devices and programs. These usually create captures with internal audio
    and video offsets, which work properly under DirectShow but are
    typically ignored by editing software. This tool calculates the total
    skew, writes the offsets to zero, and renames the file so that you can
    adjust the audio skew in VirtualDub or other software. This should
    result in proper sync for both editing and playback.
    http://darkfalz.kiczek.com/software/AVIOffsetCalculator1.20.zip
  2. Archived from groups: rec.video.desktop (More info?)

    Ken Frost <oldfrostyNOSPAM@btinternet.com> wrote:

    >Hope this is not too long but trying to give enough info.
    >
    >Fairly new to capturing (but picking up experience fast because of the
    >number of mistakes I have made) - I am capturing VHS using an XStream
    >TV/Capture Card - using VirtualVCR to do the actual capture, huffyuv
    >compression - capturing at 352x576 (working in PAL land)- audio at 44 or
    >48 Mhz (I have used various). I end up with an avi file that if I play it
    >on the PC is in sync from one end to the other. The statistics on the
    >actual capture say that there were some dropped frames - out of 175307
    >captured frames there were Dropped1=357 and Dropped2=58 - the captured
    >clip is 1 Hour 56 Minutes long (I don't know what the Dropped2 figure
    >represents ?).
    >
    >However, notwithstanding the dropped frames the avi file appears to playy
    >in sync all the way through. I then encode the file using TMPG (version
    >TMPGEnc 2.521.58.169) - I have tried various settings but am currently
    >encoding to an MPEG2 (at 352x576) file using a Constant Quality setting,
    >'Normal' motion search. My problem is that the audio is going out of sync
    >! Obviously, depending what settings you use my recode's are taking
    >between 3 and 9 hours a time and you can only tell whether the audio
    >stays in sync by encoding the whole file (around 6 times to date, for
    >various problems !). I don't see anything in TMPG that adjusts the audio
    >but as I say the avi seems to be synced anyway so I assume that the
    >'capture' went OK.
    >
    >If anyone has any helpful suggestions I would be really grateful.

    Here's something you can try in TMPGEnc:
    Under Option / Environmental setting, select the VFAPI plug-in tab.
    Right-click on DirectShow Multimedia File Reader, and select Higher
    priority. Repeat that until it is at the top of the list. Then
    you'll have to try encoding again to see if it helps.
  3. Archived from groups: rec.video.desktop (More info?)

    Thanks to both of you for the replies - I will start again on Thursday
    and check back again.

    Thank you

    DeepOne@ix.netcom.com wrote in
    news:H76td.7278$Va5.851@newsread3.news.atl.earthlink.net:

    > Ken Frost <oldfrostyNOSPAM@btinternet.com> wrote:
    >
    >>Hope this is not too long but trying to give enough info.
    >>
    >>Fairly new to capturing (but picking up experience fast because of the
    >>number of mistakes I have made) - I am capturing VHS using an XStream
    >>TV/Capture Card - using VirtualVCR to do the actual capture, huffyuv
    >>compression - capturing at 352x576 (working in PAL land)- audio at 44
    >>or 48 Mhz (I have used various). I end up with an avi file that if I
    >>play it on the PC is in sync from one end to the other. The statistics
    >>on the actual capture say that there were some dropped frames - out of
    >>175307 captured frames there were Dropped1=357 and Dropped2=58 - the
    >>captured clip is 1 Hour 56 Minutes long (I don't know what the
    >>Dropped2 figure represents ?).
    >>
    >>However, notwithstanding the dropped frames the avi file appears to
    >>playy in sync all the way through. I then encode the file using TMPG
    >>(version TMPGEnc 2.521.58.169) - I have tried various settings but am
    >>currently encoding to an MPEG2 (at 352x576) file using a Constant
    >>Quality setting, 'Normal' motion search. My problem is that the audio
    >>is going out of sync ! Obviously, depending what settings you use my
    >>recode's are taking between 3 and 9 hours a time and you can only tell
    >>whether the audio stays in sync by encoding the whole file (around 6
    >>times to date, for various problems !). I don't see anything in TMPG
    >>that adjusts the audio but as I say the avi seems to be synced anyway
    >>so I assume that the 'capture' went OK.
    >>
    >>If anyone has any helpful suggestions I would be really grateful.
    >
    > Here's something you can try in TMPGEnc:
    > Under Option / Environmental setting, select the VFAPI plug-in tab.
    > Right-click on DirectShow Multimedia File Reader, and select Higher
    > priority. Repeat that until it is at the top of the list. Then
    > you'll have to try encoding again to see if it helps.
    >
Ask a new question

Read More

Tuner Cards Audio Graphics