Sign in with
Sign up | Sign in
Your question

Prevent currently logged on user from denying remote deskt..

Last response: in Windows XP
Share
September 10, 2004 1:04:39 PM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Is there a way - reg tweak, group policy setting - to
prevent a user (not admin) who is currently logged on to
a WinXP SP2 machine from denying remote desktop access to
an administrator? From KB 280828:

The user currently logged on to the remote computer will
receive the following error message:
<Domain or Computer Name>\<username> is trying to connect
to this computer. If you allow, you will be disconnected,
but you can resume later. Do you want to allow this
connection?
If the user clicks No, the remote user will get the
message:
<Domain or Computer Name>\<username> is currently logged
on this computer, and did not allow you to connect.

It seems unreasonable to me that a user can prevent an
admin from logging on to the machine. There's gotta be a
solution -- I've looked and found nothing.

Anyone?

Thanks!
Anonymous
September 10, 2004 11:22:19 PM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Submit an MSWISH?
http://register.microsoft.com/mswish/suggestion.asp


"Peter" <anonymous@discussions.microsoft.com> wrote in message
news:9a6a01c4974f$e04b7a70$a501280a@phx.gbl...
> Is there a way - reg tweak, group policy setting - to
> prevent a user (not admin) who is currently logged on to
> a WinXP SP2 machine from denying remote desktop access to
> an administrator? From KB 280828:
>
> The user currently logged on to the remote computer will
> receive the following error message:
> <Domain or Computer Name>\<username> is trying to connect
> to this computer. If you allow, you will be disconnected,
> but you can resume later. Do you want to allow this
> connection?
> If the user clicks No, the remote user will get the
> message:
> <Domain or Computer Name>\<username> is currently logged
> on this computer, and did not allow you to connect.
>
> It seems unreasonable to me that a user can prevent an
> admin from logging on to the machine. There's gotta be a
> solution -- I've looked and found nothing.
>
> Anyone?
>
> Thanks!
Anonymous
September 10, 2004 11:22:20 PM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Thanks Bill, I did just that. Also, I configured the
following setting in the Group Policy:

User Configuration\Administrative Templates\Windows
Components\Terminal Services\"Sets rules for remote
control of Terminal Services user sessions" to Enabled:
Full control without user's permission.

I don't know if that will do the trick (I can't terminal
myself with my current setup) but if I find I've nailed
it I'll post back.

Thanks again.

>-----Original Message-----
>Submit an MSWISH?
>http://register.microsoft.com/mswish/suggestion.asp
>
>
>"Peter" <anonymous@discussions.microsoft.com> wrote in
message
>news:9a6a01c4974f$e04b7a70$a501280a@phx.gbl...
>> Is there a way - reg tweak, group policy setting - to
>> prevent a user (not admin) who is currently logged on
to
>> a WinXP SP2 machine from denying remote desktop access
to
>> an administrator? From KB 280828:
>>
>> The user currently logged on to the remote computer
will
>> receive the following error message:
>> <Domain or Computer Name>\<username> is trying to
connect
>> to this computer. If you allow, you will be
disconnected,
>> but you can resume later. Do you want to allow this
>> connection?
>> If the user clicks No, the remote user will get the
>> message:
>> <Domain or Computer Name>\<username> is currently
logged
>> on this computer, and did not allow you to connect.
>>
>> It seems unreasonable to me that a user can prevent an
>> admin from logging on to the machine. There's gotta be
a
>> solution -- I've looked and found nothing.
>>
>> Anyone?
>>
>> Thanks!
>
>
>.
>
Related resources
Anonymous
September 15, 2004 5:46:55 PM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Well that sure didn't work: the currently logged on user
(non-admin) can still prevent an admin from logging on
even with that group policy setting enabled. Bummer.

>-----Original Message-----
>Thanks Bill, I did just that. Also, I configured the
>following setting in the Group Policy:
>
>User Configuration\Administrative Templates\Windows
>Components\Terminal Services\"Sets rules for remote
>control of Terminal Services user sessions" to Enabled:
>Full control without user's permission.
>
>I don't know if that will do the trick (I can't terminal
>myself with my current setup) but if I find I've nailed
>it I'll post back.
>
>Thanks again.
>
>>-----Original Message-----
>>Submit an MSWISH?
>>http://register.microsoft.com/mswish/suggestion.asp
>>
>>
>>"Peter" <anonymous@discussions.microsoft.com> wrote in
>message
>>news:9a6a01c4974f$e04b7a70$a501280a@phx.gbl...
>>> Is there a way - reg tweak, group policy setting - to
>>> prevent a user (not admin) who is currently logged on
>to
>>> a WinXP SP2 machine from denying remote desktop
access
>to
>>> an administrator? From KB 280828:
>>>
>>> The user currently logged on to the remote computer
>will
>>> receive the following error message:
>>> <Domain or Computer Name>\<username> is trying to
>connect
>>> to this computer. If you allow, you will be
>disconnected,
>>> but you can resume later. Do you want to allow this
>>> connection?
>>> If the user clicks No, the remote user will get the
>>> message:
>>> <Domain or Computer Name>\<username> is currently
>logged
>>> on this computer, and did not allow you to connect.
>>>
>>> It seems unreasonable to me that a user can prevent an
>>> admin from logging on to the machine. There's gotta
be
>a
>>> solution -- I've looked and found nothing.
>>>
>>> Anyone?
>>>
>>> Thanks!
>>
>>
>>.
>>
>.
>
Anonymous
September 16, 2004 3:10:08 AM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Yeah--I don't think there is a good solution for this one at the moment.
At least I haven't heard anyone saying they had one!

<anonymous@discussions.microsoft.com> wrote in message
news:1c6c01c49b65$231d4720$a601280a@phx.gbl...
> Well that sure didn't work: the currently logged on user
> (non-admin) can still prevent an admin from logging on
> even with that group policy setting enabled. Bummer.
>
>>-----Original Message-----
>>Thanks Bill, I did just that. Also, I configured the
>>following setting in the Group Policy:
>>
>>User Configuration\Administrative Templates\Windows
>>Components\Terminal Services\"Sets rules for remote
>>control of Terminal Services user sessions" to Enabled:
>>Full control without user's permission.
>>
>>I don't know if that will do the trick (I can't terminal
>>myself with my current setup) but if I find I've nailed
>>it I'll post back.
>>
>>Thanks again.
>>
>>>-----Original Message-----
>>>Submit an MSWISH?
>>>http://register.microsoft.com/mswish/suggestion.asp
>>>
>>>
>>>"Peter" <anonymous@discussions.microsoft.com> wrote in
>>message
>>>news:9a6a01c4974f$e04b7a70$a501280a@phx.gbl...
>>>> Is there a way - reg tweak, group policy setting - to
>>>> prevent a user (not admin) who is currently logged on
>>to
>>>> a WinXP SP2 machine from denying remote desktop
> access
>>to
>>>> an administrator? From KB 280828:
>>>>
>>>> The user currently logged on to the remote computer
>>will
>>>> receive the following error message:
>>>> <Domain or Computer Name>\<username> is trying to
>>connect
>>>> to this computer. If you allow, you will be
>>disconnected,
>>>> but you can resume later. Do you want to allow this
>>>> connection?
>>>> If the user clicks No, the remote user will get the
>>>> message:
>>>> <Domain or Computer Name>\<username> is currently
>>logged
>>>> on this computer, and did not allow you to connect.
>>>>
>>>> It seems unreasonable to me that a user can prevent an
>>>> admin from logging on to the machine. There's gotta
> be
>>a
>>>> solution -- I've looked and found nothing.
>>>>
>>>> Anyone?
>>>>
>>>> Thanks!
>>>
>>>
>>>.
>>>
>>.
>>
Anonymous
September 17, 2004 3:11:33 AM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Disable Fast User Switching... Then it takes an admin to override a
user login...

On Wed, 15 Sep 2004 23:10:08 -0400, "Bill Sanderson"
<Bill_Sanderson@msn.com.plugh.org> wrote:

>Yeah--I don't think there is a good solution for this one at the moment.
>At least I haven't heard anyone saying they had one!
>
><anonymous@discussions.microsoft.com> wrote in message
>news:1c6c01c49b65$231d4720$a601280a@phx.gbl...
>> Well that sure didn't work: the currently logged on user
>> (non-admin) can still prevent an admin from logging on
>> even with that group policy setting enabled. Bummer.
>>
>>>-----Original Message-----
>>>Thanks Bill, I did just that. Also, I configured the
>>>following setting in the Group Policy:
>>>
>>>User Configuration\Administrative Templates\Windows
>>>Components\Terminal Services\"Sets rules for remote
>>>control of Terminal Services user sessions" to Enabled:
>>>Full control without user's permission.
>>>
>>>I don't know if that will do the trick (I can't terminal
>>>myself with my current setup) but if I find I've nailed
>>>it I'll post back.
>>>
>>>Thanks again.
>>>
>>>>-----Original Message-----
>>>>Submit an MSWISH?
>>>>http://register.microsoft.com/mswish/suggestion.asp
>>>>
>>>>
>>>>"Peter" <anonymous@discussions.microsoft.com> wrote in
>>>message
>>>>news:9a6a01c4974f$e04b7a70$a501280a@phx.gbl...
>>>>> Is there a way - reg tweak, group policy setting - to
>>>>> prevent a user (not admin) who is currently logged on
>>>to
>>>>> a WinXP SP2 machine from denying remote desktop
>> access
>>>to
>>>>> an administrator? From KB 280828:
>>>>>
>>>>> The user currently logged on to the remote computer
>>>will
>>>>> receive the following error message:
>>>>> <Domain or Computer Name>\<username> is trying to
>>>connect
>>>>> to this computer. If you allow, you will be
>>>disconnected,
>>>>> but you can resume later. Do you want to allow this
>>>>> connection?
>>>>> If the user clicks No, the remote user will get the
>>>>> message:
>>>>> <Domain or Computer Name>\<username> is currently
>>>logged
>>>>> on this computer, and did not allow you to connect.
>>>>>
>>>>> It seems unreasonable to me that a user can prevent an
>>>>> admin from logging on to the machine. There's gotta
>> be
>>>a
>>>>> solution -- I've looked and found nothing.
>>>>>
>>>>> Anyone?
>>>>>
>>>>> Thanks!
>>>>
>>>>
>>>>.
>>>>
>>>.
>>>
>
!