Sign in with
Sign up | Sign in
Your question

Permissions, ownership and an undeletable folder

Last response: in Windows 7
Share
January 5, 2011 5:59:41 PM

Hey guys

Im in the process of spring cleaning my big stack of hard-drives, in preperation for doing a clean windows install onto my shiney new Kingston V100 SSD.

I'm currently looking at one of my 2TB external archive drives, which used to be the system disk on my media-server but is now just an archive disk. Anyways, on that drive, I found a windows folder (no big shock for a system disk) and I figured that I don't need that, as I've previous migrated all the user files when I took it out of the old machine.

So I went to delete it, and it told me that I needed permission from 'S-1-5-21-432763403-189175183-190391661-1000' to delete the folder. From there, I went to the permissions tab, figuring that I'd just have to give myself the rights to get rid of it. No dice there, I couldn't change any permissions, or add or remove users.

From there, I went over to the advanced tab, figuring that I could take ownership and from there get the rights I need. About halfway through the ownership change dialogue, I got a:

'You do not have permission to read the contents of E:\etcetc, do you want to replace permissions with permissions granting full control?'

dialogue, so I hit yes, which brought up:

'An error occurred while applying security information to E:\blahblah. Access is denied.'

None of the ownership, nor permissions changed, so I still can't get rid of anything in the folder.

So, what do I have to do to get rid of this thing ?

Sure its only 20gb on a 2tb disk, but its clutter and I want rid of it!

There is a possibility that this was a botched install of windows, rather than a full one (i know it happened once, but I can't remember if it was this one or a different drive), which I guess might explain why the permissions are all hinky, but either way, I wanna know how to clean it out.

Thanks in advance guys!
Lost

January 5, 2011 7:28:04 PM

Have you tried logging in as the local administrator and taking ownership of the files? Make sure you check the box "Replace owner on all subcontainers and objects".
January 5, 2011 7:46:21 PM

yah...that SID isnt resolved, so the permissions are screwed. You ought to be able to change the permissions by logging in as local administrator as Gamertech stated, but also try taking ownership of the entire drive, and letting the permissions propogate to sub directories. If that doesnt work, go into users/groups and see if that unresolved sid is in there. If it is (which it should be if it is showing up in the ownership props on that folder), delete it, it doesnt need to be there regardless. This should effectively remove the current owner of that folder (and anything else the mystery sid might be hiding in) and allow you to take control it.

-l
Related resources
January 6, 2011 8:12:46 AM

Looks like the whole drive (but only one or two bits of its contents) have that same corrupted owner flag, so I changed the ownership of the whole drive.

That took ok, and I can now manipulate the security settings on that windows folder.

However, when I go to delete the folder it tell me 'You need permission from whoever currently owns this folder' and no matter what I set the ownership to (Admin, my user, everyone) it always tell me I need permission from someone, even though I am all of those people.

Any thoughts ?
January 6, 2011 8:59:10 AM

Some extra stuff-

I've discovered I can go and change individual permissions to each folder starting at the bottom of the heirerarchy and then delete them. Every time I try to get folder-trees to inherit permissions it'll give me an access denied and I have to do it the painfully slow way.

Since I'm going to have to do it for every single folder in windows (lots), I'd greatly appreciate any further ideas on how to do this in a timely manner.

Any way I can get around the ownership stuff through safe mode or booting to a LiveLinux distro ?

Am willing to do anything to avoid having to sit and click alllllllll day!
a b $ Windows 7
January 6, 2011 9:04:07 AM

Can you move the folder or rename it? If so try doing that and then reboot and delete the sucker.
January 6, 2011 9:27:16 AM

Try it with an Ubuntu live disk, I can't really remember if I was able to do delete the folder or just ended up reformatting.
January 6, 2011 9:56:36 AM

Use knoppix on a usb pen, boot from usb, it shouldn't care about the permissions and should blast away.

If you're also doing it windows and having to change permissions on tons of files at once you could do it via a batch file
a b $ Windows 7
January 6, 2011 11:18:41 AM

try this...

from the CMD (ran as admin)

takeown /r /f [location]
icacls [location] /grant [username]:( F)
del [location]
August 10, 2012 1:47:41 AM

I have this exact problem, but for me it is in random and important folders that I don't want to delete :( 
August 20, 2012 7:35:44 AM

Taking ownership and inheritted permissions has often worked; ensure you are sole owner and Supreme - trusted installer will thwart if given a chance. Takeown /F * works sometimes. Streamlining properties and asserting authority may also work...ignore all button is helpful. Changing its name/extension and sometimes moving the file as a prelude to deleting has worked...

There are various File Shredders I have had to use (& felt good and justified...).
December 6, 2012 10:57:47 AM

Hello.
I was having simillar problems this morning, and I tried unlocking file, changing owner, safe mode, administrator privileges on CMD, and nothing was helping. I was desperate and was ready to try anything, so this is the solution I came with and the only one that worked for me:

I added the file on my Antivirus software (comodo) to the quarantine and then deleted it from the quarantine.

Not the classies solution, but hey, it worked, right?
hope it helps.
!