Sign in with
Sign up | Sign in
Your question

Changing Remote Listening Ports for more than one computer

Last response: in Windows XP
Share
Anonymous
October 2, 2004 2:33:54 AM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

I have two computers connected to a wireless Router Linksys. Both Computers
have Wins XP Pro. I have set up remote desktop for tsweb as well as an
internal network. I am having problems connecting to one of my computers
outside of the network. I have on computer configured with the Default
Listening Port 3389, and the other computer has been changed in the Registry
to 3991. My router configuration goes as follows

Computer 1 Port TCP Enabled
Remote 192.168.1.101 80 YES YES
Listn'n Port 192.168.1.101 3389 YES YES


Computer 2 Port TCP Enable
Remote 192.168.1.100 1474 YES YES
Listn' Port 192.168.1.100 3391 YES YES


I can connect Computer 1 No Problem, But when I try to access Computer 2 I
cannot.... In the address bar I Place the Following:

64.244.......:1474/tsweb

It will let me connect to the remote desktop page, but when i hit connect,
it will not Display the Window to enter the User name and Password,,,,, I
get a error Message that Follows : Cannot Connect to server, either not
connected to a Network or the Terminal Server is to Busy. Please try again
Later.... Am I suppose to change another Setting To configure The Listening
Port (3991) Besides the Registry to allow remote desktop to connect to the
other Computer ?

Thank you


Derick Bourque
October 2, 2004 2:57:08 AM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Just a thought,

Instead of changing the listening port, why not just forward the alternate
port on your router to port 3389 on the private IP of the other computer.

I have done this and do not have any issues with connecting to either
machine.

--
Don't have the need for a full time IT staff, Contact Sean.
For all of your IT needs SCD@ourfamilyzoo.net.
Anonymous
October 2, 2004 9:56:18 AM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

You need to change the RDP port in the default.htm file on the second PC, ie. the PC your having
trouble connecting to. Look at this thread, from yesterday, for help with that...

http://groups.google.com/groups?hl=en&lr=&ie=UTF-8&c2co...

Personally, I recommend downloading Jeffery's 'default.htm' file because of the ability to change
the RDP port dynamically...If you really need to use the web based access method...

--
Al Jarvi (MS-MVP Windows Networking)

Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
The MS-MVP Program - http://mvp.support.microsoft.com
This posting is provided "AS IS" with no warranties, and confers no rights...

"Derick Bourque" <heyyu1@hotmail.com> wrote in message news:uIZyHhCqEHA.1992@TK2MSFTNGP09.phx.gbl...
>I have two computers connected to a wireless Router Linksys. Both Computers
> have Wins XP Pro. I have set up remote desktop for tsweb as well as an
> internal network. I am having problems connecting to one of my computers
> outside of the network. I have on computer configured with the Default
> Listening Port 3389, and the other computer has been changed in the Registry
> to 3991. My router configuration goes as follows
>
> Computer 1 Port TCP Enabled
> Remote 192.168.1.101 80 YES YES
> Listn'n Port 192.168.1.101 3389 YES YES
>
>
> Computer 2 Port TCP Enable
> Remote 192.168.1.100 1474 YES YES
> Listn' Port 192.168.1.100 3391 YES YES
>
>
> I can connect Computer 1 No Problem, But when I try to access Computer 2 I
> cannot.... In the address bar I Place the Following:
>
> 64.244.......:1474/tsweb
>
> It will let me connect to the remote desktop page, but when i hit connect,
> it will not Display the Window to enter the User name and Password,,,,, I
> get a error Message that Follows : Cannot Connect to server, either not
> connected to a Network or the Terminal Server is to Busy. Please try again
> Later.... Am I suppose to change another Setting To configure The Listening
> Port (3991) Besides the Registry to allow remote desktop to connect to the
> other Computer ?
>
> Thank you
>
>
> Derick Bourque
>
>
>
Anonymous
October 4, 2004 4:34:06 PM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Just a conceptual note here: You really only need one operational webserver
to allow you to connect to both machines, and having just one reduces
(slightly) your security exposure because of those machines.

You need to modify default.htm as Al mentions, to have connect buttons
customized for the two machines, on different ports.

"Derick Bourque" <heyyu1@hotmail.com> wrote in message
news:uIZyHhCqEHA.1992@TK2MSFTNGP09.phx.gbl...
>I have two computers connected to a wireless Router Linksys. Both Computers
> have Wins XP Pro. I have set up remote desktop for tsweb as well as an
> internal network. I am having problems connecting to one of my computers
> outside of the network. I have on computer configured with the Default
> Listening Port 3389, and the other computer has been changed in the
> Registry
> to 3991. My router configuration goes as follows
>
> Computer 1 Port TCP Enabled
> Remote 192.168.1.101 80 YES YES
> Listn'n Port 192.168.1.101 3389 YES YES
>
>
> Computer 2 Port TCP Enable
> Remote 192.168.1.100 1474 YES YES
> Listn' Port 192.168.1.100 3391 YES YES
>
>
> I can connect Computer 1 No Problem, But when I try to access Computer 2 I
> cannot.... In the address bar I Place the Following:
>
> 64.244.......:1474/tsweb
>
> It will let me connect to the remote desktop page, but when i hit connect,
> it will not Display the Window to enter the User name and Password,,,,, I
> get a error Message that Follows : Cannot Connect to server, either not
> connected to a Network or the Terminal Server is to Busy. Please try again
> Later.... Am I suppose to change another Setting To configure The
> Listening
> Port (3991) Besides the Registry to allow remote desktop to connect to the
> other Computer ?
>
> Thank you
>
>
> Derick Bourque
>
>
>
!