Sign in with
Sign up | Sign in
Your question

Bridging Wireless and Ethernet subnets

Last response: in Wireless Networking
Share
Anonymous
a b F Wireless
October 25, 2004 10:36:31 AM

Archived from groups: microsoft.public.windows.networking.wireless (More info?)

I have a small LAN made of two desktops with Ethernet
adapters, linked with a cross cable (no hubs, no routers),
which is working fine.
In order to add to the network a laptop (Centrino WinXP
SP1 with a preinstalled Intel PRO/Wireless LAN 2100 3B
Mini PCI Adapter 811.b), I bought a Qtec Wireless adapter
802.11g, installed it on one of the desktops (WinXP SP1),
and configured it as an ad-hoc subnet (with no security to
start with).
The WiFi subnet is working (laptop-desktop1), but
obviously cannot see the Ethernet subnet (desktop1-
desktop2) and viceversa.
In more detail: If I use two different ranges (192.168.0.x
and 169.254.x.y) they coexist separately, whereas if I use
the same range (169.254.x.y) they conflict because they
are based on different media (Ethernet-WiFi).
I therefore started to set up a Windows XP Bridge which is
supposed to just merge the two subnets into one, but I
could'nt make it work. The two WiFi cards don't see each
other across the bridge!
Although I read a lot of documentation from various
sources I could'nt find a solution todate.
Amongst other things I did:
1. Force promiscuity mode, as some adapters are not able
to enter that mode automatically when in the bridge
(source Microsoft)
2. Update driver to the Qtec adapter, as the 802.11g
standard was finally defined after many adapters were
already on the market, and interoperability could not be
guaranteed (source Internet, somewhere)
3. Setup a bridge also on the laptop in case the two WiFi
cards can communicate only if they are both in 'bridge
mode' (I'm not sure).
Can somebody help, please?
Eddy
October 26, 2004 10:59:41 PM

Archived from groups: microsoft.public.windows.networking.wireless (More info?)

Hi

First keep in mind that there is No WIFI vs. Ethernet.

It is all Ethernet. Wireless is just a replacement to a Wire and the name
WIFI is the name of the device certification.

If your Wireless works by it self I.e. you can really transfer files via
wireless between the computers (not just see signal in the utility) you
should be able to bridge Since you mentioned the 169.x.x. I have the feeling
that something is not working right and thus you can not Bridge.

The two networks as to be configured along the line of (Example) Wired
Network 192.168.1.1 and Wireless Network 192.168.2.1 or similar ranges.

Jack (MVP-Networking).







"Eddy Borg" <edelborg@everyday.com> wrote in message
news:0c1701c4ba97$a32b2bc0$a601280a@phx.gbl...
> I have a small LAN made of two desktops with Ethernet
> adapters, linked with a cross cable (no hubs, no routers),
> which is working fine.
> In order to add to the network a laptop (Centrino WinXP
> SP1 with a preinstalled Intel PRO/Wireless LAN 2100 3B
> Mini PCI Adapter 811.b), I bought a Qtec Wireless adapter
> 802.11g, installed it on one of the desktops (WinXP SP1),
> and configured it as an ad-hoc subnet (with no security to
> start with).
> The WiFi subnet is working (laptop-desktop1), but
> obviously cannot see the Ethernet subnet (desktop1-
> desktop2) and viceversa.
> In more detail: If I use two different ranges (192.168.0.x
> and 169.254.x.y) they coexist separately, whereas if I use
> the same range (169.254.x.y) they conflict because they
> are based on different media (Ethernet-WiFi).
> I therefore started to set up a Windows XP Bridge which is
> supposed to just merge the two subnets into one, but I
> could'nt make it work. The two WiFi cards don't see each
> other across the bridge!
> Although I read a lot of documentation from various
> sources I could'nt find a solution todate.
> Amongst other things I did:
> 1. Force promiscuity mode, as some adapters are not able
> to enter that mode automatically when in the bridge
> (source Microsoft)
> 2. Update driver to the Qtec adapter, as the 802.11g
> standard was finally defined after many adapters were
> already on the market, and interoperability could not be
> guaranteed (source Internet, somewhere)
> 3. Setup a bridge also on the laptop in case the two WiFi
> cards can communicate only if they are both in 'bridge
> mode' (I'm not sure).
> Can somebody help, please?
> Eddy
Anonymous
a b F Wireless
October 27, 2004 6:23:44 AM

Archived from groups: microsoft.public.windows.networking.wireless (More info?)

Most wi-fi adapters do NOT support ethernet style bridging,
because they can not work in true promiscuous mode.
And this is because they only simulate ethernet, but really are
not ethernet (despite of beliefs of some MVPs).
Either enable routing, or use NAT.

There are 802.11 devices specially designed to work as
ethernet bridges, but most cheapo wi-fi's, by design, are not.

Regards,
--PA



"Eddy Borg" <edelborg@everyday.com> wrote in message news:0c1701c4ba97$a32b2bc0$a601280a@phx.gbl...
> I have a small LAN made of two desktops with Ethernet
> adapters, linked with a cross cable (no hubs, no routers),
> which is working fine.
> In order to add to the network a laptop (Centrino WinXP
> SP1 with a preinstalled Intel PRO/Wireless LAN 2100 3B
> Mini PCI Adapter 811.b), I bought a Qtec Wireless adapter
> 802.11g, installed it on one of the desktops (WinXP SP1),
> and configured it as an ad-hoc subnet (with no security to
> start with).
> The WiFi subnet is working (laptop-desktop1), but
> obviously cannot see the Ethernet subnet (desktop1-
> desktop2) and viceversa.
> In more detail: If I use two different ranges (192.168.0.x
> and 169.254.x.y) they coexist separately, whereas if I use
> the same range (169.254.x.y) they conflict because they
> are based on different media (Ethernet-WiFi).
> I therefore started to set up a Windows XP Bridge which is
> supposed to just merge the two subnets into one, but I
> could'nt make it work. The two WiFi cards don't see each
> other across the bridge!
> Although I read a lot of documentation from various
> sources I could'nt find a solution todate.
> Amongst other things I did:
> 1. Force promiscuity mode, as some adapters are not able
> to enter that mode automatically when in the bridge
> (source Microsoft)
> 2. Update driver to the Qtec adapter, as the 802.11g
> standard was finally defined after many adapters were
> already on the market, and interoperability could not be
> guaranteed (source Internet, somewhere)
> 3. Setup a bridge also on the laptop in case the two WiFi
> cards can communicate only if they are both in 'bridge
> mode' (I'm not sure).
> Can somebody help, please?
> Eddy
Anonymous
a b F Wireless
November 16, 2004 9:48:02 AM

Archived from groups: microsoft.public.windows.networking.wireless (More info?)

Sorry for the late follow-up.
I try and clarify the situation in case I have not been able to make it
clear in my previous post.
I have three computers: A (Ethernet adapter and wireless adapter), B
(Ethernet adapter), and C (wireless adapter). A and B are linked with a cross
RJ45 cable (no hub). A and C are linked wireless.
Both subnets work perfectly (they ping each other AND transfer data).
To link them together I have created a WinXP (software) bridge on A,
incluthing the two adapters.
Whereas A and B can communicate through the bridge, A and C cannot (no data,
no ping).
MS Knoledge Base states that this might be due to the wireless adapter
within the bridge not being able to automatically enter promiscuous mode
(layer2), and that this can be worked around by forcing compatibility mode
(layer3).
The above has to be done with the command netsh bridge set a x e (x being
the number of the adapter).
I have done that and checked that compatibility mode has been enabled;
however, A and C still do not communicate under the bridge (they do outside
the bridge).
Is there a way to solve this without having to buy a router or configuring A
to act like a router (I need it for ICS)?
Is the Qtec 54G wireless adapter not compatible with WinXP bridge?
Have I done something wrong?
thanks and regards
Eddy

"Jack" wrote:

> Hi
>
> First keep in mind that there is No WIFI vs. Ethernet.
>
> It is all Ethernet. Wireless is just a replacement to a Wire and the name
> WIFI is the name of the device certification.
>
> If your Wireless works by it self I.e. you can really transfer files via
> wireless between the computers (not just see signal in the utility) you
> should be able to bridge Since you mentioned the 169.x.x. I have the feeling
> that something is not working right and thus you can not Bridge.
>
> The two networks as to be configured along the line of (Example) Wired
> Network 192.168.1.1 and Wireless Network 192.168.2.1 or similar ranges.
>
> Jack (MVP-Networking).
>
>
>
>
>
>
>
> "Eddy Borg" <edelborg@everyday.com> wrote in message
> news:0c1701c4ba97$a32b2bc0$a601280a@phx.gbl...
> > I have a small LAN made of two desktops with Ethernet
> > adapters, linked with a cross cable (no hubs, no routers),
> > which is working fine.
> > In order to add to the network a laptop (Centrino WinXP
> > SP1 with a preinstalled Intel PRO/Wireless LAN 2100 3B
> > Mini PCI Adapter 811.b), I bought a Qtec Wireless adapter
> > 802.11g, installed it on one of the desktops (WinXP SP1),
> > and configured it as an ad-hoc subnet (with no security to
> > start with).
> > The WiFi subnet is working (laptop-desktop1), but
> > obviously cannot see the Ethernet subnet (desktop1-
> > desktop2) and viceversa.
> > In more detail: If I use two different ranges (192.168.0.x
> > and 169.254.x.y) they coexist separately, whereas if I use
> > the same range (169.254.x.y) they conflict because they
> > are based on different media (Ethernet-WiFi).
> > I therefore started to set up a Windows XP Bridge which is
> > supposed to just merge the two subnets into one, but I
> > could'nt make it work. The two WiFi cards don't see each
> > other across the bridge!
> > Although I read a lot of documentation from various
> > sources I could'nt find a solution todate.
> > Amongst other things I did:
> > 1. Force promiscuity mode, as some adapters are not able
> > to enter that mode automatically when in the bridge
> > (source Microsoft)
> > 2. Update driver to the Qtec adapter, as the 802.11g
> > standard was finally defined after many adapters were
> > already on the market, and interoperability could not be
> > guaranteed (source Internet, somewhere)
> > 3. Setup a bridge also on the laptop in case the two WiFi
> > cards can communicate only if they are both in 'bridge
> > mode' (I'm not sure).
> > Can somebody help, please?
> > Eddy
>
>
>
!