Sign in with
Sign up | Sign in
Your question

Remote Assistance not working

Last response: in Windows XP
Share
October 15, 2004 4:53:05 AM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

I am unable to connect via Remote Assistance. The PC initiating the request
is on a LAN behind a NAT Router (A Prolink Hurricane 9000 ADSL
modem/routher). I am running Windows XP SP2 and have made the necessary
exceptions for UPnP and Remote Assistance. On the initiating PC we have
turned off the firewall but still doesn't work. The Router manufacturer
claims that this model is not UPnP capable and suggested enabling port
fowarding to port 3389 which we did and also enabling DMZ which we did but it
still doesn't work. We also tried editing the invitation files but that
didn't work either. We also tried the processw in reverse, the PC on the LAN
can connect to me (I am on a Laptop connect directly to cable broadband) and
we also tried it the original diretcion with the PC on the LAN using a dial
up connection and that worked also so the problem is the NAT router. Any
suggestions ??
Anonymous
October 15, 2004 3:37:07 PM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

"Jeff" <Jeff@discussions.microsoft.com> wrote in message
news:D 413EDDD-DAB1-4D52-8FE5-B02A68F5FC0B@microsoft.com...
>
> I am unable to connect via Remote Assistance. The PC initiating the
> request
> is on a LAN behind a NAT Router (A Prolink Hurricane 9000 ADSL
> modem/routher). I am running Windows XP SP2 and have made the necessary
> exceptions for UPnP and Remote Assistance. On the initiating PC we have
> turned off the firewall but still doesn't work. The Router manufacturer
> claims that this model is not UPnP capable and suggested enabling port
> fowarding to port 3389 which we did and also enabling DMZ which we did but
> it
> still doesn't work.

Correct: forwarding to 3389 or placing the PC in the DMZ is not sufficient
to enable Remote Assistance to work if the requester is behind a NAT router.
Remote Assistance *requires* UPnP support in the NAT router, so as to
discover the WAN IP address to write into the request ticket for the expert
to connect to. If UPnP is present, then Remote Assistance will sort out the
port-forwarding automatically.

> We also tried editing the invitation files but that didn't work either.

Unsure why that did not work for you, if you edited the correct WAN address
in place of the LAN address. But you would also have needed to port-forward
3389 in the NAT router at the same time.

> Any suggestions ??

If you wish to support Remote Assiatnce, scrap the NAT router and replace it
with one that supports UPnP.

--
Robin Walker
rdhw@cam.ac.uk
October 18, 2004 1:25:01 AM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Thanks for the info. I tried one more time using the edit the request file
but still did not work. I set prot forwarding in the router to 3389 and then
got initiating PC to check its public WAn address which was
203.213.206.72:3476. The original request I then received was as follws:

<?xml version="1.0" encoding="Unicode" ?><UPLOADINFO
TYPE="Escalated"><UPLOADDATA USERNAME="Pidge" PROBLEMDESCRIPTION="tt"
RCTICKET="65538,1,0.0.0.0:5001;office:3389;10.0.0.12:3389,UUSTneFBo9eQShq+p7I=,DBtaWGL48V9EOwITcuKIqH03+hqMQCHbk/9s7pNrkcY=,SolicitedHelp,ZETU/JAT8MCjc2iUm6sbOIfS2qZD/EQG1wnf/AKvS/tWmjWYwDnjnw==,2zMWXOJreU0m8dCf701SUFcqT8c="
RCTICKETENCRYPTED="0" DtStart="1098072113" DtLength="60" PassStub="" L="0"
/></UPLOADINFO>

I then editied to the following:

<?xml version="1.0" encoding="Unicode" ?><UPLOADINFO
TYPE="Escalated"><UPLOADDATA USERNAME="Pidge" PROBLEMDESCRIPTION="tt"
RCTICKET="65538,1,203.213.206.72:3389;office:3389;10.0.0.12:3389,UUSTneFBo9eQShq+p7I=,DBtaWGL48V9EOwITcuKIqH03+hqMQCHbk/9s7pNrkcY=,SolicitedHelp,ZETU/JAT8MCjc2iUm6sbOIfS2qZD/EQG1wnf/AKvS/tWmjWYwDnjnw==,2zMWXOJreU0m8dCf701SUFcqT8c="
RCTICKETENCRYPTED="0" DtStart="1098072113" DtLength="60" PassStub="" L="0"
/></UPLOADINFO>

Still did not work. Was my editing wrong ??


"Robin Walker" wrote:

> "Jeff" <Jeff@discussions.microsoft.com> wrote in message
> news:D 413EDDD-DAB1-4D52-8FE5-B02A68F5FC0B@microsoft.com...
> >
> > I am unable to connect via Remote Assistance. The PC initiating the
> > request
> > is on a LAN behind a NAT Router (A Prolink Hurricane 9000 ADSL
> > modem/routher). I am running Windows XP SP2 and have made the necessary
> > exceptions for UPnP and Remote Assistance. On the initiating PC we have
> > turned off the firewall but still doesn't work. The Router manufacturer
> > claims that this model is not UPnP capable and suggested enabling port
> > fowarding to port 3389 which we did and also enabling DMZ which we did but
> > it
> > still doesn't work.
>
> Correct: forwarding to 3389 or placing the PC in the DMZ is not sufficient
> to enable Remote Assistance to work if the requester is behind a NAT router.
> Remote Assistance *requires* UPnP support in the NAT router, so as to
> discover the WAN IP address to write into the request ticket for the expert
> to connect to. If UPnP is present, then Remote Assistance will sort out the
> port-forwarding automatically.
>
> > We also tried editing the invitation files but that didn't work either.
>
> Unsure why that did not work for you, if you edited the correct WAN address
> in place of the LAN address. But you would also have needed to port-forward
> 3389 in the NAT router at the same time.
>
> > Any suggestions ??
>
> If you wish to support Remote Assiatnce, scrap the NAT router and replace it
> with one that supports UPnP.
>
> --
> Robin Walker
> rdhw@cam.ac.uk
>
>
>
Related resources
Anonymous
October 18, 2004 7:29:31 PM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

"Jeff" <Jeff@discussions.microsoft.com> wrote in message
news:3D9FCC75-C5C7-4384-B9CB-019C44890C8E@microsoft.com
>
> I tried one more time using the edit the request
> file but still did not work. I set prot forwarding in the router to
> 3389 and then got initiating PC to check its public WAn address which
> was 203.213.206.72:3476.

Where did 3476 come from? Should it not be 3389?

> The original request I then received was as follows:
>
> <?xml version="1.0" encoding="Unicode" ?><UPLOADINFO
TYPE="Escalated"><UPLOADDATA USERNAME="Pidge" PROBLEMDESCRIPTION="tt"
RCTICKET="65538,1,0.0.0.0:5001;office:3389;10.0.0.12:3389,UUSTneFBo9eQShq+p7I=,DBtaWGL48V9EOwITcuKIqH03+hqMQCHbk/9s7pNrkcY=,SolicitedHelp,ZETU/JAT8MCjc2iUm6sbOIfS2qZD/EQG1wnf/AKvS/tWmjWYwDnjnw==,2zMWXOJreU0m8dCf701SUFcqT8c="
RCTICKETENCRYPTED="0" DtStart="1098072113" DtLength="60" PassStub=""
L="0" /></UPLOADINFO>
>
> I then editied to the following:
>
> <?xml version="1.0" encoding="Unicode" ?><UPLOADINFO
> TYPE="Escalated"><UPLOADDATA USERNAME="Pidge" PROBLEMDESCRIPTION="tt"
> RCTICKET="65538,1,203.213.206.72:3389;office:3389;10.0.0.12:3389,UUSTneFBo9eQShq+p7I=,DBtaWGL48V9EOwITcuKIqH03+hqMQCHbk/9s7pNrkcY=,SolicitedHelp,ZETU/JAT8MCjc2iUm6sbOIfS2qZD/EQG1wnf/AKvS/tWmjWYwDnjnw==,2zMWXOJreU0m8dCf701SUFcqT8c="
> RCTICKETENCRYPTED="0" DtStart="1098072113" DtLength="60" PassStub="" L="0"
> /></UPLOADINFO>
>
> Still did not work. Was my editing wrong ??

Personally, I would have left the :5001 entry alone, and edited one of the
:3389 entries. For instance, change 10.0.0.12 to 203.213.206.72.

Alternatively, if the PC at the Expert end had an entry in its HOSTS file
which translated "office" to 203.213.206.72, then you would not need to edit
the ticket at all. You can only play this game if you have a set of unique
names for your PCs.

--
Robin Walker
rdhw@cam.ac.uk
October 18, 2004 10:15:02 PM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

I tried editing the invite again and left the :5001 entry alone as you
suggested and I substitued the office:3389 entry with the WAN IP address and
it connected and worked fine. Many thanks for your help Robin.

Jeff

"Robin Walker" wrote:

> "Jeff" <Jeff@discussions.microsoft.com> wrote in message
> news:3D9FCC75-C5C7-4384-B9CB-019C44890C8E@microsoft.com
> >
> > I tried one more time using the edit the request
> > file but still did not work. I set prot forwarding in the router to
> > 3389 and then got initiating PC to check its public WAn address which
> > was 203.213.206.72:3476.
>
> Where did 3476 come from? Should it not be 3389?
>
> > The original request I then received was as follows:
> >
> > <?xml version="1.0" encoding="Unicode" ?><UPLOADINFO
> TYPE="Escalated"><UPLOADDATA USERNAME="Pidge" PROBLEMDESCRIPTION="tt"
> RCTICKET="65538,1,0.0.0.0:5001;office:3389;10.0.0.12:3389,UUSTneFBo9eQShq+p7I=,DBtaWGL48V9EOwITcuKIqH03+hqMQCHbk/9s7pNrkcY=,SolicitedHelp,ZETU/JAT8MCjc2iUm6sbOIfS2qZD/EQG1wnf/AKvS/tWmjWYwDnjnw==,2zMWXOJreU0m8dCf701SUFcqT8c="
> RCTICKETENCRYPTED="0" DtStart="1098072113" DtLength="60" PassStub=""
> L="0" /></UPLOADINFO>
> >
> > I then editied to the following:
> >
> > <?xml version="1.0" encoding="Unicode" ?><UPLOADINFO
> > TYPE="Escalated"><UPLOADDATA USERNAME="Pidge" PROBLEMDESCRIPTION="tt"
> > RCTICKET="65538,1,203.213.206.72:3389;office:3389;10.0.0.12:3389,UUSTneFBo9eQShq+p7I=,DBtaWGL48V9EOwITcuKIqH03+hqMQCHbk/9s7pNrkcY=,SolicitedHelp,ZETU/JAT8MCjc2iUm6sbOIfS2qZD/EQG1wnf/AKvS/tWmjWYwDnjnw==,2zMWXOJreU0m8dCf701SUFcqT8c="
> > RCTICKETENCRYPTED="0" DtStart="1098072113" DtLength="60" PassStub="" L="0"
> > /></UPLOADINFO>
> >
> > Still did not work. Was my editing wrong ??
>
> Personally, I would have left the :5001 entry alone, and edited one of the
> :3389 entries. For instance, change 10.0.0.12 to 203.213.206.72.
>
> Alternatively, if the PC at the Expert end had an entry in its HOSTS file
> which translated "office" to 203.213.206.72, then you would not need to edit
> the ticket at all. You can only play this game if you have a set of unique
> names for your PCs.
>
> --
> Robin Walker
> rdhw@cam.ac.uk
>
>
>
!