Sign in with
Sign up | Sign in
Your question

XP Pro not allowing Remote Desktop Connect after VOIP Rout..

Last response: in Windows XP
Share
Anonymous
October 22, 2004 12:33:01 AM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

I have a DSL line pushing a static IP address through a switch to my office
where it goes through a VOIP router (Linksys RT41P2) Internet jack, then into
and out of ethernet jacks on a wireless router (Linksys BEFW11S4) and finally
to my XP Pro machine. Prior to installing the VOIP router, I was able to
access this machine flawlessly via Remote Desktop Connection on various other
machines. The VOIP router is set up for the static IP address, and the
wireless one is set to obtain automatically. Since Linksys had me go through
the Ethernet jacks on the wireless router, I can't see or access its control
panel any longer. So, Linksys als had me go into the TCP/IP internet protocol
window and set it to "Use the following IP address," which corresponds to the
internal IP address of the VOIP router. They now say that the problem lies
within the Remote Desktop configuration, however I don't know what can be
adjusted there. Does anyone see where I'm going wrong?
Anonymous
October 22, 2004 6:33:12 PM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

"Gadget1969" <Gadget1969@discussions.microsoft.com> wrote in message
news:FD0E9161-5423-4FA2-BBB8-F8604D417E35@microsoft.com
> I have a DSL line pushing a static IP address through a switch to my
> office where it goes through a VOIP router (Linksys RT41P2) Internet
> jack, then into and out of ethernet jacks on a wireless router
> (Linksys BEFW11S4) and finally to my XP Pro machine. Prior to
> installing the VOIP router, I was able to access this machine
> flawlessly via Remote Desktop Connection on various other machines.
> The VOIP router is set up for the static IP address, and the wireless
> one is set to obtain automatically.

Your problem is that you now have two layers of Network Address Translation
(NAT), one in the VoIP router, and one in the BEFW11S4. Incoming calls such
as Remote Desktop now have to negotiate both NAT routers, which would
require you to configure port-forwards in both routers for TCP port 3389.

You will also have difficulties if both routers assume that they can use the
same IP range on their LAN side (such as 192.168.1.xxx): you will have to
reconfigure one router to avoid the LAN range of the other. For instance,
you could reconfigure one of them to use 192.168.5.xxx, and leave the other
on 192.168.1.xxx.

Unfortunately, having two layers of NAT will prevent any applications that
rely on UPnP functionality in the router from working correctly.

I recommend that you dispose of the BEFW11S4, and just use a Wireless Access
Point plugged in to one of the LAN sockets of the RT41P2 (or is it RT31P2?).
One router is enough for any home situation, and if you want VoIP, then it
has to be that one.

It is possible to reconfigure the BEFW11S4 to act as a Wireless Access Point
instead of a router. To do this, in the BEFW11S4, you need to disable UPnP,
disable DHCP server, and then connect the outer world to a LAN port of the
BEFW11S4 with a cross-over ethernet cable, and leave the WAN port
unconnected.

> So, Linksys als had me go into the TCP/IP
> internet protocol window and set it to "Use the following IP
> address," which corresponds to the internal IP address of the VOIP router.

That makes no sense at all: I suggest you revert to setting an IP address
that lies within the LAN range of the router that the PC is connected to.
For instance, with the default Linksys allocation of 192.168.1.xxx, you can
use any static IP address in the range 192.168.1.2 to 192.168.1.99: one
unique address per client. Then you can configure TCP port 3389 to forward
to the desired local static address.

--
Robin Walker
rdhw@cam.ac.uk
Anonymous
February 8, 2005 12:03:06 PM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

I had the same problem with a similar configuration and this worked for me:

In the Port Range Forwarding section of the Applications
& Gaming menu:

Port Range
Application Start End Protocol IP Address Enable
RDT 3389 3389 TCPUDPBoth 192.168.15.100 <check>
RDT 80 80 TCPUDPBoth 192.168.15.100 <check>

Good luck.


"Gadget1969" wrote:

> I have a DSL line pushing a static IP address through a switch to my office
> where it goes through a VOIP router (Linksys RT41P2) Internet jack, then into
> and out of ethernet jacks on a wireless router (Linksys BEFW11S4) and finally
> to my XP Pro machine. Prior to installing the VOIP router, I was able to
> access this machine flawlessly via Remote Desktop Connection on various other
> machines. The VOIP router is set up for the static IP address, and the
> wireless one is set to obtain automatically. Since Linksys had me go through
> the Ethernet jacks on the wireless router, I can't see or access its control
> panel any longer. So, Linksys als had me go into the TCP/IP internet protocol
> window and set it to "Use the following IP address," which corresponds to the
> internal IP address of the VOIP router. They now say that the problem lies
> within the Remote Desktop configuration, however I don't know what can be
> adjusted there. Does anyone see where I'm going wrong?
!