Wake On Lan problem

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

looking for some suggestions to troubleshoot the Wake-On-Lan feature that
I am trying to use. Here are some specs and what I have done so far.

mobo is a Gigabyte 8INXP

I'm on a home network with a linksys wireless B router (although I plan
to use this from outside this network (obviously)).

machine that I am trying to turn on is hardwired with a static ip of
192.68.1.2


I have made sure the option is on in the bios

I have redirected port 9 (UDP) to my static connection, on the router.

I have opened the same port in Windows firewall (although I don't know if
this was really needed).

I have used the right MAC address (optained through running 'ipconfig.exe
/all' on the computer I am trying to wake).

This is where I got the Wake-On-Lan GUI that I am using;
'http://www.depicus.com/wake-on-lan/wake-on-lan-gui.asp'

I've tried to wake it up on both the subnet and the internet setting;
I'm assuming that the subnet will be used for when I am inside my home on
the network and internet whan I am not.


The only thing that I can think of is a connection on the motherboard
that I do not have. I had read somewhere about needing a power
connecter, but the LAN connection is onboard with this mobo, so I didn't
think that that would apply. Am I wrong.

Any help or suggestions would be appreciated.

Thx,

Andrew
5 answers Last reply
More about wake problem
  1. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    "A" <F@Chance.com> wrote in message
    news:Xns96F9D6D151D0FChancecom@64.59.144.76
    > looking for some suggestions to troubleshoot the Wake-On-Lan feature
    > that I am trying to use. Here are some specs and what I have done so
    > far.
    >
    > mobo is a Gigabyte 8INXP
    > [snip]
    > I have redirected port 9 (UDP) to my static connection, on the router.

    First, you need to ascertain whether your PC actually supports Wake-on-LAN.
    If it doesn't, then no amount of configuration and sending of magic packets
    will make it work. This depends on both the ethernet interface and the
    motherboard.

    Second, you can't forward to your static IP address on the LAN, because when
    your PC is asleep, that IP address does not exist, and your PC will not
    respond to ARP requests for that address, so the router will never pass on
    the magic packet. You neded to configure the router to forward port 9 to a
    LAN broadcast address (usually subnet.255), so that the magic packet goes
    everywhere on the LAN without the need for something to respond to an ARP.

    Third, you need to ensure that the Device Properties, Power Management tab,
    of your ethernet card are set to "Allow this device to bring the computer
    out of standby".

    There might also be Wake-on-LAN options to configure on the Advanced tab of
    the Device Properties.

    --
    Robin Walker
    rdhw@cam.ac.uk
  2. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Thanks Robin, I really appreciate the help. I think I'm alomost there,
    but I'm a little confused about one thing.

    Firstly, I am almost positive that the ethernet interface supports WOL
    and I know the mobo does because I have read the specs and turned the
    feature on in the bios.

    The option to allow the network adapter to power on the computer has been
    checked and there are WOL settings (currently set to 'wake on Magic
    Packet'.

    This leads me to believe that the port forwarding is my problem. This is
    where I'm a little confused.

    When I go to the 'Forwarding' tab in my linksys router settings, it seems
    that I only have the option of forwarding to an IP. They even go as far
    as to fill in the first 3 sections of the IP address for me
    (unchangable). So, when I tell it to forward port 9, the only
    information that it seems I can fill in is the .2. That is to say, the
    168.192.1.__ is already there and I just fill in the blank with the
    machine that I want to forward to.

    If it is not to complex and you are familiar with the settings of a
    Linksys router, I would greatly appreciate it if you could explain how I
    forward to a subnet. Is this something that I can just do with the WOL
    GUI that I am using, or does it definately have to be an adjustment made
    to the router settings?

    I'm working remotely right now, so my troubleshooting methods are
    limited, but I plan to put the machine in the DMZ to see if that at least
    gets me around the problem temporarily; until I figure out how to
    accomplish what you have suggested.

    Best regards,

    Andrew


    "Robin Walker" <rdhw@cam.ac.uk> wrote in
    news:clmig6$hba$1@gemini.csx.cam.ac.uk:

    > "A" <F@Chance.com> wrote in message
    > news:Xns96F9D6D151D0FChancecom@64.59.144.76
    >> looking for some suggestions to troubleshoot the Wake-On-Lan feature
    >> that I am trying to use. Here are some specs and what I have done so
    >> far.
    >>
    >> mobo is a Gigabyte 8INXP
    >> [snip]
    >> I have redirected port 9 (UDP) to my static connection, on the
    >> router.
    >
    > First, you need to ascertain whether your PC actually supports
    > Wake-on-LAN. If it doesn't, then no amount of configuration and
    > sending of magic packets will make it work. This depends on both the
    > ethernet interface and the motherboard.
    >
    > Second, you can't forward to your static IP address on the LAN,
    > because when your PC is asleep, that IP address does not exist, and
    > your PC will not respond to ARP requests for that address, so the
    > router will never pass on the magic packet. You neded to configure
    > the router to forward port 9 to a LAN broadcast address (usually
    > subnet.255), so that the magic packet goes everywhere on the LAN
    > without the need for something to respond to an ARP.
    >
    > Third, you need to ensure that the Device Properties, Power Management
    > tab, of your ethernet card are set to "Allow this device to bring the
    > computer out of standby".
    >
    > There might also be Wake-on-LAN options to configure on the Advanced
    > tab of the Device Properties.
    >
  3. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    "A" <F@Chance.com> wrote in message
    news:Xns96FADFA2284D4FChancecom@64.59.144.76
    >
    > When I go to the 'Forwarding' tab in my linksys router settings, it
    > seems that I only have the option of forwarding to an IP. They even
    > go as far as to fill in the first 3 sections of the IP address for me
    > (unchangable). So, when I tell it to forward port 9, the only
    > information that it seems I can fill in is the .2. That is to say,
    > the 168.192.1.__ is already there and I just fill in the blank with
    > the machine that I want to forward to.
    >
    > If it is not to complex and you are familiar with the settings of a
    > Linksys router, I would greatly appreciate it if you could explain
    > how I forward to a subnet.

    You should configure it to forward to 192.168.1.255. The 255 is the sub-net
    broadcast address. The important thing to remember is that while your PC is
    in Standby, its IP address does not exist, so it is meaningless to forward
    to that IP address. Broadcasting the magic packet is the only way to get it
    delivered. Since the magic packet data contains the MAC address of the
    desired system, only that system will respond to the magic packet.

    Because the magic packet arrives while the PC is in standby, there is no
    need to open up any software firewall in the PC, because when the PC is in
    standby, the firewall is irrelevant: the magic packet is acted on by the
    ethernet card hardware.

    > does it definately have to be an
    > adjustment made to the router settings?

    Yes, you have to configure the router to forward the magic packet to the
    LAN's sub-net broadcast address.

    --
    Robin Walker
    rdhw@cam.ac.uk
  4. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    awesome! I'll give that a shot when I get home from work tonight and let
    you know how it goes. My confusion stemmed from thinking that the subnet
    address had to be 255.255.255.0, but now I think I have a handle on things.
    This means that simply changing the MAC address to that of another machine
    on the network will allow more than one to have this service; that's
    wonderful.

    Thanks again Robin,

    Regards,

    Andrew
  5. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    well; a few weeks later I finally get it working. Problem was the static
    IP that I had assigned that machine on the network; this has caused a lot
    of different problems for quite some time now and will be the topic of
    another post.

    Thanks again for the help.

    Andrew
Ask a new question

Read More

LAN Windows XP