Sign in with
Sign up | Sign in
Your question

The client could not connect to the remote computer

Last response: in Windows XP
Share
Anonymous
October 31, 2004 2:33:03 PM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

My end goal is to be able to access files from my office computer (which is
in my home) while I'm at a clients office. My office has dynamic IP
(unfortunately), but the IP hasn't changed in months.

I've followed all the directions about setting up my main computer to
receive RD. I AM able to connect to my second office computer from computer
1, but I cannot go from computer 2 to computer 1. I've even connected to a
clients computer from computer 2, then tried to use the IP address to connect
to my main computer through RD, but still get the same error about "The
client could not connect to the remote computer".

I have Windows Firewall on as well, with allowing the Remote Desktop
exception, checked.

Running XPPRO SP2 on both computers. Linksys WRT54G router (both computers
are hard-wired to it).

Am I missing something? Do I need to make sure that certain ports are open
somewhere?

Pulling hair...thanks for your help!
October 31, 2004 5:46:02 PM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

I have the same problem. The initial internet page opens fine to input the RD
Web Connection server info, but can never connect.
Have you in Network Connections in properties for your modem gone to
Networking|TCP/IP Properties|Advanced|WINS and typed in the network address
of your office PC?
Keep me posted if you crack it!
Simon

"curly101" wrote:

> My end goal is to be able to access files from my office computer (which is
> in my home) while I'm at a clients office. My office has dynamic IP
> (unfortunately), but the IP hasn't changed in months.
>
> I've followed all the directions about setting up my main computer to
> receive RD. I AM able to connect to my second office computer from computer
> 1, but I cannot go from computer 2 to computer 1. I've even connected to a
> clients computer from computer 2, then tried to use the IP address to connect
> to my main computer through RD, but still get the same error about "The
> client could not connect to the remote computer".
>
> I have Windows Firewall on as well, with allowing the Remote Desktop
> exception, checked.
>
> Running XPPRO SP2 on both computers. Linksys WRT54G router (both computers
> are hard-wired to it).
>
> Am I missing something? Do I need to make sure that certain ports are open
> somewhere?
>
> Pulling hair...thanks for your help!
Anonymous
November 1, 2004 5:30:03 AM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Main computer, 2d computer, office computer, 2d office computer, computer 1,
computer 2, etc. Very confusing.
When I connect to my Home (XP Pro) computer I simply click on "My network
Places" to connect to any shared files on any computer on my home network.
There are other ways to do this, but it works.
"curly101" wrote:

> My end goal is to be able to access files from my office computer (which is
> in my home) while I'm at a clients office. My office has dynamic IP
> (unfortunately), but the IP hasn't changed in months.
>
> I've followed all the directions about setting up my main computer to
> receive RD. I AM able to connect to my second office computer from computer
> 1, but I cannot go from computer 2 to computer 1. I've even connected to a
> clients computer from computer 2, then tried to use the IP address to connect
> to my main computer through RD, but still get the same error about "The
> client could not connect to the remote computer".
>
> I have Windows Firewall on as well, with allowing the Remote Desktop
> exception, checked.
>
> Running XPPRO SP2 on both computers. Linksys WRT54G router (both computers
> are hard-wired to it).
>
> Am I missing something? Do I need to make sure that certain ports are open
> somewhere?
>
> Pulling hair...thanks for your help!
Related resources
Anonymous
November 1, 2004 6:02:01 AM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Remote desktop works with port number 3389. Be sure when you go outside to
open this port for RDP traffic for the incoming traffic. Initiated traffic is
always allowed but incoming traffic needs to be allowed (create rule)

If you are connecting from computer1 to computer2 this works fine. When you
go the other way around this doesn't work. Have you also checked the checkbox
in system properties remote TAB which allows remote desktop connections and
did you add a user which you use to connect?

When you are connecting to the office by WAN it is best to create a secure
VPN. Get an assigned IP-adress/name resolution adress (DNS) from the dial-in
server.


"Simon" wrote:

> I have the same problem. The initial internet page opens fine to input the RD
> Web Connection server info, but can never connect.
> Have you in Network Connections in properties for your modem gone to
> Networking|TCP/IP Properties|Advanced|WINS and typed in the network address
> of your office PC?
> Keep me posted if you crack it!
> Simon
>
> "curly101" wrote:
>
> > My end goal is to be able to access files from my office computer (which is
> > in my home) while I'm at a clients office. My office has dynamic IP
> > (unfortunately), but the IP hasn't changed in months.
> >
> > I've followed all the directions about setting up my main computer to
> > receive RD. I AM able to connect to my second office computer from computer
> > 1, but I cannot go from computer 2 to computer 1. I've even connected to a
> > clients computer from computer 2, then tried to use the IP address to connect
> > to my main computer through RD, but still get the same error about "The
> > client could not connect to the remote computer".
> >
> > I have Windows Firewall on as well, with allowing the Remote Desktop
> > exception, checked.
> >
> > Running XPPRO SP2 on both computers. Linksys WRT54G router (both computers
> > are hard-wired to it).
> >
> > Am I missing something? Do I need to make sure that certain ports are open
> > somewhere?
> >
> > Pulling hair...thanks for your help!
November 1, 2004 7:49:02 AM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Thanks for that. Yes, I've definitely got 3389 open and RDC marked on both PCs,

My laptop (Xp Home SP2) is the one I want to make the connection from
remotely and my office PC (Xp Pro, SP1) is the one I want to be able to
connect into. When my laptop is physically connected to the LAN by ethernet
the Remote Desktop Web Connection works fine. When I disconnect my laptop
from the LAN, go someplace and use its modem to dial-up the internet, I do
still get the internet RDC page up on the screen alright, but when I type in
my server name (i.e. the name of my office PC - I just type in its name
right?, not the IP address of its network card which is 192.168.0.xxx) there
is no connection.

The office LAN uses a Netgear router/gateway so we are not using Microsoft
Internet Connection Sharing, everything goes through the router whose IP
address is different from the Office PC's network card IP address. I have the
router configured to "Always Allow" incoming and outgoing RD requests on port
3389. I have the laptop's modem TCP/IP WINS tab configured with the IP
address of the Office PC's network card address.

Very grateful for your help - I'm off on an extended trip Friday so really
hoping I can crack it by then (but don't delay in replying just cos I told
you!!).


"h@@STER" wrote:

> Remote desktop works with port number 3389. Be sure when you go outside to
> open this port for RDP traffic for the incoming traffic. Initiated traffic is
> always allowed but incoming traffic needs to be allowed (create rule)
>
> If you are connecting from computer1 to computer2 this works fine. When you
> go the other way around this doesn't work. Have you also checked the checkbox
> in system properties remote TAB which allows remote desktop connections and
> did you add a user which you use to connect?
>
> When you are connecting to the office by WAN it is best to create a secure
> VPN. Get an assigned IP-adress/name resolution adress (DNS) from the dial-in
> server.
>
>
> "Simon" wrote:
>
> > I have the same problem. The initial internet page opens fine to input the RD
> > Web Connection server info, but can never connect.
> > Have you in Network Connections in properties for your modem gone to
> > Networking|TCP/IP Properties|Advanced|WINS and typed in the network address
> > of your office PC?
> > Keep me posted if you crack it!
> > Simon
> >
> > "curly101" wrote:
> >
> > > My end goal is to be able to access files from my office computer (which is
> > > in my home) while I'm at a clients office. My office has dynamic IP
> > > (unfortunately), but the IP hasn't changed in months.
> > >
> > > I've followed all the directions about setting up my main computer to
> > > receive RD. I AM able to connect to my second office computer from computer
> > > 1, but I cannot go from computer 2 to computer 1. I've even connected to a
> > > clients computer from computer 2, then tried to use the IP address to connect
> > > to my main computer through RD, but still get the same error about "The
> > > client could not connect to the remote computer".
> > >
> > > I have Windows Firewall on as well, with allowing the Remote Desktop
> > > exception, checked.
> > >
> > > Running XPPRO SP2 on both computers. Linksys WRT54G router (both computers
> > > are hard-wired to it).
> > >
> > > Am I missing something? Do I need to make sure that certain ports are open
> > > somewhere?
> > >
> > > Pulling hair...thanks for your help!
November 1, 2004 7:49:02 AM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Thanks for that. Yes, I've definitely got 3389 open and RDC marked on both PCs,

My laptop (Xp Home SP2) is the one I want to make the connection from
remotely and my office PC (Xp Pro, SP1) is the one I want to be able to
connect into. When my laptop is physically connected to the LAN by ethernet
the Remote Desktop Web Connection works fine. When I disconnect my laptop
from the LAN, go someplace and use its modem to dial-up the internet, I do
still get the internet RDC page up on the screen alright, but when I type in
my server name (i.e. the name of my office PC - I just type in its name
right?, not the IP address of its network card which is 192.168.0.xxx) there
is no connection.

The office LAN uses a Netgear router/gateway so we are not using Microsoft
Internet Connection Sharing, everything goes through the router whose IP
address is different from the Office PC's network card IP address. I have the
router configured to "Always Allow" incoming and outgoing RD requests on port
3389. I have the laptop's modem TCP/IP WINS tab configured with the IP
address of the Office PC's network card address.

Very grateful for your help - I'm off on an extended trip Friday so really
hoping I can crack it by then (but don't delay in replying just cos I told
you!!).


"h@@STER" wrote:

> Remote desktop works with port number 3389. Be sure when you go outside to
> open this port for RDP traffic for the incoming traffic. Initiated traffic is
> always allowed but incoming traffic needs to be allowed (create rule)
>
> If you are connecting from computer1 to computer2 this works fine. When you
> go the other way around this doesn't work. Have you also checked the checkbox
> in system properties remote TAB which allows remote desktop connections and
> did you add a user which you use to connect?
>
> When you are connecting to the office by WAN it is best to create a secure
> VPN. Get an assigned IP-adress/name resolution adress (DNS) from the dial-in
> server.
>
>
> "Simon" wrote:
>
> > I have the same problem. The initial internet page opens fine to input the RD
> > Web Connection server info, but can never connect.
> > Have you in Network Connections in properties for your modem gone to
> > Networking|TCP/IP Properties|Advanced|WINS and typed in the network address
> > of your office PC?
> > Keep me posted if you crack it!
> > Simon
> >
> > "curly101" wrote:
> >
> > > My end goal is to be able to access files from my office computer (which is
> > > in my home) while I'm at a clients office. My office has dynamic IP
> > > (unfortunately), but the IP hasn't changed in months.
> > >
> > > I've followed all the directions about setting up my main computer to
> > > receive RD. I AM able to connect to my second office computer from computer
> > > 1, but I cannot go from computer 2 to computer 1. I've even connected to a
> > > clients computer from computer 2, then tried to use the IP address to connect
> > > to my main computer through RD, but still get the same error about "The
> > > client could not connect to the remote computer".
> > >
> > > I have Windows Firewall on as well, with allowing the Remote Desktop
> > > exception, checked.
> > >
> > > Running XPPRO SP2 on both computers. Linksys WRT54G router (both computers
> > > are hard-wired to it).
> > >
> > > Am I missing something? Do I need to make sure that certain ports are open
> > > somewhere?
> > >
> > > Pulling hair...thanks for your help!
November 1, 2004 7:49:03 AM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Thanks for that. Yes, I've definitely got 3389 open and RDC marked on both PCs,

My laptop (Xp Home SP2) is the one I want to make the connection from
remotely and my office PC (Xp Pro, SP1) is the one I want to be able to
connect into. When my laptop is physically connected to the LAN by ethernet
the Remote Desktop Web Connection works fine. When I disconnect my laptop
from the LAN, go someplace and use its modem to dial-up the internet, I do
still get the internet RDC page up on the screen alright, but when I type in
my server name (i.e. the name of my office PC - I just type in its name
right?, not the IP address of its network card which is 192.168.0.xxx) there
is no connection.

The office LAN uses a Netgear router/gateway so we are not using Microsoft
Internet Connection Sharing, everything goes through the router whose IP
address is different from the Office PC's network card IP address. I have the
router configured to "Always Allow" incoming and outgoing RD requests on port
3389. I have the laptop's modem TCP/IP WINS tab configured with the IP
address of the Office PC's network card address.

Very grateful for your help - I'm off on an extended trip Friday so really
hoping I can crack it by then (but don't delay in replying just cos I told
you!!).



"h@@STER" wrote:

> Remote desktop works with port number 3389. Be sure when you go outside to
> open this port for RDP traffic for the incoming traffic. Initiated traffic is
> always allowed but incoming traffic needs to be allowed (create rule)
>
> If you are connecting from computer1 to computer2 this works fine. When you
> go the other way around this doesn't work. Have you also checked the checkbox
> in system properties remote TAB which allows remote desktop connections and
> did you add a user which you use to connect?
>
> When you are connecting to the office by WAN it is best to create a secure
> VPN. Get an assigned IP-adress/name resolution adress (DNS) from the dial-in
> server.
>
>
> "Simon" wrote:
>
> > I have the same problem. The initial internet page opens fine to input the RD
> > Web Connection server info, but can never connect.
> > Have you in Network Connections in properties for your modem gone to
> > Networking|TCP/IP Properties|Advanced|WINS and typed in the network address
> > of your office PC?
> > Keep me posted if you crack it!
> > Simon
> >
> > "curly101" wrote:
> >
> > > My end goal is to be able to access files from my office computer (which is
> > > in my home) while I'm at a clients office. My office has dynamic IP
> > > (unfortunately), but the IP hasn't changed in months.
> > >
> > > I've followed all the directions about setting up my main computer to
> > > receive RD. I AM able to connect to my second office computer from computer
> > > 1, but I cannot go from computer 2 to computer 1. I've even connected to a
> > > clients computer from computer 2, then tried to use the IP address to connect
> > > to my main computer through RD, but still get the same error about "The
> > > client could not connect to the remote computer".
> > >
> > > I have Windows Firewall on as well, with allowing the Remote Desktop
> > > exception, checked.
> > >
> > > Running XPPRO SP2 on both computers. Linksys WRT54G router (both computers
> > > are hard-wired to it).
> > >
> > > Am I missing something? Do I need to make sure that certain ports are open
> > > somewhere?
> > >
> > > Pulling hair...thanks for your help!
November 1, 2004 7:49:05 AM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Thanks for that. Yes, I've definitely got 3389 open and RDC marked on both PCs,

My laptop (Xp Home SP2) is the one I want to make the connection from
remotely and my office PC (Xp Pro, SP1) is the one I want to be able to
connect into. When my laptop is physically connected to the LAN by ethernet
the Remote Desktop Web Connection works fine. When I disconnect my laptop
from the LAN, go someplace and use its modem to dial-up the internet, I do
still get the internet RDC page up on the screen alright, but when I type in
my server name (i.e. the name of my office PC - I just type in its name
right?, not the IP address of its network card which is 192.168.0.xxx) there
is no connection.

The office LAN uses a Netgear router/gateway so we are not using Microsoft
Internet Connection Sharing, everything goes through the router whose IP
address is different from the Office PC's network card IP address. I have the
router configured to "Always Allow" incoming and outgoing RD requests on port
3389. I have the laptop's modem TCP/IP WINS tab configured with the IP
address of the Office PC's network card address.

Very grateful for your help - I'm off on an extended trip Friday so really
hoping I can crack it by then (but don't delay in replying just cos I told
you!!).


"h@@STER" wrote:

> Remote desktop works with port number 3389. Be sure when you go outside to
> open this port for RDP traffic for the incoming traffic. Initiated traffic is
> always allowed but incoming traffic needs to be allowed (create rule)
>
> If you are connecting from computer1 to computer2 this works fine. When you
> go the other way around this doesn't work. Have you also checked the checkbox
> in system properties remote TAB which allows remote desktop connections and
> did you add a user which you use to connect?
>
> When you are connecting to the office by WAN it is best to create a secure
> VPN. Get an assigned IP-adress/name resolution adress (DNS) from the dial-in
> server.
>
>
> "Simon" wrote:
>
> > I have the same problem. The initial internet page opens fine to input the RD
> > Web Connection server info, but can never connect.
> > Have you in Network Connections in properties for your modem gone to
> > Networking|TCP/IP Properties|Advanced|WINS and typed in the network address
> > of your office PC?
> > Keep me posted if you crack it!
> > Simon
> >
> > "curly101" wrote:
> >
> > > My end goal is to be able to access files from my office computer (which is
> > > in my home) while I'm at a clients office. My office has dynamic IP
> > > (unfortunately), but the IP hasn't changed in months.
> > >
> > > I've followed all the directions about setting up my main computer to
> > > receive RD. I AM able to connect to my second office computer from computer
> > > 1, but I cannot go from computer 2 to computer 1. I've even connected to a
> > > clients computer from computer 2, then tried to use the IP address to connect
> > > to my main computer through RD, but still get the same error about "The
> > > client could not connect to the remote computer".
> > >
> > > I have Windows Firewall on as well, with allowing the Remote Desktop
> > > exception, checked.
> > >
> > > Running XPPRO SP2 on both computers. Linksys WRT54G router (both computers
> > > are hard-wired to it).
> > >
> > > Am I missing something? Do I need to make sure that certain ports are open
> > > somewhere?
> > >
> > > Pulling hair...thanks for your help!
Anonymous
November 1, 2004 2:25:04 PM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

The fact that you can connect to the other PC proofs that your remote desktop
connection is working fine. The only difference with working remote is that
when you connect from a remote location you have to pass the office router
and instead of a NIC you are using a dial-in modem (?).

I also do some remote administration for a small company for whom i
installed their network. I am using a cable connection. When i use the
default remote desktop client i type the external IP-adress of their
ADSL-modem or the FQDN of the internal server. On this modem port 3389 (and
port 80 for TSWEB) is open. Behind that there is a ISA firewall which allows
traffic from the external IP-adress of the FW to the LAN and forwards that
traffic to a member server from which i can connect to other machines on the
LAN by means of RDC.

If you want to use the name of the machine you should edit your host file
and insert the FQDN (i.e. computer.network.nl) and the external IP of the
ROUTER. Setting WINS to use the internal IP will never work (it is a private
IP adres!!!). So figure out the DNS domain name of the internal LAN and the
external IP of the router. Second the internal computer is XP Pro and
therefore can never be a WINS server!!!

Good luck on cracking the problem and enjoy your stay

What IP-settings
"Simon" wrote:

> Thanks for that. Yes, I've definitely got 3389 open and RDC marked on both PCs,
>
> My laptop (Xp Home SP2) is the one I want to make the connection from
> remotely and my office PC (Xp Pro, SP1) is the one I want to be able to
> connect into. When my laptop is physically connected to the LAN by ethernet
> the Remote Desktop Web Connection works fine. When I disconnect my laptop
> from the LAN, go someplace and use its modem to dial-up the internet, I do
> still get the internet RDC page up on the screen alright, but when I type in
> my server name (i.e. the name of my office PC - I just type in its name
> right?, not the IP address of its network card which is 192.168.0.xxx) there
> is no connection.
>
> The office LAN uses a Netgear router/gateway so we are not using Microsoft
> Internet Connection Sharing, everything goes through the router whose IP
> address is different from the Office PC's network card IP address. I have the
> router configured to "Always Allow" incoming and outgoing RD requests on port
> 3389. I have the laptop's modem TCP/IP WINS tab configured with the IP
> address of the Office PC's network card address.
>
> Very grateful for your help - I'm off on an extended trip Friday so really
> hoping I can crack it by then (but don't delay in replying just cos I told
> you!!).
>
>
>
> "h@@STER" wrote:
>
> > Remote desktop works with port number 3389. Be sure when you go outside to
> > open this port for RDP traffic for the incoming traffic. Initiated traffic is
> > always allowed but incoming traffic needs to be allowed (create rule)
> >
> > If you are connecting from computer1 to computer2 this works fine. When you
> > go the other way around this doesn't work. Have you also checked the checkbox
> > in system properties remote TAB which allows remote desktop connections and
> > did you add a user which you use to connect?
> >
> > When you are connecting to the office by WAN it is best to create a secure
> > VPN. Get an assigned IP-adress/name resolution adress (DNS) from the dial-in
> > server.
> >
> >
> > "Simon" wrote:
> >
> > > I have the same problem. The initial internet page opens fine to input the RD
> > > Web Connection server info, but can never connect.
> > > Have you in Network Connections in properties for your modem gone to
> > > Networking|TCP/IP Properties|Advanced|WINS and typed in the network address
> > > of your office PC?
> > > Keep me posted if you crack it!
> > > Simon
> > >
> > > "curly101" wrote:
> > >
> > > > My end goal is to be able to access files from my office computer (which is
> > > > in my home) while I'm at a clients office. My office has dynamic IP
> > > > (unfortunately), but the IP hasn't changed in months.
> > > >
> > > > I've followed all the directions about setting up my main computer to
> > > > receive RD. I AM able to connect to my second office computer from computer
> > > > 1, but I cannot go from computer 2 to computer 1. I've even connected to a
> > > > clients computer from computer 2, then tried to use the IP address to connect
> > > > to my main computer through RD, but still get the same error about "The
> > > > client could not connect to the remote computer".
> > > >
> > > > I have Windows Firewall on as well, with allowing the Remote Desktop
> > > > exception, checked.
> > > >
> > > > Running XPPRO SP2 on both computers. Linksys WRT54G router (both computers
> > > > are hard-wired to it).
> > > >
> > > > Am I missing something? Do I need to make sure that certain ports are open
> > > > somewhere?
> > > >
> > > > Pulling hair...thanks for your help!
Anonymous
November 1, 2004 4:56:13 PM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

"Simon" <Simon@discussions.microsoft.com> wrote in message
news:9BF5B570-EEEA-4A61-9FE9-8403329E2E3A@microsoft.com
>
> Thanks for that. Yes, I've definitely got 3389 open and RDC marked on
> both PCs

You only need RDP enabled and port 3389 opened on the server PC (XP Pro).
Settings on the client are not needed.

> My laptop (Xp Home SP2) is the one I want to make the connection from
> remotely and my office PC (Xp Pro, SP1) is the one I want to be able
> to connect into. When my laptop is physically connected to the LAN by
> ethernet the Remote Desktop Web Connection works fine. When I
> disconnect my laptop
> from the LAN, go someplace and use its modem to dial-up the internet,
> I do still get the internet RDC page up on the screen alright, but
> when I type in my server name (i.e. the name of my office PC - I just
> type in its name right?, not the IP address of its network card which
> is 192.168.0.xxx) there is no connection.

No, you cannot use its name, and you cannot (on the outside internet) use
its internal LAN address 192.168.0.xxx. You must use the WAN IP address of
your home router.

Only in your home LAN can you use the 192.168.xxx.xxx address of the RDP
server.

> The office LAN uses a Netgear router/gateway so we are not using
> Microsoft Internet Connection Sharing, everything goes through the
> router whose IP address is different from the Office PC's network
> card IP address. I have the router configured to "Always Allow"
> incoming and outgoing RD requests on port 3389.

That's not enough: in the router you need to port-forward TCP port 3389 to
the local LAN address of the RDP server PC. This PC should therefore be
assigned a fixed LAN IP address within the subnet of the router, but outside
its DHCP allocation pool, so that the port-forward will remain meaningful
for ever. If your XP Pro PC has a DHCP-assigned address, it could change,
and the port-forward would become invalid.

> I have the laptop's
> modem TCP/IP WINS tab configured with the IP address of the Office
> PC's network card address.

This appears to be an error, and of no possible use in the RDP context.
Remove the setting. You cannot use local LAN IP addresses (192.168.xxx.xxx)
in the broader internet anyway.

--
Robin Walker
rdhw@cam.ac.uk
November 2, 2004 8:31:02 AM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Thanks Robin, I feel I an making progress.

In my router configuration I have:
Use router as DHCP server
Starting IP Address 192.168.0.2
Ending IP Address 192.168.0.51

There is a further section titled "Reserved IP Table" with these notes:
<<<Reserved IP Table
When you specify a reserved IP address for a PC on the LAN, that PC will
always receive the same IP address each time it access the DHCP server.
Reserved IP addresses should be assigned to servers that require permanent IP
settings.

To reserve an IP address:

Click the Add button.
In the IP Address box, type the IP address to assign to the PC or server.
(choose an IP address from the router’s LAN subnet, such as 192.168.0.X)
Type the MAC Address of the PC or server.
(Tip: If the PC is already present on your network, you can copy its MAC
address from the Attached Devices menu and paste it here.)
Click Apply to enter the reserved address into the table.
>>>

Robin, this sounds relevant to what you said yes?

On my host PC's network card TCP/IP Properties I have:
Obtain an IP address automatically

Sorry to be so obtuse on this but it sounds like I need to give the host's
network card a fixed IP address (like you said "within the subnet of the
router, but outside
> its DHCP allocation pool" - can you suggest a number for me?)

and secondly I need to tell the router about it yes?

Thanks very much. (You in Cambridge UK? I am Stateside now but born in
Liverpool).

"Robin Walker" wrote:

> "Simon" <Simon@discussions.microsoft.com> wrote in message
> news:9BF5B570-EEEA-4A61-9FE9-8403329E2E3A@microsoft.com
> >
> > Thanks for that. Yes, I've definitely got 3389 open and RDC marked on
> > both PCs
>
> You only need RDP enabled and port 3389 opened on the server PC (XP Pro).
> Settings on the client are not needed.
>
> > My laptop (Xp Home SP2) is the one I want to make the connection from
> > remotely and my office PC (Xp Pro, SP1) is the one I want to be able
> > to connect into. When my laptop is physically connected to the LAN by
> > ethernet the Remote Desktop Web Connection works fine. When I
> > disconnect my laptop
> > from the LAN, go someplace and use its modem to dial-up the internet,
> > I do still get the internet RDC page up on the screen alright, but
> > when I type in my server name (i.e. the name of my office PC - I just
> > type in its name right?, not the IP address of its network card which
> > is 192.168.0.xxx) there is no connection.
>
> No, you cannot use its name, and you cannot (on the outside internet) use
> its internal LAN address 192.168.0.xxx. You must use the WAN IP address of
> your home router.
>
> Only in your home LAN can you use the 192.168.xxx.xxx address of the RDP
> server.
>
> > The office LAN uses a Netgear router/gateway so we are not using
> > Microsoft Internet Connection Sharing, everything goes through the
> > router whose IP address is different from the Office PC's network
> > card IP address. I have the router configured to "Always Allow"
> > incoming and outgoing RD requests on port 3389.
>
> That's not enough: in the router you need to port-forward TCP port 3389 to
> the local LAN address of the RDP server PC. This PC should therefore be
> assigned a fixed LAN IP address within the subnet of the router, but outside
> its DHCP allocation pool, so that the port-forward will remain meaningful
> for ever. If your XP Pro PC has a DHCP-assigned address, it could change,
> and the port-forward would become invalid.
>
> > I have the laptop's
> > modem TCP/IP WINS tab configured with the IP address of the Office
> > PC's network card address.
>
> This appears to be an error, and of no possible use in the RDP context.
> Remove the setting. You cannot use local LAN IP addresses (192.168.xxx.xxx)
> in the broader internet anyway.
>
> --
> Robin Walker
> rdhw@cam.ac.uk
>
>
>
Anonymous
November 2, 2004 6:52:27 PM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

"Simon" <Simon@discussions.microsoft.com> wrote in message
news:03D0A3C7-E895-4C75-99E2-1058FCF5A05D@microsoft.com
>
> In my router configuration I have:
> Use router as DHCP server
> Starting IP Address 192.168.0.2
> Ending IP Address 192.168.0.51

This means that the router's DHCP allocation pool is 2 to 51. If you wish,
you may use static addresses on your LAN in the range 192.168.0.52 to
192.168.0.254.

> There is a further section titled "Reserved IP Table" with these
> notes: <<<Reserved IP Table
> When you specify a reserved IP address for a PC on the LAN, that PC
> will always receive the same IP address each time it access the DHCP
> server. Reserved IP addresses should be assigned to servers that
> require permanent IP settings.

That's an equally satisfactory method of ensuring that that the local LAN
address of your RDP server does not change.

> On my host PC's network card TCP/IP Properties I have:
> Obtain an IP address automatically

That will be the correct setting provided you configure the "Reserved IP
Table" in your router for the address of this PC.

> it sounds like I need to give the
> host's network card a fixed IP address (like you said "within the
> subnet of the router, but outside its DHCP allocation pool")

If you configure the "Reserved IP Table" for the RDP Server's address, then
you do not need to assign the RDP Server a static IP address, it will happen
automatically.

If you don't configure the "Reserved IP Table", then you need to assign a
static LAN IP address for this PC, in the range 52 to 254.

> and secondly I need to tell the router about it yes?

Whatever the IP address of this RDP Server turns out to be, you need to
configure the router to forward TCP port 3389 to it.

> You in Cambridge UK?

Yes.

--
Robin Walker
rdhw@cam.ac.uk
!