1 Way VPN ??

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

The basic problem is that my friend and I have both set up incoming VPN
connections and outgoing VPN connections. He is able to connect to me
without a problem, but when I attempt to connect to his VPN, it goes through
the following:
1. Connecting to the IP Address
2. Verifying Username and Password
3. Registering your computer to the network ... TCP/IP CP reported an
ERROR 733

We've tried everything we know and still can't get it to work. We're using
it to connect through Remote Desktop Connection (not the web based version).
We appreciate the help!

~ Jonathan
4 answers Last reply
More about tomshardware
  1. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Sixstringr1981 <Sixstringr1981@discussions.microsoft.com> wrote:

    > The basic problem is that my friend and I have both set up incoming
    > VPN connections and outgoing VPN connections. He is able to connect
    > to me without a problem, but when I attempt to connect to his VPN, it
    > goes through the following:
    > 1. Connecting to the IP Address
    > 2. Verifying Username and Password
    > 3. Registering your computer to the network ... TCP/IP CP reported
    > an ERROR 733
    >
    > We've tried everything we know and still can't get it to work. We're
    > using it to connect through Remote Desktop Connection (not the web
    > based version).

    First, you don't need a VPN to use Remote Desktop: you could use Remote
    Destop directly between your two PCs.

    Second, you need to tell us much more in order for us to understand your VPN
    issue. For instance, but not exclusively:

    What operating systems at each end?
    Any firewalls?
    Directly connected to internet or through routers at each end?
    If via routers:
    - what IP ranges are in use at each end's LAN?
    - what port-forward configuration has been done?
    What configurations have been made at each end for the outgoing and incoming
    VPN objects in "Network connections"?

    See also: http://support.microsoft.com/kb/q168720/
    Error Message: TCP/IP CP Reported Error 733: the PPP Control Protocol for
    This Network Protocol Is Not Available on the Server

    If the server end is directly connected to the internet (not behind a
    router) there might be problems with the VPN server trying to acquire more
    IP addresses via DHCP, which the ISP might not allow. The VPN Server needs
    two extra IP addresses, one for each end of the VPN link. If it set by
    default to obtain these by DHCP, the ISP's DHCP server might not oblige.

    --
    Robin Walker
    rdhw@cam.ac.uk
  2. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Both XP Pro computers with all windows updates install. No firewalls are
    active (including Windows Firewall). Connecting VPN between 2 routers, mine
    = DLink, my friend's = Netgear I believe. We both forwarded ports 3389, our
    personal port number specified for Remote Desktop, UDP 500, and 1723. We
    tried it DMZ too. The web version of Remote Desktop worked fine...but the
    "full version" located in communications folder in the start menu didn't
    connect...so we set up the VPN. Like I mentioned, He can connect to my VPN
    incoming...but I can't connect to his (733 error). Once the VPN was
    connected however, we were BOTH able to use the "full version" of Remote
    Desktop to access each other's computer. The question is about VPN, but it
    is in order to make the Remote Desktop function correctly. You said we
    didn't have to use VPN to make Remote Desktop work but that seemed to do the
    trick. As far as IP ranges should be 192.168.0.x x = 15 and higher. We
    both have 2 VPN objects in Network Connections, incoming and the ones we
    made to access each other's VPN. Ran through the normal wizards using public
    ip addresses...So that's all I know.

    Don't worry about going into an explanation to fix Remote Desktop. As long
    as we get the VPN rolling, i'm happy with it! Thanks and let me know if you
    need more info,

    ~ Jonathan


    "Robin Walker" wrote:

    > Sixstringr1981 <Sixstringr1981@discussions.microsoft.com> wrote:
    >
    > > The basic problem is that my friend and I have both set up incoming
    > > VPN connections and outgoing VPN connections. He is able to connect
    > > to me without a problem, but when I attempt to connect to his VPN, it
    > > goes through the following:
    > > 1. Connecting to the IP Address
    > > 2. Verifying Username and Password
    > > 3. Registering your computer to the network ... TCP/IP CP reported
    > > an ERROR 733
    > >
    > > We've tried everything we know and still can't get it to work. We're
    > > using it to connect through Remote Desktop Connection (not the web
    > > based version).
    >
    > First, you don't need a VPN to use Remote Desktop: you could use Remote
    > Destop directly between your two PCs.
    >
    > Second, you need to tell us much more in order for us to understand your VPN
    > issue. For instance, but not exclusively:
    >
    > What operating systems at each end?
    > Any firewalls?
    > Directly connected to internet or through routers at each end?
    > If via routers:
    > - what IP ranges are in use at each end's LAN?
    > - what port-forward configuration has been done?
    > What configurations have been made at each end for the outgoing and incoming
    > VPN objects in "Network connections"?
    >
    > See also: http://support.microsoft.com/kb/q168720/
    > Error Message: TCP/IP CP Reported Error 733: the PPP Control Protocol for
    > This Network Protocol Is Not Available on the Server
    >
    > If the server end is directly connected to the internet (not behind a
    > router) there might be problems with the VPN server trying to acquire more
    > IP addresses via DHCP, which the ISP might not allow. The VPN Server needs
    > two extra IP addresses, one for each end of the VPN link. If it set by
    > default to obtain these by DHCP, the ISP's DHCP server might not oblige.
    >
    > --
    > Robin Walker
    > rdhw@cam.ac.uk
    >
    >
    >
  3. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Sixstringr1981 <Sixstringr1981@discussions.microsoft.com> wrote:

    > We both
    > forwarded ports 3389, our personal port number specified for Remote
    > Desktop, UDP 500, and 1723.

    TCP 1723 is for PPTP VPNs (OK), but UDP 500 is for IPSec, which you do not
    require. For PPTP, you also need to forward the GRE protocol: some domestic
    routers cannot do this. You need to look for options in the routers which
    say something like "PPTP pass-though" and enable them. IF your routers do
    not support PPTP pass-though, you might need to upgrade your routers.

    > the "full version" located in
    > communications folder in the start menu didn't connect

    What addresses were you trying to use in the connection dialog?

    > Once the VPN was connected
    > however, we were BOTH able to use the "full version" of Remote
    > Desktop to access each other's computer.

    Again, what address were you using in the Remote Desktop conenction dialog
    when it worked this time?

    > As far as IP ranges should be
    > 192.168.0.x x = 15 and higher.

    This is an error. If you are creating VPNs between two LANs, the IP subnet
    ranges MUST NOT be the same in both LANs. You must reconfigure one of your
    routers so that the LAN addresses are in a different range to 192.168.0.xxx

    When you have corrected the IP range clash, please post back with a full
    "ipconfig /all" print-out from both PCs taken while you have a VPN connected
    in the one direction that works.

    --
    Robin Walker
    rdhw@cam.ac.uk
  4. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Thanks for the help Robin. I looked for what you were talking about in my
    DLink 624 router, all I found was the entry I already enabled ... under
    Virtual Servers tab... PPTP - 1723. It's a pretty new router but I didn't
    find anything but that. I'll just have to contact DLink and see what they
    say about it. Thanks again,

    ~ Jonathan


    "Robin Walker" wrote:

    > Sixstringr1981 <Sixstringr1981@discussions.microsoft.com> wrote:
    >
    > > We both
    > > forwarded ports 3389, our personal port number specified for Remote
    > > Desktop, UDP 500, and 1723.
    >
    > TCP 1723 is for PPTP VPNs (OK), but UDP 500 is for IPSec, which you do not
    > require. For PPTP, you also need to forward the GRE protocol: some domestic
    > routers cannot do this. You need to look for options in the routers which
    > say something like "PPTP pass-though" and enable them. IF your routers do
    > not support PPTP pass-though, you might need to upgrade your routers.
    >
    > > the "full version" located in
    > > communications folder in the start menu didn't connect
    >
    > What addresses were you trying to use in the connection dialog?
    >
    > > Once the VPN was connected
    > > however, we were BOTH able to use the "full version" of Remote
    > > Desktop to access each other's computer.
    >
    > Again, what address were you using in the Remote Desktop conenction dialog
    > when it worked this time?
    >
    > > As far as IP ranges should be
    > > 192.168.0.x x = 15 and higher.
    >
    > This is an error. If you are creating VPNs between two LANs, the IP subnet
    > ranges MUST NOT be the same in both LANs. You must reconfigure one of your
    > routers so that the LAN addresses are in a different range to 192.168.0.xxx
    >
    > When you have corrected the IP range clash, please post back with a full
    > "ipconfig /all" print-out from both PCs taken while you have a VPN connected
    > in the one direction that works.
    >
    > --
    > Robin Walker
    > rdhw@cam.ac.uk
    >
    >
    >
Ask a new question

Read More

Connection vpn Windows XP