Problem with remote web connection of port changes...

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

hi all,

due to the office policy, i only allow to change the remote desktop port to
80 in order to access, and it works fine with standalone remote desktop
client, however when i try to set up a web connection so that i can access
through web page, the problem came out as the web connection use Active-X
control which default to connect to the remote server using standard RDP
port 3389 and which i trying to prevent, is there any way to change the port
setting on the web connection too? (the tsweb setting)

Thank for any help .....

--
HGC
5 answers Last reply
More about problem remote connection port changes
  1. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Yes you can change the RDP listening port... See these KB articles...

    http://support.microsoft.com/default.aspx?scid=kb;EN-US;256986
    http://support.microsoft.com/default.aspx?scid=kb;EN-US;322756

    http://support.microsoft.com/default.aspx?scid=kb;en-us;Q306759

    Reboot the PC after making the registry change...

    To change the RDP listening port in the tsweb default.htm file I suggest you use Jeffrey Randow's
    (MS-MVP) default.htm file that allows the change to be made dynamically. Simply replace the original
    default.htm file with this new on. Make a backup of the original just in case you need to fall back
    to the original for some reason...

    http://www.remotenetworktechnology.com/LinkClick.aspx?link=revised_rdwc.zip&mid=365

    Remember that when your using the web based access method both the IIS port and the RDP port must be
    open through your firewall...

    http://www.microsoft.com/resources/documentation/Windows/XP/all/reskit/en-us/pree_rem_bgek.asp

    --
    Al Jarvi (MS-MVP Windows Networking)

    Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
    The MS-MVP Program - http://mvp.support.microsoft.com
    This posting is provided "AS IS" with no warranties, and confers no rights...

    "Seyse@@" <dseys@hotmail.com> wrote in message news:OFaZ4%23C2EHA.3092@TK2MSFTNGP10.phx.gbl...
    > hi all,
    >
    > due to the office policy, i only allow to change the remote desktop port to
    > 80 in order to access, and it works fine with standalone remote desktop
    > client, however when i try to set up a web connection so that i can access
    > through web page, the problem came out as the web connection use Active-X
    > control which default to connect to the remote server using standard RDP
    > port 3389 and which i trying to prevent, is there any way to change the port
    > setting on the web connection too? (the tsweb setting)
    >
    > Thank for any help .....
    >
    > --
    > HGC
    >
    >
    >
  2. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Al's links give all the info needed to change ports, but bear in mind that
    you are going to need TWO ports--both inbound at the remote location and
    outbound from the work location, for this to work. One port for the HTTP
    connection, and a second one for the ActiveX control.

    You can't use 80 for both of them.

    "Seyse@@" <dseys@hotmail.com> wrote in message
    news:OFaZ4%23C2EHA.3092@TK2MSFTNGP10.phx.gbl...
    > hi all,
    >
    > due to the office policy, i only allow to change the remote desktop port
    > to
    > 80 in order to access, and it works fine with standalone remote desktop
    > client, however when i try to set up a web connection so that i can access
    > through web page, the problem came out as the web connection use Active-X
    > control which default to connect to the remote server using standard RDP
    > port 3389 and which i trying to prevent, is there any way to change the
    > port
    > setting on the web connection too? (the tsweb setting)
    >
    > Thank for any help .....
    >
    > --
    > HGC
    >
    >
    >
  3. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Hello there, I forwarded all the ports necessary, changed the port in the
    registry and downloaded Jeffrey Randow's version of the default.htm page and
    replaced it with what I had and when I try to connect to my PC via RDWC, I
    get this error message.... http://home.cogeco.ca/~mash17/ActiveXerror.JPG .
    What does this mean and how can I fix this? Thanks,

    -Ryan

    "Sooner Al" wrote:

    > Yes you can change the RDP listening port... See these KB articles...
    >
    > http://support.microsoft.com/default.aspx?scid=kb;EN-US;256986
    > http://support.microsoft.com/default.aspx?scid=kb;EN-US;322756
    >
    > http://support.microsoft.com/default.aspx?scid=kb;en-us;Q306759
    >
    > Reboot the PC after making the registry change...
    >
    > To change the RDP listening port in the tsweb default.htm file I suggest you use Jeffrey Randow's
    > (MS-MVP) default.htm file that allows the change to be made dynamically. Simply replace the original
    > default.htm file with this new on. Make a backup of the original just in case you need to fall back
    > to the original for some reason...
    >
    > http://www.remotenetworktechnology.com/LinkClick.aspx?link=revised_rdwc.zip&mid=365
    >
    > Remember that when your using the web based access method both the IIS port and the RDP port must be
    > open through your firewall...
    >
    > http://www.microsoft.com/resources/documentation/Windows/XP/all/reskit/en-us/pree_rem_bgek.asp
    >
    > --
    > Al Jarvi (MS-MVP Windows Networking)
    >
    > Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
    > The MS-MVP Program - http://mvp.support.microsoft.com
    > This posting is provided "AS IS" with no warranties, and confers no rights...
    >
    > "Seyse@@" <dseys@hotmail.com> wrote in message news:OFaZ4%23C2EHA.3092@TK2MSFTNGP10.phx.gbl...
    > > hi all,
    > >
    > > due to the office policy, i only allow to change the remote desktop port to
    > > 80 in order to access, and it works fine with standalone remote desktop
    > > client, however when i try to set up a web connection so that i can access
    > > through web page, the problem came out as the web connection use Active-X
    > > control which default to connect to the remote server using standard RDP
    > > port 3389 and which i trying to prevent, is there any way to change the port
    > > setting on the web connection too? (the tsweb setting)
    > >
    > > Thank for any help .....
    > >
    > > --
    > > HGC
    > >
    > >
    > >
    >
    >
  4. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    It means that IE is setup to not allow ActiveX controls to be installed from the internet. That is
    required if you want to use the web based method. Check your security settings...

    --
    Al Jarvi (MS-MVP Windows Networking)

    Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
    The MS-MVP Program - http://mvp.support.microsoft.com
    This posting is provided "AS IS" with no warranties, and confers no rights...

    "Ryan" <Ryan@discussions.microsoft.com> wrote in message
    news:DD2D6D35-C917-4D92-B222-172CD0F9AB74@microsoft.com...
    > Hello there, I forwarded all the ports necessary, changed the port in the
    > registry and downloaded Jeffrey Randow's version of the default.htm page and
    > replaced it with what I had and when I try to connect to my PC via RDWC, I
    > get this error message.... http://home.cogeco.ca/~mash17/ActiveXerror.JPG .
    > What does this mean and how can I fix this? Thanks,
    >
    > -Ryan
    >
    > "Sooner Al" wrote:
    >
    >> Yes you can change the RDP listening port... See these KB articles...
    >>
    >> http://support.microsoft.com/default.aspx?scid=kb;EN-US;256986
    >> http://support.microsoft.com/default.aspx?scid=kb;EN-US;322756
    >>
    >> http://support.microsoft.com/default.aspx?scid=kb;en-us;Q306759
    >>
    >> Reboot the PC after making the registry change...
    >>
    >> To change the RDP listening port in the tsweb default.htm file I suggest you use Jeffrey Randow's
    >> (MS-MVP) default.htm file that allows the change to be made dynamically. Simply replace the
    >> original
    >> default.htm file with this new on. Make a backup of the original just in case you need to fall
    >> back
    >> to the original for some reason...
    >>
    >> http://www.remotenetworktechnology.com/LinkClick.aspx?link=revised_rdwc.zip&mid=365
    >>
    >> Remember that when your using the web based access method both the IIS port and the RDP port must
    >> be
    >> open through your firewall...
    >>
    >> http://www.microsoft.com/resources/documentation/Windows/XP/all/reskit/en-us/pree_rem_bgek.asp
    >>
    >> --
    >> Al Jarvi (MS-MVP Windows Networking)
    >>
    >> Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
    >> The MS-MVP Program - http://mvp.support.microsoft.com
    >> This posting is provided "AS IS" with no warranties, and confers no rights...
    >>
    >> "Seyse@@" <dseys@hotmail.com> wrote in message news:OFaZ4%23C2EHA.3092@TK2MSFTNGP10.phx.gbl...
    >> > hi all,
    >> >
    >> > due to the office policy, i only allow to change the remote desktop port to
    >> > 80 in order to access, and it works fine with standalone remote desktop
    >> > client, however when i try to set up a web connection so that i can access
    >> > through web page, the problem came out as the web connection use Active-X
    >> > control which default to connect to the remote server using standard RDP
    >> > port 3389 and which i trying to prevent, is there any way to change the port
    >> > setting on the web connection too? (the tsweb setting)
    >> >
    >> > Thank for any help .....
    >> >
    >> > --
    >> > HGC
    >> >
    >> >
    >> >
    >>
    >>
  5. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    I went into the remote computer's IE security settings and enabled all
    ActiveX and scripting and I still get the same error.

    "Sooner Al" wrote:

    > It means that IE is setup to not allow ActiveX controls to be installed from the internet. That is
    > required if you want to use the web based method. Check your security settings...
    >
    > --
    > Al Jarvi (MS-MVP Windows Networking)
    >
    > Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
    > The MS-MVP Program - http://mvp.support.microsoft.com
    > This posting is provided "AS IS" with no warranties, and confers no rights...
    >
    > "Ryan" <Ryan@discussions.microsoft.com> wrote in message
    > news:DD2D6D35-C917-4D92-B222-172CD0F9AB74@microsoft.com...
    > > Hello there, I forwarded all the ports necessary, changed the port in the
    > > registry and downloaded Jeffrey Randow's version of the default.htm page and
    > > replaced it with what I had and when I try to connect to my PC via RDWC, I
    > > get this error message.... http://home.cogeco.ca/~mash17/ActiveXerror.JPG .
    > > What does this mean and how can I fix this? Thanks,
    > >
    > > -Ryan
    > >
    > > "Sooner Al" wrote:
    > >
    > >> Yes you can change the RDP listening port... See these KB articles...
    > >>
    > >> http://support.microsoft.com/default.aspx?scid=kb;EN-US;256986
    > >> http://support.microsoft.com/default.aspx?scid=kb;EN-US;322756
    > >>
    > >> http://support.microsoft.com/default.aspx?scid=kb;en-us;Q306759
    > >>
    > >> Reboot the PC after making the registry change...
    > >>
    > >> To change the RDP listening port in the tsweb default.htm file I suggest you use Jeffrey Randow's
    > >> (MS-MVP) default.htm file that allows the change to be made dynamically. Simply replace the
    > >> original
    > >> default.htm file with this new on. Make a backup of the original just in case you need to fall
    > >> back
    > >> to the original for some reason...
    > >>
    > >> http://www.remotenetworktechnology.com/LinkClick.aspx?link=revised_rdwc.zip&mid=365
    > >>
    > >> Remember that when your using the web based access method both the IIS port and the RDP port must
    > >> be
    > >> open through your firewall...
    > >>
    > >> http://www.microsoft.com/resources/documentation/Windows/XP/all/reskit/en-us/pree_rem_bgek.asp
    > >>
    > >> --
    > >> Al Jarvi (MS-MVP Windows Networking)
    > >>
    > >> Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
    > >> The MS-MVP Program - http://mvp.support.microsoft.com
    > >> This posting is provided "AS IS" with no warranties, and confers no rights...
    > >>
    > >> "Seyse@@" <dseys@hotmail.com> wrote in message news:OFaZ4%23C2EHA.3092@TK2MSFTNGP10.phx.gbl...
    > >> > hi all,
    > >> >
    > >> > due to the office policy, i only allow to change the remote desktop port to
    > >> > 80 in order to access, and it works fine with standalone remote desktop
    > >> > client, however when i try to set up a web connection so that i can access
    > >> > through web page, the problem came out as the web connection use Active-X
    > >> > control which default to connect to the remote server using standard RDP
    > >> > port 3389 and which i trying to prevent, is there any way to change the port
    > >> > setting on the web connection too? (the tsweb setting)
    > >> >
    > >> > Thank for any help .....
    > >> >
    > >> > --
    > >> > HGC
    > >> >
    > >> >
    > >> >
    > >>
    > >>
    >
    >
Ask a new question

Read More

Remote Desktop Connection Microsoft Windows XP