Remote Desktop not possible with computer names

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

I am able to connect with Remote Desktop to PC's on my home network by
specifying their IP address, but if I use the computer name I get a message:

"The client cannot connect to the remote computer.
Remote connections might not be enabled or the computer might be too busy to
accept new connections. It is also possible that network problems are
preventing your connection. "

How do I fix this? I have XP sp1 on two computers and XP sp2 on the my
laptop that I use to Remote Desktop to the others. I also cannot path out by
computername to the shared folders, but again it works if I use the IP
address.

thanks
Dingo
10 answers Last reply
More about remote desktop computer names
  1. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Dingo wrote:
    > I am able to connect with Remote Desktop to PC's on my home network by
    > specifying their IP address, but if I use the computer name I get a
    > message:
    >
    > "The client cannot connect to the remote computer.
    > Remote connections might not be enabled or the computer might be too
    > busy to accept new connections. It is also possible that network
    > problems are preventing your connection. "
    >
    > How do I fix this? I have XP sp1 on two computers and XP sp2 on the
    > my laptop that I use to Remote Desktop to the others. I also cannot
    > path out by computername to the shared folders, but again it works if
    > I use the IP address.
    >
    > thanks
    > Dingo

    Can you ping the host computer by name successfully?
  2. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Dingo <Dingo@discussions.microsoft.com> wrote:

    > I am able to connect with Remote Desktop to PC's on my home network by
    > specifying their IP address, but if I use the computer name I get a
    > message:
    >
    > "The client cannot connect to the remote computer.
    > Remote connections might not be enabled or the computer might be too
    > busy to accept new connections. It is also possible that network
    > problems are preventing your connection. "
    >
    > How do I fix this? I have XP sp1 on two computers and XP sp2 on the
    > my laptop that I use to Remote Desktop to the others. I also cannot
    > path out by computername to the shared folders, but again it works if
    > I use the IP address.

    Your home network PCs do not have entries in the DNS naming system, so DNS
    names will not work. IP addresses will work fine.

    To reference other PCs by NetBIOS name in order to make an IP connection
    requires that you have NetBIOS-over-TCP/IP enabled on all PCs, and that you
    have configured Windows Firewall to allow Microsoft File and Printer Sharing
    as an Exception. You should also ensure that all PCs have the same
    Workgroup name configured.

    --
    Robin Walker
    rdhw@cam.ac.uk
  3. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    "Robin Walker" wrote:
    >
    > Your home network PCs do not have entries in the DNS naming system, so DNS
    > names will not work. IP addresses will work fine.
    >
    > To reference other PCs by NetBIOS name in order to make an IP connection
    > requires that you have NetBIOS-over-TCP/IP enabled on all PCs, and that you
    > have configured Windows Firewall to allow Microsoft File and Printer Sharing
    > as an Exception. You should also ensure that all PCs have the same
    > Workgroup name configured.
    >
    > --
    > Robin Walker
    > rdhw@cam.ac.uk
    >

    I have confirmed that I have NetBios over TCP/IP enabled on all my
    computers, they are all in the same one Workgroup and the Firewall is
    configured to let File & Printer sharing through as well as Remote Desktop.
    Still no luck though. I can also ping all machines by IP address, but not by
    computername. I've noticed in the event log the following is showing up and
    suspect it is related...

    The browser was unable to retrieve a list of servers from the browser master
    \\MYPCNAME on the network
    \Device\NetBT_Tcpip_{5113EA66-E1F3-48B3-9CA8-A6DBD031BBD1}. The data is the
    error code.

    Question: Can I get round this problem by typing in my IP to computername in
    the LMHOSTS file? Would I have to do that on all computers?

    Thanks..... appreciate the help. :^)
  4. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Dingo <Dingo@discussions.microsoft.com> wrote:

    > I have confirmed that I have NetBios over TCP/IP enabled on all my
    > computers, they are all in the same one Workgroup and the Firewall is
    > configured to let File & Printer sharing through as well as Remote
    > Desktop. Still no luck though. I can also ping all machines by IP
    > address, but not by computername. I've noticed in the event log the
    > following is showing up and suspect it is related...
    >
    > The browser was unable to retrieve a list of servers from the browser
    > master \\MYPCNAME on the network
    > \Device\NetBT_Tcpip_{5113EA66-E1F3-48B3-9CA8-A6DBD031BBD1}. The data
    > is the error code.

    This is indeed progress. It shows that your problems are due to a failure to
    get info from the browsemaster. The next step is to find out why. At each
    PC on your LAN, open a command window and type the command

    ipconfig /all

    and especially note the value in the line "Node Type". A value of "Unknown"
    is usually fine. Anything like "Point to Point" or "Peer to Peer" is bad.

    Also, on the identified browsemaster PC, does the log file reveal anything
    more useful?

    > Question: Can I get round this problem by typing in my IP to
    > computername in the LMHOSTS file? Would I have to do that on all
    > computers?

    Yes, and yes. Though you would need to be quite sure that they all worked
    with the same IP address all the time, which you cannot guarantee with
    DHCP-issued IP addresses.

    --
    Robin Walker
    rdhw@cam.ac.uk
  5. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Robin wrote:
    > This is indeed progress. It shows that your problems are due to a failure to
    > get info from the browsemaster. The next step is to find out why. At each
    > PC on your LAN, open a command window and type the command
    >
    > ipconfig /all
    >
    > and especially note the value in the line "Node Type". A value of "Unknown"
    > is usually fine. Anything like "Point to Point" or "Peer to Peer" is bad.
    >
    > Also, on the identified browsemaster PC, does the log file reveal anything
    > more useful?
    >
    > > Question: Can I get round this problem by typing in my IP to
    > > computername in the LMHOSTS file? Would I have to do that on all
    > > computers?
    >
    > Yes, and yes. Though you would need to be quite sure that they all worked
    > with the same IP address all the time, which you cannot guarantee with
    > DHCP-issued IP addresses.
    >
    > --
    > Robin Walker
    > rdhw@cam.ac.uk


    On the 3 PC's on my home network they all have the following settings:
    Node Type : Hybrid
    IP routing Enabled : No
    WINS Proxy Enabled : No
    DHCP Enabled : Yes
    Autoconfiguration Enabled : Yes
    The Default Gateway, DHCP Server and DNS Server all correctly point to my
    Router's IP address, and all machines have the IP addresses I expect to be
    assigned to them from the router.

    In the event log on the MasterBrowser, I am seeing some odd events in this
    order...
    1. The system detected that network adapter \DEVICE\TCPIP_{<gid#>} was
    connected to the network, and has initiated normal operation over the network
    adapter.
    2. The browser has forced an election on network
    \Device\NetBT_Tcpip_{<different gid> because a master browser was stopped.
    I see the 2nd event msg about 3 or 4 times in a day but I'm seeing the 1st
    message about 15 -20 times and even throughout the night. One thing to note,
    I am not switching these computers off during the day or night so that should
    not be a factor in affecting the MasterBrowser or the reason for the event
    msgs.
    (I do also get a message about 3 times a day about the IPSEC Service
    starting and then later stopping, but I don't think that is material to this
    issue -- it is probably just my company enforcing their security policy
    through the VPN connection I have with them.)

    Seeing the 1st Event msg repeatedly made me think maybe I have a NIC thats
    going bad on the MasterBrowser PC, but on the other hand I have not had any
    other problems with it accessing the internet or staying connected to my VPN,
    so it can't be failing regularly.

    Thanks.
  6. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Dingo <Dingo@discussions.microsoft.com> wrote:

    > On the 3 PC's on my home network they all have the following settings:
    > Node Type : Hybrid

    That is not the default. Do you have (or have you ever had) WINS servers
    defined in the TCP/IP properties? If so, your PCs will be trying to use
    your corporate WINS server to do name resolution. As every PC is behind a
    NAT router, the responses from the WINS server will be confusing.

    If you have WINS servers defined, then try removing them from your PC
    configuration.

    It is possible that your PCs are acquiring this WINS and NodeType
    configuration when they connect by VPN to your company network, as such
    things can be pushed by VPN configuration at the time of connection.

    --
    Robin Walker
    rdhw@cam.ac.uk
  7. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    > That is not the default. Do you have (or have you ever had) WINS servers
    > defined in the TCP/IP properties? If so, your PCs will be trying to use
    > your corporate WINS server to do name resolution. As every PC is behind a
    > NAT router, the responses from the WINS server will be confusing.

    I checked and found one of my computers had WINS server entries. I removed
    them and then did ipconfig /all again. I noticed this changed the NoteType
    to "Broadcast" on that PC, but my 2 other PCs have remained at Hybrid (even
    after an IP release as well as a reboot) *How do I get them to change
    NodeType?*

    > It is possible that your PCs are acquiring this WINS and NodeType
    > configuration when they connect by VPN to your company network

    The WINS entries were on an older PC of mine that I used to connect to work
    with. Removing them and connecting to my work VPN has worked fine. It is
    not repopulating the WINS entries.

    Two other things - checking my router's dynamic DHCP entries; it was not
    listing computer names for 2 of my PCs. When I did an ipconfig /renew from
    those 2 PCs, that populated the router's dyn-DHCP table again. I then also
    reran the home network wizard and though all my computers now show up in my
    workgroup I am still not able to connect by COMPUTERNAME via Remote Desktop.
    And I get the 'network path cannot be found' when I try to connect through
    the workgroup explorer window....very strange...

    thx, Louie
  8. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    From a response by Steve Winograd, MS-MVP, to another user...

    **************************************

    http://groups-beta.google.com/group/microsoft.public.windowsxp.network_web/browse_thread/thread/97dbb3f1a9a0bf89/115901c10e408185?q=node+type+group:*.network_web&_done=%2Fgroups%3Fq%3Dnode+type+group:*.network_web%26start%3D0%26scoring%3Dd%26safe%3Dimages%26lr%3D%26hl%3Den%26&_doneTitle=Back+to+Search&&d#115901c10e408185

    4. Run "ipconfig /all" on XP and look at the "Node Type" at the
    beginning of the output. If it says "Peer-to-Peer" (which should
    actually be "Point-to-Point") that's the problem. It means that the
    computer only uses a WINS server, which isn't available on a
    peer-to-peer network, for NetBIOS name resolution.


    If that's the case, run the registry editor, open this key:


    HLM\System\CurrentControlSet\Services\Netbt\Parametersand delete these values if they're present:


    NodeType
    DhcpNodeType


    Reboot, then try network access again.


    If that doesn't fix it, open that registry key again, create a DWORD
    value called "NodeType", and set it to 1 for "Broadcast" or 4 for
    "Mixed".


    For details, see these Microsoft Knowledge Base articles:


    Default Node Type for Microsoft Clients


    http://support.microsoft.com/default.aspx?scid=kb;en-us;160177TCP/IP and NBT Configuration
    Parameters for Windows XP


    http://support.microsoft.com/default.aspx?scid=kb;en-us;314053******************************
    --
    Al Jarvi (MS-MVP Windows Networking)

    Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
    The MS-MVP Program - http://mvp.support.microsoft.com
    This posting is provided "AS IS" with no warranties, and confers no rights...

    "Dingo" <Dingo@discussions.microsoft.com> wrote in message
    news:927E6567-FCD5-4DC5-9C6E-E7B42CC23227@microsoft.com...
    >
    >> That is not the default. Do you have (or have you ever had) WINS servers
    >> defined in the TCP/IP properties? If so, your PCs will be trying to use
    >> your corporate WINS server to do name resolution. As every PC is behind a
    >> NAT router, the responses from the WINS server will be confusing.
    >
    > I checked and found one of my computers had WINS server entries. I removed
    > them and then did ipconfig /all again. I noticed this changed the NoteType
    > to "Broadcast" on that PC, but my 2 other PCs have remained at Hybrid (even
    > after an IP release as well as a reboot) *How do I get them to change
    > NodeType?*
    >
    >> It is possible that your PCs are acquiring this WINS and NodeType
    >> configuration when they connect by VPN to your company network
    >
    > The WINS entries were on an older PC of mine that I used to connect to work
    > with. Removing them and connecting to my work VPN has worked fine. It is
    > not repopulating the WINS entries.
    >
    > Two other things - checking my router's dynamic DHCP entries; it was not
    > listing computer names for 2 of my PCs. When I did an ipconfig /renew from
    > those 2 PCs, that populated the router's dyn-DHCP table again. I then also
    > reran the home network wizard and though all my computers now show up in my
    > workgroup I am still not able to connect by COMPUTERNAME via Remote Desktop.
    > And I get the 'network path cannot be found' when I try to connect through
    > the workgroup explorer window....very strange...
    >
    > thx, Louie
  9. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    "Sooner Al" wrote:

    > From a response by Steve Winograd, MS-MVP, to another user...
    >
    > **************************************
    >
    > http://groups-beta.google.com/group/microsoft.public.windowsxp.network_web/browse_thread/thread/97dbb3f1a9a0bf89/115901c10e408185?q=node+type+group:*.network_web&_done=%2Fgroups%3Fq%3Dnode+type+group:*.network_web%26start%3D0%26scoring%3Dd%26safe%3Dimages%26lr%3D%26hl%3Den%26&_doneTitle=Back+to+Search&&d#115901c10e408185
    >
    > 4. Run "ipconfig /all" on XP and look at the "Node Type" at the
    > beginning of the output. If it says "Peer-to-Peer" (which should
    > actually be "Point-to-Point") that's the problem. It means that the
    > computer only uses a WINS server, which isn't available on a
    > peer-to-peer network, for NetBIOS name resolution.
    >
    >
    > If that's the case, run the registry editor, open this key:
    >
    >
    >
    > HLM\System\CurrentControlSet\Services\Netbt\Parametersand delete these values if they're present:
    >
    >
    > NodeType
    > DhcpNodeType
    >
    >
    > Reboot, then try network access again.
    >
    >
    > If that doesn't fix it, open that registry key again, create a DWORD
    > value called "NodeType", and set it to 1 for "Broadcast" or 4 for
    > "Mixed".
    >
    >
    > For details, see these Microsoft Knowledge Base articles:
    >
    >
    > Default Node Type for Microsoft Clients
    >
    >
    > http://support.microsoft.com/default.aspx?scid=kb;en-us;160177TCP/IP and NBT Configuration
    > Parameters for Windows XP
    >
    >
    > http://support.microsoft.com/default.aspx?scid=kb;en-us;314053******************************
    > --
    > Al Jarvi (MS-MVP Windows Networking)
    >
    > Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
    > The MS-MVP Program - http://mvp.support.microsoft.com
    > This posting is provided "AS IS" with no warranties, and confers no rights...
    >
    > "Dingo" <Dingo@discussions.microsoft.com> wrote in message
    > news:927E6567-FCD5-4DC5-9C6E-E7B42CC23227@microsoft.com...
    > >
    > >> That is not the default. Do you have (or have you ever had) WINS servers
    > >> defined in the TCP/IP properties? If so, your PCs will be trying to use
    > >> your corporate WINS server to do name resolution. As every PC is behind a
    > >> NAT router, the responses from the WINS server will be confusing.
    > >
    > > I checked and found one of my computers had WINS server entries. I removed
    > > them and then did ipconfig /all again. I noticed this changed the NoteType
    > > to "Broadcast" on that PC, but my 2 other PCs have remained at Hybrid (even
    > > after an IP release as well as a reboot) *How do I get them to change
    > > NodeType?*
    > >
    > >> It is possible that your PCs are acquiring this WINS and NodeType
    > >> configuration when they connect by VPN to your company network
    > >
    > > The WINS entries were on an older PC of mine that I used to connect to work
    > > with. Removing them and connecting to my work VPN has worked fine. It is
    > > not repopulating the WINS entries.
    > >
    > > Two other things - checking my router's dynamic DHCP entries; it was not
    > > listing computer names for 2 of my PCs. When I did an ipconfig /renew from
    > > those 2 PCs, that populated the router's dyn-DHCP table again. I then also
    > > reran the home network wizard and though all my computers now show up in my
    > > workgroup I am still not able to connect by COMPUTERNAME via Remote Desktop.
    > > And I get the 'network path cannot be found' when I try to connect through
    > > the workgroup explorer window....very strange...
    > >
    > > thx, Louie

    It's working now. Thx to all on this thread. :^)
    Just to confirm: I removed the DhcpNodeType entry and created a new
    NodeType entry with a DWORD value of 1 - that changed the NodeType setting to
    'Broadcast' when viewed through ipconfig /all.
    Then I also found some old static entries in a hosts file on 2 of the
    computers - some of which I put there a while back when trying to fix this.
    I removed those and rebooted, and after that I am now able to ping
    computernames and attach to them via RemoteDesktop.

    Thank You!
  10. For those looking for a solution, this is what worked for me:

    It appears the issue had to do with the DhcpDomain registry key. For some reason it was set to my ISP's domain on one computer and my business's domain on another even though both were my home computers. Setting them to blank fixed the issues I was having.

    Edit DhcpDomain="" in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Tcpip\Parameters\Interfaces\<the interface that corresponds with your current connection>\
Ask a new question

Read More

Remote Desktop Connection Computers Windows XP