XP "Remote Desktop" disabled

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

I tried to enable "Remote Desktop" on my machine (running Win XP Pro Sevice
Pack 1), noticed that it is disabled, i.e., "Allow users to connect remotely
to this computer" is greyed out. What's wrong? ("Remote Assistance" is OK.)

Thanks!
10 answers Last reply
More about remote desktop disabled
  1. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Is the workstation on a home or work network? It is possible that security
    policies are being applied to the machine that eliminate the functionality.
    Do you have the ability to log onto the machine as an administrator? If so,
    is the option still grayed out?

    Kind Regards,

    --
    Colin M. McGroarty, MCSE, MCP+I, NT-CIP
    2004 Microsoft MVP, Windows Server - General
    www.McGroarty.org


    "L.H." <LH@discussions.microsoft.com> wrote in message
    news:70DF2B34-DC27-43FD-9BB7-ADADDC2F5F32@microsoft.com...
    I tried to enable "Remote Desktop" on my machine (running Win XP Pro Sevice
    Pack 1), noticed that it is disabled, i.e., "Allow users to connect remotely
    to this computer" is greyed out. What's wrong? ("Remote Assistance" is
    OK.)

    Thanks!
  2. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    This computer is at work. My account is as an administrator and the option
    is still grayed out.

    Thank you for answering my question.

    "Colin M. McGroarty" wrote:

    > Is the workstation on a home or work network? It is possible that security
    > policies are being applied to the machine that eliminate the functionality.
    > Do you have the ability to log onto the machine as an administrator? If so,
    > is the option still grayed out?
    >
    > Kind Regards,
    >
    > --
    > Colin M. McGroarty, MCSE, MCP+I, NT-CIP
    > 2004 Microsoft MVP, Windows Server - General
    > www.McGroarty.org
    >
    >
    > "L.H." <LH@discussions.microsoft.com> wrote in message
    > news:70DF2B34-DC27-43FD-9BB7-ADADDC2F5F32@microsoft.com...
    > I tried to enable "Remote Desktop" on my machine (running Win XP Pro Sevice
    > Pack 1), noticed that it is disabled, i.e., "Allow users to connect remotely
    > to this computer" is greyed out. What's wrong? ("Remote Assistance" is
    > OK.)
    >
    > Thanks!
    >
    >
    >
  3. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Unfortunately I can't think of a reason other than permissions or policy
    limitations that would result in this scenario. It can't hurt to attempt
    reinstalling the RDP client. You can download this from my web site at
    http://www.mcgroarty.org/Downloads.htm. Alternately, you can search
    Microsoft's web site to download the file as well (file name is
    msrdpcli.exe). Hope this helps.

    I'll keep monitoring this thread and post any additional information that I
    come accross.

    Kind Regards,

    --
    Colin M. McGroarty, MCSE, MCP+I, NT-CIP
    2004 Microsoft MVP, Windows Server - General
    www.McGroarty.org


    "L.H." <LH@discussions.microsoft.com> wrote in message
    news:1042C5BF-E752-4A76-8C77-D43EDAF44A5E@microsoft.com...
    This computer is at work. My account is as an administrator and the option
    is still grayed out.

    Thank you for answering my question.

    "Colin M. McGroarty" wrote:

    > Is the workstation on a home or work network? It is possible that
    > security
    > policies are being applied to the machine that eliminate the
    > functionality.
    > Do you have the ability to log onto the machine as an administrator? If
    > so,
    > is the option still grayed out?
    >
    > Kind Regards,
    >
    > --
    > Colin M. McGroarty, MCSE, MCP+I, NT-CIP
    > 2004 Microsoft MVP, Windows Server - General
    > www.McGroarty.org
    >
    >
    > "L.H." <LH@discussions.microsoft.com> wrote in message
    > news:70DF2B34-DC27-43FD-9BB7-ADADDC2F5F32@microsoft.com...
    > I tried to enable "Remote Desktop" on my machine (running Win XP Pro
    > Sevice
    > Pack 1), noticed that it is disabled, i.e., "Allow users to connect
    > remotely
    > to this computer" is greyed out. What's wrong? ("Remote Assistance" is
    > OK.)
    >
    > Thanks!
    >
    >
    >
  4. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    To enable/disable Remote Desktop on the XP Pro Remote Desktop host via a Group Policy go to
    "Start -> Run" and type gpedit.msc at the command line. Navigate to the "Local Computer Policy ->
    Computer Configuration -> Administrative Templates -> Windows Components -> Terminal Services".
    Highlight and double-click on "Do not allow new client connections", or if your running SP2 the
    "Allow users to connect remotely using Terminal Services", policy and configure as needed. Select
    "Ok"...

    Reinstalling the client won't help...

    --
    Al Jarvi (MS-MVP Windows Networking)

    Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
    The MS-MVP Program - http://mvp.support.microsoft.com
    This posting is provided "AS IS" with no warranties, and confers no rights...

    "Colin M. McGroarty" <CMcGroarty@hotmail.com> wrote in message
    news:eQwjgbn7EHA.1396@tk2msftngp13.phx.gbl...
    > Unfortunately I can't think of a reason other than permissions or policy
    > limitations that would result in this scenario. It can't hurt to attempt
    > reinstalling the RDP client. You can download this from my web site at
    > http://www.mcgroarty.org/Downloads.htm. Alternately, you can search
    > Microsoft's web site to download the file as well (file name is
    > msrdpcli.exe). Hope this helps.
    >
    > I'll keep monitoring this thread and post any additional information that I
    > come accross.
    >
    > Kind Regards,
    >
    > --
    > Colin M. McGroarty, MCSE, MCP+I, NT-CIP
    > 2004 Microsoft MVP, Windows Server - General
    > www.McGroarty.org
    >
    >
    > "L.H." <LH@discussions.microsoft.com> wrote in message
    > news:1042C5BF-E752-4A76-8C77-D43EDAF44A5E@microsoft.com...
    > This computer is at work. My account is as an administrator and the option
    > is still grayed out.
    >
    > Thank you for answering my question.
    >
    > "Colin M. McGroarty" wrote:
    >
    >> Is the workstation on a home or work network? It is possible that
    >> security
    >> policies are being applied to the machine that eliminate the
    >> functionality.
    >> Do you have the ability to log onto the machine as an administrator? If
    >> so,
    >> is the option still grayed out?
    >>
    >> Kind Regards,
    >>
    >> --
    >> Colin M. McGroarty, MCSE, MCP+I, NT-CIP
    >> 2004 Microsoft MVP, Windows Server - General
    >> www.McGroarty.org
    >>
    >>
    >> "L.H." <LH@discussions.microsoft.com> wrote in message
    >> news:70DF2B34-DC27-43FD-9BB7-ADADDC2F5F32@microsoft.com...
    >> I tried to enable "Remote Desktop" on my machine (running Win XP Pro
    >> Sevice
    >> Pack 1), noticed that it is disabled, i.e., "Allow users to connect
    >> remotely
    >> to this computer" is greyed out. What's wrong? ("Remote Assistance" is
    >> OK.)
    >>
    >> Thanks!
    >>
    >>
    >>
    >
  5. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Thank you for all the quick response. I tried Al's method on my home
    computer and it works! I will try it at work next week.

    You guys have a wonderful New Year!

    "Sooner Al" wrote:

    > To enable/disable Remote Desktop on the XP Pro Remote Desktop host via a Group Policy go to
    > "Start -> Run" and type gpedit.msc at the command line. Navigate to the "Local Computer Policy ->
    > Computer Configuration -> Administrative Templates -> Windows Components -> Terminal Services".
    > Highlight and double-click on "Do not allow new client connections", or if your running SP2 the
    > "Allow users to connect remotely using Terminal Services", policy and configure as needed. Select
    > "Ok"...
    >
    > Reinstalling the client won't help...
    >
    > --
    > Al Jarvi (MS-MVP Windows Networking)
    >
    > Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
    > The MS-MVP Program - http://mvp.support.microsoft.com
    > This posting is provided "AS IS" with no warranties, and confers no rights...
    >
    > "Colin M. McGroarty" <CMcGroarty@hotmail.com> wrote in message
    > news:eQwjgbn7EHA.1396@tk2msftngp13.phx.gbl...
    > > Unfortunately I can't think of a reason other than permissions or policy
    > > limitations that would result in this scenario. It can't hurt to attempt
    > > reinstalling the RDP client. You can download this from my web site at
    > > http://www.mcgroarty.org/Downloads.htm. Alternately, you can search
    > > Microsoft's web site to download the file as well (file name is
    > > msrdpcli.exe). Hope this helps.
    > >
    > > I'll keep monitoring this thread and post any additional information that I
    > > come accross.
    > >
    > > Kind Regards,
    > >
    > > --
    > > Colin M. McGroarty, MCSE, MCP+I, NT-CIP
    > > 2004 Microsoft MVP, Windows Server - General
    > > www.McGroarty.org
    > >
    > >
    > > "L.H." <LH@discussions.microsoft.com> wrote in message
    > > news:1042C5BF-E752-4A76-8C77-D43EDAF44A5E@microsoft.com...
    > > This computer is at work. My account is as an administrator and the option
    > > is still grayed out.
    > >
    > > Thank you for answering my question.
    > >
    > > "Colin M. McGroarty" wrote:
    > >
    > >> Is the workstation on a home or work network? It is possible that
    > >> security
    > >> policies are being applied to the machine that eliminate the
    > >> functionality.
    > >> Do you have the ability to log onto the machine as an administrator? If
    > >> so,
    > >> is the option still grayed out?
    > >>
    > >> Kind Regards,
    > >>
    > >> --
    > >> Colin M. McGroarty, MCSE, MCP+I, NT-CIP
    > >> 2004 Microsoft MVP, Windows Server - General
    > >> www.McGroarty.org
    > >>
    > >>
    > >> "L.H." <LH@discussions.microsoft.com> wrote in message
    > >> news:70DF2B34-DC27-43FD-9BB7-ADADDC2F5F32@microsoft.com...
    > >> I tried to enable "Remote Desktop" on my machine (running Win XP Pro
    > >> Sevice
    > >> Pack 1), noticed that it is disabled, i.e., "Allow users to connect
    > >> remotely
    > >> to this computer" is greyed out. What's wrong? ("Remote Assistance" is
    > >> OK.)
    > >>
    > >> Thanks!
    > >>
    > >>
    > >>
    > >
    >
    >
  6. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Unfortunately, Domain policy will overwrite local policies...
    ---
    Jeffrey Randow (Windows Networking MVP)
    jeffreyr-support@remotenetworktechnology.com

    Please post all responses to the newsgroups for the benefit
    of all USENET users. Messages sent via email may or may not
    be answered depending on time availability....

    Remote Networking Technology Support Site -
    http://www.remotenetworktechnology.com
    Windows Network Technology Community -
    http://www.microsoft.com/windowsserver2003/community/centers/networking/default.mspx
    Windows Home Networking Community -
    http://www.microsoft.com/windowsxp/expertzone/communities/wireless.mspx

    On Thu, 30 Dec 2004 08:21:46 -0600, "Sooner Al"
    <SoonerAl@somewhere.net.invalid> wrote:

    >To enable/disable Remote Desktop on the XP Pro Remote Desktop host via a Group Policy go to
    >"Start -> Run" and type gpedit.msc at the command line. Navigate to the "Local Computer Policy ->
    >Computer Configuration -> Administrative Templates -> Windows Components -> Terminal Services".
    >Highlight and double-click on "Do not allow new client connections", or if your running SP2 the
    >"Allow users to connect remotely using Terminal Services", policy and configure as needed. Select
    >"Ok"...
    >
    >Reinstalling the client won't help...
  7. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    This is more than likely being disabled by domain group policy... To
    change this, you need to have your group policy membership or settings
    changed...
    ---
    Jeffrey Randow (Windows Networking MVP)
    jeffreyr-support@remotenetworktechnology.com

    Please post all responses to the newsgroups for the benefit
    of all USENET users. Messages sent via email may or may not
    be answered depending on time availability....

    Remote Networking Technology Support Site -
    http://www.remotenetworktechnology.com
    Windows Network Technology Community -
    http://www.microsoft.com/windowsserver2003/community/centers/networking/default.mspx
    Windows Home Networking Community -
    http://www.microsoft.com/windowsxp/expertzone/communities/wireless.mspx

    On Wed, 29 Dec 2004 22:53:30 -0600, "Colin M. McGroarty"
    <CMcGroarty@hotmail.com> wrote:

    >Is the workstation on a home or work network? It is possible that security
    >policies are being applied to the machine that eliminate the functionality.
    >Do you have the ability to log onto the machine as an administrator? If so,
    >is the option still grayed out?
    >
    >Kind Regards,
  8. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Thank you for all the posts! I followed Al's instruction and it works.


    "L.H." wrote:

    > I tried to enable "Remote Desktop" on my machine (running Win XP Pro Sevice
    > Pack 1), noticed that it is disabled, i.e., "Allow users to connect remotely
    > to this computer" is greyed out. What's wrong? ("Remote Assistance" is OK.)
    >
    > Thanks!
  9. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Great...glad it worked for you...

    --
    Al Jarvi (MS-MVP Windows Networking)

    Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
    The MS-MVP Program - http://mvp.support.microsoft.com
    This posting is provided "AS IS" with no warranties, and confers no rights...

    "L.H." <LH@discussions.microsoft.com> wrote in message
    news:977F72CB-A322-4F2E-B5B8-6EBAB7E223F6@microsoft.com...
    > Thank you for all the posts! I followed Al's instruction and it works.
    >
    >
    > "L.H." wrote:
    >
    >> I tried to enable "Remote Desktop" on my machine (running Win XP Pro Sevice
    >> Pack 1), noticed that it is disabled, i.e., "Allow users to connect remotely
    >> to this computer" is greyed out. What's wrong? ("Remote Assistance" is OK.)
    >>
    >> Thanks!
  10. Hi, I'm experiencing a similar problem and was wondering if people found an answer. On my Domain Controller allow remote desktop is checked and grayed out, but even so I cannot log in remotely because it gives me a message that I have to be granted the allow log on through terminal services right. I am logging in as domain admin which after researching seems by default I should have that right. I've checked the local and domain group policy and they are both set to undefined. I've set them to allow and it did not help. I've rebooted the DC, I've gone in the registry to make sure that denyconnections registry setting was set to allow connections. I can't think of anything else. I've noticed on my computer at work this connection is also grayed out even though i'm running as local admin.
Ask a new question

Read More

Remote Desktop Microsoft Windows XP