Can't get to work remote desktop

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

First look at this..

Internet----->HOST pc (home edition)----->client or slave pc (professional
edition).

Ok, understand? I got my network running like that. The router gets the
internet, it goes to my host PC on an ethernet adapter, then i got ANOTHER
ethernet adapter to link the other pc to this one, that other pc has
professional edition.

Ok, I open the port 3389 (port forwarding, speed stream rouert, piece of
cake). I open my windows firewall on both PC allowing remote desktop. First i
try connecting from my host pc to the other pc, no problem, it worked, then,
"just for fun", i asked a friend to take control over my winXP pro PC (the
one is behind this one on my network). To make things easier for me, I use
remote assistance to configure everything on his PC (note he got winXP home
edition, so connecting to his PC from mine wont work since Home edition can't
be controlled remotly, i know that). Ok, i run ipconfig to see which is the
IP address for my other computer, and on remote desktop I put on computer
name (note that I am controlling his PC via remote assistance windows
messenger), it show up this error: "The client could not connect to the
remote computer. Remote connections might not be enabled or the computer
might be too busy to accept new connections. It is also possible that network
problems are preventing your connection. Please try your connection again
later. If the problem continues to occur, contact your administrator.".

So, what could be going wrong? I specified that my winXP pro PC is behind
this PC i am using now "Home edition" becasuse I think that there could be
the mistake, later i will try putting my router directly to the pc running
winXP pro. But i think it should work just as i have my settings right now.
(NOTE that i always let my host pc online and looged on).
7 answers Last reply
More about work remote desktop
  1. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    even with a router forwarding all traffic on 3389 to your XP Home PC,
    your XP Pro machine would not receive any 3389 traffic, because
    it is all processed by the XP Home PC (not forwarded further).

    your XP Pro machine would only receive traffic on 3389, only if your XP
    Home firewall could forward traffic on 3389 to your XP Pro machine, but
    i don't think the XP firewall can do that (act like a router), and i
    don't think Internet Connection Sharing is designed for that either
    (even though ICS knows how to return responses to the right machine that
    originates requests).

    the same is true in the above statements, if you substitute XP Home with
    XP Pro and vice-versa. the router can forward traffic to a machine
    connected to the router (wired or wireless), but software firewalls do
    not do that to my knowledge.

    please accept my apology if i misunderstood your configuration or question.


    Guille wrote:
    > First look at this..
    >
    > Internet----->HOST pc (home edition)----->client or slave pc (professional
    > edition).
    >
    > Ok, understand? I got my network running like that. The router gets the
    > internet, it goes to my host PC on an ethernet adapter, then i got ANOTHER
    > ethernet adapter to link the other pc to this one, that other pc has
    > professional edition.
    >
    > Ok, I open the port 3389 (port forwarding, speed stream rouert, piece of
    > cake). I open my windows firewall on both PC allowing remote desktop. First i
    > try connecting from my host pc to the other pc, no problem, it worked, then,
    > "just for fun", i asked a friend to take control over my winXP pro PC (the
    > one is behind this one on my network). To make things easier for me, I use
    > remote assistance to configure everything on his PC (note he got winXP home
    > edition, so connecting to his PC from mine wont work since Home edition can't
    > be controlled remotly, i know that). Ok, i run ipconfig to see which is the
    > IP address for my other computer, and on remote desktop I put on computer
    > name (note that I am controlling his PC via remote assistance windows
    > messenger), it show up this error: "The client could not connect to the
    > remote computer. Remote connections might not be enabled or the computer
    > might be too busy to accept new connections. It is also possible that network
    > problems are preventing your connection. Please try your connection again
    > later. If the problem continues to occur, contact your administrator.".
    >
    > So, what could be going wrong? I specified that my winXP pro PC is behind
    > this PC i am using now "Home edition" becasuse I think that there could be
    > the mistake, later i will try putting my router directly to the pc running
    > winXP pro. But i think it should work just as i have my settings right now.
    > (NOTE that i always let my host pc online and looged on).
    >
  2. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Guille <Guille@discussions.microsoft.com> wrote:

    > Internet----->HOST pc (home edition)----->client or slave pc
    > (professional edition).
    >
    > Ok, understand? I got my network running like that. The router gets
    > the internet, it goes to my host PC on an ethernet adapter, then i
    > got ANOTHER ethernet adapter to link the other pc to this one, that
    > other pc has professional edition.

    I presume that you have Microsoft ICS (Internet Connection Sharing) active
    in the host XP Home PC. If not, you will never be able to connect between
    the internet and the slave XP Pro PC.

    > Ok, I open the port 3389 (port forwarding, speed stream rouert, piece
    > of cake). I open my windows firewall on both PC allowing remote
    > desktop.

    You also need to configure ICS on the XP Home PC to forward TCP port 3389 to
    the XP Pro slave PC.

    > Ok, i run ipconfig to see which is
    > the IP address for my other computer

    That will not work. For outside callers, they need to call the IP address
    of the WAN interface of your Speedstream router.

    > and on remote desktop I put on computer name

    You cannot use computer names across the internet. The names you give your
    PCs in your home LAN have no meaning in the outside world.

    > it show up this error: "The client
    > could not connect to the remote computer. Remote connections might
    > not be enabled or the computer might be too busy to accept new
    > connections. It is also possible that network problems are preventing
    > your connection. Please try your connection again later. If the
    > problem continues to occur, contact your administrator.".
    >
    > So, what could be going wrong?

    See all the points above.

    --
    Robin Walker [MVP Networking]
    rdhw@cam.ac.uk
  3. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    JW <JustPostYourReply@ToThisNewsGroup.pls> wrote:

    > your XP Pro machine would only receive traffic on 3389, only if your
    > XP Home firewall could forward traffic on 3389 to your XP Pro
    > machine, but i don't think the XP firewall can do that (act like a
    > router), and i
    > don't think Internet Connection Sharing is designed for that either

    ICS is perfectly capable of behaving like a router and being configured to
    forward ports. In XP SP2, the port-forwards can be configured on the
    Advanced panel of Windows Firewall, using the connection-specific
    configuration, which is similar to the ICS configuration of XP and XP SP1.

    --
    Robin Walker [MVP Networking]
    rdhw@cam.ac.uk
  4. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    thanks Robin
    i didn't know port forwarding could be used on software firewalls just
    like with hardware firewalls. thanks to you, now i know.
    glad you chimed in.


    Robin Walker [MVP] wrote:
    > JW <JustPostYourReply@ToThisNewsGroup.pls> wrote:
    >
    >
    >>your XP Pro machine would only receive traffic on 3389, only if your
    >>XP Home firewall could forward traffic on 3389 to your XP Pro
    >>machine, but i don't think the XP firewall can do that (act like a
    >>router), and i
    >>don't think Internet Connection Sharing is designed for that either
    >
    >
    > ICS is perfectly capable of behaving like a router and being configured to
    > forward ports. In XP SP2, the port-forwards can be configured on the
    > Advanced panel of Windows Firewall, using the connection-specific
    > configuration, which is similar to the ICS configuration of XP and XP SP1.
    >
  5. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Problem Solved!!!

    What was the problem?

    Having noticed that I have to forward port 3389 from my router, I have to
    search for my "public IP", not private IP. I wasn't able to find it thru the
    comand 'ip config' because this was giving my private ip. I went into the
    internet and search for a page that could tell me which is my public IP
    (easy, just went to a internet searcher and typed 'ip').

    I gave that IP to my friend, and he wrote it, and that's it! Thanks everyone
    for your help!! This forum is for great help!!
  6. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    I have the same network configuration and in the process of installing XP Pro
    in a client PC to enable remote access from the outside. My Host PC runs XP
    Home with Norton Internet Sercurity as a Firewall, insteacd of Windows.

    Does anyone know how to "open" Port 3389 within Norton?

    Thanks,
    Eduardo

    "Guille" wrote:

    > First look at this..
    >
    > Internet----->HOST pc (home edition)----->client or slave pc (professional
    > edition).
    >
    > Ok, understand? I got my network running like that. The router gets the
    > internet, it goes to my host PC on an ethernet adapter, then i got ANOTHER
    > ethernet adapter to link the other pc to this one, that other pc has
    > professional edition.
    >
    > Ok, I open the port 3389 (port forwarding, speed stream rouert, piece of
    > cake). I open my windows firewall on both PC allowing remote desktop. First i
    > try connecting from my host pc to the other pc, no problem, it worked, then,
    > "just for fun", i asked a friend to take control over my winXP pro PC (the
    > one is behind this one on my network). To make things easier for me, I use
    > remote assistance to configure everything on his PC (note he got winXP home
    > edition, so connecting to his PC from mine wont work since Home edition can't
    > be controlled remotly, i know that). Ok, i run ipconfig to see which is the
    > IP address for my other computer, and on remote desktop I put on computer
    > name (note that I am controlling his PC via remote assistance windows
    > messenger), it show up this error: "The client could not connect to the
    > remote computer. Remote connections might not be enabled or the computer
    > might be too busy to accept new connections. It is also possible that network
    > problems are preventing your connection. Please try your connection again
    > later. If the problem continues to occur, contact your administrator.".
    >
    > So, what could be going wrong? I specified that my winXP pro PC is behind
    > this PC i am using now "Home edition" becasuse I think that there could be
    > the mistake, later i will try putting my router directly to the pc running
    > winXP pro. But i think it should work just as i have my settings right now.
    > (NOTE that i always let my host pc online and looged on).
    >
  7. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Eduardo Pietri <Eduardo Pietri@discussions.microsoft.com> wrote:

    > My Host PC runs XP Home with Norton Internet Sercurity as a
    > Firewall, insteacd of Windows.
    >
    > Does anyone know how to "open" Port 3389 within Norton?

    XP Home does not support being a Remote Desktop host, so opening port 3389
    is pointless.

    XP Home can run the Remote Desktop Client, but that does not require any
    ports to be opened, as it would be an outgoing connection.

    --
    Robin Walker [MVP Networking]
    rdhw@cam.ac.uk
Ask a new question

Read More

Remote Desktop Ethernet Card Windows XP