Sign in with
Sign up | Sign in
Your question

Various Windows 7 annoyances...

Last response: in Windows 7
Share
January 7, 2011 4:05:38 PM

Hello all,

I skipped over Vista, so I'm moving directly from XP to Windows 7, and as I'm sure you're all aware there are more than a few differences between XP and Windows 7. In addition, I'm also running a 64-bit operating system with this new Windows 7 Ultimate for the first time for me.

Lots of questions,... if you have any ideas on even one of them, it'd be appreciated.

- Disabling Windows 7 blocking of all unsigned drivers

I was trying to install Acronis True Image 8.0 in Windows 7 and it refused to do that saying that it had an unsigned driver... in fact, the first time I tried to do this, I believe Windows 7 uninstalled a whole bunch of other programs besides the two Acronis program I was trying to install... Disk Director was the other one. In any case, after I reinstalled all the programs Windows 7 had uninstalled, I tried disabling the boot integrity checks and got Windows 7 in Test Mode, but it still wouldn't install Acronis True Image. I didn't want to delete the boot integrity checks, so I took Windows 7 out of Test Mode, and set my sights on trying to install True Image in Windows XP Mode, which, if like is the default for Windows XP, might warn me of unsigned drivers, but would let me install True Image anyway. More on that effort below...

For now, is there some reasonably 'kosher' manner in which to tell Windows 7 to install software with unsigned drivers? It's telling me that I should go back to Acronis and ask them if they have a copy of True Image 8.0 with signed drivers... However, I have a strong suspicion that Acronis is just going to say no,... you need to pay for an upgrade.

- Windows XP Mode

EchoVNC won't install in Windows XP Mode? I don't understand... it just hangs at a certain point in the installation?

Acronis True Image 8.0 also won't install in Windows XP Mode? It too just hangs at a certain point in the installation? So much for my clever attempt to get around Windows 7 refusal to install unsigned drivers(!)

I've already reinstalled Windows XP Mode once because I've corrupted its installation. Now, it seems I may have corrupted it again. In this incarnation of Windows XP Mode I haven't tried to install EchoVNC, but I did try to install Acronis True Image, which was a disaster... When I tried to start it up after the partial installation, True Image just says you have to complete the installation, but there's no obvious method through which to do that. What's more, True Image doesn't show up the Add/Drop Programs listing in the Control Panel, so it's not obvious how to uninstall the partial installation either. So, I just deleted it shortcuts on the Start Menu, desktop, etc. deleting its program folders and ran the Wise Registry Cleaner, and hoped that I got most of it. However, I also ran the Registry Cleaner's registry Defrag, and after it defragged the registry and asked if I wanted to reboot now, I said yes.

Well, Windows XP Mode didn't reboot (restart)... and now Windows XP Mode refuses to reboot, shut down... It will hibernate, but I believe there are some things, like completing the compacting of the registry for which I'll need to reboot Windows XP Mode. Any ideas on how to get past this problem and get Windows XP Mode to reboot... or, is the only choice to once again uninstall Windows XP Mode and reinstall?

Also, in the first incarnation of Windows XP Mode I tried to check Windows XP Mode to a static IP address, and I think(!) that got it upset... I pretty sure I had it set for bridged networking. I'm not sure if this corrupted Windows XP Mode in its first incarnation, but does anyone know if this gets Windows XP Mode upset?

Also, like with VMWare, is there some way to take a 'Snapshot'... an image... of the virtual machine in Windows Virtual PC? If I have to reinstall Windows XP Mode again, it'd be nice to be able to take a Snapshot of Windows XP Mode before I do anything that might corrupt it again...

- Teracopy, run as administrator

Coming from XP, this run as administrator annoyance is new, and unlike Unix, it often doesn't seem to make sense to me. For instance, if I try to copy folders in one of the program folders (I'm running 64-bit Windows 7) Windows 7 refuses saying something about needing administrator privileges. However, unlike when I try to do the same copying through FileMenu tools, for instance, it doesn't prompt me to grant the administrator privilege and proceed. What's kinda bizarre to me here is that Teracopy was installed with an administrator account and is being run from an administrator account (at least seemingly!)

So, what's going on? Is Windows 7 actually not running Teracopy from the account that I'm logged in under? Presumably a non-administrator account? If this is the case, can I perhaps tell Windows 7... perhaps I'll have to reinstall these programs... to use some administrator account to run them? Certainly with Teracopy, Windows 7 just refuses to do the operation and doesn't even prompt me to grant the administrator privilege...

- Sysinternals, pagedfrg

I know Vista and Windows 7 have enhanced caching operations, etc., but I believe Windows 7 does still have a pagefile, yes?

When I try to launch pagedfrg, even with using "Run as administrator", Windows 7 gives me this error...

---------------------------
Pagefile Defragger
---------------------------
Make sure that you are an administrator.
Error loading PageDefrag driver.
---------------------------
OK
---------------------------

Again, I am running from an administrator account. Does pagedfrg just not work in Windows 7?

- Bootmgr, bcdedit, EasyBCD

On the hard disk on the machine where Windows 7 now runs there's a HP recovery partition which I didn't not to delete even though I do have the recovery disks. When Windows 7 originally installed itself it included a link to this... what it apparently thought was an old Windows OS... on the boot menu. I tried it to see if it would work... it did bring up the initial screens, but I stop it before it actually started making changes to the hard disk. However, when I went to reboot, the system wouldn't boot. I'm assuming the HP recovery routine made some changes to the MBR and/or the boot sector of Windows 7 partition.

In any case, I was able to use the repair facility on the Windows 7 DVD to repair the boot menu to reestablish access to Windows 7. However, there was no longer a link on the boot menu to the HP recovery partition (probably for the better!) nor a link to the Recovery Console, both of which were on the main initial boot menu with Windows 7.

I'd kinda like a link on the main boot menu to the Recovery Console,... although, correct me if I'm wrong... but it appears that you can still get to the (new Windows 7) Recovery Console by going to the secondary boot menu and following the link 'Repair my computer' and go to the command prompt...?

EasyBCD doesn't appear to do anything this involved... so, if I decide to attempt to make a link to the Recovery Console on the main boot menu, does anyone know of a thorough tutorial and/or reference on bcdedit? Am I correct that Windows 7 doesn't use boot.ini anymore?

Also... I thought Windows 7 was supposed to install a hidden recovery partition,... in case the Windows 7 system partition gets corrupted... but I'm not seeing it with Acronis Disk Director from within Windows 7 or from boot...? Did I just misunderstand about this hidden recovery partition, or is it a special Windows 7 installation option?

Thanks,

Paul
pmccarthy002@nc.rr.com
pmccarthy002@gmail.com

More about : windows annoyances

a b $ Windows 7
January 7, 2011 4:22:48 PM

Ku Ku Kachoo.
a b $ Windows 7
January 7, 2011 6:56:31 PM

This post is a bit long and hard for me to remember, so I will deal with your first complaint about installing Acronis True Image 8.
It is not compatible with Windows 7 and no amount of control access is going to change it. Put simply it won't work, it's not even Vista compatible. Acronis True Image 2010 Home works with W7, but it's Acronis True Image 2011 that is W7 certified.

You can go to microsoft and check compatability of your programs and devices.
http://www.microsoft.com/windows/compatibility/windows-...
!