Windows 7 Remote Desktop

Hello,
I've read the thread(s) regarding this issue but it doesn't appear to have been resolved in my situation. I have used Remote Desktop to connect to a Windows 7 64 bit computer using Windows 7 for a long time. I recently got a new Windows 7 64 bit PC to replace the standard Windows 7 computer. Now, whenever I minimize my remote desktop client window on my new PC, it immediately disconnects from the remote session. When I maximize the window, it automatically tries to reconnect. It is not always successful and takes several minutes to get back to the remote session which is still running as if I never left. The event viewer on the remote computer shows this message:
The RDP protocol component X.224 detected an error in the protocol stream and has disconnected the client.
I have looked on the search engines and on Microsoft, but nothing addresses this issue in Windows 7 and most answers don't take into account that it only happens when the client is minimized. Since it worked just fine until I went from using the RDP client on a Win 7 PC to a Win 7 64 bit PC I'm assuming that it has something to do with a setting on the new PC, but I have not been able to find a single setting that relates to this issue. I'm using remote desktop for administration only and I am the only user of the remote PC. Any ideas?
5 answers Last reply
More about windows remote desktop
  1. Strange problem indeed. I havent had isssues doing 32bit anything into my W7 64bit machines. If it was a server I would look at the policy settings but it isnt.

    Have you tried updating the ethernet drivers on either on them? It may be dropping some packets for some strange reason.
  2. Use WRD all the time to connect to server, never had a drop out, although I am using a different port number than the default.
  3. All of my drivers are up to date and the problem still persists. I think I've narrowed it down to a Netgear WNDR 3700 V1 router, but it could still be a setting somewhere on my new RDP client. What I've noticed is that sometimes I can minimize the RD client window and come back to it 30 minutes later and it's still working. Sometimes I come back to it and the window is black and unresponsive after one minute, sometimes I come back to it and I can see what was on my screen when I minimized it, but it is unresponsive. Sometimes the client will reconnect to the session without needing a password, sometimes it says "can't connect to the remote computer", but then when I click "connect" right away, I can login as usual. There must be some setting either in the router or the client that is sending some sort of suspend command whenever I minimize the client, or somewhere in the router that gives a timeout command when there is no activity? This is one of the toughest problems I've ever encountered, and one of the most frustrating! Thanks for the suggestions, keep them coming!
  4. this computer can't connect to the remote computer try connecting again.If the problem continues, contact owner of the remote computer or your network administrator
  5. I have EXACTLY the same problem and EXACTLY the same router! So did you ever figure it out?! It's been over a year now and I never saw a conclusion.
Ask a new question

Read More

Configuration Remote Desktop Windows 7