Sign in with
Sign up | Sign in
Your question

Remote desktop not connecting thru VPN

Last response: in Windows XP
Share
Anonymous
February 1, 2005 11:01:03 PM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Hi,

Here is my setup. Two offices with D-Link VPN routers. Each router has a
computer connected with XP pro, no windows firewall. No hibernation, no
spyware, virus. Port 3389 open in router's firewall for both TCP/UDP and
"always on" connection. From my house I can always establish the VPN
connection but Remote desktop will not hold a connection, sometimes it will
connect, maybe twice a day in more than 100 attempts, sometimes, no
connection at all, sometimes the remote computer will ask for my ID and
password then after entering it and getting to the desktop of my remote PC it
willl freeze. Sometimes I see the little tab at the top and nothing else,
sometimes, the little remote desktop tab at the top and a black screen. I
have exhausted 3rd level support with D-link and they can't find anything to
correct this. Any help? Eight straight days in the same situation. Really
tired of this. Please send yr comments.

Regards,
Anonymous
February 1, 2005 11:45:03 PM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Try disabling the point-to-point VPN, and try to connect over the public
Internet. If this works then you know it a problem with the VPN.

When doing this, the firewall on the router should be enabled and port 3389
should be open to the terminal server host.

Patrick Rouse
Microsoft MVP - Terminal Server
http://www.workthin.com

"Cuzurro" wrote:

> Hi,
>
> Here is my setup. Two offices with D-Link VPN routers. Each router has a
> computer connected with XP pro, no windows firewall. No hibernation, no
> spyware, virus. Port 3389 open in router's firewall for both TCP/UDP and
> "always on" connection. From my house I can always establish the VPN
> connection but Remote desktop will not hold a connection, sometimes it will
> connect, maybe twice a day in more than 100 attempts, sometimes, no
> connection at all, sometimes the remote computer will ask for my ID and
> password then after entering it and getting to the desktop of my remote PC it
> willl freeze. Sometimes I see the little tab at the top and nothing else,
> sometimes, the little remote desktop tab at the top and a black screen. I
> have exhausted 3rd level support with D-link and they can't find anything to
> correct this. Any help? Eight straight days in the same situation. Really
> tired of this. Please send yr comments.
>
> Regards,
>
Anonymous
February 2, 2005 11:11:04 PM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

I disabled the point-to-point vpn, rdp would not connect either. Port 3389 is
open in the firewall.

"Patrick Rouse" wrote:

> Try disabling the point-to-point VPN, and try to connect over the public
> Internet. If this works then you know it a problem with the VPN.
>
> When doing this, the firewall on the router should be enabled and port 3389
> should be open to the terminal server host.
>
> Patrick Rouse
> Microsoft MVP - Terminal Server
> http://www.workthin.com
>
> "Cuzurro" wrote:
>
> > Hi,
> >
> > Here is my setup. Two offices with D-Link VPN routers. Each router has a
> > computer connected with XP pro, no windows firewall. No hibernation, no
> > spyware, virus. Port 3389 open in router's firewall for both TCP/UDP and
> > "always on" connection. From my house I can always establish the VPN
> > connection but Remote desktop will not hold a connection, sometimes it will
> > connect, maybe twice a day in more than 100 attempts, sometimes, no
> > connection at all, sometimes the remote computer will ask for my ID and
> > password then after entering it and getting to the desktop of my remote PC it
> > willl freeze. Sometimes I see the little tab at the top and nothing else,
> > sometimes, the little remote desktop tab at the top and a black screen. I
> > have exhausted 3rd level support with D-link and they can't find anything to
> > correct this. Any help? Eight straight days in the same situation. Really
> > tired of this. Please send yr comments.
> >
> > Regards,
> >
Related resources
Anonymous
February 3, 2005 12:05:46 AM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Cuzurro <Cuzurro@discussions.microsoft.com> wrote:

> Two offices with D-Link VPN routers. Each router
> has a computer connected with XP pro, no windows firewall. No
> hibernation, no spyware, virus. Port 3389 open in router's firewall
> for both TCP/UDP and "always on" connection. From my house I can
> always establish the VPN connection but Remote desktop will not hold
> a connection, sometimes it will connect, maybe twice a day in more
> than 100 attempts, sometimes, no connection at all, sometimes the
> remote computer will ask for my ID and password then after entering
> it and getting to the desktop of my remote PC it willl freeze.

Since the routers are doing the VPN end-points, your ethernet network
connection is unaware of the MTU restriction imposed by the hidden VPN link.

In your PC (and maybe also in the one at the other end), you need to reduce
the MTU for the network interface connecting to the D-Link router. You can
adjust the MTU of any of your network connections by using the utility DrTCP
from http://www.broadbandreports.com/drtcp

Ensure that you have the correct network interface selected before setting
the MTU. The default (blank entry) is equivalent to 1500 bytes. You will
need to set a smaller figure than 1500 to get reliable connections. You can
trial it at 1400, for instance, but you might be able to go higher. You
lose 8 bytes off the 1500 if your internet connection is via PPPoE (as are
most DSL), and you probably lose at least another 8 bytes for the VPN
encapsulation.

After you have adjusted the MTU, you need to disable and then re-enable the
network connection (or restart Windows) to get the new setting to take.

--
Robin Walker [MVP Networking]
rdhw@cam.ac.uk
Anonymous
February 3, 2005 12:05:47 AM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

I have tried Dr.TCP and lowering MTU values to no avail.

Cuzurro.

"Robin Walker [MVP]" wrote:

> Cuzurro <Cuzurro@discussions.microsoft.com> wrote:
>
> > Two offices with D-Link VPN routers. Each router
> > has a computer connected with XP pro, no windows firewall. No
> > hibernation, no spyware, virus. Port 3389 open in router's firewall
> > for both TCP/UDP and "always on" connection. From my house I can
> > always establish the VPN connection but Remote desktop will not hold
> > a connection, sometimes it will connect, maybe twice a day in more
> > than 100 attempts, sometimes, no connection at all, sometimes the
> > remote computer will ask for my ID and password then after entering
> > it and getting to the desktop of my remote PC it willl freeze.
>
> Since the routers are doing the VPN end-points, your ethernet network
> connection is unaware of the MTU restriction imposed by the hidden VPN link.
>
> In your PC (and maybe also in the one at the other end), you need to reduce
> the MTU for the network interface connecting to the D-Link router. You can
> adjust the MTU of any of your network connections by using the utility DrTCP
> from http://www.broadbandreports.com/drtcp
>
> Ensure that you have the correct network interface selected before setting
> the MTU. The default (blank entry) is equivalent to 1500 bytes. You will
> need to set a smaller figure than 1500 to get reliable connections. You can
> trial it at 1400, for instance, but you might be able to go higher. You
> lose 8 bytes off the 1500 if your internet connection is via PPPoE (as are
> most DSL), and you probably lose at least another 8 bytes for the VPN
> encapsulation.
>
> After you have adjusted the MTU, you need to disable and then re-enable the
> network connection (or restart Windows) to get the new setting to take.
>
> --
> Robin Walker [MVP Networking]
> rdhw@cam.ac.uk
>
>
>
!