RDP to Internal Ip with ICS Port Forwarding

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Hi there

I have the following set up:
Box A - Windows XP Pro, Cable connection to the internet with static IP and
software firewall, ICS enabled (my box)
Box B - Windows XP Pro, Networked to Box A with internal 192.168.x.x IP
address. (friends box)

I would like to have remote access to my machine, and likewise my friend
would like to have remote access to his machine.

I set up a port forwarding from 3390 to 3389 on the internal IP address and
use statis_ip:3390 in the RD client to connect, but this does not work. I am
getting an error message that the connection cannot be made, computer may be
too busy to accept connections.

I allowed a rule in my firewall (Norton Internet Secruity professional) to
allow traffic incoming and outgoing on por 3390, but still no joy. I even
changed the listening RDP port on Box B to 3390 and changed the port forward
on Box A to 3390>3390 but I am still getting the same error.

Can anyone suggest what else I can try?

Thanks in advance,
Adam
3 answers Last reply
More about internal port forwarding
  1. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Look at this page for help with this issue...

    http://theillustratednetwork.mvps.org/RemoteDesktop/Multiple_PC_RD.html

    --
    Al Jarvi (MS-MVP Windows Networking)

    Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
    The MS-MVP Program - http://mvp.support.microsoft.com
    This posting is provided "AS IS" with no warranties, and confers no rights...

    "Adam" <Adam@discussions.microsoft.com> wrote in message
    news:8479A507-B59D-4C34-9F77-8A8E6236B886@microsoft.com...
    > Hi there
    >
    > I have the following set up:
    > Box A - Windows XP Pro, Cable connection to the internet with static IP and
    > software firewall, ICS enabled (my box)
    > Box B - Windows XP Pro, Networked to Box A with internal 192.168.x.x IP
    > address. (friends box)
    >
    > I would like to have remote access to my machine, and likewise my friend
    > would like to have remote access to his machine.
    >
    > I set up a port forwarding from 3390 to 3389 on the internal IP address and
    > use statis_ip:3390 in the RD client to connect, but this does not work. I am
    > getting an error message that the connection cannot be made, computer may be
    > too busy to accept connections.
    >
    > I allowed a rule in my firewall (Norton Internet Secruity professional) to
    > allow traffic incoming and outgoing on por 3390, but still no joy. I even
    > changed the listening RDP port on Box B to 3390 and changed the port forward
    > on Box A to 3390>3390 but I am still getting the same error.
    >
    > Can anyone suggest what else I can try?
    >
    > Thanks in advance,
    > Adam
  2. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    This article makes reference fo ICF. Do I need the windows firewall enabled
    to get this to work? I only have ICS enabled to share the connection, I am
    not using the Windows Firewall.


    "Sooner Al [MVP]" wrote:

    > Look at this page for help with this issue...
    >
    > http://theillustratednetwork.mvps.org/RemoteDesktop/Multiple_PC_RD.html
    >
    > --
    > Al Jarvi (MS-MVP Windows Networking)
    >
    > Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
    > The MS-MVP Program - http://mvp.support.microsoft.com
    > This posting is provided "AS IS" with no warranties, and confers no rights...
    >
    > "Adam" <Adam@discussions.microsoft.com> wrote in message
    > news:8479A507-B59D-4C34-9F77-8A8E6236B886@microsoft.com...
    > > Hi there
    > >
    > > I have the following set up:
    > > Box A - Windows XP Pro, Cable connection to the internet with static IP and
    > > software firewall, ICS enabled (my box)
    > > Box B - Windows XP Pro, Networked to Box A with internal 192.168.x.x IP
    > > address. (friends box)
    > >
    > > I would like to have remote access to my machine, and likewise my friend
    > > would like to have remote access to his machine.
    > >
    > > I set up a port forwarding from 3390 to 3389 on the internal IP address and
    > > use statis_ip:3390 in the RD client to connect, but this does not work. I am
    > > getting an error message that the connection cannot be made, computer may be
    > > too busy to accept connections.
    > >
    > > I allowed a rule in my firewall (Norton Internet Secruity professional) to
    > > allow traffic incoming and outgoing on por 3390, but still no joy. I even
    > > changed the listening RDP port on Box B to 3390 and changed the port forward
    > > on Box A to 3390>3390 but I am still getting the same error.
    > >
    > > Can anyone suggest what else I can try?
    > >
    > > Thanks in advance,
    > > Adam
    >
    >
  3. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    You need to modify your NIS Pro settings based on the settings I illustrated on that page. Check
    with their support web pages for instructions on how to do that... I don't personally use NIS...

    Any chance you could budget the purchase of a broadband router for your network. It makes it a lot
    easier to setup, plus you have the added benefit of not having to have your PC powered on just so
    your friend can access the internet. Also a broadband router's NAT firewall functionality adds
    another level of security to your internet connection...

    --
    Al Jarvi (MS-MVP Windows Networking)

    Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
    The MS-MVP Program - http://mvp.support.microsoft.com
    This posting is provided "AS IS" with no warranties, and confers no rights...

    "Adam" <Adam@discussions.microsoft.com> wrote in message
    news:0AC1ADAA-2693-489E-B12F-42736B50D235@microsoft.com...
    > This article makes reference fo ICF. Do I need the windows firewall enabled
    > to get this to work? I only have ICS enabled to share the connection, I am
    > not using the Windows Firewall.
    >
    >
    > "Sooner Al [MVP]" wrote:
    >
    >> Look at this page for help with this issue...
    >>
    >> http://theillustratednetwork.mvps.org/RemoteDesktop/Multiple_PC_RD.html
    >>
    >> --
    >> Al Jarvi (MS-MVP Windows Networking)
    >>
    >> Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
    >> The MS-MVP Program - http://mvp.support.microsoft.com
    >> This posting is provided "AS IS" with no warranties, and confers no rights...
    >>
    >> "Adam" <Adam@discussions.microsoft.com> wrote in message
    >> news:8479A507-B59D-4C34-9F77-8A8E6236B886@microsoft.com...
    >> > Hi there
    >> >
    >> > I have the following set up:
    >> > Box A - Windows XP Pro, Cable connection to the internet with static IP and
    >> > software firewall, ICS enabled (my box)
    >> > Box B - Windows XP Pro, Networked to Box A with internal 192.168.x.x IP
    >> > address. (friends box)
    >> >
    >> > I would like to have remote access to my machine, and likewise my friend
    >> > would like to have remote access to his machine.
    >> >
    >> > I set up a port forwarding from 3390 to 3389 on the internal IP address and
    >> > use statis_ip:3390 in the RD client to connect, but this does not work. I am
    >> > getting an error message that the connection cannot be made, computer may be
    >> > too busy to accept connections.
    >> >
    >> > I allowed a rule in my firewall (Norton Internet Secruity professional) to
    >> > allow traffic incoming and outgoing on por 3390, but still no joy. I even
    >> > changed the listening RDP port on Box B to 3390 and changed the port forward
    >> > on Box A to 3390>3390 but I am still getting the same error.
    >> >
    >> > Can anyone suggest what else I can try?
    >> >
    >> > Thanks in advance,
    >> > Adam
    >>
    >>
Ask a new question

Read More

Port Forwarding IP Windows XP