TightVNC "Failed to connect to server" issue

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

I have just set up TightVNC on my home machine which is running XP Home
edition. It is my first experience using VNC with port forwarding from
a router (I have comcast for internet access and a SpeedStream 2623
wireless router connecting my cable modem to my PC). When I try to
establish a connection from a client, it will pause for maybe 10
seconds and then return with a "Failed to connect to server" dialog.
The puzzling thing is that I turned on logging for the server and from
the log file it looks like it's connecting just fine. The log entry
looks like this:

Tue Feb 08 22:17:17 2005
vncSockConnect.cpp : accepted connection from xx.xx.xx.x
vncClient.cpp : client connected : xx.xx.xx.xx (id 1)

If I use http://www.gotomyvnc.com/ it tells me that my VNC server is
accepting connections just fine (and that entry too shows up in the log

Could anybody give me some guidance as to why the log shows that the
client connects, but the client doesn't seem to realize this?

I'm a bit suspicious of the advanced settings in the tightvnc server,
which I admittedly don't fully understand. I have:
For Query Settings:
Query Console on incoming connections: Checked
Query Timeout: 120
Default Action: Accept
Allow option to accept without authentication: not checked
For Administration:
Disable empty passwords: checked
Allow loopback connections: not checked

If anybody has any clue whatsoever what I can try, I would very much
appreciated. So far all my spelunking in documentation and FAQ's have
not turned out anything that works

Thanks!

Sergio.
7 answers Last reply
More about tightvnc failed connect server issue
  1. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Sergio:
    Here's a few things to check:

    When you set up the Server on your PC, you had to specify a port, possibly
    5900. This port wil need to be opened on your router. This can be done in
    the port forwarding section. You want to forward whatever port you specified
    during setup to your PC's internal IP address on the network utilizing a
    TCP/IP connection (opposed to UDP) (the internal network IP is probably
    something like 192.168.1.xxx). If you don't know your IP, go to Start--> Run
    and type CMD and hit enter. Then type ipconfig /all at the prompt and scroll
    down to find your IP address.

    Also, uncheck the box for query console on incoming connection. What this
    means is that the PC you are trying to connect to is waiting at a pop-up box
    for someone to click OK to accept the incoming VNC request. If no one is
    sitting at the computer you want to control, you will get the timeout message
    you have been getting.

    Also make sure you are specifying a password that must be entered in order
    to access the PC. This will ensure security for the connection, and will
    have no affect on the issues you have been having.

    Good luck, I hope this helps. Let me know either way. If it doesn't, I'll
    see what other advice I can offer.

    -Jon

    "Sergio" wrote:

    > I have just set up TightVNC on my home machine which is running XP Home
    > edition. It is my first experience using VNC with port forwarding from
    > a router (I have comcast for internet access and a SpeedStream 2623
    > wireless router connecting my cable modem to my PC). When I try to
    > establish a connection from a client, it will pause for maybe 10
    > seconds and then return with a "Failed to connect to server" dialog.
    > The puzzling thing is that I turned on logging for the server and from
    > the log file it looks like it's connecting just fine. The log entry
    > looks like this:
    >
    > Tue Feb 08 22:17:17 2005
    > vncSockConnect.cpp : accepted connection from xx.xx.xx.x
    > vncClient.cpp : client connected : xx.xx.xx.xx (id 1)
    >
    > If I use http://www.gotomyvnc.com/ it tells me that my VNC server is
    > accepting connections just fine (and that entry too shows up in the log
    >
    > Could anybody give me some guidance as to why the log shows that the
    > client connects, but the client doesn't seem to realize this?
    >
    > I'm a bit suspicious of the advanced settings in the tightvnc server,
    > which I admittedly don't fully understand. I have:
    > For Query Settings:
    > Query Console on incoming connections: Checked
    > Query Timeout: 120
    > Default Action: Accept
    > Allow option to accept without authentication: not checked
    > For Administration:
    > Disable empty passwords: checked
    > Allow loopback connections: not checked
    >
    > If anybody has any clue whatsoever what I can try, I would very much
    > appreciated. So far all my spelunking in documentation and FAQ's have
    > not turned out anything that works
    >
    > Thanks!
    >
    > Sergio.
    >
    >
  2. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Jon: Thanks very much for your reply. I think that I have all the
    settings indicated by you in order (port forwarding and such). I assume
    this is the case given that gotomyvnc checks out fine. Just in case it
    was a firewall issue, I retried the whole thing turning off my router
    firewall and my winXP SP2 firewall too and still no dice... Do you
    happen to know what the "Allow Loopback Connections" setting is for?
    That's still a mystery to me... In the meantime, I will try it from a
    couple of different clients just to make sure it's not a client
    problem.

    Thanks again for your advice!

    Sergio.
  3. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Sergio,

    The 'Allow Local Loopback Connection' is not needed. It is used for secure
    tunneling (like SSH) because the actual connection is done from the SSH
    server over the loopback address. This is used for tunneling within your
    network. Since you are trying to access from the outside and probably will
    have no need for SSH tunneling, this feature does not need to be enabled.

    Did you have any luck trying from a different client?

    -Jon

    "Sergio" wrote:

    > Jon: Thanks very much for your reply. I think that I have all the
    > settings indicated by you in order (port forwarding and such). I assume
    > this is the case given that gotomyvnc checks out fine. Just in case it
    > was a firewall issue, I retried the whole thing turning off my router
    > firewall and my winXP SP2 firewall too and still no dice... Do you
    > happen to know what the "Allow Loopback Connections" setting is for?
    > That's still a mystery to me... In the meantime, I will try it from a
    > couple of different clients just to make sure it's not a client
    > problem.
    >
    > Thanks again for your advice!
    >
    > Sergio.
    >
    >
  4. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Hello again! Indeed, it turned out to be some client-specific issue. I
    was able to connect from a different PC and it's now working just fine.

    Thanks again for all your help!

    Sergio.
  5. Hi Sergio,

    It seems I face the same problem, a client-specific issue preventing that specific client from connecting to the server. Would you please tell me how you solved your problem. Your solution may help my PC connect to the server.

    Best Regards,
    Dalia
  6. I know this is an old thread, but this is the problem I am having right now. I have installed TightVNC on both my Vista box and my XP box. I have added port forwarding for both ports 5800 and 5900 to my router with the internal IP address of my Vista box, which is set as static. I have the DynDNS Updater installed, and it is working fine, reporting as the external IP for the router exactly the IP being reported by my router. I unblocked the TightVNC Server software on my Vista box, and opened ports number 5800 and 5900. This all seems to me to be in order, per what I'm seeing written all over the internet. Unfortunately, this doesn't work for me, and I'm a little bit lost as to why.

    What does work is if I go to the XP box and start TightVNC Viewer giving it the internal IP address for my Vista box. I get a response login prompt, and I can login and see the Vista desktop. What doesn't work is that if I give the external IP address for the router, or the known machine name corresponding to that, I get a "Failed to connect to server" message. Oh, and if I start a viewer from my XP laptop it does the same thing.

    I need to be able to log in from outside of my LAN. Any suggestions would be well appreciated right now.
    Thanks...
    Bruce
  7. I'm using Real VNC for a remote desktop connection. The problem is that my computer can't be remotely accessed, although all the settings seem to be properly applied. Remote desktop is enabled in advanced system properties, and the VNC option is checked in the windows firewall. For some reason however, the ports 3389 and 5900 are still closed. I'm not using a router. Any idea what the problem might be?
    Thanks
    Roger
Ask a new question

Read More

Connection Servers Windows XP