Sign in with
Sign up | Sign in
Your question

Remoted Desktop fails outside firewall

Last response: in Windows XP
Share
Anonymous
February 10, 2005 6:39:36 AM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

I am trying to get remote desktop working so I can access my computer from
work. I have a linksys befw11s4 router. I have port 3389 forwarded and
dynamic forwarding set up through dyndns.org It works if I use it from
within my firewall using my dyndns address or my internal address. When I
connect from outside my firewall it does not work. If I connect using the
web version of the remote desktop I can get to my pc but it fails when I try
to connect.

Any Ideas?
Anonymous
February 10, 2005 3:05:09 PM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

On Thu, 10 Feb 2005 03:39:36 GMT, "Randall W. Bowles"
<randall70b-news1@yahoo.com> wrote:

>I am trying to get remote desktop working so I can access my computer from
>work. I have a linksys befw11s4 router. I have port 3389 forwarded and
>dynamic forwarding set up through dyndns.org It works if I use it from
>within my firewall using my dyndns address or my internal address. When I
>connect from outside my firewall it does not work. If I connect using the
>web version of the remote desktop I can get to my pc but it fails when I try
>to connect.
>
>Any Ideas?

Not too familiar with linksys, you have 3389 forwarded to your
internal address correct ? Maybe your work has their router spoofed,
can you ping your work from home and get a reply ?
>
Anonymous
February 10, 2005 3:05:10 PM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

That's a good point "Humpy" brings up...Your work network administrators may be blocking TCP Port
3389 outbound...

Two other ways to test are...

1. Try to access your home PC using Remote Desktop from a friends house, ie. not work...using both
the dyndns.org alias and the public IP of your router.
2. Go to this site, while at home on the PC you want to RD into...and see if it connects on TCP Port
3389...

http://www.canyouseeme.org/

--
Al Jarvi (MS-MVP Windows Networking)

Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
The MS-MVP Program - http://mvp.support.microsoft.com
This posting is provided "AS IS" with no warranties, and confers no rights...

"Humpy" <rex@ioy.com> wrote in message news:bs4n0113t1e70fhamudpr92uvcjnmuaegt@4ax.com...
> On Thu, 10 Feb 2005 03:39:36 GMT, "Randall W. Bowles"
> <randall70b-news1@yahoo.com> wrote:
>
>>I am trying to get remote desktop working so I can access my computer from
>>work. I have a linksys befw11s4 router. I have port 3389 forwarded and
>>dynamic forwarding set up through dyndns.org It works if I use it from
>>within my firewall using my dyndns address or my internal address. When I
>>connect from outside my firewall it does not work. If I connect using the
>>web version of the remote desktop I can get to my pc but it fails when I try
>>to connect.
>>
>>Any Ideas?
>
> Not too familiar with linksys, you have 3389 forwarded to your
> internal address correct ? Maybe your work has their router spoofed,
> can you ping your work from home and get a reply ?
>>
>
Related resources
Anonymous
February 11, 2005 7:01:02 AM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

I was told from a co-worker that it may in fact be blocked but they are not
sure. I will try your suggestion of having a friend connect from there
house.

I have been connecting using a different port with port forwarding. IE.
http://xxxxx.gotdns.com:3737/tsweb/ Would this bypass port 3389?

Thanks,

Randy


"Sooner Al [MVP]" <SoonerAl@somewhere.net.invalid> wrote in message
news:o 6iYga5DFHA.3972@TK2MSFTNGP15.phx.gbl...
> That's a good point "Humpy" brings up...Your work network administrators
> may be blocking TCP Port 3389 outbound...
>
> Two other ways to test are...
>
> 1. Try to access your home PC using Remote Desktop from a friends house,
> ie. not work...using both the dyndns.org alias and the public IP of your
> router.
> 2. Go to this site, while at home on the PC you want to RD into...and see
> if it connects on TCP Port 3389...
>
> http://www.canyouseeme.org/
>
> --
> Al Jarvi (MS-MVP Windows Networking)
>
> Please post *ALL* questions and replies to the news group for the mutual
> benefit of all of us...
> The MS-MVP Program - http://mvp.support.microsoft.com
> This posting is provided "AS IS" with no warranties, and confers no
> rights...
>
> "Humpy" <rex@ioy.com> wrote in message
> news:bs4n0113t1e70fhamudpr92uvcjnmuaegt@4ax.com...
>> On Thu, 10 Feb 2005 03:39:36 GMT, "Randall W. Bowles"
>> <randall70b-news1@yahoo.com> wrote:
>>
>>>I am trying to get remote desktop working so I can access my computer
>>>from
>>>work. I have a linksys befw11s4 router. I have port 3389 forwarded and
>>>dynamic forwarding set up through dyndns.org It works if I use it from
>>>within my firewall using my dyndns address or my internal address. When
>>>I
>>>connect from outside my firewall it does not work. If I connect using
>>>the
>>>web version of the remote desktop I can get to my pc but it fails when I
>>>try
>>>to connect.
>>>
>>>Any Ideas?
>>
>> Not too familiar with linksys, you have 3389 forwarded to your
>> internal address correct ? Maybe your work has their router spoofed,
>> can you ping your work from home and get a reply ?
>>>
>>
>
Anonymous
February 11, 2005 8:12:59 AM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

That would bypass TCP Port 3389...

You also need to verify that...

1. You have IIS installed and configured for Remote Desktop on your home PC...

http://support.microsoft.com/?kbid=284931

2. You have changed the listening port on the home PC to 3737...

http://support.microsoft.com/default.aspx?scid=kb;en-us;Q306759

3. Both TCP Port 80 (IIS) and TCP Port 3737 are forwarded through your router.

4. Your home ISP does not block TCP Port 80. Some ISP's block that because running personal servers
violates the terms of service for home users.

5. You work does not block TCP Port 80 and TCP Port 3737 outbound...

--
Al Jarvi (MS-MVP Windows Networking)

Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
The MS-MVP Program - http://mvp.support.microsoft.com
This posting is provided "AS IS" with no warranties, and confers no rights...

"Randall W. Bowles" <randall70b-news1@yahoo.com> wrote in message
news:26WOd.3595$ng6.2032@newssvr17.news.prodigy.com...
>I was told from a co-worker that it may in fact be blocked but they are not sure. I will try your
>suggestion of having a friend connect from there house.
>
> I have been connecting using a different port with port forwarding. IE.
> http://xxxxx.gotdns.com:3737/tsweb/ Would this bypass port 3389?
>
> Thanks,
>
> Randy
>
>
> "Sooner Al [MVP]" <SoonerAl@somewhere.net.invalid> wrote in message
> news:o 6iYga5DFHA.3972@TK2MSFTNGP15.phx.gbl...
>> That's a good point "Humpy" brings up...Your work network administrators may be blocking TCP Port
>> 3389 outbound...
>>
>> Two other ways to test are...
>>
>> 1. Try to access your home PC using Remote Desktop from a friends house, ie. not work...using
>> both the dyndns.org alias and the public IP of your router.
>> 2. Go to this site, while at home on the PC you want to RD into...and see if it connects on TCP
>> Port 3389...
>>
>> http://www.canyouseeme.org/
>>
>> --
>> Al Jarvi (MS-MVP Windows Networking)
>>
>> Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
>> The MS-MVP Program - http://mvp.support.microsoft.com
>> This posting is provided "AS IS" with no warranties, and confers no rights...
>>
>> "Humpy" <rex@ioy.com> wrote in message news:bs4n0113t1e70fhamudpr92uvcjnmuaegt@4ax.com...
>>> On Thu, 10 Feb 2005 03:39:36 GMT, "Randall W. Bowles"
>>> <randall70b-news1@yahoo.com> wrote:
>>>
>>>>I am trying to get remote desktop working so I can access my computer from
>>>>work. I have a linksys befw11s4 router. I have port 3389 forwarded and
>>>>dynamic forwarding set up through dyndns.org It works if I use it from
>>>>within my firewall using my dyndns address or my internal address. When I
>>>>connect from outside my firewall it does not work. If I connect using the
>>>>web version of the remote desktop I can get to my pc but it fails when I try
>>>>to connect.
>>>>
>>>>Any Ideas?
>>>
>>> Not too familiar with linksys, you have 3389 forwarded to your
>>> internal address correct ? Maybe your work has their router spoofed,
>>> can you ping your work from home and get a reply ?
>>>>
>>>
>>
>
>
Anonymous
February 11, 2005 9:51:16 AM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

I forgot to add that you also need to modify the default.htm file on the Remote Desktop host to
include the changed TCP Port 3737...

To change the RDP listening port in the tsweb default.htm file I suggest you use Jeffrey Randow's
(MS-MVP) default.htm file that allows the change to be made dynamically. Simply replace the original
default.htm file with this new on. Make a backup of the original just in case you need to fall back
to the original for some reason...

http://www.remotenetworktechnology.com/LinkClick.aspx?l...

Also, when you change the listening port from TCP Port 3389 to TCP 3737 you need to reboot the PC
after making the registry change...

--
Al Jarvi (MS-MVP Windows Networking)

Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
The MS-MVP Program - http://mvp.support.microsoft.com
This posting is provided "AS IS" with no warranties, and confers no rights...

"Sooner Al [MVP]" <SoonerAl@somewhere.net.invalid> wrote in message
news:eDNNmqCEFHA.1564@TK2MSFTNGP09.phx.gbl...
> That would bypass TCP Port 3389...
>
> You also need to verify that...
>
> 1. You have IIS installed and configured for Remote Desktop on your home PC...
>
> http://support.microsoft.com/?kbid=284931
>
> 2. You have changed the listening port on the home PC to 3737...
>
> http://support.microsoft.com/default.aspx?scid=kb;en-us;Q306759
>
> 3. Both TCP Port 80 (IIS) and TCP Port 3737 are forwarded through your router.
>
> 4. Your home ISP does not block TCP Port 80. Some ISP's block that because running personal
> servers violates the terms of service for home users.
>
> 5. You work does not block TCP Port 80 and TCP Port 3737 outbound...
>
> --
> Al Jarvi (MS-MVP Windows Networking)
>
> Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
> The MS-MVP Program - http://mvp.support.microsoft.com
> This posting is provided "AS IS" with no warranties, and confers no rights...
>
> "Randall W. Bowles" <randall70b-news1@yahoo.com> wrote in message
> news:26WOd.3595$ng6.2032@newssvr17.news.prodigy.com...
>>I was told from a co-worker that it may in fact be blocked but they are not sure. I will try your
>>suggestion of having a friend connect from there house.
>>
>> I have been connecting using a different port with port forwarding. IE.
>> http://xxxxx.gotdns.com:3737/tsweb/ Would this bypass port 3389?
>>
>> Thanks,
>>
>> Randy
>>
>>
>> "Sooner Al [MVP]" <SoonerAl@somewhere.net.invalid> wrote in message
>> news:o 6iYga5DFHA.3972@TK2MSFTNGP15.phx.gbl...
>>> That's a good point "Humpy" brings up...Your work network administrators may be blocking TCP
>>> Port 3389 outbound...
>>>
>>> Two other ways to test are...
>>>
>>> 1. Try to access your home PC using Remote Desktop from a friends house, ie. not work...using
>>> both the dyndns.org alias and the public IP of your router.
>>> 2. Go to this site, while at home on the PC you want to RD into...and see if it connects on TCP
>>> Port 3389...
>>>
>>> http://www.canyouseeme.org/
>>>
>>> --
>>> Al Jarvi (MS-MVP Windows Networking)
>>>
>>> Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
>>> The MS-MVP Program - http://mvp.support.microsoft.com
>>> This posting is provided "AS IS" with no warranties, and confers no rights...
>>>
>>> "Humpy" <rex@ioy.com> wrote in message news:bs4n0113t1e70fhamudpr92uvcjnmuaegt@4ax.com...
>>>> On Thu, 10 Feb 2005 03:39:36 GMT, "Randall W. Bowles"
>>>> <randall70b-news1@yahoo.com> wrote:
>>>>
>>>>>I am trying to get remote desktop working so I can access my computer from
>>>>>work. I have a linksys befw11s4 router. I have port 3389 forwarded and
>>>>>dynamic forwarding set up through dyndns.org It works if I use it from
>>>>>within my firewall using my dyndns address or my internal address. When I
>>>>>connect from outside my firewall it does not work. If I connect using the
>>>>>web version of the remote desktop I can get to my pc but it fails when I try
>>>>>to connect.
>>>>>
>>>>>Any Ideas?
>>>>
>>>> Not too familiar with linksys, you have 3389 forwarded to your
>>>> internal address correct ? Maybe your work has their router spoofed,
>>>> can you ping your work from home and get a reply ?
>>>>>
>>>>
>>>
>>
>>
>
Anonymous
April 7, 2005 5:47:04 AM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

I think I have the same problem with not be able to connect using port 3389.
I don't know what outbound ports that are open. Is there some way I could
find this out?

Could I use one of the familiar ports like 80 or 21 for Remote Desktop to my
home? I don't need to run any web or ftp services, only remote desktop.


"Sooner Al [MVP]" wrote:

> I forgot to add that you also need to modify the default.htm file on the Remote Desktop host to
> include the changed TCP Port 3737...
>
> To change the RDP listening port in the tsweb default.htm file I suggest you use Jeffrey Randow's
> (MS-MVP) default.htm file that allows the change to be made dynamically. Simply replace the original
> default.htm file with this new on. Make a backup of the original just in case you need to fall back
> to the original for some reason...
>
> http://www.remotenetworktechnology.com/LinkClick.aspx?l...
>
> Also, when you change the listening port from TCP Port 3389 to TCP 3737 you need to reboot the PC
> after making the registry change...
>
> --
> Al Jarvi (MS-MVP Windows Networking)
>
> Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
> The MS-MVP Program - http://mvp.support.microsoft.com
> This posting is provided "AS IS" with no warranties, and confers no rights...
>
> "Sooner Al [MVP]" <SoonerAl@somewhere.net.invalid> wrote in message
> news:eDNNmqCEFHA.1564@TK2MSFTNGP09.phx.gbl...
> > That would bypass TCP Port 3389...
> >
> > You also need to verify that...
> >
> > 1. You have IIS installed and configured for Remote Desktop on your home PC...
> >
> > http://support.microsoft.com/?kbid=284931
> >
> > 2. You have changed the listening port on the home PC to 3737...
> >
> > http://support.microsoft.com/default.aspx?scid=kb;en-us;Q306759
> >
> > 3. Both TCP Port 80 (IIS) and TCP Port 3737 are forwarded through your router.
> >
> > 4. Your home ISP does not block TCP Port 80. Some ISP's block that because running personal
> > servers violates the terms of service for home users.
> >
> > 5. You work does not block TCP Port 80 and TCP Port 3737 outbound...
> >
> > --
> > Al Jarvi (MS-MVP Windows Networking)
> >
> > Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
> > The MS-MVP Program - http://mvp.support.microsoft.com
> > This posting is provided "AS IS" with no warranties, and confers no rights...
> >
> > "Randall W. Bowles" <randall70b-news1@yahoo.com> wrote in message
> > news:26WOd.3595$ng6.2032@newssvr17.news.prodigy.com...
> >>I was told from a co-worker that it may in fact be blocked but they are not sure. I will try your
> >>suggestion of having a friend connect from there house.
> >>
> >> I have been connecting using a different port with port forwarding. IE.
> >> http://xxxxx.gotdns.com:3737/tsweb/ Would this bypass port 3389?
> >>
> >> Thanks,
> >>
> >> Randy
> >>
> >>
> >> "Sooner Al [MVP]" <SoonerAl@somewhere.net.invalid> wrote in message
> >> news:o 6iYga5DFHA.3972@TK2MSFTNGP15.phx.gbl...
> >>> That's a good point "Humpy" brings up...Your work network administrators may be blocking TCP
> >>> Port 3389 outbound...
> >>>
> >>> Two other ways to test are...
> >>>
> >>> 1. Try to access your home PC using Remote Desktop from a friends house, ie. not work...using
> >>> both the dyndns.org alias and the public IP of your router.
> >>> 2. Go to this site, while at home on the PC you want to RD into...and see if it connects on TCP
> >>> Port 3389...
> >>>
> >>> http://www.canyouseeme.org/
> >>>
> >>> --
> >>> Al Jarvi (MS-MVP Windows Networking)
> >>>
> >>> Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
> >>> The MS-MVP Program - http://mvp.support.microsoft.com
> >>> This posting is provided "AS IS" with no warranties, and confers no rights...
> >>>
> >>> "Humpy" <rex@ioy.com> wrote in message news:bs4n0113t1e70fhamudpr92uvcjnmuaegt@4ax.com...
> >>>> On Thu, 10 Feb 2005 03:39:36 GMT, "Randall W. Bowles"
> >>>> <randall70b-news1@yahoo.com> wrote:
> >>>>
> >>>>>I am trying to get remote desktop working so I can access my computer from
> >>>>>work. I have a linksys befw11s4 router. I have port 3389 forwarded and
> >>>>>dynamic forwarding set up through dyndns.org It works if I use it from
> >>>>>within my firewall using my dyndns address or my internal address. When I
> >>>>>connect from outside my firewall it does not work. If I connect using the
> >>>>>web version of the remote desktop I can get to my pc but it fails when I try
> >>>>>to connect.
> >>>>>
> >>>>>Any Ideas?
> >>>>
> >>>> Not too familiar with linksys, you have 3389 forwarded to your
> >>>> internal address correct ? Maybe your work has their router spoofed,
> >>>> can you ping your work from home and get a reply ?
> >>>>>
> >>>>
> >>>
> >>
> >>
> >
>
>
Anonymous
April 7, 2005 9:05:30 AM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

You need to check with the network administrators on the network your on for that information.

--

Al Jarvi (MS-MVP Windows Networking)

Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
The MS-MVP Program - http://mvp.support.microsoft.com
This posting is provided "AS IS" with no warranties, and confers no rights...


"Johnny_O" <Johnny_O@discussions.microsoft.com> wrote in message
news:C8224535-F6C7-40D2-8ECE-CC9850215F5C@microsoft.com...
>I think I have the same problem with not be able to connect using port 3389.
> I don't know what outbound ports that are open. Is there some way I could
> find this out?
>
> Could I use one of the familiar ports like 80 or 21 for Remote Desktop to my
> home? I don't need to run any web or ftp services, only remote desktop.
>
>
> "Sooner Al [MVP]" wrote:
>
>> I forgot to add that you also need to modify the default.htm file on the Remote Desktop host to
>> include the changed TCP Port 3737...
>>
>> To change the RDP listening port in the tsweb default.htm file I suggest you use Jeffrey Randow's
>> (MS-MVP) default.htm file that allows the change to be made dynamically. Simply replace the
>> original
>> default.htm file with this new on. Make a backup of the original just in case you need to fall
>> back
>> to the original for some reason...
>>
>> http://www.remotenetworktechnology.com/LinkClick.aspx?l...
>>
>> Also, when you change the listening port from TCP Port 3389 to TCP 3737 you need to reboot the PC
>> after making the registry change...
>>
>> --
>> Al Jarvi (MS-MVP Windows Networking)
>>
>> Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
>> The MS-MVP Program - http://mvp.support.microsoft.com
>> This posting is provided "AS IS" with no warranties, and confers no rights...
>>
>> "Sooner Al [MVP]" <SoonerAl@somewhere.net.invalid> wrote in message
>> news:eDNNmqCEFHA.1564@TK2MSFTNGP09.phx.gbl...
>> > That would bypass TCP Port 3389...
>> >
>> > You also need to verify that...
>> >
>> > 1. You have IIS installed and configured for Remote Desktop on your home PC...
>> >
>> > http://support.microsoft.com/?kbid=284931
>> >
>> > 2. You have changed the listening port on the home PC to 3737...
>> >
>> > http://support.microsoft.com/default.aspx?scid=kb;en-us;Q306759
>> >
>> > 3. Both TCP Port 80 (IIS) and TCP Port 3737 are forwarded through your router.
>> >
>> > 4. Your home ISP does not block TCP Port 80. Some ISP's block that because running personal
>> > servers violates the terms of service for home users.
>> >
>> > 5. You work does not block TCP Port 80 and TCP Port 3737 outbound...
>> >
>> > --
>> > Al Jarvi (MS-MVP Windows Networking)
>> >
>> > Please post *ALL* questions and replies to the news group for the mutual benefit of all of
>> > us...
>> > The MS-MVP Program - http://mvp.support.microsoft.com
>> > This posting is provided "AS IS" with no warranties, and confers no rights...
>> >
>> > "Randall W. Bowles" <randall70b-news1@yahoo.com> wrote in message
>> > news:26WOd.3595$ng6.2032@newssvr17.news.prodigy.com...
>> >>I was told from a co-worker that it may in fact be blocked but they are not sure. I will try
>> >>your
>> >>suggestion of having a friend connect from there house.
>> >>
>> >> I have been connecting using a different port with port forwarding. IE.
>> >> http://xxxxx.gotdns.com:3737/tsweb/ Would this bypass port 3389?
>> >>
>> >> Thanks,
>> >>
>> >> Randy
>> >>
>> >>
>> >> "Sooner Al [MVP]" <SoonerAl@somewhere.net.invalid> wrote in message
>> >> news:o 6iYga5DFHA.3972@TK2MSFTNGP15.phx.gbl...
>> >>> That's a good point "Humpy" brings up...Your work network administrators may be blocking TCP
>> >>> Port 3389 outbound...
>> >>>
>> >>> Two other ways to test are...
>> >>>
>> >>> 1. Try to access your home PC using Remote Desktop from a friends house, ie. not work...using
>> >>> both the dyndns.org alias and the public IP of your router.
>> >>> 2. Go to this site, while at home on the PC you want to RD into...and see if it connects on
>> >>> TCP
>> >>> Port 3389...
>> >>>
>> >>> http://www.canyouseeme.org/
>> >>>
>> >>> --
>> >>> Al Jarvi (MS-MVP Windows Networking)
>> >>>
>> >>> Please post *ALL* questions and replies to the news group for the mutual benefit of all of
>> >>> us...
>> >>> The MS-MVP Program - http://mvp.support.microsoft.com
>> >>> This posting is provided "AS IS" with no warranties, and confers no rights...
>> >>>
>> >>> "Humpy" <rex@ioy.com> wrote in message news:bs4n0113t1e70fhamudpr92uvcjnmuaegt@4ax.com...
>> >>>> On Thu, 10 Feb 2005 03:39:36 GMT, "Randall W. Bowles"
>> >>>> <randall70b-news1@yahoo.com> wrote:
>> >>>>
>> >>>>>I am trying to get remote desktop working so I can access my computer from
>> >>>>>work. I have a linksys befw11s4 router. I have port 3389 forwarded and
>> >>>>>dynamic forwarding set up through dyndns.org It works if I use it from
>> >>>>>within my firewall using my dyndns address or my internal address. When I
>> >>>>>connect from outside my firewall it does not work. If I connect using the
>> >>>>>web version of the remote desktop I can get to my pc but it fails when I try
>> >>>>>to connect.
>> >>>>>
>> >>>>>Any Ideas?
>> >>>>
>> >>>> Not too familiar with linksys, you have 3389 forwarded to your
>> >>>> internal address correct ? Maybe your work has their router spoofed,
>> >>>> can you ping your work from home and get a reply ?
>> >>>>>
>> >>>>
>> >>>
>> >>
>> >>
>> >
>>
>>
!