Sign in with
Sign up | Sign in
Your question

Remote Connection and SP2

Last response: in Windows XP
Share
February 20, 2005 5:45:03 PM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Hi all,
It is getting late and i am in desparate need of sleep so i though i would
see if anyone could help me solve my last problem of the night :-)

I have set up remote Desktop connection through a router and most of it is
ok. However i am not able to connect to one of the machines this may be
because it has SP2 installed. I have updated the registy and added a new
termsrv.dll to the System32 dir but nothing has helped.

Has anyone got any ideas ???

Thanks
Martin

More about : remote connection sp2

Anonymous
February 20, 2005 8:59:20 PM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

With SP2 installed, I'd suspect the Windows Firewall.
Go to Start -> Control Panel -> Windows Firewall.
On the Exceptions page, make sure there is a checkmark in the box
next to Remote Desktop.

--
Nepatsfan
"martin" <mhayes@europe.sial.com> wrote in message
news:265DEF63-B37B-4E85-919F-920A1FEA9B2E@microsoft.com...
> Hi all,
> It is getting late and i am in desparate need of sleep so i
> though i would
> see if anyone could help me solve my last problem of the night
> :-)
>
> I have set up remote Desktop connection through a router and
> most of it is
> ok. However i am not able to connect to one of the machines
> this may be
> because it has SP2 installed. I have updated the registy and
> added a new
> termsrv.dll to the System32 dir but nothing has helped.
>
> Has anyone got any ideas ???
>
> Thanks
> Martin
February 20, 2005 8:59:21 PM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

hi,

Thanks for the suggestion but i allready have Remote Desktop ticked in the
win firewall exceptions tab.
This problem is really getting annoying now :-(

Any more suggestions would be FAB
Thanks again
Martin

"Nepatsfan" wrote:

> With SP2 installed, I'd suspect the Windows Firewall.
> Go to Start -> Control Panel -> Windows Firewall.
> On the Exceptions page, make sure there is a checkmark in the box
> next to Remote Desktop.
>
> --
> Nepatsfan
> "martin" <mhayes@europe.sial.com> wrote in message
> news:265DEF63-B37B-4E85-919F-920A1FEA9B2E@microsoft.com...
> > Hi all,
> > It is getting late and i am in desparate need of sleep so i
> > though i would
> > see if anyone could help me solve my last problem of the night
> > :-)
> >
> > I have set up remote Desktop connection through a router and
> > most of it is
> > ok. However i am not able to connect to one of the machines
> > this may be
> > because it has SP2 installed. I have updated the registy and
> > added a new
> > termsrv.dll to the System32 dir but nothing has helped.
> >
> > Has anyone got any ideas ???
> >
> > Thanks
> > Martin
>
>
>
Related resources
Anonymous
February 20, 2005 10:43:34 PM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

I just saw your earlier post, so I'll try to follow up on some of
the things Sooner Al alluded to.

On your Netgear router, you have to set up Port Forwarding so it
looks something like this. I'm doing this from memory, so
hopefully I've got it right.

Name Start End IP
RD1 3389 3389 192.168.0.11
RD2 3390 3389 192.168.0.12
RD3 3391 3389 192.168.0.13
RD4 3392 3389 192.168.0.14

Note: Change the IP addresses to ones appropriate for your
network. It also helps to set up IP reservations. Look for that
in the LAN IP Setup section of your router's interface.

You also have to enable UPnP. It's listed near the bottom of the
box on the left.

To connect to each machine you'd enter the external IP address
(the one that's assigned by your ISP) followed by the port
number. For example, to connect to RD1, enter just the external
IP. For RD2, you'd enter the external IP followed by the
redirected port number, e.g. 123.123.123.123:3390. For RD3,
123.123.123.123:3391 and so on.

If you've done all this and are still having difficulties
connecting, then it may be time to look elsewhere. Is the problem
PC running XP Professional? Are there any 3rd party firewalls
such as Zone Alarm, Sygate or Kerio installed? How about Internet
Security Suites such as Norton or McAfee?

File the following away for when you get everything running
correctly:

Unless you have a static IP address assigned by your internet
provider, you might want to set up an account to get dynamic dns
from www.no-ip.com. It's free, reliable and best of all you can
set up a domain name that's much easier to keep track of then a
set up numbers. That way when you go to connect you enter
something like martin.myvnc.com:3391 instead of the IP address
and port number.

--
Nepatsfan
"martin" <mhayes@europe.sial.com> wrote in message
news:142A7475-ED99-4FD7-AD68-97C703D46B3F@microsoft.com...
> hi,
>
> Thanks for the suggestion but i allready have Remote Desktop
> ticked in the
> win firewall exceptions tab.
> This problem is really getting annoying now :-(
>
> Any more suggestions would be FAB
> Thanks again
> Martin
>
> "Nepatsfan" wrote:
>
>> With SP2 installed, I'd suspect the Windows Firewall.
>> Go to Start -> Control Panel -> Windows Firewall.
>> On the Exceptions page, make sure there is a checkmark in the
>> box
>> next to Remote Desktop.
>>
>> --
>> Nepatsfan
>> "martin" <mhayes@europe.sial.com> wrote in message
>> news:265DEF63-B37B-4E85-919F-920A1FEA9B2E@microsoft.com...
>> > Hi all,
>> > It is getting late and i am in desparate need of sleep so i
>> > though i would
>> > see if anyone could help me solve my last problem of the
>> > night
>> > :-)
>> >
>> > I have set up remote Desktop connection through a router and
>> > most of it is
>> > ok. However i am not able to connect to one of the machines
>> > this may be
>> > because it has SP2 installed. I have updated the registy and
>> > added a new
>> > termsrv.dll to the System32 dir but nothing has helped.
>> >
>> > Has anyone got any ideas ???
>> >
>> > Thanks
>> > Martin
>>
>>
>>
Anonymous
February 20, 2005 11:07:14 PM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Following up, I totally missed the fact that you're connecting to
these machines from within your LAN. That takes the external IP
address out of the equation. Likewise the need for a dynamic DNS
service.

What that means is that when you go to connect to each machine in
the LAN, you can enter the PC's name with the port number
appended to it in the Computer box, e.g. MAINPC:3391 or
MARTINSPC:3390. Sorry for the confusion. When I've set up RD,
it's usually involved remote locations.

--
Nepatsfan
"Nepatsfan" <nepatsfan@SBXXXVIII.com> wrote in message
news:o IGdnbdQTdgos4TfRVn-ig@comcast.com...
>I just saw your earlier post, so I'll try to follow up on some
>of
> the things Sooner Al alluded to.
>
> On your Netgear router, you have to set up Port Forwarding so
> it
> looks something like this. I'm doing this from memory, so
> hopefully I've got it right.
>
> Name Start End IP
> RD1 3389 3389 192.168.0.11
> RD2 3390 3389 192.168.0.12
> RD3 3391 3389 192.168.0.13
> RD4 3392 3389 192.168.0.14
>
> Note: Change the IP addresses to ones appropriate for your
> network. It also helps to set up IP reservations. Look for that
> in the LAN IP Setup section of your router's interface.
>
> You also have to enable UPnP. It's listed near the bottom of
> the
> box on the left.
>
> To connect to each machine you'd enter the external IP address
> (the one that's assigned by your ISP) followed by the port
> number. For example, to connect to RD1, enter just the external
> IP. For RD2, you'd enter the external IP followed by the
> redirected port number, e.g. 123.123.123.123:3390. For RD3,
> 123.123.123.123:3391 and so on.
>
> If you've done all this and are still having difficulties
> connecting, then it may be time to look elsewhere. Is the
> problem
> PC running XP Professional? Are there any 3rd party firewalls
> such as Zone Alarm, Sygate or Kerio installed? How about
> Internet
> Security Suites such as Norton or McAfee?
>
> File the following away for when you get everything running
> correctly:
>
> Unless you have a static IP address assigned by your internet
> provider, you might want to set up an account to get dynamic
> dns
> from www.no-ip.com. It's free, reliable and best of all you can
> set up a domain name that's much easier to keep track of then a
> set up numbers. That way when you go to connect you enter
> something like martin.myvnc.com:3391 instead of the IP address
> and port number.
>
> --
> Nepatsfan
> "martin" <mhayes@europe.sial.com> wrote in message
> news:142A7475-ED99-4FD7-AD68-97C703D46B3F@microsoft.com...
>> hi,
>>
>> Thanks for the suggestion but i allready have Remote Desktop
>> ticked in the
>> win firewall exceptions tab.
>> This problem is really getting annoying now :-(
>>
>> Any more suggestions would be FAB
>> Thanks again
>> Martin
>>
>> "Nepatsfan" wrote:
>>
>>> With SP2 installed, I'd suspect the Windows Firewall.
>>> Go to Start -> Control Panel -> Windows Firewall.
>>> On the Exceptions page, make sure there is a checkmark in the
>>> box
>>> next to Remote Desktop.
>>>
>>> --
>>> Nepatsfan
>>> "martin" <mhayes@europe.sial.com> wrote in message
>>> news:265DEF63-B37B-4E85-919F-920A1FEA9B2E@microsoft.com...
>>> > Hi all,
>>> > It is getting late and i am in desparate need of sleep so i
>>> > though i would
>>> > see if anyone could help me solve my last problem of the
>>> > night
>>> > :-)
>>> >
>>> > I have set up remote Desktop connection through a router
>>> > and
>>> > most of it is
>>> > ok. However i am not able to connect to one of the machines
>>> > this may be
>>> > because it has SP2 installed. I have updated the registy
>>> > and
>>> > added a new
>>> > termsrv.dll to the System32 dir but nothing has helped.
>>> >
>>> > Has anyone got any ideas ???
>>> >
>>> > Thanks
>>> > Martin
>>>
>>>
>>>
>
>
>
Anonymous
February 22, 2005 3:35:02 AM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

"martin" wrote:

> Hi all,
> It is getting late and i am in desparate need of sleep so i though i would
> see if anyone could help me solve my last problem of the night :-)
>
> I have set up remote Desktop connection through a router and most of it is
> ok. However i am not able to connect to one of the machines this may be
> because it has SP2 installed. I have updated the registy and added a new
> termsrv.dll to the System32 dir but nothing has helped.
>
> Has anyone got any ideas ???
>
> Thanks
> Martin
Anonymous
February 22, 2005 8:43:12 PM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

I have a simliar problem on WinXP SP2 Pro. As soon as I installed SP2, I
started experiencing this problem. I can't even ping my PC from another
machine. I've turned off the firewall and every other security mechanism I
can think of. I have no trouble pinging or connecting to other machines
from this XP SP2 machine but it seems impossible to initiate connections to
this box. I am the domain administrator and do not have this problem on any
machine except my XP SP2 machine that I use. We have another machine
running XP SP1 that is nearly identical in every other way and it has no
problems. Any ideas? I'm tempted to reinstall at this point.
Unfortuantely everything else works on this machine so I hate to do that
just so I can connect to this machine externally but I may have to.

Thanks
Jayme

"martin" <mhayes@europe.sial.com> wrote in message
news:265DEF63-B37B-4E85-919F-920A1FEA9B2E@microsoft.com...
> Hi all,
> It is getting late and i am in desparate need of sleep so i though i would
> see if anyone could help me solve my last problem of the night :-)
>
> I have set up remote Desktop connection through a router and most of it is
> ok. However i am not able to connect to one of the machines this may be
> because it has SP2 installed. I have updated the registy and added a new
> termsrv.dll to the System32 dir but nothing has helped.
>
> Has anyone got any ideas ???
>
> Thanks
> Martin
!