Help needed with Remote Desktop and SP2

Archived from groups: microsoft.public.windowsxp.general,microsoft.public.windowsxp.work_remotely (More info?)

Hi,

I have XP pro SP2 and I am trying to connect remotely to my PC, (I also have
Zone Alarm Pro).

At first I could not connect because I thought it was ZA that was at fault
but then, after turning off both firewalls, I realized that the XP firewall
was blocking.
I simply cannot connect with the Windows firewall on.

Under the advanced settings I checked "VPN L2PT", "VPN PPTP" as well as
"Remote desktop".
But I still cannot connect.

Looking around google it appears that I have to allow a certain port in my
exceptions, but what port number is that?

The error I get on the other computer when I do http://ww.xx.yy.zz/tsweb is
simply a "Cannot find server".
If I disabled the XP firewall it works like a charm.

Any idea? I just don't want to turn my firewall off when I go to work.

Many thanks

Simon
19 answers Last reply
More about help needed remote desktop
  1. Archived from groups: microsoft.public.windowsxp.general,microsoft.public.windowsxp.work_remotely (More info?)

    >
    > Any idea? I just don't want to turn my firewall off when I go to work.
    >
    > Many thanks
    >
    > Simon

    Ok,

    I fixed it, and much to my embarrassment it was my fault all along.
    I thought I had installed remote access on the Win98 machine but I hadn't
    really.

    So after a quick install I got it running just fine with both ZA and WinXP
    firewall.

    For the record the Advanced tab didn't have remote access allowed and that's
    why it was not working with my Work Xp machine.
    But even allowing remote access was not working because it was not working
    properly.

    I am not sure why it was working with the firewall totally off.

    Many thanks

    Simon
  2. Archived from groups: microsoft.public.windowsxp.general,microsoft.public.windowsxp.work_remotely (More info?)

    "simon" <spambucket@myoddweb.com> wrote in message
    news:urCYSaVIFHA.2564@tk2msftngp13.phx.gbl...
    > Hi,
    >
    > I have XP pro SP2 and I am trying to connect remotely to my PC, (I also
    have
    > Zone Alarm Pro).
    >
    > At first I could not connect because I thought it was ZA that was at fault
    > but then, after turning off both firewalls, I realized that the XP
    firewall
    > was blocking.
    > I simply cannot connect with the Windows firewall on.
    >
    > Under the advanced settings I checked "VPN L2PT", "VPN PPTP" as well as
    > "Remote desktop".
    > But I still cannot connect.
    >
    > Looking around google it appears that I have to allow a certain port in my
    > exceptions, but what port number is that?
    >
    > The error I get on the other computer when I do http://ww.xx.yy.zz/tsweb
    is
    > simply a "Cannot find server".
    > If I disabled the XP firewall it works like a charm.
    >
    > Any idea? I just don't want to turn my firewall off when I go to work.
    >
    > Many thanks
    >
    > Simon
    >

    The simplest way would be to open port 3389 on your firewall,
    and to set up your router (if you have one) to forward port 3389
    packets to your PC. If you do it like this then you won't need
    a VPN.
  3. Archived from groups: microsoft.public.windowsxp.general,microsoft.public.windowsxp.work_remotely (More info?)

    >>
    >> The error I get on the other computer when I do http://ww.xx.yy.zz/tsweb
    > is
    >> simply a "Cannot find server".
    >> If I disabled the XP firewall it works like a charm.
    >>
    >> Any idea? I just don't want to turn my firewall off when I go to work.
    >>
    >> Many thanks
    >>
    >> Simon
    >>
    >
    > The simplest way would be to open port 3389 on your firewall,
    > and to set up your router (if you have one) to forward port 3389
    > packets to your PC. If you do it like this then you won't need
    > a VPN.
    >

    Thanks, but that does not work.
    Under the exception there is already an entry "Remote Desktop TCP 3389" and
    for a test I added UDP but that made no difference.

    Simon
  4. Archived from groups: microsoft.public.windowsxp.general,microsoft.public.windowsxp.work_remotely (More info?)

    "simon" <spambucket@myoddweb.com> wrote in message
    news:e%23h%23uvVIFHA.1996@TK2MSFTNGP12.phx.gbl...
    >>>
    >>> The error I get on the other computer when I do http://ww.xx.yy.zz/tsweb
    >> is
    >>> simply a "Cannot find server".
    >>> If I disabled the XP firewall it works like a charm.
    >>>
    >>> Any idea? I just don't want to turn my firewall off when I go to work.
    >>>
    >>> Many thanks
    >>>
    >>> Simon
    >>>
    >>
    >> The simplest way would be to open port 3389 on your firewall,
    >> and to set up your router (if you have one) to forward port 3389
    >> packets to your PC. If you do it like this then you won't need
    >> a VPN.
    >>
    >
    > Thanks, but that does not work.
    > Under the exception there is already an entry "Remote Desktop TCP 3389"
    > and for a test I added UDP but that made no difference.
    >
    > Simon

    Scope = Any ?
  5. Archived from groups: microsoft.public.windowsxp.general,microsoft.public.windowsxp.work_remotely (More info?)

    >
    >>>>
    >>>
    >>> The simplest way would be to open port 3389 on your firewall,
    >>> and to set up your router (if you have one) to forward port 3389
    >>> packets to your PC. If you do it like this then you won't need
    >>> a VPN.
    >>>
    >>
    >> Thanks, but that does not work.
    >> Under the exception there is already an entry "Remote Desktop TCP 3389"
    >> and for a test I added UDP but that made no difference.
    >>
    >> Simon
    >
    > Scope = Any ?

    Yes, Scope=Any.

    And under 'Advanced' I cannot edit the port number, it is 3389 by default.

    Simon
  6. Archived from groups: microsoft.public.windowsxp.general,microsoft.public.windowsxp.work_remotely (More info?)

    "Simon" <spambucket@myoddweb.com> wrote in message
    news:38tbf3F5no2ghU1@individual.net...
    > >
    >>>>>
    >>>>
    >>>> The simplest way would be to open port 3389 on your firewall,
    >>>> and to set up your router (if you have one) to forward port 3389
    >>>> packets to your PC. If you do it like this then you won't need
    >>>> a VPN.
    >>>>
    >>>
    >>> Thanks, but that does not work.
    >>> Under the exception there is already an entry "Remote Desktop TCP 3389"
    >>> and for a test I added UDP but that made no difference.
    >>>
    >>> Simon
    >>
    >> Scope = Any ?
    >
    > Yes, Scope=Any.
    >
    > And under 'Advanced' I cannot edit the port number, it is 3389 by default.
    >
    > Simon
    >
    >


    How to change the listening port for Remote Desktop
    http://support.microsoft.com/kb/306759/EN-US/

    --
    William
  7. Archived from groups: microsoft.public.windowsxp.general,microsoft.public.windowsxp.work_remotely (More info?)

    >
    > How to change the listening port for Remote Desktop
    > http://support.microsoft.com/kb/306759/EN-US/
    >
    > --
    > William
    >
    >

    Thanks, but the problem seems to be something else.
    Even with port number 3389 open it does not work.

    If I shutdown the server it works, so I guess something else is blocking.
    Maybe RD is not listening on port 3389, so opening that port is useless.

    So I guess that changing the port number would not help really.

    Simon
  8. Archived from groups: microsoft.public.windowsxp.general,microsoft.public.windowsxp.work_remotely (More info?)

    "Simon" <spambucket@myoddweb.com> wrote in message
    news:38td4vF5s2ormU1@individual.net...
    > >
    >> How to change the listening port for Remote Desktop
    >> http://support.microsoft.com/kb/306759/EN-US/
    >>
    >> --
    >> William
    >>
    >>
    >
    > Thanks, but the problem seems to be something else.
    > Even with port number 3389 open it does not work.
    >
    > If I shutdown the server it works, so I guess something else is blocking.
    > Maybe RD is not listening on port 3389, so opening that port is useless.
    >
    > So I guess that changing the port number would not help really.
    >
    > Simon
    >


    Are you port forwarding the port to the IP address of the computer you want
    to connect to?

    --
    William
  9. Archived from groups: microsoft.public.windowsxp.general,microsoft.public.windowsxp.work_remotely (More info?)

    >
    > Are you port forwarding the port to the IP address of the computer you
    > want to connect to?

    do you mean http://ww.xx.yy.zz:3389/tsweb? if so then yes, i tried that and
    it does not work.
    I also tried without of course and it also does not work.

    Again, as mentioned, it all works fine with MS Firewall disabled.

    > --
    > William
    >

    Simon
  10. Archived from groups: microsoft.public.windowsxp.general,microsoft.public.windowsxp.work_remotely (More info?)

    "simon" <spambucket@myoddweb.com> wrote in message
    news:OUGBcoWIFHA.3472@TK2MSFTNGP09.phx.gbl...
    > >
    >> Are you port forwarding the port to the IP address of the computer you
    >> want to connect to?
    >
    > do you mean http://ww.xx.yy.zz:3389/tsweb? if so then yes, i tried that
    > and it does not work.
    > I also tried without of course and it also does not work.
    >
    > Again, as mentioned, it all works fine with MS Firewall disabled.
    >
    >> --
    >> William
    >>
    >
    > Simon
    >


    No I do not mean that. Are you behind a router? Or just a server? Once I
    know this I can explain.

    --
    William
  11. Archived from groups: microsoft.public.windowsxp.general,microsoft.public.windowsxp.work_remotely (More info?)

    >>
    >
    >
    > No I do not mean that. Are you behind a router? Or just a server? Once I
    > know this I can explain.

    No, i am not behind a router.

    >
    > --
    > William
    >

    Simon
  12. Archived from groups: microsoft.public.windowsxp.general,microsoft.public.windowsxp.work_remotely (More info?)

    "simon" <spambucket@myoddweb.com> wrote in message
    news:uoJ5dtWIFHA.2648@TK2MSFTNGP14.phx.gbl...
    >>>
    >>
    >>
    >> No I do not mean that. Are you behind a router? Or just a server? Once I
    >> know this I can explain.
    >
    > No, i am not behind a router.
    >
    >>
    >> --
    >> William
    >>
    >
    > Simon
    >


    How to manually open ports in Internet Connection Firewall in Windows XP
    http://support.microsoft.com/default.aspx?scid=kb;en-us;q308127

    --
    William
  13. Archived from groups: microsoft.public.windowsxp.general,microsoft.public.windowsxp.work_remotely (More info?)

    >
    > How to manually open ports in Internet Connection Firewall in Windows XP
    > http://support.microsoft.com/default.aspx?scid=kb;en-us;q308127
    >
    > --
    > William
    >

    Like I mentioned, opening the port does not seem to work.
    I am not sure if the port number is even correct.

    Port 3389 might be open, but it does not allow RD.
    Port 3389 might not be the right port.

    Is there a way to test what port RD is listening on, that might actually
    help to see if that's the problem?

    Simon
  14. Archived from groups: microsoft.public.windowsxp.general,microsoft.public.windowsxp.work_remotely (More info?)

    "Simon" <spambucket@myoddweb.com> wrote in message
    news:38th7fF5sqri9U1@individual.net...
    > >
    > > How to manually open ports in Internet Connection Firewall in Windows XP
    > > http://support.microsoft.com/default.aspx?scid=kb;en-us;q308127
    > >
    > > --
    > > William
    > >
    >
    > Like I mentioned, opening the port does not seem to work.
    > I am not sure if the port number is even correct.
    >
    > Port 3389 might be open, but it does not allow RD.
    > Port 3389 might not be the right port.
    >
    > Is there a way to test what port RD is listening on, that might actually
    > help to see if that's the problem?
    >
    > Simon

    You never told us how you connect to your outside world.
    All we know so far is that you do not use a router.

    The easiest way to trouble-shoot such problems is to start
    from the inside: Use another PC to issue this command:

    telnet aaa.bbb.ccc.ddd 3389

    where aaa.bbb.ccc.ddd is the RDP host. Once you
    get the host to respond, you can extend your tests to
    the outside world.

    I assume that you have Remote Desktop enabled on
    your RDP host.
  15. Archived from groups: microsoft.public.windowsxp.general,microsoft.public.windowsxp.work_remotely (More info?)

    In addition there is some troubleshooting help on this page..

    http://theillustratednetwork.mvps.org/RemoteDesktop/RemoteDesktopSetupandTroubleshooting.html

    --
    Al Jarvi (MS-MVP Windows Networking)

    Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
    The MS-MVP Program - http://mvp.support.microsoft.com
    This posting is provided "AS IS" with no warranties, and confers no rights...

    "Pegasus (MVP)" <I.can@fly.com> wrote in message news:eD0UeNXIFHA.2924@TK2MSFTNGP15.phx.gbl...
    >
    > "Simon" <spambucket@myoddweb.com> wrote in message
    > news:38th7fF5sqri9U1@individual.net...
    >> >
    >> > How to manually open ports in Internet Connection Firewall in Windows XP
    >> > http://support.microsoft.com/default.aspx?scid=kb;en-us;q308127
    >> >
    >> > --
    >> > William
    >> >
    >>
    >> Like I mentioned, opening the port does not seem to work.
    >> I am not sure if the port number is even correct.
    >>
    >> Port 3389 might be open, but it does not allow RD.
    >> Port 3389 might not be the right port.
    >>
    >> Is there a way to test what port RD is listening on, that might actually
    >> help to see if that's the problem?
    >>
    >> Simon
    >
    > You never told us how you connect to your outside world.
    > All we know so far is that you do not use a router.
    >
    > The easiest way to trouble-shoot such problems is to start
    > from the inside: Use another PC to issue this command:
    >
    > telnet aaa.bbb.ccc.ddd 3389
    >
    > where aaa.bbb.ccc.ddd is the RDP host. Once you
    > get the host to respond, you can extend your tests to
    > the outside world.
    >
    > I assume that you have Remote Desktop enabled on
    > your RDP host.
    >
    >
  16. Archived from groups: microsoft.public.windowsxp.general,microsoft.public.windowsxp.work_remotely (More info?)

    >
    > You never told us how you connect to your outside world.
    > All we know so far is that you do not use a router.

    Sorry, I didn't know it mattered because I did mention that it worked with
    windows firewall off.
    BTW, I might get in trouble for mentioning that so late, but I am using win
    98 as my other machine, (that's the only one I have).

    But seen that it works fine without the firewall I can only assume that it
    should work with it.

    >
    > The easiest way to trouble-shoot such problems is to start
    > from the inside: Use another PC to issue this command:
    >
    > telnet aaa.bbb.ccc.ddd 3389

    With or without the firewall I get the telnet screen, (it seems ok). But
    after around 40 sec I get "Connection to host lost"
    I can ping my ip address, (without the firewall of course).

    >
    > where aaa.bbb.ccc.ddd is the RDP host. Once you
    > get the host to respond, you can extend your tests to
    > the outside world.

    I am not sure if the response I get is a success or not.

    >
    > I assume that you have Remote Desktop enabled on
    > your RDP host.
    >

    Yes, (System->Remove->"Allow users...")

    Simon
  17. Archived from groups: microsoft.public.windowsxp.general,microsoft.public.windowsxp.work_remotely (More info?)

    Going back to your original post...

    Why are you running with both ZA Pro and the Windows SP2 firewall on the same PC? Turn off the
    windows firewall and only use ZA Pro...

    --
    Al Jarvi (MS-MVP Windows Networking)

    Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
    The MS-MVP Program - http://mvp.support.microsoft.com
    This posting is provided "AS IS" with no warranties, and confers no rights...

    "simon" <spambucket@myoddweb.com> wrote in message news:eV5eHqXIFHA.1476@TK2MSFTNGP09.phx.gbl...
    > >
    >> You never told us how you connect to your outside world.
    >> All we know so far is that you do not use a router.
    >
    > Sorry, I didn't know it mattered because I did mention that it worked with windows firewall off.
    > BTW, I might get in trouble for mentioning that so late, but I am using win 98 as my other
    > machine, (that's the only one I have).
    >
    > But seen that it works fine without the firewall I can only assume that it should work with it.
    >
    >>
    >> The easiest way to trouble-shoot such problems is to start
    >> from the inside: Use another PC to issue this command:
    >>
    >> telnet aaa.bbb.ccc.ddd 3389
    >
    > With or without the firewall I get the telnet screen, (it seems ok). But after around 40 sec I get
    > "Connection to host lost"
    > I can ping my ip address, (without the firewall of course).
    >
    >>
    >> where aaa.bbb.ccc.ddd is the RDP host. Once you
    >> get the host to respond, you can extend your tests to
    >> the outside world.
    >
    > I am not sure if the response I get is a success or not.
    >
    >>
    >> I assume that you have Remote Desktop enabled on
    >> your RDP host.
    >>
    >
    > Yes, (System->Remove->"Allow users...")
    >
    > Simon
    >
  18. Archived from groups: microsoft.public.windowsxp.general,microsoft.public.windowsxp.work_remotely (More info?)

    > Going back to your original post...
    >
    > Why are you running with both ZA Pro and the Windows SP2 firewall on the
    > same PC? Turn off the windows firewall and only use ZA Pro...
    >

    It looks like I will have to do that :(
    I just wanted to understand why ZA can allow the connection while WinXP does
    not.

    I am guessing that there is something blatantly wrong in my setup somewhere.

    Simon
  19. Archived from groups: microsoft.public.windowsxp.general,microsoft.public.windowsxp.work_remotely (More info?)

    "Sooner Al [MVP]" <SoonerAl@somewhere.net.invalid> wrote in
    news:OZrjY3XIFHA.2924@TK2MSFTNGP15.phx.gbl:

    > Going back to your original post...
    >
    > Why are you running with both ZA Pro and the Windows SP2 firewall on
    > the same PC? Turn off the windows firewall and only use ZA Pro...
    >

    thats the best answer i heard all thread
Ask a new question

Read More

Remote Desktop Firewalls Connection Microsoft Windows XP