Have a dos program that I want to print remotely

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Would like to start off by saying I know just enough to get myself into
trouble. I have set up remote desktop on my office computer and on my laptop.
Both machines are running xp pro. The remote desktop connection works fine,
and I can print any window programs at the remote location(laptop). I cannot
print from a dos program(the main reason for weeks of trial & error), I am
assuming because it is printing to the lpt1 port at the office machine. How
would I go about redirecting this print command to the laptop @ my house. The
printer is connected directlty to the lpt1 port of the laptop at my home.The
printer is a panasonic kx-p2624.
Any help would be greatly appreciated!
5 answers Last reply
More about have program print remotely
  1. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    in your RDP session do:

    Start -> Run -> cmd.exe -> "net use LPT1: \\tsclient\PrinterName"

    "Joe" wrote:

    > Would like to start off by saying I know just enough to get myself into
    > trouble. I have set up remote desktop on my office computer and on my laptop.
    > Both machines are running xp pro. The remote desktop connection works fine,
    > and I can print any window programs at the remote location(laptop). I cannot
    > print from a dos program(the main reason for weeks of trial & error), I am
    > assuming because it is printing to the lpt1 port at the office machine. How
    > would I go about redirecting this print command to the laptop @ my house. The
    > printer is connected directlty to the lpt1 port of the laptop at my home.The
    > printer is a panasonic kx-p2624.
    > Any help would be greatly appreciated!
  2. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Thanks for the reply, I tried the command but I received the following error
    message: system error 66 has occured the network resource type is not
    correct. I am entering the following way:
    net_use_lpt1:_\\ts(name of my laptop)\printer share name
    I also tried inserting the name of the office computer instead of the laptop
    name which gave me the same error.
    one other thing I noticed is that in checking for the proper sharename for
    the printer there are two panasonic printers, of which one says my laptops
    name in parenthesis next to it on the office computer. I tried both printer
    names both gave same error message.
    Any additional help would again be greatly appreciated, like I said I know
    just enough to get myself into trouble. Thanks again for the reply

    "Patrick Rouse" wrote:

    > in your RDP session do:
    >
    > Start -> Run -> cmd.exe -> "net use LPT1: \\tsclient\PrinterName"
    >
    > "Joe" wrote:
    >
    > > Would like to start off by saying I know just enough to get myself into
    > > trouble. I have set up remote desktop on my office computer and on my laptop.
    > > Both machines are running xp pro. The remote desktop connection works fine,
    > > and I can print any window programs at the remote location(laptop). I cannot
    > > print from a dos program(the main reason for weeks of trial & error), I am
    > > assuming because it is printing to the lpt1 port at the office machine. How
    > > would I go about redirecting this print command to the laptop @ my house. The
    > > printer is connected directlty to the lpt1 port of the laptop at my home.The
    > > printer is a panasonic kx-p2624.
    > > Any help would be greatly appreciated!
  3. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    When I wrote "\\tsclient", that's exactly what I meant, as this is the UNC
    path to the client device for the current session. If you have the client
    printer shared as HPLJ, you'd do :

    NET USE LPT1: \\tsclient\HPLJ /persistent /yes

    To verify that it's available, browse My Network Places (or Network
    Neighborhood) -> Entire Network -> Client Network -> \\tsclient (or \\client
    if using Citrix).

    "Joe" wrote:

    > Thanks for the reply, I tried the command but I received the following error
    > message: system error 66 has occured the network resource type is not
    > correct. I am entering the following way:
    > net_use_lpt1:_\\ts(name of my laptop)\printer share name
    > I also tried inserting the name of the office computer instead of the laptop
    > name which gave me the same error.
    > one other thing I noticed is that in checking for the proper sharename for
    > the printer there are two panasonic printers, of which one says my laptops
    > name in parenthesis next to it on the office computer. I tried both printer
    > names both gave same error message.
    > Any additional help would again be greatly appreciated, like I said I know
    > just enough to get myself into trouble. Thanks again for the reply
    >
    > "Patrick Rouse" wrote:
    >
    > > in your RDP session do:
    > >
    > > Start -> Run -> cmd.exe -> "net use LPT1: \\tsclient\PrinterName"
    > >
    > > "Joe" wrote:
    > >
    > > > Would like to start off by saying I know just enough to get myself into
    > > > trouble. I have set up remote desktop on my office computer and on my laptop.
    > > > Both machines are running xp pro. The remote desktop connection works fine,
    > > > and I can print any window programs at the remote location(laptop). I cannot
    > > > print from a dos program(the main reason for weeks of trial & error), I am
    > > > assuming because it is printing to the lpt1 port at the office machine. How
    > > > would I go about redirecting this print command to the laptop @ my house. The
    > > > printer is connected directlty to the lpt1 port of the laptop at my home.The
    > > > printer is a panasonic kx-p2624.
    > > > Any help would be greatly appreciated!
  4. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    When I tried that command came back with "you used an option with an invalid
    value". Just want to verify that I am doing this command line using the
    office computer start button when I am logged on using the RDP, not the start
    button on my laptop. When I searched (my network neighborhood on the office
    machine) there is no option for entire network client network. Am I missing
    something. Also I tried a ":" instead of a "/" in front of the yes that came
    back with system error 87

    "Patrick Rouse" wrote:

    > When I wrote "\\tsclient", that's exactly what I meant, as this is the UNC
    > path to the client device for the current session. If you have the client
    > printer shared as HPLJ, you'd do :
    >
    > NET USE LPT1: \\tsclient\HPLJ /persistent /yes
    >
    > To verify that it's available, browse My Network Places (or Network
    > Neighborhood) -> Entire Network -> Client Network -> \\tsclient (or \\client
    > if using Citrix).
    >
    > "Joe" wrote:
    >
    > > Thanks for the reply, I tried the command but I received the following error
    > > message: system error 66 has occured the network resource type is not
    > > correct. I am entering the following way:
    > > net_use_lpt1:_\\ts(name of my laptop)\printer share name
    > > I also tried inserting the name of the office computer instead of the laptop
    > > name which gave me the same error.
    > > one other thing I noticed is that in checking for the proper sharename for
    > > the printer there are two panasonic printers, of which one says my laptops
    > > name in parenthesis next to it on the office computer. I tried both printer
    > > names both gave same error message.
    > > Any additional help would again be greatly appreciated, like I said I know
    > > just enough to get myself into trouble. Thanks again for the reply
    > >
    > > "Patrick Rouse" wrote:
    > >
    > > > in your RDP session do:
    > > >
    > > > Start -> Run -> cmd.exe -> "net use LPT1: \\tsclient\PrinterName"
    > > >
    > > > "Joe" wrote:
    > > >
    > > > > Would like to start off by saying I know just enough to get myself into
    > > > > trouble. I have set up remote desktop on my office computer and on my laptop.
    > > > > Both machines are running xp pro. The remote desktop connection works fine,
    > > > > and I can print any window programs at the remote location(laptop). I cannot
    > > > > print from a dos program(the main reason for weeks of trial & error), I am
    > > > > assuming because it is printing to the lpt1 port at the office machine. How
    > > > > would I go about redirecting this print command to the laptop @ my house. The
    > > > > printer is connected directlty to the lpt1 port of the laptop at my home.The
    > > > > printer is a panasonic kx-p2624.
    > > > > Any help would be greatly appreciated!
  5. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Thanks for the time I will keep trying different things until I figure it out.

    "Joe" wrote:

    > When I tried that command came back with "you used an option with an invalid
    > value". Just want to verify that I am doing this command line using the
    > office computer start button when I am logged on using the RDP, not the start
    > button on my laptop. When I searched (my network neighborhood on the office
    > machine) there is no option for entire network client network. Am I missing
    > something. Also I tried a ":" instead of a "/" in front of the yes that came
    > back with system error 87
    >
    > "Patrick Rouse" wrote:
    >
    > > When I wrote "\\tsclient", that's exactly what I meant, as this is the UNC
    > > path to the client device for the current session. If you have the client
    > > printer shared as HPLJ, you'd do :
    > >
    > > NET USE LPT1: \\tsclient\HPLJ /persistent /yes
    > >
    > > To verify that it's available, browse My Network Places (or Network
    > > Neighborhood) -> Entire Network -> Client Network -> \\tsclient (or \\client
    > > if using Citrix).
    > >
    > > "Joe" wrote:
    > >
    > > > Thanks for the reply, I tried the command but I received the following error
    > > > message: system error 66 has occured the network resource type is not
    > > > correct. I am entering the following way:
    > > > net_use_lpt1:_\\ts(name of my laptop)\printer share name
    > > > I also tried inserting the name of the office computer instead of the laptop
    > > > name which gave me the same error.
    > > > one other thing I noticed is that in checking for the proper sharename for
    > > > the printer there are two panasonic printers, of which one says my laptops
    > > > name in parenthesis next to it on the office computer. I tried both printer
    > > > names both gave same error message.
    > > > Any additional help would again be greatly appreciated, like I said I know
    > > > just enough to get myself into trouble. Thanks again for the reply
    > > >
    > > > "Patrick Rouse" wrote:
    > > >
    > > > > in your RDP session do:
    > > > >
    > > > > Start -> Run -> cmd.exe -> "net use LPT1: \\tsclient\PrinterName"
    > > > >
    > > > > "Joe" wrote:
    > > > >
    > > > > > Would like to start off by saying I know just enough to get myself into
    > > > > > trouble. I have set up remote desktop on my office computer and on my laptop.
    > > > > > Both machines are running xp pro. The remote desktop connection works fine,
    > > > > > and I can print any window programs at the remote location(laptop). I cannot
    > > > > > print from a dos program(the main reason for weeks of trial & error), I am
    > > > > > assuming because it is printing to the lpt1 port at the office machine. How
    > > > > > would I go about redirecting this print command to the laptop @ my house. The
    > > > > > printer is connected directlty to the lpt1 port of the laptop at my home.The
    > > > > > printer is a panasonic kx-p2624.
    > > > > > Any help would be greatly appreciated!
Ask a new question

Read More

Laptops Remote Desktop Windows XP