Sign in with
Sign up | Sign in
Your question

RD works on LAN not across Internet

Last response: in Windows XP
Share
Anonymous
April 15, 2005 10:52:03 AM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Running XP Pro SP2 on both host (desktop) & client (laptop). Windows Firewall
running on host, Remote Desktop enabled through System Properties and users
assigned (I've also verfied that the Firewall allows exceptions and Remote
Desktop is checked, and the 'Advanced' tab shows Remote Desktop enabled and
pointing to itself by computer name).

Remote Desktop works flawlessly when connecting within the LAN.

At one time RD worked just fine across the Internet using port forwarding
through my router. Now it refuses to connect across the Internet.

I've tried numerous things, up to and including switching from cable to DSL,
rebuilding the router settings after doing a factory reset - - and even
by-passing the router and connecting the host directly to the DSL modem.

I can ping the host PC without problem, so I know I've got the correct IP
address.

I've seen suggestions for rolling the terminal services .dll on the host
back to the SP1 version. Before doing that, is there something I've missed?
For example, an MS Hotfix?

More about : works lan internet

Anonymous
April 15, 2005 1:31:27 PM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Well, if you can connect to the Remote Desktop host across your LAN then its obviously an issue with
port forwarding through your firewall/NAT/router device or an addressing issue.

What router? Are you using a static IP for the PC on your LAN? Are you calling the correct public IP
for the router?

There is some troubleshooting help on this page...

http://theillustratednetwork.mvps.org/RemoteDesktop/Rem...

--

Al Jarvi (MS-MVP Windows Networking)

Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
The MS-MVP Program - http://mvp.support.microsoft.com
This posting is provided "AS IS" with no warranties, and confers no rights...


"Jim Johnson - Serenity Consulting" <JimJohnsonSerenityConsulting@discussions.microsoft.com> wrote
in message news:A15029FE-AFA4-46B9-A04F-E3807A59A459@microsoft.com...
> Running XP Pro SP2 on both host (desktop) & client (laptop). Windows Firewall
> running on host, Remote Desktop enabled through System Properties and users
> assigned (I've also verfied that the Firewall allows exceptions and Remote
> Desktop is checked, and the 'Advanced' tab shows Remote Desktop enabled and
> pointing to itself by computer name).
>
> Remote Desktop works flawlessly when connecting within the LAN.
>
> At one time RD worked just fine across the Internet using port forwarding
> through my router. Now it refuses to connect across the Internet.
>
> I've tried numerous things, up to and including switching from cable to DSL,
> rebuilding the router settings after doing a factory reset - - and even
> by-passing the router and connecting the host directly to the DSL modem.
>
> I can ping the host PC without problem, so I know I've got the correct IP
> address.
>
> I've seen suggestions for rolling the terminal services .dll on the host
> back to the SP1 version. Before doing that, is there something I've missed?
> For example, an MS Hotfix?
Anonymous
April 15, 2005 1:31:28 PM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

I was using a static IP behind the router, and yes the public IP was
verified. I have verified that the Windows Firewall's scope for Remote
Desktop includes all computers, even those with public IP addresses. No
policies have been implemented on the host. My attempted login is with an
administrator group account (actually the same account to which I login
locally).

For last test, I physically by-passed the router altogether and connected
the host directly to the DSL modem - along with changing the host's IP
settings to fully use DHCP to access the Internet. In other words, the host
is no longer part of the LAN (and no other PC on the LAN can connect to the
Internet).

I *still* cannot make a RD connection across the Internet. Both my former
ISP (Charter Cable) and my new ISP (SBC/Yahoo DSL) claim they do not block
port 3389. However, using web-based port checking tools, my PC cannot be seen
at port 3389. I *am* able to successfully ping the public IP address of the
host across the Internet.

So, within a LAN using private IP addressing, RD works fine. Using a direct
connection to the Internet (no local router in the circuit) and public IP
addressing, RD fails.

By the way, I had also tested using the router and port forwarding to a
static private IP address (no changes from what used to work), AND disabling
all software firewall protection at the host (relied on the router's
firewall). The result was identical.

*Something* within the host simply does not like doing RD across the
Internet. I am leary of dredging up a SP1 copy of trmserv.dll - but may
experiment if no one has a better suggestion.

thanks,

Jim Johnson


"Sooner Al [MVP]" wrote:

> Well, if you can connect to the Remote Desktop host across your LAN then its obviously an issue with
> port forwarding through your firewall/NAT/router device or an addressing issue.
>
> What router? Are you using a static IP for the PC on your LAN? Are you calling the correct public IP
> for the router?
>
> There is some troubleshooting help on this page...
>
> http://theillustratednetwork.mvps.org/RemoteDesktop/Rem...
>
> --
>
> Al Jarvi (MS-MVP Windows Networking)
>
> Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
> The MS-MVP Program - http://mvp.support.microsoft.com
> This posting is provided "AS IS" with no warranties, and confers no rights...
>
>
> "Jim Johnson - Serenity Consulting" <JimJohnsonSerenityConsulting@discussions.microsoft.com> wrote
> in message news:A15029FE-AFA4-46B9-A04F-E3807A59A459@microsoft.com...
> > Running XP Pro SP2 on both host (desktop) & client (laptop). Windows Firewall
> > running on host, Remote Desktop enabled through System Properties and users
> > assigned (I've also verfied that the Firewall allows exceptions and Remote
> > Desktop is checked, and the 'Advanced' tab shows Remote Desktop enabled and
> > pointing to itself by computer name).
> >
> > Remote Desktop works flawlessly when connecting within the LAN.
> >
> > At one time RD worked just fine across the Internet using port forwarding
> > through my router. Now it refuses to connect across the Internet.
> >
> > I've tried numerous things, up to and including switching from cable to DSL,
> > rebuilding the router settings after doing a factory reset - - and even
> > by-passing the router and connecting the host directly to the DSL modem.
> >
> > I can ping the host PC without problem, so I know I've got the correct IP
> > address.
> >
> > I've seen suggestions for rolling the terminal services .dll on the host
> > back to the SP1 version. Before doing that, is there something I've missed?
> > For example, an MS Hotfix?
>
>
>
Related resources
Anonymous
April 19, 2005 12:16:29 AM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

I think I have the same problem... somebody does solve it ?


"Jim Johnson - Serenity Consulting"
<JimJohnsonSerenityConsulting@discussions.microsoft.com> wrote in message
news:B0457AE0-AB4C-4B38-9022-5A56D44AD5D8@microsoft.com...
>I was using a static IP behind the router, and yes the public IP was
> verified. I have verified that the Windows Firewall's scope for Remote
> Desktop includes all computers, even those with public IP addresses. No
> policies have been implemented on the host. My attempted login is with an
> administrator group account (actually the same account to which I login
> locally).
>
> For last test, I physically by-passed the router altogether and connected
> the host directly to the DSL modem - along with changing the host's IP
> settings to fully use DHCP to access the Internet. In other words, the
> host
> is no longer part of the LAN (and no other PC on the LAN can connect to
> the
> Internet).
>
> I *still* cannot make a RD connection across the Internet. Both my former
> ISP (Charter Cable) and my new ISP (SBC/Yahoo DSL) claim they do not block
> port 3389. However, using web-based port checking tools, my PC cannot be
> seen
> at port 3389. I *am* able to successfully ping the public IP address of
> the
> host across the Internet.
>
> So, within a LAN using private IP addressing, RD works fine. Using a
> direct
> connection to the Internet (no local router in the circuit) and public IP
> addressing, RD fails.
>
> By the way, I had also tested using the router and port forwarding to a
> static private IP address (no changes from what used to work), AND
> disabling
> all software firewall protection at the host (relied on the router's
> firewall). The result was identical.
>
> *Something* within the host simply does not like doing RD across the
> Internet. I am leary of dredging up a SP1 copy of trmserv.dll - but may
> experiment if no one has a better suggestion.
>
> thanks,
>
> Jim Johnson
>
>
> "Sooner Al [MVP]" wrote:
>
>> Well, if you can connect to the Remote Desktop host across your LAN then
>> its obviously an issue with
>> port forwarding through your firewall/NAT/router device or an addressing
>> issue.
>>
>> What router? Are you using a static IP for the PC on your LAN? Are you
>> calling the correct public IP
>> for the router?
>>
>> There is some troubleshooting help on this page...
>>
>> http://theillustratednetwork.mvps.org/RemoteDesktop/Rem...
>>
>> --
>>
>> Al Jarvi (MS-MVP Windows Networking)
>>
>> Please post *ALL* questions and replies to the news group for the mutual
>> benefit of all of us...
>> The MS-MVP Program - http://mvp.support.microsoft.com
>> This posting is provided "AS IS" with no warranties, and confers no
>> rights...
>>
>>
>> "Jim Johnson - Serenity Consulting"
>> <JimJohnsonSerenityConsulting@discussions.microsoft.com> wrote
>> in message news:A15029FE-AFA4-46B9-A04F-E3807A59A459@microsoft.com...
>> > Running XP Pro SP2 on both host (desktop) & client (laptop). Windows
>> > Firewall
>> > running on host, Remote Desktop enabled through System Properties and
>> > users
>> > assigned (I've also verfied that the Firewall allows exceptions and
>> > Remote
>> > Desktop is checked, and the 'Advanced' tab shows Remote Desktop enabled
>> > and
>> > pointing to itself by computer name).
>> >
>> > Remote Desktop works flawlessly when connecting within the LAN.
>> >
>> > At one time RD worked just fine across the Internet using port
>> > forwarding
>> > through my router. Now it refuses to connect across the Internet.
>> >
>> > I've tried numerous things, up to and including switching from cable to
>> > DSL,
>> > rebuilding the router settings after doing a factory reset - - and even
>> > by-passing the router and connecting the host directly to the DSL
>> > modem.
>> >
>> > I can ping the host PC without problem, so I know I've got the correct
>> > IP
>> > address.
>> >
>> > I've seen suggestions for rolling the terminal services .dll on the
>> > host
>> > back to the SP1 version. Before doing that, is there something I've
>> > missed?
>> > For example, an MS Hotfix?
>>
>>
>>
Anonymous
April 19, 2005 12:16:30 AM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

If you setup port forwarding for TCP Port 3389 on your router to the private LAN IP of the PC you
want to connect to remotely using Remote Desktop, then run this test...

http://www.canyouseeme.org/

If it fails then you have an issue with port forwarding on the router.

--

Al Jarvi (MS-MVP Windows Networking)

Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
The MS-MVP Program - http://mvp.support.microsoft.com
This posting is provided "AS IS" with no warranties, and confers no rights...


"mobief" <mobief@ya-hoooooooooooo.com> wrote in message
news:xAU8e.68275$YC4.4788260@phobos.telenet-ops.be...
>I think I have the same problem... somebody does solve it ?
>
>
> "Jim Johnson - Serenity Consulting" <JimJohnsonSerenityConsulting@discussions.microsoft.com> wrote
> in message news:B0457AE0-AB4C-4B38-9022-5A56D44AD5D8@microsoft.com...
>>I was using a static IP behind the router, and yes the public IP was
>> verified. I have verified that the Windows Firewall's scope for Remote
>> Desktop includes all computers, even those with public IP addresses. No
>> policies have been implemented on the host. My attempted login is with an
>> administrator group account (actually the same account to which I login
>> locally).
>>
>> For last test, I physically by-passed the router altogether and connected
>> the host directly to the DSL modem - along with changing the host's IP
>> settings to fully use DHCP to access the Internet. In other words, the host
>> is no longer part of the LAN (and no other PC on the LAN can connect to the
>> Internet).
>>
>> I *still* cannot make a RD connection across the Internet. Both my former
>> ISP (Charter Cable) and my new ISP (SBC/Yahoo DSL) claim they do not block
>> port 3389. However, using web-based port checking tools, my PC cannot be seen
>> at port 3389. I *am* able to successfully ping the public IP address of the
>> host across the Internet.
>>
>> So, within a LAN using private IP addressing, RD works fine. Using a direct
>> connection to the Internet (no local router in the circuit) and public IP
>> addressing, RD fails.
>>
>> By the way, I had also tested using the router and port forwarding to a
>> static private IP address (no changes from what used to work), AND disabling
>> all software firewall protection at the host (relied on the router's
>> firewall). The result was identical.
>>
>> *Something* within the host simply does not like doing RD across the
>> Internet. I am leary of dredging up a SP1 copy of trmserv.dll - but may
>> experiment if no one has a better suggestion.
>>
>> thanks,
>>
>> Jim Johnson
>>
>>
>> "Sooner Al [MVP]" wrote:
>>
>>> Well, if you can connect to the Remote Desktop host across your LAN then its obviously an issue
>>> with
>>> port forwarding through your firewall/NAT/router device or an addressing issue.
>>>
>>> What router? Are you using a static IP for the PC on your LAN? Are you calling the correct
>>> public IP
>>> for the router?
>>>
>>> There is some troubleshooting help on this page...
>>>
>>> http://theillustratednetwork.mvps.org/RemoteDesktop/Rem...
>>>
>>> --
>>>
>>> Al Jarvi (MS-MVP Windows Networking)
>>>
>>> Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
>>> The MS-MVP Program - http://mvp.support.microsoft.com
>>> This posting is provided "AS IS" with no warranties, and confers no rights...
>>>
>>>
>>> "Jim Johnson - Serenity Consulting" <JimJohnsonSerenityConsulting@discussions.microsoft.com>
>>> wrote
>>> in message news:A15029FE-AFA4-46B9-A04F-E3807A59A459@microsoft.com...
>>> > Running XP Pro SP2 on both host (desktop) & client (laptop). Windows Firewall
>>> > running on host, Remote Desktop enabled through System Properties and users
>>> > assigned (I've also verfied that the Firewall allows exceptions and Remote
>>> > Desktop is checked, and the 'Advanced' tab shows Remote Desktop enabled and
>>> > pointing to itself by computer name).
>>> >
>>> > Remote Desktop works flawlessly when connecting within the LAN.
>>> >
>>> > At one time RD worked just fine across the Internet using port forwarding
>>> > through my router. Now it refuses to connect across the Internet.
>>> >
>>> > I've tried numerous things, up to and including switching from cable to DSL,
>>> > rebuilding the router settings after doing a factory reset - - and even
>>> > by-passing the router and connecting the host directly to the DSL modem.
>>> >
>>> > I can ping the host PC without problem, so I know I've got the correct IP
>>> > address.
>>> >
>>> > I've seen suggestions for rolling the terminal services .dll on the host
>>> > back to the SP1 version. Before doing that, is there something I've missed?
>>> > For example, an MS Hotfix?
>>>
>>>
>>>
>
>
Anonymous
April 19, 2005 10:54:02 AM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

I have a similar problem. RD works fine within my LAN but not across the
Internet.

I turned off Windows Firewall and NIS on all computers. Going to
www.canyouseeme.org still does not see my host computer, or any other
computer for that matter. I tried forwarding the 3389 to each individual
PC's and none worked.

Strange thing I see happening. Even with all the firewalls turned off, when
I run Symantec's security check everything checks as secured... how can this
be?

Eduardo

"Sooner Al [MVP]" wrote:

> If you setup port forwarding for TCP Port 3389 on your router to the private LAN IP of the PC you
> want to connect to remotely using Remote Desktop, then run this test...
>
> http://www.canyouseeme.org/
>
> If it fails then you have an issue with port forwarding on the router.
>
> --
>
> Al Jarvi (MS-MVP Windows Networking)
>
> Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
> The MS-MVP Program - http://mvp.support.microsoft.com
> This posting is provided "AS IS" with no warranties, and confers no rights...
>
>
> "mobief" <mobief@ya-hoooooooooooo.com> wrote in message
> news:xAU8e.68275$YC4.4788260@phobos.telenet-ops.be...
> >I think I have the same problem... somebody does solve it ?
> >
> >
> > "Jim Johnson - Serenity Consulting" <JimJohnsonSerenityConsulting@discussions.microsoft.com> wrote
> > in message news:B0457AE0-AB4C-4B38-9022-5A56D44AD5D8@microsoft.com...
> >>I was using a static IP behind the router, and yes the public IP was
> >> verified. I have verified that the Windows Firewall's scope for Remote
> >> Desktop includes all computers, even those with public IP addresses. No
> >> policies have been implemented on the host. My attempted login is with an
> >> administrator group account (actually the same account to which I login
> >> locally).
> >>
> >> For last test, I physically by-passed the router altogether and connected
> >> the host directly to the DSL modem - along with changing the host's IP
> >> settings to fully use DHCP to access the Internet. In other words, the host
> >> is no longer part of the LAN (and no other PC on the LAN can connect to the
> >> Internet).
> >>
> >> I *still* cannot make a RD connection across the Internet. Both my former
> >> ISP (Charter Cable) and my new ISP (SBC/Yahoo DSL) claim they do not block
> >> port 3389. However, using web-based port checking tools, my PC cannot be seen
> >> at port 3389. I *am* able to successfully ping the public IP address of the
> >> host across the Internet.
> >>
> >> So, within a LAN using private IP addressing, RD works fine. Using a direct
> >> connection to the Internet (no local router in the circuit) and public IP
> >> addressing, RD fails.
> >>
> >> By the way, I had also tested using the router and port forwarding to a
> >> static private IP address (no changes from what used to work), AND disabling
> >> all software firewall protection at the host (relied on the router's
> >> firewall). The result was identical.
> >>
> >> *Something* within the host simply does not like doing RD across the
> >> Internet. I am leary of dredging up a SP1 copy of trmserv.dll - but may
> >> experiment if no one has a better suggestion.
> >>
> >> thanks,
> >>
> >> Jim Johnson
> >>
> >>
> >> "Sooner Al [MVP]" wrote:
> >>
> >>> Well, if you can connect to the Remote Desktop host across your LAN then its obviously an issue
> >>> with
> >>> port forwarding through your firewall/NAT/router device or an addressing issue.
> >>>
> >>> What router? Are you using a static IP for the PC on your LAN? Are you calling the correct
> >>> public IP
> >>> for the router?
> >>>
> >>> There is some troubleshooting help on this page...
> >>>
> >>> http://theillustratednetwork.mvps.org/RemoteDesktop/Rem...
> >>>
> >>> --
> >>>
> >>> Al Jarvi (MS-MVP Windows Networking)
> >>>
> >>> Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
> >>> The MS-MVP Program - http://mvp.support.microsoft.com
> >>> This posting is provided "AS IS" with no warranties, and confers no rights...
> >>>
> >>>
> >>> "Jim Johnson - Serenity Consulting" <JimJohnsonSerenityConsulting@discussions.microsoft.com>
> >>> wrote
> >>> in message news:A15029FE-AFA4-46B9-A04F-E3807A59A459@microsoft.com...
> >>> > Running XP Pro SP2 on both host (desktop) & client (laptop). Windows Firewall
> >>> > running on host, Remote Desktop enabled through System Properties and users
> >>> > assigned (I've also verfied that the Firewall allows exceptions and Remote
> >>> > Desktop is checked, and the 'Advanced' tab shows Remote Desktop enabled and
> >>> > pointing to itself by computer name).
> >>> >
> >>> > Remote Desktop works flawlessly when connecting within the LAN.
> >>> >
> >>> > At one time RD worked just fine across the Internet using port forwarding
> >>> > through my router. Now it refuses to connect across the Internet.
> >>> >
> >>> > I've tried numerous things, up to and including switching from cable to DSL,
> >>> > rebuilding the router settings after doing a factory reset - - and even
> >>> > by-passing the router and connecting the host directly to the DSL modem.
> >>> >
> >>> > I can ping the host PC without problem, so I know I've got the correct IP
> >>> > address.
> >>> >
> >>> > I've seen suggestions for rolling the terminal services .dll on the host
> >>> > back to the SP1 version. Before doing that, is there something I've missed?
> >>> > For example, an MS Hotfix?
> >>>
> >>>
> >>>
> >
> >
>
>
>
Anonymous
April 19, 2005 5:43:01 PM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Please post your results.
When the trouble started I was using a D-link cable modem - it worked, then
the next time I tried it a week or so later, it didn't.

This and other reasons caused me to switch to DSL - specifically SBC/Yahoo
using the SBC supplied Speedstream 5100b PPPoE modem (no router
capabilities). This modem is currently configured to operate as a pure
DSL/ethernet bridge with all PPPoE functions controlled by a Belkin wireless
router (the XP Pro host is using a wired ethernet connection). Port
forwarding to the host IS working (see earlier message).

Everything seems to be working the same as it did with the cable connection
INCLUDING that I cannot get to the host across the Internet using Remote
Desktop. It continues to work perfectly from within the LAN.

canyouseeme.org and other web-based port scans haven't been able to see me
at all.



"Eduardo Pietri" wrote:
> I was finally able to be seen by "canyouseeme" tool. I just opened the 3389
> port in the cable modem. I didn't have it open there; I never thought it
> would make a difference. I am not using a router, I use a HPNA network and
> my "host" PC is the DHCP.
>
> Now I will try it accessing my XP Pro PC from the outside world to see if it
> really works.
>
> Eduardo
Anonymous
April 19, 2005 11:19:02 PM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

PROBLEM FIXED?:

I activitated various event logs, and found this error...
ID: 20106
Source: RemoteAccess
Version: 5.2
Symbolic Name: ROUTERLOG_COULDNT_ADD_INTERFACE
Message: Unable to add the interface %1 with the Router Manager for the %2
protocol. The following error occurred: %3

Explanation
Possible causes include:

The interface type is not dedicated
The loopback and router is configured in Lanonly mode
======================
I then checked Services in the Adminstrative Tools and found that the
following services where in manual mode and not started:
Remote Access Auto Connection Manager
Remote Access Connection Manager
Remote Desktop Help Session Manager

Changing these services to 'automatic' (and starting the Remote Access
services) now allows port 3389 to be seen using the web-based port scanner,
www.canyouseeme.org. Without these services running, Remote Desktop will only
work on a LAN.

How they got changed to manual and turned off in the first place is beyond me.


"Jim Johnson - Serenity Consulting" wrote:

> Running XP Pro SP2 on both host (desktop) & client (laptop). Windows Firewall
> running on host, Remote Desktop enabled through System Properties and users
> assigned (I've also verfied that the Firewall allows exceptions and Remote
> Desktop is checked, and the 'Advanced' tab shows Remote Desktop enabled and
> pointing to itself by computer name).
>
> Remote Desktop works flawlessly when connecting within the LAN.
>
> At one time RD worked just fine across the Internet using port forwarding
> through my router. Now it refuses to connect across the Internet.
>
> I've tried numerous things, up to and including switching from cable to DSL,
> rebuilding the router settings after doing a factory reset - - and even
> by-passing the router and connecting the host directly to the DSL modem.
>
> I can ping the host PC without problem, so I know I've got the correct IP
> address.
>
> I've seen suggestions for rolling the terminal services .dll on the host
> back to the SP1 version. Before doing that, is there something I've missed?
> For example, an MS Hotfix?
Anonymous
April 20, 2005 9:04:02 AM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Thanks for the feedback...

Al

"Jim Johnson - Serenity Consulting" wrote:

> PROBLEM FIXED?:
>
> I activitated various event logs, and found this error...
> ID: 20106
> Source: RemoteAccess
> Version: 5.2
> Symbolic Name: ROUTERLOG_COULDNT_ADD_INTERFACE
> Message: Unable to add the interface %1 with the Router Manager for the %2
> protocol. The following error occurred: %3
>
> Explanation
> Possible causes include:
>
> The interface type is not dedicated
> The loopback and router is configured in Lanonly mode
> ======================
> I then checked Services in the Adminstrative Tools and found that the
> following services where in manual mode and not started:
> Remote Access Auto Connection Manager
> Remote Access Connection Manager
> Remote Desktop Help Session Manager
>
> Changing these services to 'automatic' (and starting the Remote Access
> services) now allows port 3389 to be seen using the web-based port scanner,
> www.canyouseeme.org. Without these services running, Remote Desktop will only
> work on a LAN.
>
> How they got changed to manual and turned off in the first place is beyond me.
>
>
> "Jim Johnson - Serenity Consulting" wrote:
>
> > Running XP Pro SP2 on both host (desktop) & client (laptop). Windows Firewall
> > running on host, Remote Desktop enabled through System Properties and users
> > assigned (I've also verfied that the Firewall allows exceptions and Remote
> > Desktop is checked, and the 'Advanced' tab shows Remote Desktop enabled and
> > pointing to itself by computer name).
> >
> > Remote Desktop works flawlessly when connecting within the LAN.
> >
> > At one time RD worked just fine across the Internet using port forwarding
> > through my router. Now it refuses to connect across the Internet.
> >
> > I've tried numerous things, up to and including switching from cable to DSL,
> > rebuilding the router settings after doing a factory reset - - and even
> > by-passing the router and connecting the host directly to the DSL modem.
> >
> > I can ping the host PC without problem, so I know I've got the correct IP
> > address.
> >
> > I've seen suggestions for rolling the terminal services .dll on the host
> > back to the SP1 version. Before doing that, is there something I've missed?
> > For example, an MS Hotfix?
Anonymous
April 20, 2005 9:27:03 AM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Yes it is fixed, just tested from remote location outside the LAN and Remote
Desktop is again fully operational.

As both Remote Assistance and Remote Desktop are checked to allow in System
Properties/Remote, Windows Firewall was set to allow Remote Desktop, and
Remote Desktop "suddenly" stopped working outside the LAN, I suspect one of
Microsoft's security updates turned off the Remote Access services.

"Jim Johnson - Serenity Consulting" wrote:

> PROBLEM FIXED?:
>
> I activitated various event logs, and found this error...
> ID: 20106
> Source: RemoteAccess
> Version: 5.2
> Symbolic Name: ROUTERLOG_COULDNT_ADD_INTERFACE
> Message: Unable to add the interface %1 with the Router Manager for the %2
> protocol. The following error occurred: %3
>
> Explanation
> Possible causes include:
>
> The interface type is not dedicated
> The loopback and router is configured in Lanonly mode
> ======================
> I then checked Services in the Adminstrative Tools and found that the
> following services where in manual mode and not started:
> Remote Access Auto Connection Manager
> Remote Access Connection Manager
> Remote Desktop Help Session Manager
>
> Changing these services to 'automatic' (and starting the Remote Access
> services) now allows port 3389 to be seen using the web-based port scanner,
> www.canyouseeme.org. Without these services running, Remote Desktop will only
> work on a LAN.
>
> How they got changed to manual and turned off in the first place is beyond me.
>
>
> "Jim Johnson - Serenity Consulting" wrote:
>
> > Running XP Pro SP2 on both host (desktop) & client (laptop). Windows Firewall
> > running on host, Remote Desktop enabled through System Properties and users
> > assigned (I've also verfied that the Firewall allows exceptions and Remote
> > Desktop is checked, and the 'Advanced' tab shows Remote Desktop enabled and
> > pointing to itself by computer name).
> >
> > Remote Desktop works flawlessly when connecting within the LAN.
> >
> > At one time RD worked just fine across the Internet using port forwarding
> > through my router. Now it refuses to connect across the Internet.
> >
> > I've tried numerous things, up to and including switching from cable to DSL,
> > rebuilding the router settings after doing a factory reset - - and even
> > by-passing the router and connecting the host directly to the DSL modem.
> >
> > I can ping the host PC without problem, so I know I've got the correct IP
> > address.
> >
> > I've seen suggestions for rolling the terminal services .dll on the host
> > back to the SP1 version. Before doing that, is there something I've missed?
> > For example, an MS Hotfix?
Anonymous
April 20, 2005 10:15:01 AM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Problem fixed. I tested it from the outside world and it worked.

It seems as if the only reason was that the network card connected to the
cable modem did not have Port 3389 open. I don't recall reading anything
regarding opening this port for the network card connected to the modem. I
remember always referring to the LAN only.

My next situation is to allow access only from one location. The person who
will be accessing my PC is using DSL and it appears as if her DSL provider
assigns a different IP address every time it connects. If that's the case I
may have to use VPN or some other tool.

Eduardo

"Jim Johnson - Serenity Consulting" wrote:

>
> Please post your results.
> When the trouble started I was using a D-link cable modem - it worked, then
> the next time I tried it a week or so later, it didn't.
>
> This and other reasons caused me to switch to DSL - specifically SBC/Yahoo
> using the SBC supplied Speedstream 5100b PPPoE modem (no router
> capabilities). This modem is currently configured to operate as a pure
> DSL/ethernet bridge with all PPPoE functions controlled by a Belkin wireless
> router (the XP Pro host is using a wired ethernet connection). Port
> forwarding to the host IS working (see earlier message).
>
> Everything seems to be working the same as it did with the cable connection
> INCLUDING that I cannot get to the host across the Internet using Remote
> Desktop. It continues to work perfectly from within the LAN.
>
> canyouseeme.org and other web-based port scans haven't been able to see me
> at all.
>
>
>
> "Eduardo Pietri" wrote:
> > I was finally able to be seen by "canyouseeme" tool. I just opened the 3389
> > port in the cable modem. I didn't have it open there; I never thought it
> > would make a difference. I am not using a router, I use a HPNA network and
> > my "host" PC is the DHCP.
> >
> > Now I will try it accessing my XP Pro PC from the outside world to see if it
> > really works.
> >
> > Eduardo
>
Anonymous
April 20, 2005 4:17:14 PM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

That's interesting because I just looked at my XP Pro desktop and all of those services are listed
as both "Manual" and the status is "Stopped". In my case I can access my XP Pro desktop using Remote
Desktop just fine from the public internet through a SSH tunnel...

Weird...

--

Al Jarvi (MS-MVP Windows Networking)

Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
The MS-MVP Program - http://mvp.support.microsoft.com
This posting is provided "AS IS" with no warranties, and confers no rights...


"Jim Johnson - Serenity Consulting" <JimJohnsonSerenityConsulting@discussions.microsoft.com> wrote
in message news:752EDB65-D7D9-4E10-BEDE-DDD9B3E94062@microsoft.com...
> Yes it is fixed, just tested from remote location outside the LAN and Remote
> Desktop is again fully operational.
>
> As both Remote Assistance and Remote Desktop are checked to allow in System
> Properties/Remote, Windows Firewall was set to allow Remote Desktop, and
> Remote Desktop "suddenly" stopped working outside the LAN, I suspect one of
> Microsoft's security updates turned off the Remote Access services.
>
> "Jim Johnson - Serenity Consulting" wrote:
>
>> PROBLEM FIXED?:
>>
>> I activitated various event logs, and found this error...
>> ID: 20106
>> Source: RemoteAccess
>> Version: 5.2
>> Symbolic Name: ROUTERLOG_COULDNT_ADD_INTERFACE
>> Message: Unable to add the interface %1 with the Router Manager for the %2
>> protocol. The following error occurred: %3
>>
>> Explanation
>> Possible causes include:
>>
>> The interface type is not dedicated
>> The loopback and router is configured in Lanonly mode
>> ======================
>> I then checked Services in the Adminstrative Tools and found that the
>> following services where in manual mode and not started:
>> Remote Access Auto Connection Manager
>> Remote Access Connection Manager
>> Remote Desktop Help Session Manager
>>
>> Changing these services to 'automatic' (and starting the Remote Access
>> services) now allows port 3389 to be seen using the web-based port scanner,
>> www.canyouseeme.org. Without these services running, Remote Desktop will only
>> work on a LAN.
>>
>> How they got changed to manual and turned off in the first place is beyond me.
>>
>>
>> "Jim Johnson - Serenity Consulting" wrote:
>>
>> > Running XP Pro SP2 on both host (desktop) & client (laptop). Windows Firewall
>> > running on host, Remote Desktop enabled through System Properties and users
>> > assigned (I've also verfied that the Firewall allows exceptions and Remote
>> > Desktop is checked, and the 'Advanced' tab shows Remote Desktop enabled and
>> > pointing to itself by computer name).
>> >
>> > Remote Desktop works flawlessly when connecting within the LAN.
>> >
>> > At one time RD worked just fine across the Internet using port forwarding
>> > through my router. Now it refuses to connect across the Internet.
>> >
>> > I've tried numerous things, up to and including switching from cable to DSL,
>> > rebuilding the router settings after doing a factory reset - - and even
>> > by-passing the router and connecting the host directly to the DSL modem.
>> >
>> > I can ping the host PC without problem, so I know I've got the correct IP
>> > address.
>> >
>> > I've seen suggestions for rolling the terminal services .dll on the host
>> > back to the SP1 version. Before doing that, is there something I've missed?
>> > For example, an MS Hotfix?
Anonymous
April 21, 2005 3:01:05 PM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Al,
I'll bet most VPN's will work because the remote connection appears to be
part of the local subnet; i.e., part of the LAN.

My LAN access worked fine (although I have few needs to manipulate the host
from another PC when I am sitting right next to it <g>). For the few times I
need to access my home-office PC remotely, I don't want to deal with setting
up a VPN. Remote Desktop alone has sufficient security for my needs. It was
when I was logging in across the Internet with an IP in a different subnet
that Remote Desktop would no longer work. It USED to work fine.

Without changing any of your Remote Access related services on your Remote
Desktop host, and without setting up a VPN tunnel, try launching the Remote
Desktop from outside the host's subnet.

By turning off Remote Access, Microsoft did indeed make many PCs more
secure. However, I contend that it is the rough equivalent of curing a
headache with a guillotine. The security issues would be better addressed in
the firewall through a close link between port 3389 and Terminal Services.

Jim Johnson
Serenity Consulting

"Sooner Al [MVP]" wrote:

> That's interesting because I just looked at my XP Pro desktop and all of those services are listed
> as both "Manual" and the status is "Stopped". In my case I can access my XP Pro desktop using Remote
> Desktop just fine from the public internet through a SSH tunnel...
>
> Weird...
>
> --
>
> Al Jarvi (MS-MVP Windows Networking)
>
> Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
> The MS-MVP Program - http://mvp.support.microsoft.com
> This posting is provided "AS IS" with no warranties, and confers no rights...
>
>
> "Jim Johnson - Serenity Consulting" <JimJohnsonSerenityConsulting@discussions.microsoft.com> wrote
> in message news:752EDB65-D7D9-4E10-BEDE-DDD9B3E94062@microsoft.com...
> > Yes it is fixed, just tested from remote location outside the LAN and Remote
> > Desktop is again fully operational.
> >
> > As both Remote Assistance and Remote Desktop are checked to allow in System
> > Properties/Remote, Windows Firewall was set to allow Remote Desktop, and
> > Remote Desktop "suddenly" stopped working outside the LAN, I suspect one of
> > Microsoft's security updates turned off the Remote Access services.
> >
> > "Jim Johnson - Serenity Consulting" wrote:
> >
> >> PROBLEM FIXED?:
> >>
> >> I activitated various event logs, and found this error...
> >> ID: 20106
> >> Source: RemoteAccess
> >> Version: 5.2
> >> Symbolic Name: ROUTERLOG_COULDNT_ADD_INTERFACE
> >> Message: Unable to add the interface %1 with the Router Manager for the %2
> >> protocol. The following error occurred: %3
> >>
> >> Explanation
> >> Possible causes include:
> >>
> >> The interface type is not dedicated
> >> The loopback and router is configured in Lanonly mode
> >> ======================
> >> I then checked Services in the Adminstrative Tools and found that the
> >> following services where in manual mode and not started:
> >> Remote Access Auto Connection Manager
> >> Remote Access Connection Manager
> >> Remote Desktop Help Session Manager
> >>
> >> Changing these services to 'automatic' (and starting the Remote Access
> >> services) now allows port 3389 to be seen using the web-based port scanner,
> >> www.canyouseeme.org. Without these services running, Remote Desktop will only
> >> work on a LAN.
> >>
> >> How they got changed to manual and turned off in the first place is beyond me.
> >>
> >>
> >> "Jim Johnson - Serenity Consulting" wrote:
> >>
> >> > Running XP Pro SP2 on both host (desktop) & client (laptop). Windows Firewall
> >> > running on host, Remote Desktop enabled through System Properties and users
> >> > assigned (I've also verfied that the Firewall allows exceptions and Remote
> >> > Desktop is checked, and the 'Advanced' tab shows Remote Desktop enabled and
> >> > pointing to itself by computer name).
> >> >
> >> > Remote Desktop works flawlessly when connecting within the LAN.
> >> >
> >> > At one time RD worked just fine across the Internet using port forwarding
> >> > through my router. Now it refuses to connect across the Internet.
> >> >
> >> > I've tried numerous things, up to and including switching from cable to DSL,
> >> > rebuilding the router settings after doing a factory reset - - and even
> >> > by-passing the router and connecting the host directly to the DSL modem.
> >> >
> >> > I can ping the host PC without problem, so I know I've got the correct IP
> >> > address.
> >> >
> >> > I've seen suggestions for rolling the terminal services .dll on the host
> >> > back to the SP1 version. Before doing that, is there something I've missed?
> >> > For example, an MS Hotfix?
>
>
>
Anonymous
April 22, 2005 11:36:19 AM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Well, I tried with out going through a SSH tunnel and I connected just fine from a remote PC. The
RDP host is a fully patched XP Pro SP2 machine on my local LAN. So, there is something else going on
here, but I can't say what.

By the way, AFAIK, SSH does not assign a local subnet IP to the remote PC when you connect. I could
be wrong about that though and need to look into that further...

Bottom line though is as long as it works for you then that's good...

Later...

--

Al Jarvi (MS-MVP Windows Networking)

Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
The MS-MVP Program - http://mvp.support.microsoft.com
This posting is provided "AS IS" with no warranties, and confers no rights...


"Jim Johnson - Serenity Consulting" <JimJohnsonSerenityConsulting@discussions.microsoft.com> wrote
in message news:CFCE151B-5D41-4CE4-A712-F5C43F69053C@microsoft.com...
> Al,
> I'll bet most VPN's will work because the remote connection appears to be
> part of the local subnet; i.e., part of the LAN.
>
> My LAN access worked fine (although I have few needs to manipulate the host
> from another PC when I am sitting right next to it <g>). For the few times I
> need to access my home-office PC remotely, I don't want to deal with setting
> up a VPN. Remote Desktop alone has sufficient security for my needs. It was
> when I was logging in across the Internet with an IP in a different subnet
> that Remote Desktop would no longer work. It USED to work fine.
>
> Without changing any of your Remote Access related services on your Remote
> Desktop host, and without setting up a VPN tunnel, try launching the Remote
> Desktop from outside the host's subnet.
>
> By turning off Remote Access, Microsoft did indeed make many PCs more
> secure. However, I contend that it is the rough equivalent of curing a
> headache with a guillotine. The security issues would be better addressed in
> the firewall through a close link between port 3389 and Terminal Services.
>
> Jim Johnson
> Serenity Consulting
>
> "Sooner Al [MVP]" wrote:
>
>> That's interesting because I just looked at my XP Pro desktop and all of those services are
>> listed
>> as both "Manual" and the status is "Stopped". In my case I can access my XP Pro desktop using
>> Remote
>> Desktop just fine from the public internet through a SSH tunnel...
>>
>> Weird...
>>
>> --
>>
>> Al Jarvi (MS-MVP Windows Networking)
>>
>> Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
>> The MS-MVP Program - http://mvp.support.microsoft.com
>> This posting is provided "AS IS" with no warranties, and confers no rights...
>>
>>
>> "Jim Johnson - Serenity Consulting" <JimJohnsonSerenityConsulting@discussions.microsoft.com>
>> wrote
>> in message news:752EDB65-D7D9-4E10-BEDE-DDD9B3E94062@microsoft.com...
>> > Yes it is fixed, just tested from remote location outside the LAN and Remote
>> > Desktop is again fully operational.
>> >
>> > As both Remote Assistance and Remote Desktop are checked to allow in System
>> > Properties/Remote, Windows Firewall was set to allow Remote Desktop, and
>> > Remote Desktop "suddenly" stopped working outside the LAN, I suspect one of
>> > Microsoft's security updates turned off the Remote Access services.
>> >
>> > "Jim Johnson - Serenity Consulting" wrote:
>> >
>> >> PROBLEM FIXED?:
>> >>
>> >> I activitated various event logs, and found this error...
>> >> ID: 20106
>> >> Source: RemoteAccess
>> >> Version: 5.2
>> >> Symbolic Name: ROUTERLOG_COULDNT_ADD_INTERFACE
>> >> Message: Unable to add the interface %1 with the Router Manager for the %2
>> >> protocol. The following error occurred: %3
>> >>
>> >> Explanation
>> >> Possible causes include:
>> >>
>> >> The interface type is not dedicated
>> >> The loopback and router is configured in Lanonly mode
>> >> ======================
>> >> I then checked Services in the Adminstrative Tools and found that the
>> >> following services where in manual mode and not started:
>> >> Remote Access Auto Connection Manager
>> >> Remote Access Connection Manager
>> >> Remote Desktop Help Session Manager
>> >>
>> >> Changing these services to 'automatic' (and starting the Remote Access
>> >> services) now allows port 3389 to be seen using the web-based port scanner,
>> >> www.canyouseeme.org. Without these services running, Remote Desktop will only
>> >> work on a LAN.
>> >>
>> >> How they got changed to manual and turned off in the first place is beyond me.
>> >>
>> >>
>> >> "Jim Johnson - Serenity Consulting" wrote:
>> >>
>> >> > Running XP Pro SP2 on both host (desktop) & client (laptop). Windows Firewall
>> >> > running on host, Remote Desktop enabled through System Properties and users
>> >> > assigned (I've also verfied that the Firewall allows exceptions and Remote
>> >> > Desktop is checked, and the 'Advanced' tab shows Remote Desktop enabled and
>> >> > pointing to itself by computer name).
>> >> >
>> >> > Remote Desktop works flawlessly when connecting within the LAN.
>> >> >
>> >> > At one time RD worked just fine across the Internet using port forwarding
>> >> > through my router. Now it refuses to connect across the Internet.
>> >> >
>> >> > I've tried numerous things, up to and including switching from cable to DSL,
>> >> > rebuilding the router settings after doing a factory reset - - and even
>> >> > by-passing the router and connecting the host directly to the DSL modem.
>> >> >
>> >> > I can ping the host PC without problem, so I know I've got the correct IP
>> >> > address.
>> >> >
>> >> > I've seen suggestions for rolling the terminal services .dll on the host
>> >> > back to the SP1 version. Before doing that, is there something I've missed?
>> >> > For example, an MS Hotfix?
>>
>>
>>
Anonymous
April 24, 2005 9:21:37 AM

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

This KB article was just released. I wonder if it pertains in your case...

http://support.microsoft.com/default.aspx?scid=898060

--

Al Jarvi (MS-MVP Windows Networking)

Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
The MS-MVP Program - http://mvp.support.microsoft.com
This posting is provided "AS IS" with no warranties, and confers no rights...


"Jim Johnson - Serenity Consulting" <JimJohnsonSerenityConsulting@discussions.microsoft.com> wrote
in message news:752EDB65-D7D9-4E10-BEDE-DDD9B3E94062@microsoft.com...
> Yes it is fixed, just tested from remote location outside the LAN and Remote
> Desktop is again fully operational.
>
> As both Remote Assistance and Remote Desktop are checked to allow in System
> Properties/Remote, Windows Firewall was set to allow Remote Desktop, and
> Remote Desktop "suddenly" stopped working outside the LAN, I suspect one of
> Microsoft's security updates turned off the Remote Access services.
>
> "Jim Johnson - Serenity Consulting" wrote:
>
>> PROBLEM FIXED?:
>>
>> I activitated various event logs, and found this error...
>> ID: 20106
>> Source: RemoteAccess
>> Version: 5.2
>> Symbolic Name: ROUTERLOG_COULDNT_ADD_INTERFACE
>> Message: Unable to add the interface %1 with the Router Manager for the %2
>> protocol. The following error occurred: %3
>>
>> Explanation
>> Possible causes include:
>>
>> The interface type is not dedicated
>> The loopback and router is configured in Lanonly mode
>> ======================
>> I then checked Services in the Adminstrative Tools and found that the
>> following services where in manual mode and not started:
>> Remote Access Auto Connection Manager
>> Remote Access Connection Manager
>> Remote Desktop Help Session Manager
>>
>> Changing these services to 'automatic' (and starting the Remote Access
>> services) now allows port 3389 to be seen using the web-based port scanner,
>> www.canyouseeme.org. Without these services running, Remote Desktop will only
>> work on a LAN.
>>
>> How they got changed to manual and turned off in the first place is beyond me.
>>
>>
>> "Jim Johnson - Serenity Consulting" wrote:
>>
>> > Running XP Pro SP2 on both host (desktop) & client (laptop). Windows Firewall
>> > running on host, Remote Desktop enabled through System Properties and users
>> > assigned (I've also verfied that the Firewall allows exceptions and Remote
>> > Desktop is checked, and the 'Advanced' tab shows Remote Desktop enabled and
>> > pointing to itself by computer name).
>> >
>> > Remote Desktop works flawlessly when connecting within the LAN.
>> >
>> > At one time RD worked just fine across the Internet using port forwarding
>> > through my router. Now it refuses to connect across the Internet.
>> >
>> > I've tried numerous things, up to and including switching from cable to DSL,
>> > rebuilding the router settings after doing a factory reset - - and even
>> > by-passing the router and connecting the host directly to the DSL modem.
>> >
>> > I can ping the host PC without problem, so I know I've got the correct IP
>> > address.
>> >
>> > I've seen suggestions for rolling the terminal services .dll on the host
>> > back to the SP1 version. Before doing that, is there something I've missed?
>> > For example, an MS Hotfix?
!