Remote Desktop Fail after SP2 Installation Windows XP (The..

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

Hello everyboddy,

I think i found a solution for the Remote Desktop Problem with Win XP
SP2:

Error Message:
English:The Remote Computer Has ended the connection
German: Die Verbindung wurde vom Remotecomputer getrennt

Try the following I found at:

http://www-dsp.syr.edu/meetings/agenda_archive/04Dec.html

Quote:

XP DisableDFS will set
HKLM\System\CurrentControlSet\Services\Mup\DisableDFS = 0

When Windows XP was originally deployed in the CS/SUMMON environment,
CMS set a series of speed tweaks to help speed up the operating
system. These settings initially caused Windows Remote Desktop and
Timbuktu to stop functioning properly when Windows XP SP2 is
installed. Changing the DisableDFS parameter to 0 allows Windows
Remote Desktop and Timbuktu to function properly with Windows XP SP2
installed.

Quote end...

so just look for the registry key:
HKLM\System\CurrentControlSet\Services\Mup\DisableDFS

if it is set on "1" the DFS (Distributed File System) Service is
disabled, for Remote Desktop DFS has to be enabled, which means "0"

maybe it helps.....

greets,
oliver neuhauser - IT Centre - University of Innsbruck - Austria
2 answers Last reply
More about remote desktop fail installation windows
  1. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Hello, oliver neuhauser,
    you are unbelievable.

    > so just look for the registry key:
    > HKLM\System\CurrentControlSet\Services\Mup\DisableDFS
    >
    > if it is set on "1" the DFS (Distributed File System) Service is
    > disabled, for Remote Desktop DFS has to be enabled, which means "0"
    >
    > maybe it helps.....
    >
    > greets,
    > oliver neuhauser - IT Centre - University of Innsbruck - Austria

    I was trying to solve RDP problems with one of our XP+SP2
    machines for several months. I tried all possible suggestions
    that I was able to get on the web - no success. Unfortunatelly, I
    didn't found the page you did. Registry setting DisableDFS=1
    indeed cripples RDP in XP+SP2. The same situation happens
    also in Windows 2003+SP1.

    BTW, you can enable Remote Desktop in XP+SP2 with
    DisableDFS=1 (if your network does not allow 0)
    with the following trick: copy termsrv.dll from XP+SP1.
    But, in this case you cannot print to local printers and cannot
    access local disks (\\tsclient).

    Thanks for this precious piece of information,

    Roman Modic
    Ljubljana, Slovenia

    P.S. This should be added to MSKB ...
Ask a new question

Read More

Remote Desktop Windows XP