Sign in with
Sign up | Sign in
Your question

Network Sharing Issues

Last response: in Windows 8
Share
November 16, 2012 2:36:59 AM

I've searched for the solution to my problem but cannot seem to find it. I have a home network of 3 computers currently. 2 older machines running XP, and my new build running windows 8. I am able to browse my 2 windows xp computers through windows 8, but I cannot browse my windows 8 computer through the xp computers.

I read that if I change the network name on the 2 xp machines to the same name of the windows 8 workgroup that it would work. Once I did this, the shared files show up on the xp machines, but I get a permission error when trying to access them.

My network settings on the windows 8 pc are set to allow "Everyone" access.

Any suggestions?

More about : network sharing issues

November 16, 2012 3:11:15 PM

"My network settings on the windows 8 pc are set to allow "Everyone" access."

I suspect you mean your share permissions are at least read/write or possibly full control for the Everyone group.

You also need to set NTFS permissions on the Folders/Files you want to access, these can be found on the Security Tab of the folder or file properties dialog box.

When dealing with Share vs NTFS permissions the most restrictive apply.

You also need to ensure that the user accounts you are using on the XP machines also exists on the Windows 8 box.
m
0
l
a b * Windows 8
November 16, 2012 10:28:40 PM

from your xp machine cmd prompt
net use \\YourWin8Box\ipc$ /U:yourwin8account /P:yourwind8password

see if that helps to get started
m
0
l
Related resources
November 26, 2012 11:18:32 PM

tr2012 said:
"My network settings on the windows 8 pc are set to allow "Everyone" access."

I suspect you mean your share permissions are at least read/write or possibly full control for the Everyone group.

You also need to set NTFS permissions on the Folders/Files you want to access, these can be found on the Security Tab of the folder or file properties dialog box.

When dealing with Share vs NTFS permissions the most restrictive apply.

You also need to ensure that the user accounts you are using on the XP machines also exists on the Windows 8 box.


I had to take multiple steps to enable the sharing across the network, here's what I did:

Created a user account for each XP machine:
1. On the XP machine, navigate to Control Panel > User Accounts. The account name(s) listed there is what needs to be created on the Windows 8 pc.
2. On the Windows 8 machine, navigate to Control Panel > User Accounts (left panel).
3. Select 'Manage Another Account', then 'Add a new pc user in PC settings'
4. Create an account with the same username as the windows xp pc(s) (ie, XPMachine1, XPMachine2, W8Machine1)

Created a new Homegroup:
1. On each PC (windows 8 and windows xp), create a separate temporary homegroup and restart (ie, com 1 was "Temp1", comp 2 was "Temp2" etc.)
2. Once I joined separate homegroups on each computer, I created my permanent homegroup on the XP machine (ie, "TomsHomegroup").
3. I created the identical homegroup on each of the remaining pc's (I'm sure this is called 'joining' the homegroup, but I never found where I had the option to join different homegroups).

Logging in to the Windows 8 PC
1. On the XP machine, navigate to 'My Network Places'
2. On the left panel, select 'View Workgroup Computers'
3. Double click on the computer you want to access (in my case, the Windows 8 PC)
4. Login with the username and password created earlier (ie, XPMachine1).

That may be a bit too thorough of instructions, but if I would have seen these steps it would have saved me a lot of time. My situation was a little goofy because 2 of the computers had the same username, but the third didn't, and when I tried to login using a username that wasn't the current logged in user it wasn't working. Then I must have had some kind of homegroup issue because I couldn't login to the computer even with the same username, but resetting the homegroup fixed it.

Thanks for the help!
m
0
l
November 26, 2012 11:19:25 PM

tr2012 said:
"My network settings on the windows 8 pc are set to allow "Everyone" access."

I suspect you mean your share permissions are at least read/write or possibly full control for the Everyone group.

You also need to set NTFS permissions on the Folders/Files you want to access, these can be found on the Security Tab of the folder or file properties dialog box.

When dealing with Share vs NTFS permissions the most restrictive apply.

You also need to ensure that the user accounts you are using on the XP machines also exists on the Windows 8 box.


I had to take multiple steps to enable the sharing across the network, here's what I did:

Created a user account for each XP machine:
1. On the XP machine, navigate to Control Panel > User Accounts. The account name(s) listed there is what needs to be created on the Windows 8 pc.
2. On the Windows 8 machine, navigate to Control Panel > User Accounts (left panel).
3. Select 'Manage Another Account', then 'Add a new pc user in PC settings'
4. Create an account with the same username as the windows xp pc(s) (ie, XPMachine1, XPMachine2, W8Machine1)

Created a new Homegroup:
1. On each PC (windows 8 and windows xp), create a separate temporary homegroup and restart (ie, com 1 was "Temp1", comp 2 was "Temp2" etc.)
2. Once I joined separate homegroups on each computer, I created my permanent homegroup on the XP machine (ie, "TomsHomegroup").
3. I created the identical homegroup on each of the remaining pc's (I'm sure this is called 'joining' the homegroup, but I never found where I had the option to join different homegroups).

Logging in to the Windows 8 PC
1. On the XP machine, navigate to 'My Network Places'
2. On the left panel, select 'View Workgroup Computers'
3. Double click on the computer you want to access (in my case, the Windows 8 PC)
4. Login with the username and password created earlier (ie, XPMachine1).

That may be a bit too thorough of instructions, but if I would have seen these steps it would have saved me a lot of time. My situation was a little goofy because 2 of the computers had the same username, but the third didn't, and when I tried to login using a username that wasn't the current logged in user it wasn't working. Then I must have had some kind of homegroup issue because I couldn't login to the computer even with the same username, but resetting the homegroup fixed it.

Thanks for the help!
m
0
l
!