Remote Desktop web connection does not work outside my loc..

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

I've set up Remote Desktop web connection and it works well when I use it
using a local ip address within the network. However when I connect from
outside the network, I get to the main screen where the Active X loads. when
I click connect though, after some time I get an error message saying that
maybe remote desktop connection is not enabled on the machine or there is
some network problem and I should try again later. I use an Aztech DSL turbo
900 router which has NAT enabled and I've tried opening up all the ports in
the posts. I suspect the problem lies with the router configuration. Can
anyone help?
5 answers Last reply
More about remote desktop connection work
  1. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    You need both TCP Port 80 (IIS) and TCP Port 3389 (Remote Desktop) forwarded through the router to
    the static LAN IP of the IIS server and PC your trying to connect to. Call using the public IP of
    the router, ie. the IP assigned by your ISP.

    --

    Al Jarvi (MS-MVP Windows Networking)

    Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
    The MS-MVP Program - http://mvp.support.microsoft.com
    This posting is provided "AS IS" with no warranties, and confers no rights...


    "Benjy" <Benjy@discussions.microsoft.com> wrote in message
    news:663388EF-14C6-4B78-B9F0-B4E16427A426@microsoft.com...
    > I've set up Remote Desktop web connection and it works well when I use it
    > using a local ip address within the network. However when I connect from
    > outside the network, I get to the main screen where the Active X loads. when
    > I click connect though, after some time I get an error message saying that
    > maybe remote desktop connection is not enabled on the machine or there is
    > some network problem and I should try again later. I use an Aztech DSL turbo
    > 900 router which has NAT enabled and I've tried opening up all the ports in
    > the posts. I suspect the problem lies with the router configuration. Can
    > anyone help?
  2. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Thanks, but I've already done that. I noticed a strange thing though, (after
    I posted) if I leave the server name blank and click on connect, a black
    screen opens with the external ip of my router on the title. when I login on
    the next screen using an account on the machine where IIS is running, I can
    use it normally. But I cant connect to any other machine on my network even
    though remote desktop is enabled on them. Do I need to set up all the sytems
    as hosts using different port numbers for IIS for each one of them? That
    would be a big task.


    "Sooner Al [MVP]" wrote:

    > You need both TCP Port 80 (IIS) and TCP Port 3389 (Remote Desktop) forwarded through the router to
    > the static LAN IP of the IIS server and PC your trying to connect to. Call using the public IP of
    > the router, ie. the IP assigned by your ISP.
    >
    > --
    >
    > Al Jarvi (MS-MVP Windows Networking)
    >
    > Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
    > The MS-MVP Program - http://mvp.support.microsoft.com
    > This posting is provided "AS IS" with no warranties, and confers no rights...
    >
    >
    > "Benjy" <Benjy@discussions.microsoft.com> wrote in message
    > news:663388EF-14C6-4B78-B9F0-B4E16427A426@microsoft.com...
    > > I've set up Remote Desktop web connection and it works well when I use it
    > > using a local ip address within the network. However when I connect from
    > > outside the network, I get to the main screen where the Active X loads. when
    > > I click connect though, after some time I get an error message saying that
    > > maybe remote desktop connection is not enabled on the machine or there is
    > > some network problem and I should try again later. I use an Aztech DSL turbo
    > > 900 router which has NAT enabled and I've tried opening up all the ports in
    > > the posts. I suspect the problem lies with the router configuration. Can
    > > anyone help?
    >
    >
    >
  3. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    The web based method, using IIS, still requires you to port forward the RDP protocol to each PC
    through the router. You simply can not get around that. You then need to use Jeffrey Randow's
    (MS-MVP) modified default.htm file on the IIS server so you can dynamically change the port your
    calling with...

    For information on how to setup port forwarding to multiple PCs behind a firewall/NAT/router look at
    this page...

    http://theillustratednetwork.mvps.org/RemoteDesktop/Multiple_PC_RD.html

    To download the modified default.htm file from here...

    http://www.remotenetworktechnology.com/LinkClick.aspx?link=revised_rdwc.zip&mid=365

    Make a backup of the original default.htm file first just to be safe...

    As you can see, using the web based method adds complexity to the process. It may be easier for you
    to simply access the PCs via either a VPN or SSH tunnel. Personally I use the SSH tunnel method to
    access one or more XP Pro/Home boxes using either XP Pro Remote Desktop or UltraVNC for XP Home
    machines...

    http://theillustratednetwork.mvps.org/RemoteDesktop/SSH-RDP-VNC/RemoteDesktopVNCandSSH.html

    Other SSH and Remote Desktop information...

    http://www.bluestream.org/Networking/SSHTunnelRDP.htm
    http://www.dslreports.com/faq/vnc

    PPTP VPN help...

    http://www.onecomputerguy.com/networking/xp_vpn_server.htm
    http://www.onecomputerguy.com/networking/xp_vpn.htm

    --

    Al Jarvi (MS-MVP Windows Networking)

    Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
    The MS-MVP Program - http://mvp.support.microsoft.com
    This posting is provided "AS IS" with no warranties, and confers no rights...


    "Benjy" <Benjy@discussions.microsoft.com> wrote in message
    news:19997058-ECD3-4F30-BACC-6529ECF52551@microsoft.com...
    > Thanks, but I've already done that. I noticed a strange thing though, (after
    > I posted) if I leave the server name blank and click on connect, a black
    > screen opens with the external ip of my router on the title. when I login on
    > the next screen using an account on the machine where IIS is running, I can
    > use it normally. But I cant connect to any other machine on my network even
    > though remote desktop is enabled on them. Do I need to set up all the sytems
    > as hosts using different port numbers for IIS for each one of them? That
    > would be a big task.
    >
    >
    > "Sooner Al [MVP]" wrote:
    >
    >> You need both TCP Port 80 (IIS) and TCP Port 3389 (Remote Desktop) forwarded through the router
    >> to
    >> the static LAN IP of the IIS server and PC your trying to connect to. Call using the public IP of
    >> the router, ie. the IP assigned by your ISP.
    >>
    >> --
    >>
    >> Al Jarvi (MS-MVP Windows Networking)
    >>
    >> Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
    >> The MS-MVP Program - http://mvp.support.microsoft.com
    >> This posting is provided "AS IS" with no warranties, and confers no rights...
    >>
    >>
    >> "Benjy" <Benjy@discussions.microsoft.com> wrote in message
    >> news:663388EF-14C6-4B78-B9F0-B4E16427A426@microsoft.com...
    >> > I've set up Remote Desktop web connection and it works well when I use it
    >> > using a local ip address within the network. However when I connect from
    >> > outside the network, I get to the main screen where the Active X loads. when
    >> > I click connect though, after some time I get an error message saying that
    >> > maybe remote desktop connection is not enabled on the machine or there is
    >> > some network problem and I should try again later. I use an Aztech DSL turbo
    >> > 900 router which has NAT enabled and I've tried opening up all the ports in
    >> > the posts. I suspect the problem lies with the router configuration. Can
    >> > anyone help?
    >>
    >>
    >>
  4. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Thanks Sooner, I'll try that out & get back.

    "Sooner Al [MVP]" wrote:

    > The web based method, using IIS, still requires you to port forward the RDP protocol to each PC
    > through the router. You simply can not get around that. You then need to use Jeffrey Randow's
    > (MS-MVP) modified default.htm file on the IIS server so you can dynamically change the port your
    > calling with...
    >
    > For information on how to setup port forwarding to multiple PCs behind a firewall/NAT/router look at
    > this page...
    >
    > http://theillustratednetwork.mvps.org/RemoteDesktop/Multiple_PC_RD.html
    >
    > To download the modified default.htm file from here...
    >
    > http://www.remotenetworktechnology.com/LinkClick.aspx?link=revised_rdwc.zip&mid=365
    >
    > Make a backup of the original default.htm file first just to be safe...
    >
    > As you can see, using the web based method adds complexity to the process. It may be easier for you
    > to simply access the PCs via either a VPN or SSH tunnel. Personally I use the SSH tunnel method to
    > access one or more XP Pro/Home boxes using either XP Pro Remote Desktop or UltraVNC for XP Home
    > machines...
    >
    > http://theillustratednetwork.mvps.org/RemoteDesktop/SSH-RDP-VNC/RemoteDesktopVNCandSSH.html
    >
    > Other SSH and Remote Desktop information...
    >
    > http://www.bluestream.org/Networking/SSHTunnelRDP.htm
    > http://www.dslreports.com/faq/vnc
    >
    > PPTP VPN help...
    >
    > http://www.onecomputerguy.com/networking/xp_vpn_server.htm
    > http://www.onecomputerguy.com/networking/xp_vpn.htm
    >
    > --
    >
    > Al Jarvi (MS-MVP Windows Networking)
    >
    > Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
    > The MS-MVP Program - http://mvp.support.microsoft.com
    > This posting is provided "AS IS" with no warranties, and confers no rights...
    >
    >
    > "Benjy" <Benjy@discussions.microsoft.com> wrote in message
    > news:19997058-ECD3-4F30-BACC-6529ECF52551@microsoft.com...
    > > Thanks, but I've already done that. I noticed a strange thing though, (after
    > > I posted) if I leave the server name blank and click on connect, a black
    > > screen opens with the external ip of my router on the title. when I login on
    > > the next screen using an account on the machine where IIS is running, I can
    > > use it normally. But I cant connect to any other machine on my network even
    > > though remote desktop is enabled on them. Do I need to set up all the sytems
    > > as hosts using different port numbers for IIS for each one of them? That
    > > would be a big task.
    > >
    > >
    > > "Sooner Al [MVP]" wrote:
    > >
    > >> You need both TCP Port 80 (IIS) and TCP Port 3389 (Remote Desktop) forwarded through the router
    > >> to
    > >> the static LAN IP of the IIS server and PC your trying to connect to. Call using the public IP of
    > >> the router, ie. the IP assigned by your ISP.
    > >>
    > >> --
    > >>
    > >> Al Jarvi (MS-MVP Windows Networking)
    > >>
    > >> Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
    > >> The MS-MVP Program - http://mvp.support.microsoft.com
    > >> This posting is provided "AS IS" with no warranties, and confers no rights...
    > >>
    > >>
    > >> "Benjy" <Benjy@discussions.microsoft.com> wrote in message
    > >> news:663388EF-14C6-4B78-B9F0-B4E16427A426@microsoft.com...
    > >> > I've set up Remote Desktop web connection and it works well when I use it
    > >> > using a local ip address within the network. However when I connect from
    > >> > outside the network, I get to the main screen where the Active X loads. when
    > >> > I click connect though, after some time I get an error message saying that
    > >> > maybe remote desktop connection is not enabled on the machine or there is
    > >> > some network problem and I should try again later. I use an Aztech DSL turbo
    > >> > 900 router which has NAT enabled and I've tried opening up all the ports in
    > >> > the posts. I suspect the problem lies with the router configuration. Can
    > >> > anyone help?
    > >>
    > >>
    > >>
    >
    >
    >
  5. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    "=?Utf-8?B?QmVuank=?=" <Benjy@discussions.microsoft.com> wrote in
    news:663388EF-14C6-4B78-B9F0-B4E16427A426@microsoft.com:

    > I've set up Remote Desktop web connection and it works well when I use
    > it using a local ip address within the network. However when I connect
    > from outside the network, I get to the main screen where the Active X
    > loads. when I click connect though, after some time I get an error
    > message saying that maybe remote desktop connection is not enabled on
    > the machine or there is some network problem and I should try again
    > later. I use an Aztech DSL turbo 900 router which has NAT enabled and
    > I've tried opening up all the ports in the posts. I suspect the
    > problem lies with the router configuration. Can anyone help?

    make sure the DNS servers on the TSServer are set to the correct address,
    and not just pointing to the router.
Ask a new question

Read More

Remote Desktop Connection Windows XP