Sign in with
Sign up | Sign in
Your question

Remote Desktop and Refresh Rates

Last response: in Windows XP
Share
Anonymous
May 23, 2005 10:19:49 PM

Archived from groups: alt.comp.networking.connectivity,microsoft.public.windowsxp.work_remotely (More info?)

Both the flat panel monitor on my XP system and the flat panel monitor
on the XP host I am connecting to with Remote Desktop have 60hz refresh
rates.
When I connect via Remote Desktop the host sets its refresh rate to
42hz. And this works fine, until I disconnect or log off. The host monitor
doesn't support 42hz so the host has to be re-booted to reset the refresh
rate back to normal. I tried changing the refresh rate while connected but
the only choice shown is 42hz, yet when I am in front of the host I normally
get a whole bunch of refresh rate choices.
I connect to several networks using remote desktop and only have this
problem with this one host. Has anyone seen this behavior before and does
anyone know a workaround for it?
Thanks.
Phil
Anonymous
May 23, 2005 10:31:42 PM

Archived from groups: alt.comp.networking.connectivity,microsoft.public.windowsxp.work_remotely (More info?)

Additional info, the host graphics controller is an Intel 82845G.

"Phil Borod" <avpab@bellsouth.net> wrote in message
news:p Dske.23503$J25.17693@bignews6.bellsouth.net...
> Both the flat panel monitor on my XP system and the flat panel monitor
> on the XP host I am connecting to with Remote Desktop have 60hz refresh
> rates.
> When I connect via Remote Desktop the host sets its refresh rate to
> 42hz. And this works fine, until I disconnect or log off. The host
> monitor
> doesn't support 42hz so the host has to be re-booted to reset the refresh
> rate back to normal. I tried changing the refresh rate while connected
> but
> the only choice shown is 42hz, yet when I am in front of the host I
> normally
> get a whole bunch of refresh rate choices.
> I connect to several networks using remote desktop and only have this
> problem with this one host. Has anyone seen this behavior before and does
> anyone know a workaround for it?
> Thanks.
> Phil
>
>
>
>
June 2, 2005 6:35:29 PM

Archived from groups: alt.comp.networking.connectivity,microsoft.public.windowsxp.work_remotely (More info?)

You might give this a shot. Don't know if it will work for you but we
have used it in the past for other issues.

It will stop the host from saving the changes to the refresh rate. It
will also stop anyone from manually making and saving any other changes
so you might not want to use it.

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
Create a new DWORD value, or modify the existing value called
'NoSaveSettings' set the value to equal '0'.
Exit your registry, you may need to restart for the changes to take
effect.

Fred


Phil Borod wrote:
> Both the flat panel monitor on my XP system and the flat panel monitor
> on the XP host I am connecting to with Remote Desktop have 60hz refresh
> rates.
> When I connect via Remote Desktop the host sets its refresh rate to
> 42hz. And this works fine, until I disconnect or log off. The host monitor
> doesn't support 42hz so the host has to be re-booted to reset the refresh
> rate back to normal. I tried changing the refresh rate while connected but
> the only choice shown is 42hz, yet when I am in front of the host I normally
> get a whole bunch of refresh rate choices.
> I connect to several networks using remote desktop and only have this
> problem with this one host. Has anyone seen this behavior before and does
> anyone know a workaround for it?
> Thanks.
> Phil
February 1, 2010 8:50:17 AM

Quote:
Archived from groups: alt.comp.networking.connectivity,microsoft.public.windowsxp.work_remotely (More info?)

Both the flat panel monitor on my XP system and the flat panel monitor
on the XP host I am connecting to with Remote Desktop have 60hz refresh
rates.
When I connect via Remote Desktop the host sets its refresh rate to
42hz. And this works fine, until I disconnect or log off. The host monitor
doesn't support 42hz so the host has to be re-booted to reset the refresh
rate back to normal. I tried changing the refresh rate while connected but
the only choice shown is 42hz, yet when I am in front of the host I normally
get a whole bunch of refresh rate choices.
I connect to several networks using remote desktop and only have this
problem with this one host. Has anyone seen this behavior before and does
anyone know a workaround for it?
Thanks.
Phil
I've found a nice workaround:

1. Download and install a free tool RefreshLock.
2. Run it and go to "Advanced settings"
3. In the "Timing" tab set "Only override mode if running at" to 42Hz.
4. On the main Refreshlock form set "Refresh overriding" to On.

This will force resolution to change everytime the refreshrate is 42Hz. While using Remote Desktop it will not have any effect (on the client side), and when you log in to the server directly the resolution will auto-change to acceptable refresh rate.
!