Port is not working, Now what?

Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

I checked out this theillustratednetwork site that is recommended to everyone
on this newsgroup. It was helpful in fituring out that the problem is my
home connection. Port 3389 is not working on my home computer. Port 3389 is
working just fine at the office. So what do I do now? How do I make Port
3389 work at home (the remote computer)?
6 answers Last reply
More about port working what
  1. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Is the home PC the one you trying to connect to from the office?
    Is it possible your office network administrators are blocking TCP Port 3389 outbound?
    Can you go to a friends house and call your home PC successfully?


    How is the home PC connected to the public internet, ie. dialup, cable or dsl modem?
    From the home PC can you run the http://www.canyouseeme.org test successfully?
    Do you have a home router involved that may be blocking the incoming port?
    Are you running any personal firewall software on the home PC that is blocking the incoming port?
    Are you running any anti-virus/trojan/worm software on the home PC that may be blocking the incoming
    port?

    --

    Al Jarvi (MS-MVP Windows Networking)

    Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
    The MS-MVP Program - http://mvp.support.microsoft.com
    This posting is provided "AS IS" with no warranties, and confers no rights...


    "gnomehunter" <gnomehunter@discussions.microsoft.com> wrote in message
    news:98883369-CD10-42D7-A8CB-8CA6EE87DAE3@microsoft.com...
    >I checked out this theillustratednetwork site that is recommended to everyone
    > on this newsgroup. It was helpful in fituring out that the problem is my
    > home connection. Port 3389 is not working on my home computer. Port 3389 is
    > working just fine at the office. So what do I do now? How do I make Port
    > 3389 work at home (the remote computer)?
  2. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    I guess I was unclear the first time. I run Win XP Pro at the office. I
    run Win XP Home at home. I am trying to connect to my office computer from
    home. That is where the useful statistical programs are and I would like to
    work from home.

    Collegues can connect to their office computers from home and
    CanYouSeeMe.org tells me that the port 3389 is working at the office. That
    is why I have conclude that the problem is my outgoing connection from home.
    I don't have a friend with XP pro at home so I can't try connecting to a
    friend's computer from home.

    At home I use a dialup to MSN. At home I ran CanYouSeeMe and it took about
    2 seconds to reply: "I could not see your service on <IP address> on port
    (3389). Reason: connection timed out"

    No home router, just one computer with dialup.
    I run Windows Firewall but I have checked the "Remote Desktop" box in the
    "Exceptions" tab.
    I run Symantic Anit-Virus but can not see any setting in there that would
    block outgoing remote connect.


    "Sooner Al [MVP]" wrote:

    > Is the home PC the one you trying to connect to from the office?
    > Is it possible your office network administrators are blocking TCP Port 3389 outbound?
    > Can you go to a friends house and call your home PC successfully?
    >
    >
    > How is the home PC connected to the public internet, ie. dialup, cable or dsl modem?
    > From the home PC can you run the http://www.canyouseeme.org test successfully?
    > Do you have a home router involved that may be blocking the incoming port?
    > Are you running any personal firewall software on the home PC that is blocking the incoming port?
    > Are you running any anti-virus/trojan/worm software on the home PC that may be blocking the incoming
    > port?
    >
    > --
    >
    > Al Jarvi (MS-MVP Windows Networking)
    >
    > Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
    > The MS-MVP Program - http://mvp.support.microsoft.com
    > This posting is provided "AS IS" with no warranties, and confers no rights...
    >
    >
    > "gnomehunter" <gnomehunter@discussions.microsoft.com> wrote in message
    > news:98883369-CD10-42D7-A8CB-8CA6EE87DAE3@microsoft.com...
    > >I checked out this theillustratednetwork site that is recommended to everyone
    > > on this newsgroup. It was helpful in fituring out that the problem is my
    > > home connection. Port 3389 is not working on my home computer. Port 3389 is
    > > working just fine at the office. So what do I do now? How do I make Port
    > > 3389 work at home (the remote computer)?
    >
    >
    >
  3. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Ok...so your trying to connect to your office XP Pro PC from your home XP Home PC...

    Is Remote Desktop enabled on the office PC?
    Have you tested this over the office LAN from another PC?

    Are you calling the correct public IP for the office router when you call from home?
    Does your office PC use a static private LAN IP? If not, its possible port forwarding as configured
    in the router may be pointing to the wrong PC if you rebooted/restarted your office PC.
    Anything of interest in the logs on the office PC?
    What error message do you get when you try to connect from home?

    As far as your home PC is concerned you need not worry about TCP Port 3389 being open and failing
    the canyouseeme.org site test. I also doubt your ISP blocks TCP Port 3389 outbound.

    --

    Al Jarvi (MS-MVP Windows Networking)

    Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
    The MS-MVP Program - http://mvp.support.microsoft.com
    This posting is provided "AS IS" with no warranties, and confers no rights...


    "gnomehunter" <gnomehunter@discussions.microsoft.com> wrote in message
    news:3C945A7F-8DD4-4338-9011-D68AD14367C9@microsoft.com...
    >
    > I guess I was unclear the first time. I run Win XP Pro at the office. I
    > run Win XP Home at home. I am trying to connect to my office computer from
    > home. That is where the useful statistical programs are and I would like to
    > work from home.
    >
    > Collegues can connect to their office computers from home and
    > CanYouSeeMe.org tells me that the port 3389 is working at the office. That
    > is why I have conclude that the problem is my outgoing connection from home.
    > I don't have a friend with XP pro at home so I can't try connecting to a
    > friend's computer from home.
    >
    > At home I use a dialup to MSN. At home I ran CanYouSeeMe and it took about
    > 2 seconds to reply: "I could not see your service on <IP address> on port
    > (3389). Reason: connection timed out"
    >
    > No home router, just one computer with dialup.
    > I run Windows Firewall but I have checked the "Remote Desktop" box in the
    > "Exceptions" tab.
    > I run Symantic Anit-Virus but can not see any setting in there that would
    > block outgoing remote connect.
    >
  4. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Remote Desktop is enabled on the office PC. I was able to connect from a
    coworker's office, and from his house. I was also able to connect from my
    home computer until about three weeks ago.

    The IP in the office is constant, the same every day.

    I looked in the logs last week but did not see anything that meant anything
    to me. I tried to connect in the morning before work and then checked the
    logs for around the time that I tried to connect and did not see any evidence
    that the connection was tried.

    The error message is:
    "The client could not connect to the remote computer.
    "Remote connections might not be enabled or the computer might be too busy
    to accept new connections.
    " It is also possible that network problems are preventing your connection.
    "Please try connecting again later. If the problem continuse to occur,
    contact your administrator."

    Any ideas?


    "Sooner Al [MVP]" wrote:

    > Ok...so your trying to connect to your office XP Pro PC from your home XP Home PC...
    >
    > Is Remote Desktop enabled on the office PC?
    > Have you tested this over the office LAN from another PC?
    >
    > Are you calling the correct public IP for the office router when you call from home?
    > Does your office PC use a static private LAN IP? If not, its possible port forwarding as configured
    > in the router may be pointing to the wrong PC if you rebooted/restarted your office PC.
    > Anything of interest in the logs on the office PC?
    > What error message do you get when you try to connect from home?
    >
    > As far as your home PC is concerned you need not worry about TCP Port 3389 being open and failing
    > the canyouseeme.org site test. I also doubt your ISP blocks TCP Port 3389 outbound.
    >
    > --
    >
    > Al Jarvi (MS-MVP Windows Networking)
    >
    > Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
    > The MS-MVP Program - http://mvp.support.microsoft.com
    > This posting is provided "AS IS" with no warranties, and confers no rights...
    >
    >
    > "gnomehunter" <gnomehunter@discussions.microsoft.com> wrote in message
    > news:3C945A7F-8DD4-4338-9011-D68AD14367C9@microsoft.com...
    > >
    > > I guess I was unclear the first time. I run Win XP Pro at the office. I
    > > run Win XP Home at home. I am trying to connect to my office computer from
    > > home. That is where the useful statistical programs are and I would like to
    > > work from home.
    > >
    > > Collegues can connect to their office computers from home and
    > > CanYouSeeMe.org tells me that the port 3389 is working at the office. That
    > > is why I have conclude that the problem is my outgoing connection from home.
    > > I don't have a friend with XP pro at home so I can't try connecting to a
    > > friend's computer from home.
    > >
    > > At home I use a dialup to MSN. At home I ran CanYouSeeMe and it took about
    > > 2 seconds to reply: "I could not see your service on <IP address> on port
    > > (3389). Reason: connection timed out"
    > >
    > > No home router, just one computer with dialup.
    > > I run Windows Firewall but I have checked the "Remote Desktop" box in the
    > > "Exceptions" tab.
    > > I run Symantic Anit-Virus but can not see any setting in there that would
    > > block outgoing remote connect.
    > >
    >
    >
    >
  5. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    Hmmm...

    Any chance the firewall/NAT/router at the office end of the connection is blocking IP addresses from
    your home ISP?
    Are there any logs on the firewall/NAT/router at the office end that might tell you something?
    Can you connect to your office PC from a friends house as a test?
    Have you installed any updates to your anti-virus/trojan/worm software at home that might be causing
    a problem?

    --

    Al Jarvi (MS-MVP Windows Networking)

    Please post *ALL* questions and replies to the news group for the mutual benefit of all of us...
    The MS-MVP Program - http://mvp.support.microsoft.com
    This posting is provided "AS IS" with no warranties, and confers no rights...


    "gnomehunter" <gnomehunter@discussions.microsoft.com> wrote in message
    news:5423413A-D697-433B-875F-D5EA7726A9B4@microsoft.com...
    >
    > Remote Desktop is enabled on the office PC. I was able to connect from a
    > coworker's office, and from his house. I was also able to connect from my
    > home computer until about three weeks ago.
    >
    > The IP in the office is constant, the same every day.
    >
    > I looked in the logs last week but did not see anything that meant anything
    > to me. I tried to connect in the morning before work and then checked the
    > logs for around the time that I tried to connect and did not see any evidence
    > that the connection was tried.
    >
    > The error message is:
    > "The client could not connect to the remote computer.
    > "Remote connections might not be enabled or the computer might be too busy
    > to accept new connections.
    > " It is also possible that network problems are preventing your connection.
    > "Please try connecting again later. If the problem continuse to occur,
    > contact your administrator."
    >
    > Any ideas?
    >
  6. Archived from groups: microsoft.public.windowsxp.work_remotely (More info?)

    ok, so the way it normally works is this:

    At the office you have...
    **a router which allows everyone at the office to connect to the internet.
    ** several PC's running XP Pro
    All RDC, by default, listens on port 3389.
    so... at your office you have several PC's all listening on port 3389 for an
    incoming call...so how does it know which one to go to.. I mean how can you
    make it so that when YOU connect to the office (suing the same IP address
    that all other remote users use,,) that it connects to YOUR PC??

    That is done in the router.. the router is configured so that when a packet
    (a call, so to speak) that is meant for a particulr port, comes into the
    router, it is FORWARDED to a specif PC. You physically put in information
    into the router and tell it permanently where to send those packets to...

    So what if ya got several remote systems that want to use RDC to remotely
    control their office PC?

    You can do that by changing the LISTENING port (3389 by default) on some
    of the systems. You change it so that each PC is listening on a different
    port. This is done in the registry and I think that that site you were at
    expalins how. It's pretty easy to do...
    THEN... from your home pc,when you start the client, you specify the port to
    use..

    For example..say your particular office PC was changed to listen on port
    3390.
    Then lets say that the STATIC ip address of YOUR system was 192.168.1.100
    Lets also say the STATIC ip address of your router was 4.4.4.4 (If you don't
    have a static WAN ip address, then look into DDNS. I like no-ip.com, it's
    free.

    You would then go into the router (if ya don't know how to do this, call a
    tech) and configure PORT FORWARDING (different routers call it different
    things) to forward port 3390 to IP address 192.168.1.100

    Then at your home, in the RDC client, you would type in 4.4.4.4:3390
    ...and that should work.

    Maybe some other offices you may have colleges (sp) in, do it a somewhat
    different way (still pretty common).. they use a TERMINAL SERVER.which
    basically allows lots of people to connect remotely and simultaniously. It's
    not remote control.. youre not controlling YOUR pc.. but if the applications
    are installed on the terminal server, then all remote users will be able to
    use them as if they were IN the office... so it accomplishes the same thing
    in a better way.

    BTW.. your dial up connection at your home is a major bottleneck. Remote
    control wont be very fast. turn off all the options you can. Get broadband,
    it's very much worth it.
    ...also-- the web test you did on the ports at your home, failed because XP
    home does NOT support an RDC connection.. you can use it to connect to
    others, but others cant connect to you. So your Home pc is NOT listening on
    port 3389, so the test fails.

    Bitvise makes a really nice SSH server for a good price. The client will
    even make an RDC connection for you. It also supports TFTP for file
    transfer. and it's SSH, so it is very secure. Out of the box, I think,
    doesn't really have an data security... something to think about!! That
    data travels over the internet in plain text!! Also, consider how secure
    your password is. Remember.. if YOU can connect, so can anyone else anywhere
    on the internet! Protect yourself!.. I'd really recommend the SSH system.
    there are free ones you can get, but this one is nice and easy!

    If you did use it, the server runs on your office PC. forward port 22 to
    your office ip. Run the client at your home.


    "Sooner Al [MVP]" <SoonerAl@somewhere.net.invalid> wrote in message
    news:eZ5wGz1aFHA.3240@TK2MSFTNGP12.phx.gbl...
    > Hmmm...
    >
    > Any chance the firewall/NAT/router at the office end of the connection is
    > blocking IP addresses from your home ISP?
    > Are there any logs on the firewall/NAT/router at the office end that might
    > tell you something?
    > Can you connect to your office PC from a friends house as a test?
    > Have you installed any updates to your anti-virus/trojan/worm software at
    > home that might be causing a problem?
    >
    > --
    >
    > Al Jarvi (MS-MVP Windows Networking)
    >
    > Please post *ALL* questions and replies to the news group for the mutual
    > benefit of all of us...
    > The MS-MVP Program - http://mvp.support.microsoft.com
    > This posting is provided "AS IS" with no warranties, and confers no
    > rights...
    >
    >
    > "gnomehunter" <gnomehunter@discussions.microsoft.com> wrote in message
    > news:5423413A-D697-433B-875F-D5EA7726A9B4@microsoft.com...
    >>
    >> Remote Desktop is enabled on the office PC. I was able to connect from a
    >> coworker's office, and from his house. I was also able to connect from
    >> my
    >> home computer until about three weeks ago.
    >>
    >> The IP in the office is constant, the same every day.
    >>
    >> I looked in the logs last week but did not see anything that meant
    >> anything
    >> to me. I tried to connect in the morning before work and then checked
    >> the
    >> logs for around the time that I tried to connect and did not see any
    >> evidence
    >> that the connection was tried.
    >>
    >> The error message is:
    >> "The client could not connect to the remote computer.
    >> "Remote connections might not be enabled or the computer might be too
    >> busy
    >> to accept new connections.
    >> " It is also possible that network problems are preventing your
    >> connection.
    >> "Please try connecting again later. If the problem continuse to occur,
    >> contact your administrator."
    >>
    >> Any ideas?
    >>
    >
    >
Ask a new question

Read More

Computers Microsoft Windows XP Product