Sign in with
Sign up | Sign in
Your question

VLC and gamma

Last response: in Graphics & Displays
Share
August 7, 2005 3:21:07 AM

Archived from groups: comp.sys.mac.apps,comp.sys.mac.hardware.video,comp.sys.mac.portables,comp.sys.mac.system,rec.video.desktop (More info?)

Loaded a commercial DVD and watched it in DVD Player under OS X. Played
normal, with video looking typically good on my laptop's LCD display.

I tried VLC and while it would play the video, it was very dark. I'm guessing
that the gamma is set differently in VLC. I presume it's set for a television
display (connected as an external display).

How can I change the gamma in VLC so that it plays the DVD with gamma
appropriate for my computer's LCD display? Preferences has no such setting.

PowerBook G3/400; OS X 10.3.9; DVD Player 4.0; VLC 0.8.1

Thanks,
--
Please, no "Go Google this" replies. I wouldn't
ask a question here if I hadn't done that already.

DaveC
me@privacy.net
This is an invalid return address
Please reply in the news group

More about : vlc gamma

Anonymous
August 7, 2005 9:50:07 PM

Archived from groups: comp.sys.mac.apps,comp.sys.mac.hardware.video,comp.sys.mac.portables,comp.sys.mac.system,rec.video.desktop (More info?)

DaveC <me@privacy.net> wrote:
> Loaded a commercial DVD and watched it in DVD Player under OS
> X. Played normal, with video looking typically good on my
> laptop's LCD display.
>
> I tried VLC and while it would play the video, it was very
> dark. I'm guessing that the gamma is set differently in VLC. I
> presume it's set for a television display (connected as an
> external display).
>
> How can I change the gamma in VLC so that it plays the DVD with
> gamma appropriate for my computer's LCD display? Preferences
> has no such setting.

Found this via Google.

http://www.via.ecp.fr/via/ml/vlc/2003-05/msg00101.html

I've tried it; it works. Two points:

1. Nothing will happen unless you check the "Image Properties
Filter" box. You'll see this box with a bunch of others when
you click on Filters.
2. You won't see any changes until you save your settings, stop
(not pause) VLC playback and start it again.

This is a tiresome and clumsy process, but it does work.
August 10, 2005 6:01:56 PM

Archived from groups: comp.sys.mac.apps,comp.sys.mac.hardware.video,comp.sys.mac.portables,comp.sys.mac.system,rec.video.desktop (More info?)

Thus spake Kyle Jones:

> I've tried it; it works.

Thanks, Kyle,

To clarify the procedure for the usenet archive:

1. On the VLC control panel, click the Stop button (pause won't do it...).

2. Choose Preferences from the VLC menu.

3. In the scrolling list on the left, click on the entry titled "Video".

4. In the panel on the right, from the drop-down list titled "Video Filter
Module", choose "Image Properties filter".

5. Again, in the scrolling list on the left, click on the triangle next to
the entry titled "Video" so it expands.

6. In the scrolling list on the left, click on the triangle next to the entry
titled "Video filter".

7. In the scrolling list on the left, click on the entry titled "Adjust".

8. In the panel on the right, adjust the slider titled "Image gamma", and any
other image parameters you want to change.

9. Click the Save button in the lower right corner of the window.

10. On the VLC control panel, click the Play button.

You may have to readjust your parameters several times to get it just the way
you want it.

Enjoy!
!